<!DOCTYPE html><!-- Powered by RebelMouse. https://www.rebelmouse.com --><html lang="en"><head prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#"><link rel="stylesheet" type="text/css" href="https://htlbid.com/v3/spectrum.ieee.org/rblbid.css"/><link rel="preload" as="font" href="https://partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Light.woff2" type="font/woff2" crossorigin=""/><link rel="preload" as="font" href="https://partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Regular.woff2" type="font/woff2" crossorigin=""/><link rel="preload" as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Light.woff2" type="font/woff2" crossorigin=""/><link rel="preload" as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Regular.woff2" type="font/woff2" crossorigin=""/><link rel="preload" as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Bold.woff2" type="font/woff2" crossorigin=""/><link rel="preload" as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Regular.woff2" type="font/woff2" crossorigin=""/><link rel="preload" as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Bold.woff2" type="font/woff2" crossorigin=""/><meta name="robots" content="max-image-preview:large"/><link fetchpriority="high" rel="preload" imagesrcset="https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=3600&height=2700 3x, https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=2400&height=1800 2x, https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=1200&height=900 1x" as="image"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@"/><meta name="twitter:site:id" content=""/><meta name="twitter:image" content="https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=1200&height=600&coordinates=0%2C450%2C0%2C450"/><meta property="fb:app_id" content="200167090048537"/><meta property="og:type" content="article"/><meta property="article:section" content="History of Technology"/><meta property="og:url" content="https://spectrum.ieee.org/graphical-user-interface"/><link rel="canonical" href="https://spectrum.ieee.org/graphical-user-interface"/><meta property="og:site_name" content="IEEE Spectrum"/><meta property="og:image" content="https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=1200&height=600&coordinates=0%2C450%2C0%2C450"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="600"/><meta property="og:title" content="How the Graphical User Interface Was Invented"/><meta property="og:description" content="Mice, windows, icons, and menus: these are the ingredients of computer interfaces designed to be simplicity itself to use. But the development was anything but simple. It took some 30 years of effort."/><meta name="description" content="Three decades of UI research came together in the mice, windows, and icons used today"/><meta name="referrer" content="always"/><meta charset="utf-8"/><link rel="preconnect" href="https://assets.rebelmouse.io/" crossorigin="crossorigin"/><link rel="preconnect" href="https://user-stats.rbl.ms/" crossorigin="crossorigin"/><link rel="preconnect" href="https://pages-stats.rbl.ms/" crossorigin="crossorigin"/><!--link rel="preload" href="https://static.rbl.ms/static/fonts/fontawesome/fontawesome-mini.woff" as="font" type="font/woff2" crossorigin--><script class="rm-i-script">window.REBELMOUSE_BOOTSTRAP_DATA = {"isUserLoggedIn": false, "site": {"id": 20265424, "isCommunitySite": false}, "runner": {"id": 20265424}, "post": {"id": 2658380204, "sections": [0, 497728257, 544169516, 544169517, 539617903, 539619441], "shareUrl": "https%3A%2F%2Fspectrum.ieee.org%2Fgraphical-user-interface", "status": 0, "tags": ["computer history", "Alto", "Ivan Sutherland", "user interface", "computer mouse", "Doug Engelbart", "Xerox Parc", "Apple", "Larry Tesler", "Windows", "history"]}, "resourceId": "pp_2658380204", "pathParams": {"slug": "graphical-user-interface"}, "fbId": "200167090048537", "fbAppVersion": "v2.5", "clientGaId": "UA-747464-1", "messageBusUri": "wss://messages.rebelmouse.io", "section": {"id": null}, "tag": {"slug": "history"}, "fullBootstrapUrl": "/res/bootstrap/data.js?site_id=20265424\u0026resource_id=pp_2658380204\u0026path_params=%7B%22slug%22%3A%22graphical-user-interface%22%7D\u0026warehouse10x=1\u0026override_device=desktop\u0026post_id=2658380204", "whitelabel_menu": {}, "useRiver": true, "engine": {"lazyLoadShortcodeImages": true, "backButtonGoToPage": true, "changeParticleUrlScroll": false, "countKeepReadingAsPageview": true, "defaultVideoPlayer": "", "theoPlayerLibraryLocation": "", "trackPageViewOnParticleUrlScroll": false, "webVitalsSampleRate": 100}};
    </script><script class="rm-i-script">
        window.REBELMOUSE_BASE_ASSETS_URL = "https://spectrum.ieee.org/static/dist/social-ux/";
        window.REBELMOUSE_BASE_SSL_DOMAIN = "https://spectrum.ieee.org";
        window.REBELMOUSE_TASKS_QUEUE = [];
        window.REBELMOUSE_LOW_TASKS_QUEUE = [];
        window.REBELMOUSE_LOWEST_TASKS_QUEUE = [];
        window.REBELMOUSE_ACTIVE_TASKS_QUEUE = [];
        window.REBELMOUSE_STDLIB = {};
        window.RM_OVERRIDES = {};
        window.RM_AD_LOADER = [];
    </script><script src="https://spectrum.ieee.org/static/dist/social-ux/main.54640f01964388be1a4d.bundle.mjs" class="rm-i-script" type="module" async="async" src="https://spectrum.ieee.org/static/dist/social-ux/main.54640f01964388be1a4d.bundle.mjs" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="main.mjs"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/main.55cd78632f79fa4884f8.bundle.js" class="rm-i-script" nomodule="nomodule" defer="defer" src="https://spectrum.ieee.org/static/dist/social-ux/main.55cd78632f79fa4884f8.bundle.js" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="main.js"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/runtime.6b7d3051bc7fb1e9e042.bundle.mjs" class="rm-i-script" type="module" async="async" src="https://spectrum.ieee.org/static/dist/social-ux/runtime.6b7d3051bc7fb1e9e042.bundle.mjs" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="runtime.mjs"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/runtime.c96f793cea75f41b9e5e.bundle.js" class="rm-i-script" nomodule="nomodule" defer="defer" src="https://spectrum.ieee.org/static/dist/social-ux/runtime.c96f793cea75f41b9e5e.bundle.js" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="runtime.js"></script><!-- we collected enough need to fix it first before turn in back on--><!--script src="//cdn.ravenjs.com/3.16.0/raven.min.js" crossorigin="anonymous"></script--><!--script type="text/javascript">
        Raven.config('https://6b64f5cc8af542cbb920e0238864390a@sentry.io/147999').install();
    </script--><link rel="manifest" href="/manifest.json"/><meta name="theme-color" content="#647187"/><script class="rm-i-script">
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/sw.js').then(function(registration) {
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }, function(err) {
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        } else {
          console.log('ServiceWorker not enabled');
        }
    </script><script class="rm-i-script">
        // fallback error prone google tag setup
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/><link rel="alternate" type="application/rss+xml" title="IEEE Spectrum" href="/feeds/topic/tech-history.rss"/><!-- Mobile viewport optimized: h5bp.com/viewport --><meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1.0,maximum-scale=1.0,user-scalable=no"/><title>How the Graphical User Interface Was Invented - IEEE Spectrum</title><style class="rm-i-styles">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</style><script class="rm-i-script">
        window.REBELMOUSE_LOW_TASKS_QUEUE.push(function() {
            window.REBELMOUSE_STDLIB.loadExternalStylesheet("/static/css-build/roar/runner/social-ux-non-critical.css?v=rmxassetse8b874e39b339059e338b461576785bb", function(){
                document.body.classList.add("rm-non-critical-loaded");
            });
        });
    </script><script class="rm-i-script">
        var __RUNNER_PUBLIC__ = {
          root: '#runner-root',
          events: {
            PAGE_VIEW: 'page_view.url_change.listicle_switch_page',
            URL_CHANGE_PAGE_VIEW: 'page_view.url_change',
            LISTICLE_CHANGE_PAGE_VIEW: 'page_view.listicle_switch_page'
          }
        }
    </script><script class="rm-i-script">
        window.__rebelmouseJsBaseUrl = "/static/js-build/";
        
        window.__rebelmousePrimaryColor = "#FF4C00";
        
    </script><link rel="apple-touch-icon" href="https://assets.rebelmouse.io/eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjU5NjY0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcyMjY3NDUwNn0.NkaaNg04BB5I4oecK5JfnB605uYfkVersI0HBUDgGmY/img.png?width=192&height=192" sizes="192x192"/><link rel="icon" type="image/png" href="https://assets.rebelmouse.io/eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjU5NjY0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcyMjY3NDUwNn0.NkaaNg04BB5I4oecK5JfnB605uYfkVersI0HBUDgGmY/img.png?width=32&height=32" sizes="16x16"/><meta property="article:published_time" content="2022-11-20T20:00:00+00:00"/><meta property="article:modified_time" content="2022-11-20T20:00:00+00:00"/><meta property="article:author" content="https://www.facebook.com/48576411181"/><meta name="keywords" content="computer history, Alto, Ivan Sutherland, user interface, computer mouse, Doug Engelbart, Xerox Parc, Apple, Larry Tesler, Windows, history"/><link rel="amphtml" href="https://spectrum.ieee.org/amp/graphical-user-interface-2658380204"/><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1955"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="1784"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="1482"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1955"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1939"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1904"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1892"></script><script async="async" type="text/javascript" src="//c.jsrdn.com/s/cs.js?p=23069"></script><script>
  window.postid = "2658380204";
  window.category = ["topic", "type", "feature", "computing", "tech-history"];
  window.tags = ["computer-history", "alto", "ivan-sutherland", "user-interface", "computer-mouse", "doug-engelbart", "xerox-parc", "apple", "larry-tesler", "windows", "history"];
</script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1761"></script><script type="application/json" data-abtest-name="test" data-abtest-value="greek"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="1016"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1883"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1933"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1891"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1885"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1715"></script><script type="application/json" data-abtest-name="test" data-abtest-value="newassemblerclass"></script><script type="application/json" data-abtest-name="pdf" data-abtest-value="button2"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="1326"></script><script type="application/json" data-abtest-name="test" data-abtest-value="2"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1872"></script><script type="application/json" data-abtest-name="test" data-abtest-value="badge"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1719"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="1386"></script><script type="application/json" data-abtest-name="anbar" data-abtest-value="off"></script><script type="application/json" data-abtest-name="anbar" data-abtest-value="pdf"></script><script type="application/json" data-abtest-name="anbar" data-abtest-value="4"></script><script type="application/json" data-abtest-name="anbar" data-abtest-value="on"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="1422"></script><script type="application/json" data-abtest-name="final" data-abtest-value="2"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="209"></script><script type="application/json" data-abtest-name="test" data-abtest-value="collections"></script><script type="application/json" data-abtest-name="test" data-abtest-value="tiarchive"></script><script type="application/json" data-abtest-name="h1" data-abtest-value="fix"></script><script type="application/json" data-abtest-name="footer" data-abtest-value="test"></script><script type="application/json" data-abtest-name="pdf" data-abtest-value="button2"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="gate"></script><script type="application/json" data-abtest-name="pdf" data-abtest-value="button"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1811"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1843"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1842"></script><script type="application/json" data-abtest-name="test" data-abtest-value="noaipopup"></script><meta name="google-site-verification" content="TL2pz9TZSlPds24a3mqZClMC79zWmgOKFwO4aYRjdXk"/><meta name="facebook-domain-verification" content="bgsalp9vtqx07wdoczkh2jq79qvonr"/><meta property="fb:pages" content="48576411181"/><script type="application/json" data-abtest-name="IEEE" data-abtest-value="2026"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1955"></script><script type="application/json" data-abtest-name="test" data-abtest-value="structureddata"></script><script type="application/json" data-abtest-name="com" data-abtest-value="1"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="1780"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1922"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1907"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1830"></script><script type="application/json" data-abtest-name="IEEE" data-abtest-value="1808"></script><style class="rm-i-styles" id="custom-post-styles-2658380204">
</style><style class="rm-i-styles" id="custom-post-styles-2658687697">
</style><style class="rm-i-styles" id="custom-post-styles-2658649885">
</style><script type="application/json" data-abtest-name="ieee" data-abtest-value="209"></script><script type="application/json" data-abtest-name="final" data-abtest-value="3"></script><script type="application/json" data-abtest-name="" data-abtest-value=""></script><script type="application/json" data-abtest-name="" data-abtest-value="3"></script><meta name="parsely-section" content="History of Technology"/><meta name="parsely-tags" content="computer history,Alto,Ivan Sutherland,user interface,computer mouse,Doug Engelbart,Xerox Parc,Apple,Larry Tesler,Windows,history,SpectrumType.Feature"/><meta name="parsely-author" content="Tekla S. Perry"/><meta name="parsely-author" content="John Voelcker"/><script type="application/json" data-abtest-name="ieee" data-abtest-value="1436"></script><script type="application/json" data-abtest-name="test" data-abtest-value="old"></script><script type="application/json" data-abtest-name="test" data-abtest-value="oldarrows"></script><script type="application/json" data-abtest-name="ieee" data-abtest-value="1436test"></script><script class="rm-i-script">
    
        (function() {
    var cookie = 'rebelmouse_abtests=';
        cookie += "v1:165477109-A:3";
    document.cookie = cookie + '; Path=/; SameSite=None; Secure';
})();
    
    </script><!--[if IE]>
        <script type="text/javascript" src="/static/js-build/libs/html5shiv/html5shiv.js"></script>
    <![endif]--></head><body class="logged-out-user section-tech-history"><div id="fb-root"></div><div id="runner-root"></div><div id="curtain" class="curtain"></div><nav class="menu-global"><div class="main-menu-wrapper"><div class="menu-global__search-form hide-tablet-and-desktop"><form action="/search/"><button type="submit" class="menu-global__submit fa fa-search" value="" aria-label="Submit"></button><input name="q" class="menu-global__text-input" type="text" placeholder="Search..." aria-label="Search"/></form></div><div class="divider hide-tablet-and-desktop"></div><ul class="sections-list"></ul><div class="divider"></div><ul id="main-menu" class="main-menu"></ul></div></nav><cookie_variants><cookie_variant id="a"></cookie_variant><cookie_variant id="b"></cookie_variant><cookie_variant id="c"></cookie_variant><cookie_variant id="d"></cookie_variant><cookie_variant id="e"></cookie_variant><cookie_variant id="f"></cookie_variant><cookie_variant id="g"></cookie_variant><cookie_variant id="h"></cookie_variant></cookie_variants><extra_asset_fields></extra_asset_fields><extra_section_fields></extra_section_fields><post_types_supported></post_types_supported><site_specific_data_schema><site_specific_data_property name="first_name" description="SSO First Name" grouping="" visibility="Public" type="string" default=""></site_specific_data_property><site_specific_data_property name="last_name" description="SSO Last Name" grouping="" visibility="Public" type="string" default=""></site_specific_data_property><site_specific_data_property name="Instagram" description="Add the link to your Instagram account" grouping="Social Networks" visibility="" type="string" default=""></site_specific_data_property><site_specific_data_property name="member_badges" description="Membership Badges" grouping="" visibility="Public" type="string" enum="STAFF EDITOR,CONTRIBUTOR" default=""></site_specific_data_property><site_specific_data_property name="Twitter" description="Add the link to your Twitter account" grouping="Social Networks" visibility="" type="string" default=""></site_specific_data_property><site_specific_data_property name="LinkedIn" description="Add the link to your LinkedIn account" grouping="Social Networks" visibility="" type="string" default=""></site_specific_data_property><site_specific_data_property name="grade" description="SSO Grade" grouping="" visibility="Public" type="string" default=""></site_specific_data_property><site_specific_data_property name="Facebook" description="Add the link to your Facebook account" grouping="Social Networks" visibility="" type="string" default=""></site_specific_data_property></site_specific_data_schema><post_image_settings _9x16="true" _3x1="true" _3x2="true" _1x1="true" _3x4="true" _16x9="true" _4x3="true" _2x1="true"></post_image_settings><div class="all-content-wrapper"><div class="main v-sep"><span class="js-brick-description hidden" data-name="Post"></span><div class="feature_wrapper" id="sPost_0_0_19_0_0_0_3_0"><div class="menu-overlay js-toggle" data-target="body" data-share-status-id="menu-toggle" data-toggle-class="menu-opened"></div><!-- User Code --><script>
    window.PARSELY = window.PARSELY || {};

  	function isPublished(post){
    	return [0,1,2].includes(post.status)
    }
  
  	window.PARSELY.autotrack = false;
    window.PARSELY.onload = function () {
      
      	
        if(Object.keys(window.REBELMOUSE_BOOTSTRAP_DATA.post).length > 0 && !isPublished(window.REBELMOUSE_BOOTSTRAP_DATA.post)){
        	return;
        }
      
        var event = {
          url: location.href,
          urlref: document.referrer,
          js: 1
        };
        window.PARSELY.updateDefaults({
            data: {
                level: localStorage.getItem("userMembershipStatus") || "anonymous"
            }
        });
        window.PARSELY.beacon.trackPageView(event);
    };
</script><!-- End User Code --><!-- User Code --><!-- Google Tag Manager (noscript) --><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5WJB5X2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><!-- End Google Tag Manager (noscript) --><!-- End User Code --><span class="js-brick-description hidden" data-name="CSS Fonts"></span><span class="js-brick-description hidden" data-name="CSS Spectrum"></span><span class="js-brick-description hidden" data-name="CSS for Posts"></span><span class="js-brick-description hidden" data-name="CSS Article Components"></span><span class="js-brick-description hidden" data-name="CSS for Comments"></span><div class="topbar topbar--static" id="sTop_Bar_0_0_27_0_0_13"><div class="" id="sTop_Bar_0_0_27_0_0_13_0"><span class="js-brick-description hidden" data-name="Element Bar"></span><div class="dark_top_bar" id="sElement_Bar_0_0_7_0_0_1"><div class="" id="sElement_Bar_0_0_7_0_0_1_0"><div class="top_menu_links" id="sElement_Bar_0_0_7_0_0_1_0_0"><div class="list" id="sElement_Bar_0_0_7_0_0_1_0_0_0"><a class="list__item" href="https://www.ieee.org/" target="_blank">IEEE.org</a><a class="list__item" href="https://ieeexplore.ieee.org/Xplore/home.jsp" target="_blank">IEEE Xplore Digital Library</a><a class="list__item" href="https://standards.ieee.org/" target="_blank">IEEE Standards</a><a class="list__item" href="https://www.ieee.org/sitemap.html" target="_blank">More Sites</a></div></div><div class="" id="sElement_Bar_0_0_7_0_0_1_0_1"><div class="access_links" id="sElement_Bar_0_0_7_0_0_1_0_1_0_1_1"><div class="list" id="sElement_Bar_0_0_7_0_0_1_0_1_0_1_1_0"><a class="list__item" href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https://spectrum.ieee.org/core/saml/main/login&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" target="_self">Sign In</a><a class="list__item" href="/st/join" target="_self">Join IEEE</a></div></div><div class="" id="sElement_Bar_0_0_7_0_0_1_0_1_1"><!-- User Code --><svg width="70px" height="21px" viewbox="0 0 70 21" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="0 0 21.3639449 0 21.3639449 21 0 21"></polygon></defs><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-IEEE-Bar-/-Signed-out-/-1376" transform="translate(-1274.000000, -14.000000)"><g id="Group-13" transform="translate(1274.000000, 14.000000)"><polygon id="Fill-1" fill="#FEFEFE" points="23.4111174 18.6889405 27.8363724 18.6889405 27.8363724 2.77905063 23.4111174 2.77905063"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="29.7536549 18.6881005 29.7536549 2.77821061 41.9217005 2.77821061 41.9217005 5.8624668 34.17891 5.8624668 34.17891 9.14692664 41.3017712 9.14692664 41.3017712 12.2311828 34.17891 12.2311828 34.17891 15.6024442 41.9217005 15.6024442 41.9217005 18.6881005"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="43.7923126 18.6881005 43.7923126 2.77821061 55.9603583 2.77821061 55.9603583 5.8624668 48.2175677 5.8624668 48.2175677 9.14692664 55.3418347 9.14692664 55.3418347 12.2311828 48.2175677 12.2311828 48.2175677 15.6024442 55.9603583 15.6024442 55.9603583 18.6881005"></polygon><polygon id="Fill-4" fill="#FEFEFE" points="57.8305486 2.77793061 57.8305486 18.6878205 70 18.6878205 70 15.6021642 62.2558037 15.6021642 62.2558037 12.2323028 69.3800707 12.2323028 69.3800707 9.14664663 62.2558037 9.14664663 62.2558037 5.8621868 70 5.8621868 70 2.77793061"></polygon><g id="Group-12"><g id="Group-7"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-6"></g><path d="M20.9520644,9.85449953 L20.8930235,9.84469935 C19.0838421,8.61967703 17.3983653,7.23365178 15.8098843,5.66142314 L14.0555265,3.83578988 C13.3442244,3.05037557 12.6540084,2.18095973 11.9961242,1.35074461 L11.1976665,0.22232405 C11.099265,0.164923005 10.976966,0.0669212192 10.8687244,0.0375206836 C10.6339666,-0.0646811784 10.3795285,0.0571210406 10.1883485,0.202723693 L8.74184673,2.07875787 C6.42378906,4.93900998 3.67838782,7.60885862 0.684171419,9.65429588 C0.448007872,9.84049927 0.0951682866,10.0211026 0.0220700458,10.3235081 C-0.0566511366,10.596513 0.0853281388,10.8219172 0.256827858,10.9913202 C2.65360672,12.6363502 4.94776689,14.5907858 6.98748895,16.8168264 C7.35016869,17.1962333 7.64396739,17.5728401 7.99680697,17.9284466 C8.59424452,18.719461 9.29570648,19.5160755 9.84534902,20.364491 C10.0168487,20.5450943 10.0463692,20.8390996 10.3148646,20.9259012 C10.525725,20.9987026 10.785786,21.0477034 10.9868062,20.9259012 L11.1878263,20.7256976 C13.6675436,17.2256338 16.8149851,14.0825766 20.3293236,11.5429303 C20.6821632,11.2321246 21.3541047,11.1145225 21.3639449,10.5335119 C21.3386417,10.264707 21.182605,10.0015022 20.9520644,9.85449953 M18.5496626,10.7911166 C18.1476223,11.7879348 17.3337015,12.5831492 16.6238051,13.4525651 C15.0845249,15.1017951 13.4623062,16.6992242 11.6432846,17.9718474 C11.2763877,18.2322522 10.7815688,18.4702565 10.3401679,18.2658528 C9.00190778,17.56724 7.87450799,16.4248192 6.7035304,15.3860003 C5.34559001,14.1301774 3.98202667,12.6713508 2.95302836,11.142523 C2.80120893,10.9283191 2.75763114,10.6651143 2.76184834,10.3823091 C2.89398747,9.85449953 3.2566672,9.42049162 3.60107238,8.97668354 C4.81562776,7.43385543 6.30570729,5.96942875 7.80984416,4.63240439 C7.84498755,4.59740376 7.90824564,4.5232024 7.96306932,4.48960179 C8.60970761,3.93379167 9.25212869,3.44098269 9.92828741,2.95657386 C10.6339666,2.41056392 11.5209856,2.86417218 12.114206,3.36678134 C12.7369467,3.83998996 13.383585,4.37759975 13.9529079,4.9236097 L14.0555265,4.98241077 C15.6285445,6.43703727 17.0891035,8.05406673 18.2910073,9.76209785 C18.4864045,10.0603033 18.6579042,10.3963094 18.5496626,10.7911166" id="Fill-5" fill="#FEFEFE" mask="url(#mask-2)"></path></g><path d="M17.8685838,9.92786087 C16.3152462,7.68782006 14.2755241,5.70538394 12.1135031,3.97215236 C11.5554261,3.58154525 10.9087879,2.8983328 10.1876456,3.3869417 C7.9483091,4.92836978 5.79050526,7.01860786 4.05582778,9.15084671 C3.70298819,9.66885615 3.08587035,10.1616651 3.3656117,10.8504777 C3.56663186,11.3586869 4.01646719,11.7240936 4.30604868,12.1735018 C6.00698851,14.2091389 8.01719014,16.1089735 10.1145474,17.6364013 C11.0367098,18.221612 11.6931882,17.2751947 12.4087075,16.8397868 C13.8734838,15.6875658 15.2314242,14.2875403 16.5162664,12.9253155 L16.5162664,12.8917149 C17.0307655,12.2715036 17.5747851,11.6610924 17.9768254,10.9918802 C18.1525424,10.6642743 18.0653868,10.2162661 17.8685838,9.92786087 L17.8685838,9.92786087 Z M10.4477066,5.41697869 L10.6431039,4.79256731 L10.6684071,4.79256731 C11.0704474,5.9391882 11.4865451,7.08300904 11.9181059,8.21422965 L11.0549843,8.22962993 L11.0367098,8.33183179 L11.163226,11.4020877 L11.163226,11.4510886 C10.844124,11.5042896 10.4533296,11.4902893 10.1384449,11.4608888 L10.1145474,11.4258882 L10.2565266,8.26323054 L10.2565266,8.23943011 C10.0161459,8.21422965 9.71250703,8.23943011 9.46790907,8.21422965 L10.4477066,5.41697869 Z M9.93742469,15.6203646 C10.0217688,14.491944 10.0358262,13.4531251 10.0948671,12.3289046 C10.4912844,12.3695053 10.8356896,12.3541051 11.1969636,12.3401048 L11.2222668,12.4913076 L11.3642461,15.6301648 C10.8891076,15.698766 10.3844486,15.6595653 9.93742469,15.6203646 L9.93742469,15.6203646 Z M13.5501647,11.7058933 C11.492168,12.3443049 8.90420917,12.3149044 6.95304844,11.4608888 C6.60020885,11.2900857 6.15459073,11.0268809 6.03650896,10.6166734 C5.94794763,9.86485972 6.75624548,9.44905214 7.30588802,9.17604717 C7.62920717,9.03464459 7.95814925,8.87924176 8.31520604,8.8596414 C8.64836533,9.10324584 8.99698771,9.29924941 9.33998715,9.51765339 C8.67366857,9.69405661 7.87380512,9.84525936 7.56594907,10.5718726 C7.61936702,11.1248827 8.24632501,11.2998859 8.68350872,11.4370884 C10.2565266,11.8514959 11.9574665,11.7968949 13.4672263,11.250885 C13.7511848,11.0842819 14.2024259,10.8840783 14.1630653,10.4752708 C14.1138646,10.0356628 13.6092056,9.84105928 13.256366,9.70245676 C13.0412885,9.73185729 12.8346454,9.78085819 12.6336252,9.84525936 C12.5253836,9.54285385 12.432605,9.23484824 12.3046831,8.94224291 C12.9724074,9.1172461 13.638726,9.29924941 14.3289421,9.41965161 L14.3289421,9.43505189 C14.1869628,9.44905214 14.0309262,9.49805304 13.8931641,9.551254 L13.8931641,9.57645446 C14.2853643,9.77105801 14.8293839,10.0944639 14.8336011,10.6068732 C14.7422283,11.2270845 14.0604466,11.5098897 13.5501647,11.7058933 L13.5501647,11.7058933 Z" id="Fill-8" fill="#FEFEFE"></path><path d="M14.1946944,19.3564726 L14.1946944,19.1646691 L14.3141819,19.1646691 C14.3788457,19.1646691 14.467407,19.1716693 14.467407,19.2528707 C14.467407,19.3410724 14.4224235,19.3564726 14.3465138,19.3564726 L14.1946944,19.3564726 Z M14.1946944,19.4922751 L14.2748213,19.4922751 L14.4603783,19.8268812 L14.6613985,19.8268812 L14.4575669,19.4782749 C14.562997,19.4698747 14.6501526,19.4166737 14.6501526,19.2710711 C14.6501526,19.0890678 14.5278536,19.0302667 14.3226163,19.0302667 L14.0231946,19.0302667 L14.0231946,19.8268812 L14.1946944,19.8268812 L14.1946944,19.4922751 Z M15.0620331,19.429274 C15.0620331,18.9630655 14.7105992,18.6900605 14.3183991,18.6900605 C13.9233874,18.6900605 13.5719536,18.9630655 13.5719536,19.429274 C13.5719536,19.8954825 13.9233874,20.1670874 14.3183991,20.1670874 C14.7105992,20.1670874 15.0620331,19.8954825 15.0620331,19.429274 L15.0620331,19.429274 Z M14.8483613,19.429274 C14.8483613,19.7694802 14.6051691,19.9976843 14.3183991,19.9976843 L14.3183991,19.9962843 C14.0231946,19.9976843 13.7856254,19.7694802 13.7856254,19.429274 C13.7856254,19.0890678 14.0231946,18.8622636 14.3183991,18.8622636 C14.6051691,18.8622636 14.8483613,19.0890678 14.8483613,19.429274 L14.8483613,19.429274 Z" id="Fill-10" fill="#FEFEFE"></path></g></g></g></g></svg><!-- End User Code --></div></div></div></div><div class="topbar-sticky announcement-show" id="sTop_Bar_0_0_27_0_0_13_0_1"><div id="sTop_Bar_0_0_27_0_0_13_0_1_0" class="js-hidden-panel" data-offset="0"></div><div class="rebelbar-wrapper_static announcement-show" id="sTop_Bar_0_0_27_0_0_13_0_1_1"><span class="js-brick-description hidden" data-name="Announcement Bar"></span><span class="js-brick-description hidden" data-name="__TopBar Second Bar"></span><div class="" id="s__TopBar_Second_Bar_0_0_36_0_0_0"><div class="site_logo" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0"><!-- User Code --><a href="/" title="Spectrum Logo"><svg width="214px" height="30px" viewbox="0 0 214 30" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-Sticky-Site-Header-/-1376" transform="translate(-33.000000, -17.000000)" fill="#0D0D0D" fill-rule="nonzero"><g id="IEEE-Spectrum-Logo" transform="translate(32.000000, 15.000000)"><g id="IEEESpectrum-LogoFinal-Black" transform="translate(1.454545, 2.909091)"><path d="M67.5731087,15.3769418 C67.7375958,17.1915012 68.9067885,18.8411007 71.9786975,18.8411007 C74.7749795,18.8411007 75.8285865,17.851341 75.8285865,16.3310345 C75.8285865,14.882062 74.9750314,14.1553466 73.3301597,13.923511 L68.5600317,13.3974225 C64.6123396,12.9515848 62.3361928,10.6911877 62.3361928,6.96398467 C62.3361928,2.83552769 65.4481122,6.3357346e-15 71.7475264,6.3357346e-15 C78.4915004,6.3357346e-15 81.1899792,3.23232323 81.4833887,7.133403 L75.7485657,7.133403 C75.5173945,5.38126088 74.2014972,4.22654127 71.7475264,4.22654127 C69.5247267,4.22654127 68.191047,5.11821665 68.191047,6.57164751 C68.191047,7.6907001 68.8489957,8.51549983 70.5294322,8.71612679 L74.7082955,9.16196447 C79.5095427,9.60780216 81.6834407,11.8994079 81.6834407,15.8495298 C81.6834407,20.1741553 78.984962,23.0765587 71.8764488,23.0765587 C64.6701324,23.0765587 62.1717056,19.3136886 61.9405344,15.390317 L67.5731087,15.3769418 Z" id="Path"></path><path d="M101.439684,14.266806 C101.439684,18.8544758 99.3013506,23.0141414 93.8821651,23.0141414 C91.0858831,23.0141414 89.2098403,21.9575061 88.102886,20.1741553 L88.102886,29.0909091 L82.456975,29.0909091 L82.456975,6.00543365 L88.1162228,6.00543365 L88.1162228,8.23462208 C89.2320682,6.48693835 91.1081111,5.46597005 93.8955019,5.46597005 C99.3013506,5.47934518 101.439684,9.53646813 101.439684,14.266806 Z M95.7804359,14.266806 C95.7804359,11.1994427 94.7935129,9.91097179 91.997231,9.91097179 C89.1031459,9.91097179 88.1162228,11.3287356 88.1162228,14.266806 C88.1162228,17.2048763 89.1031459,18.6226402 91.997231,18.6226402 C94.7935129,18.6092651 95.7804359,17.3207941 95.7804359,14.266806 Z" id="Shape"></path><path d="M114.367486,17.5214211 L119.862247,17.5214211 C119.302102,20.3569488 117.065965,23.0319749 111.077743,23.0319749 C104.364888,23.0319749 101.995384,18.7430164 101.995384,14.2222222 C101.995384,9.43838384 104.760546,5.47934518 111.077743,5.47934518 C117.790598,5.47934518 119.928931,9.73263671 119.928931,14.3203065 C119.934228,14.7845667 119.900021,15.2484337 119.826682,15.7068617 L107.490144,15.7068617 C107.819119,18.3462208 109.103897,19.2378962 111.211111,19.2378962 C112.887102,19.2378962 113.905144,18.5111808 114.367486,17.5214211 Z M107.556828,12.4076628 L114.563093,12.4076628 C114.367486,10.3256008 113.349444,9.20654824 111.144427,9.20654824 C109.103897,9.20654824 107.921368,10.031348 107.556828,12.4076628 Z" id="Shape"></path><path d="M129.811498,5.47934518 C135.764156,5.47934518 138.662686,8.84096134 138.791609,12.9649599 L133.247946,12.9649599 C133.083459,11.0211076 132.096536,9.89759666 129.895965,9.89759666 C127.52646,9.89759666 126.174998,10.954232 126.174998,14.2534309 C126.174998,17.5526297 127.459776,18.6092651 129.793716,18.6092651 C132.127655,18.6092651 133.119024,17.3207941 133.31463,15.4884013 L138.876075,15.4884013 C138.742707,19.4162313 136.013109,23.0141966 129.895965,23.0141966 C123.085307,23.0319749 120.520196,18.7251829 120.520196,14.266806 C120.520196,9.80842912 123.018623,5.47934518 129.811498,5.47934518 Z" id="Path"></path><path d="M141.77016,16.0011146 L141.77016,10.2542668 L138.876075,10.2542668 L138.876075,7.62382445 L142.228057,6.13472658 L144.566442,2.01072797 L147.429408,2.01072797 L147.429408,6.02326715 L151.901681,6.02326715 L151.901681,10.2542668 L147.429408,10.2542668 L147.429408,18.0163009 L151.3771,18.0163009 L151.3771,22.5014281 L148.380766,22.5014281 C143.348348,22.5014281 141.77016,20.2588645 141.77016,16.0011146 Z" id="Path"></path><path d="M164.304903,5.74238941 L164.304903,11.2529432 L162.299938,11.2529432 C159.565894,11.2529432 158.414484,12.5904563 158.414484,15.9030303 L158.414484,22.5014281 L152.755236,22.5014281 L152.755236,6.00543365 L158.263333,6.00543365 L158.263333,9.36259143 C158.921282,7.0174852 160.272744,5.73347266 162.935658,5.73347266 L164.304903,5.74238941 Z" id="Path"></path><path d="M182.989757,6.00543365 L182.989757,22.5014281 L177.330509,22.5014281 L177.330509,19.5009404 C176.281347,21.6454197 174.405304,23.0319749 171.511219,23.0319749 C167.198988,23.0319749 165.256261,20.3569488 165.256261,16.0367816 L165.256261,6.00543365 L170.915509,6.00543365 L170.915509,15.0470219 C170.915509,17.2762104 171.804629,18.4443051 173.81404,18.4443051 C176.014611,18.4443051 177.330509,16.9239986 177.330509,13.758551 L177.330509,6.00543365 L182.989757,6.00543365 Z" id="Path"></path><path d="M213.090909,12.4834552 L213.090909,22.5148032 L207.431661,22.5148032 L207.431661,13.3305468 C207.431661,11.2172762 206.613671,10.0625566 204.737628,10.0625566 C202.514828,10.0625566 201.479004,11.5159875 201.479004,14.7483107 L201.479004,22.5014281 L195.917559,22.5014281 L195.917559,13.3305468 C195.917559,11.2172762 195.095123,10.0625566 193.223526,10.0625566 C191.000726,10.0625566 189.964902,11.5159875 189.964902,14.7483107 L189.964902,22.5014281 L184.305654,22.5014281 L184.305654,6.00543365 L189.964902,6.00543365 L189.964902,8.8097527 C190.982944,6.76335772 192.725619,5.47934518 195.557466,5.47934518 C198.389312,5.47934518 200.163106,6.81685824 200.985542,9.13967259 C202.003585,6.91048415 203.812943,5.47934518 206.809277,5.47934518 C211.117063,5.47934518 213.090909,8.14991292 213.090909,12.4834552 Z" id="Path"></path><polygon id="Path" points="11.9408796 7.10219436 11.9408796 3.0450714 0 3.0450714 0 7.10219436 3.14303867 7.10219436 3.14303867 18.4086381 0 18.4086381 0 22.4702194 11.9408796 22.4702194 11.9408796 18.4086381 8.80228652 18.4086381 8.80228652 7.10219436"></polygon><polygon id="Path" points="18.8537864 18.4086381 18.8537864 14.467433 26.0378748 14.467433 26.0378748 10.6956461 18.8537864 10.6956461 18.8537864 7.10219436 26.9136579 7.10219436 26.9136579 3.0450714 18.8537864 3.0450714 13.1945386 3.0450714 13.1945386 22.4613027 13.1945386 22.4702194 27.0025699 22.4702194 27.0025699 18.4086381"></polygon><polygon id="Path" points="33.6487408 18.4086381 33.6487408 14.467433 40.8372748 14.467433 40.8372748 10.6956461 33.6487408 10.6956461 33.6487408 7.10219436 41.7086122 7.10219436 41.7086122 3.0450714 33.6487408 3.0450714 27.9939385 3.0450714 27.9939385 22.4613027 27.9939385 22.4702194 41.7975242 22.4702194 41.7975242 18.4086381"></polygon><polygon id="Path" points="48.4481407 18.4086381 48.4481407 14.467433 55.6322291 14.467433 55.6322291 10.6956461 48.4481407 10.6956461 48.4481407 7.10219436 56.5080121 7.10219436 56.5080121 3.0450714 48.4481407 3.0450714 42.7888928 3.0450714 42.7888928 22.4613027 42.7888928 22.4702194 56.5924785 22.4702194 56.5924785 18.4086381"></polygon></g></g></g></g></svg></a><!-- End User Code --><div class="topbar__sticky-headline topbar__sticky-headline--post" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0_1_0_1"><div class="text-element" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0_1_0_1_0">How the Graphical User Interface Was Invented</div></div><!-- User Code --><span class="floating-shares hide-desktop">Share</span><!-- End User Code --><!-- User Code --><script>
  function createElementChangeListener(selector, callback, oneTime) {
    const initializedNodes = new Set([]);
    let reported = false;

    document.querySelectorAll(selector).forEach((node) => {
      if (oneTime && reported) {
        return;
      }
      reported = true;
      callback(node);
      initializedNodes.add(node);
    });

    const mutationObserver = new MutationObserver(() => {
      const nodes = document.querySelectorAll(selector);
      nodes.forEach((node) => {
        if (oneTime && reported) {
          return;
        }

        if (!initializedNodes.has(node)) {
          reported = true;
          callback(node);
          initializedNodes.add(node);
          if (oneTime) {
            mutationObserver.disconnect();
          }
        }
      });
    });

    if (!oneTime || !reported) {
      mutationObserver.observe(document.body, {
        childList: true,
        subtree: true,
      });
    }
    return mutationObserver;
  }
  
</script><!-- End User Code --><div class="topbar__static-headline" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0_2"><div class="text-element" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0_2_0">FOR THE TECHNOLOGY INSIDER</div></div></div><div class="" id="s__TopBar_Second_Bar_0_0_36_0_0_0_1"><div class="search-form"><form action="/search/"><label for="q" class="hide-text">Search: </label><input placeholder="Type to search" type="text" name="q" id="q" class="search-form__text-input"/><button aria-label="Search" type="submit" class="search-form__submit" value="Search"><svg width="18px" height="19px" viewbox="0 0 18 19" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="1376---Sample-Front-Page" transform="translate(-826.000000, -102.000000)" stroke="#0D0D0D" stroke-width="1.5"><g id="Light-/-Nav" transform="translate(816.857864, 96.000000)"><g id="Search-Icon" transform="translate(7.307612, 5.000000)"><path d="M11.631728,14.6819805 C15.2215789,14.6819805 18.131728,11.7718314 18.131728,8.18198052 C18.131728,4.59212964 15.2215789,1.68198052 11.631728,1.68198052 C8.04187711,1.68198052 5.13172798,4.59212964 5.13172798,8.18198052 C5.13172798,11.7718314 8.04187711,14.6819805 11.631728,14.6819805 Z M11.631728,14.5814755 L11.631728,21.5814755" id="Combined-Shape" transform="translate(11.631728, 11.631728) rotate(-45.000000) translate(-11.631728, -11.631728) "></path></g></g></g></g></svg></button></form></div><span class="js-brick-description hidden" data-name="Element Menu"></span><div class="main-menu-el" id="sElement_Menu_0_0_8_0_0_0"><div class="menu-item" id="sElement_Menu_0_0_8_0_0_0_0"><!-- User Code --><div class="menu-item__title">Explore by topic</div><!-- End User Code --><div class="menu-dropdown" id="sElement_Menu_0_0_8_0_0_0_0_1"><div class="list" id="sElement_Menu_0_0_8_0_0_0_0_1_0"><a class="list__item" href="/topic/aerospace/" target="_self">Aerospace</a><a class="list__item" href="/topic/artificial-intelligence/" target="_self">Artificial Intelligence</a><a class="list__item" href="/topic/biomedical/" target="_self">Biomedical</a><a class="list__item" href="/topic/computing/" target="_self">Computing</a><a class="list__item" href="/topic/consumer-electronics/" target="_self">Consumer Electronics</a><a class="list__item" href="/topic/energy/" target="_self">Energy</a><a class="list__item" href="/topic/tech-history/" target="_self">History of Technology</a><a class="list__item" href="/topic/robotics/" target="_self">Robotics</a><a class="list__item" href="/topic/semiconductors/" target="_self">Semiconductors</a><a class="list__item" href="/topic/sensors/" target="_self">Sensors</a><a class="list__item" href="/topic/telecommunications/" target="_self">Telecommunications</a><a class="list__item" href="/topic/transportation/" target="_self">Transportation</a></div></div></div></div><!-- User Code --><div data-share-status-id="huge-menu-toggle" data-toggle-class="huge-menu-opened" class="rebelbar__menu-toggle js-toggle hambg-btn" data-target="body"><svg width="32px" height="18px" viewbox="0 0 32 18" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="992---Search---Open-filters---selected" transform="translate(-928.000000, -75.000000)"><g id="Light-/-Collapsed-Site-Header" transform="translate(0.000000, 56.000000)"><g id="Light-/-Nav" transform="translate(432.857864, 12.000000)"><g id="Group" transform="translate(495.142136, 7.000000)"><rect id="Rectangle" x="0" y="0" width="32" height="2"></rect><rect id="Rectangle-Copy" x="0" y="8" width="32" height="2"></rect><rect id="Rectangle-Copy-2" x="0" y="16" width="32" height="2"></rect></g></g></g></g></g></svg></div><!-- End User Code --></div></div></div></div></div></div><div class="huge-menu" id="sTop_Bar_0_0_27_0_0_14"><span class="js-brick-description hidden" data-name="__Huge Menu Links"></span><div id="s__Huge_Menu_Links_0_0_32_0_0_1" class="dark_layout row-wrapper clearfix  content sm-cp-2 md-cp-4"><div class="row px20"><div id="s__Huge_Menu_Links_0_0_32_0_0_1_0" class="Top_hugeMenu col sm-mb-2 md-mb-4 s12 m12 l12"><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_0_0"><!-- User Code --><a href="/" class="hide-text">IEEE Spectrum<svg width="214px" height="30px" class="site_logo_menu" viewbox="0 0 214 30" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-Sticky-Site-Header-/-1376" transform="translate(-33.000000, -17.000000)" fill="#F2F2F2" fill-rule="nonzero"><g id="IEEE-Spectrum-Logo" transform="translate(32.000000, 15.000000)"><g id="IEEESpectrum-LogoFinal-Black" transform="translate(1.454545, 2.909091)"><path d="M67.5731087,15.3769418 C67.7375958,17.1915012 68.9067885,18.8411007 71.9786975,18.8411007 C74.7749795,18.8411007 75.8285865,17.851341 75.8285865,16.3310345 C75.8285865,14.882062 74.9750314,14.1553466 73.3301597,13.923511 L68.5600317,13.3974225 C64.6123396,12.9515848 62.3361928,10.6911877 62.3361928,6.96398467 C62.3361928,2.83552769 65.4481122,6.3357346e-15 71.7475264,6.3357346e-15 C78.4915004,6.3357346e-15 81.1899792,3.23232323 81.4833887,7.133403 L75.7485657,7.133403 C75.5173945,5.38126088 74.2014972,4.22654127 71.7475264,4.22654127 C69.5247267,4.22654127 68.191047,5.11821665 68.191047,6.57164751 C68.191047,7.6907001 68.8489957,8.51549983 70.5294322,8.71612679 L74.7082955,9.16196447 C79.5095427,9.60780216 81.6834407,11.8994079 81.6834407,15.8495298 C81.6834407,20.1741553 78.984962,23.0765587 71.8764488,23.0765587 C64.6701324,23.0765587 62.1717056,19.3136886 61.9405344,15.390317 L67.5731087,15.3769418 Z" id="Path"></path><path d="M101.439684,14.266806 C101.439684,18.8544758 99.3013506,23.0141414 93.8821651,23.0141414 C91.0858831,23.0141414 89.2098403,21.9575061 88.102886,20.1741553 L88.102886,29.0909091 L82.456975,29.0909091 L82.456975,6.00543365 L88.1162228,6.00543365 L88.1162228,8.23462208 C89.2320682,6.48693835 91.1081111,5.46597005 93.8955019,5.46597005 C99.3013506,5.47934518 101.439684,9.53646813 101.439684,14.266806 Z M95.7804359,14.266806 C95.7804359,11.1994427 94.7935129,9.91097179 91.997231,9.91097179 C89.1031459,9.91097179 88.1162228,11.3287356 88.1162228,14.266806 C88.1162228,17.2048763 89.1031459,18.6226402 91.997231,18.6226402 C94.7935129,18.6092651 95.7804359,17.3207941 95.7804359,14.266806 Z" id="Shape"></path><path d="M114.367486,17.5214211 L119.862247,17.5214211 C119.302102,20.3569488 117.065965,23.0319749 111.077743,23.0319749 C104.364888,23.0319749 101.995384,18.7430164 101.995384,14.2222222 C101.995384,9.43838384 104.760546,5.47934518 111.077743,5.47934518 C117.790598,5.47934518 119.928931,9.73263671 119.928931,14.3203065 C119.934228,14.7845667 119.900021,15.2484337 119.826682,15.7068617 L107.490144,15.7068617 C107.819119,18.3462208 109.103897,19.2378962 111.211111,19.2378962 C112.887102,19.2378962 113.905144,18.5111808 114.367486,17.5214211 Z M107.556828,12.4076628 L114.563093,12.4076628 C114.367486,10.3256008 113.349444,9.20654824 111.144427,9.20654824 C109.103897,9.20654824 107.921368,10.031348 107.556828,12.4076628 Z" id="Shape"></path><path d="M129.811498,5.47934518 C135.764156,5.47934518 138.662686,8.84096134 138.791609,12.9649599 L133.247946,12.9649599 C133.083459,11.0211076 132.096536,9.89759666 129.895965,9.89759666 C127.52646,9.89759666 126.174998,10.954232 126.174998,14.2534309 C126.174998,17.5526297 127.459776,18.6092651 129.793716,18.6092651 C132.127655,18.6092651 133.119024,17.3207941 133.31463,15.4884013 L138.876075,15.4884013 C138.742707,19.4162313 136.013109,23.0141966 129.895965,23.0141966 C123.085307,23.0319749 120.520196,18.7251829 120.520196,14.266806 C120.520196,9.80842912 123.018623,5.47934518 129.811498,5.47934518 Z" id="Path"></path><path d="M141.77016,16.0011146 L141.77016,10.2542668 L138.876075,10.2542668 L138.876075,7.62382445 L142.228057,6.13472658 L144.566442,2.01072797 L147.429408,2.01072797 L147.429408,6.02326715 L151.901681,6.02326715 L151.901681,10.2542668 L147.429408,10.2542668 L147.429408,18.0163009 L151.3771,18.0163009 L151.3771,22.5014281 L148.380766,22.5014281 C143.348348,22.5014281 141.77016,20.2588645 141.77016,16.0011146 Z" id="Path"></path><path d="M164.304903,5.74238941 L164.304903,11.2529432 L162.299938,11.2529432 C159.565894,11.2529432 158.414484,12.5904563 158.414484,15.9030303 L158.414484,22.5014281 L152.755236,22.5014281 L152.755236,6.00543365 L158.263333,6.00543365 L158.263333,9.36259143 C158.921282,7.0174852 160.272744,5.73347266 162.935658,5.73347266 L164.304903,5.74238941 Z" id="Path"></path><path d="M182.989757,6.00543365 L182.989757,22.5014281 L177.330509,22.5014281 L177.330509,19.5009404 C176.281347,21.6454197 174.405304,23.0319749 171.511219,23.0319749 C167.198988,23.0319749 165.256261,20.3569488 165.256261,16.0367816 L165.256261,6.00543365 L170.915509,6.00543365 L170.915509,15.0470219 C170.915509,17.2762104 171.804629,18.4443051 173.81404,18.4443051 C176.014611,18.4443051 177.330509,16.9239986 177.330509,13.758551 L177.330509,6.00543365 L182.989757,6.00543365 Z" id="Path"></path><path d="M213.090909,12.4834552 L213.090909,22.5148032 L207.431661,22.5148032 L207.431661,13.3305468 C207.431661,11.2172762 206.613671,10.0625566 204.737628,10.0625566 C202.514828,10.0625566 201.479004,11.5159875 201.479004,14.7483107 L201.479004,22.5014281 L195.917559,22.5014281 L195.917559,13.3305468 C195.917559,11.2172762 195.095123,10.0625566 193.223526,10.0625566 C191.000726,10.0625566 189.964902,11.5159875 189.964902,14.7483107 L189.964902,22.5014281 L184.305654,22.5014281 L184.305654,6.00543365 L189.964902,6.00543365 L189.964902,8.8097527 C190.982944,6.76335772 192.725619,5.47934518 195.557466,5.47934518 C198.389312,5.47934518 200.163106,6.81685824 200.985542,9.13967259 C202.003585,6.91048415 203.812943,5.47934518 206.809277,5.47934518 C211.117063,5.47934518 213.090909,8.14991292 213.090909,12.4834552 Z" id="Path"></path><polygon id="Path" points="11.9408796 7.10219436 11.9408796 3.0450714 0 3.0450714 0 7.10219436 3.14303867 7.10219436 3.14303867 18.4086381 0 18.4086381 0 22.4702194 11.9408796 22.4702194 11.9408796 18.4086381 8.80228652 18.4086381 8.80228652 7.10219436"></polygon><polygon id="Path" points="18.8537864 18.4086381 18.8537864 14.467433 26.0378748 14.467433 26.0378748 10.6956461 18.8537864 10.6956461 18.8537864 7.10219436 26.9136579 7.10219436 26.9136579 3.0450714 18.8537864 3.0450714 13.1945386 3.0450714 13.1945386 22.4613027 13.1945386 22.4702194 27.0025699 22.4702194 27.0025699 18.4086381"></polygon><polygon id="Path" points="33.6487408 18.4086381 33.6487408 14.467433 40.8372748 14.467433 40.8372748 10.6956461 33.6487408 10.6956461 33.6487408 7.10219436 41.7086122 7.10219436 41.7086122 3.0450714 33.6487408 3.0450714 27.9939385 3.0450714 27.9939385 22.4613027 27.9939385 22.4702194 41.7975242 22.4702194 41.7975242 18.4086381"></polygon><polygon id="Path" points="48.4481407 18.4086381 48.4481407 14.467433 55.6322291 14.467433 55.6322291 10.6956461 48.4481407 10.6956461 48.4481407 7.10219436 56.5080121 7.10219436 56.5080121 3.0450714 48.4481407 3.0450714 42.7888928 3.0450714 42.7888928 22.4613027 42.7888928 22.4702194 56.5924785 22.4702194 56.5924785 18.4086381"></polygon></g></g></g></g></svg></a><!-- End User Code --><div class="text-element" id="s__Huge_Menu_Links_0_0_32_0_0_1_0_0_1">FOR THE TECHNOLOGY INSIDER</div><!-- User Code --><div data-share-status-id="huge-menu-toggle" data-toggle-class="huge-menu-opened" class="rebelbar__menu-toggle js-toggle hm__close js--active" data-target="body" data-loaded="true"></div><!-- End User Code --></div></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_1" class="top-menu top-menu--big-links col sm-mb-2 md-mb-4 s12 m12 l6"><!-- User Code --><h3 class="module-headline__text">Topics</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_1_1"><a class="list__item" href="/topic/aerospace/" target="_self">Aerospace</a><a class="list__item" href="/topic/artificial-intelligence/" target="_self">Artificial Intelligence</a><a class="list__item" href="/topic/biomedical/" target="_self">Biomedical</a><a class="list__item" href="/topic/computing/" target="_self">Computing</a><a class="list__item" href="/topic/consumer-electronics/" target="_self">Consumer Electronics</a><a class="list__item" href="/topic/energy/" target="_self">Energy</a><a class="list__item" href="/topic/tech-history/" target="_self">History of Technology</a><a class="list__item" href="/topic/robotics/" target="_self">Robotics</a><a class="list__item" href="/topic/semiconductors/" target="_self">Semiconductors</a><a class="list__item" href="/topic/sensors/" target="_self">Sensors</a><a class="list__item" href="/topic/telecommunications/" target="_self">Telecommunications</a><a class="list__item" href="/topic/transportation/" target="_self">Transportation</a></div></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_2" class="top-menu top-menu--sm-links col sm-mb-2 md-mb-4 s6 m12 l3"><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_0"><!-- User Code --><h3 class="module-headline__text">Sections</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_0_1"><a class="list__item" href="/type/feature/" target="_self">Features</a><a class="list__item" href="/type/news/" target="_self">News</a><a class="list__item" href="/type/opinion/" target="_self">Opinion</a><a class="list__item" href="/topic/careers/" target="_self">Careers</a><a class="list__item" href="/topic/diy/" target="_self">DIY</a><a class="list__item" href="/type/the-big-picture/" target="_self">The Big Picture</a><a class="list__item" href="/engineering-resources/" target="_self">Engineering Resources</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_1"><!-- User Code --><h3 class="module-headline__text">More</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_1_1"><a class="list__item" href="/special-reports/" target="_self">Special Reports</a><a class="list__item" href="/collections/" target="_self">Collections</a><a class="list__item" href="/type/explainer/" target="_self">Explainers</a><a class="list__item" href="/type/podcast/" target="_self">Podcasts</a><a class="list__item" href="/type/video/" target="_self">Videos</a><a class="list__item" href="/newsletters/" target="_self">Newsletters</a><a class="list__item" href="/top-programming-languages" target="_self">Top Programming Languages</a><a class="list__item" href="https://robots.ieee.org/" target="_blank">Robots Guide</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_2"><!-- User Code --><h3 class="module-headline__text">For IEEE Members</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_2_1"><a class="list__item" href="/magazine/current-issue" target="_self">Current Issue</a><a class="list__item" href="/magazine/" target="_self">Magazine Archive</a><a class="list__item" href="/the-institute/" target="_self">The Institute</a><a class="list__item" href="/the-institute/ti-archive/" target="_self">TI Archive</a></div></div></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_3" class="top-menu top-menu--sm-links col sm-mb-2 md-mb-4 s6 m12 l3"><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_0"><!-- User Code --><h3 class="module-headline__text">For IEEE Members</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_0_1"><a class="list__item" href="/magazine/current-issue" target="_self">Current Issue</a><a class="list__item" href="/magazine/" target="_self">Magazine Archive</a><a class="list__item" href="/the-institute/" target="_self">The Institute</a><a class="list__item" href="/the-institute/ti-archive/" target="_self">TI Archive</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_1"><!-- User Code --><h3 class="module-headline__text">IEEE Spectrum</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_1_1"><a class="list__item" href="/st/about" target="_self">About Us</a><a class="list__item" href="/st/contact" target="_self">Contact Us</a><a class="list__item" href="https://www.parsintl.com/publications/ieee-media/" target="_blank">Reprints &amp; Permissions</a><a class="list__item" href="https://advertise.ieee.org/ " target="_blank">Advertising</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_2"><!-- User Code --><h3 class="module-headline__text">Follow IEEE Spectrum</h3><!-- End User Code --><div class="sm-mb-2" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_2_1"><div class="social-links"><a class="social-links__link share-twitter" href="https://twitter.com/ieeespectrum" target="_blank" rel="noopener noreferrer" aria-label="Open twitter"><span aria-hidden="true" class="fa fa-twitter"></span></a><a class="social-links__link share-facebook" href="https://www.facebook.com/IEEE.Spectrum" target="_blank" rel="noopener noreferrer" aria-label="Open facebook"><span aria-hidden="true" class="fa fa-facebook"></span></a><a class="social-links__link share-instagram" href="https://www.instagram.com/ieeespectrum/" target="_blank" rel="noopener noreferrer" aria-label="Open instagram"><span aria-hidden="true" class="fa fa-instagram"></span></a><a class="social-links__link share-linkedin" href="https://www.linkedin.com/company/ieee-spectrum/" target="_blank" rel="noopener noreferrer" aria-label="Open linkedin"><span aria-hidden="true" class="fa fa-linkedin"></span></a><a class="social-links__link share-youtube" href="https://www.youtube.com/c/ieeespectrum" target="_blank" rel="noopener noreferrer" aria-label="Open youtube"><span aria-hidden="true" class="fa fa-youtube"></span></a><a class="social-links__link share-tumblr" href="/feeds/feed.rss" target="_blank" rel="noopener noreferrer" aria-label="Open tumblr"><span aria-hidden="true" class="fa fa-tumblr"></span></a></div></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_3"><!-- User Code --><h3 class="module-headline__text">Support IEEE Spectrum</h3><!-- End User Code --><div class="text-element" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_3_1"><i>IEEE Spectrum</i> is the flagship publication of the IEEE — the world’s largest professional organization devoted to engineering and applied sciences. Our articles, podcasts, and infographics inform our readers about developments in technology, engineering, and science.</div><div class="text-element" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_3_2"><a class="color-inherit" href="/st/join" target="_self" rel="orange_button">Join IEEE</a></div><div class="text-element" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_3_3"><a class="color-inherit" href="https://ieee.omeda.com/ieee/r-main.do" target="_blank" rel="orange_button">Subscribe</a></div></div></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_4" class=" col sm-mb-2 md-mb-4 s12 m12 l12"></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_5" class=" col sm-mb-2 md-mb-4 s12 m12 l12"><span class="js-brick-description hidden" data-name="Footer"></span><div class="footer" id="sFooter_0_0_9_0_0_0"><div class="" id="sFooter_0_0_9_0_0_0_0"><div id="sFooter_0_0_9_0_0_0_0_0" class=" row-wrapper clearfix  content sm-cp-2 md-cp-4"><div class="row "><div id="sFooter_0_0_9_0_0_0_0_0_0" class=" col sm-mb-2 md-mb-4 s12 m10 l10"><div class="bottom_menu_links" id="sFooter_0_0_9_0_0_0_0_0_0_0"><div class="list" id="sFooter_0_0_9_0_0_0_0_0_0_0_0"><a class="list__item" href="https://www.ieee.org/about/" target="_blank">About IEEE</a><a class="list__item" href="https://www.ieee.org/about/contact.html" target="_blank">Contact &amp; Support</a><a class="list__item" href="https://www.ieee.org/accessibility-statement.html" target="_blank">Accessibility</a><a class="list__item" href="https://www.ieee.org/about/corporate/governance/p9-26.html" target="_blank">Nondiscrimination Policy</a><a class="list__item" href="https://www.ieee.org/about/help/site-terms-conditions.html" target="_blank">Terms</a><a class="list__item" href="https://www.ieee.org/security-privacy.html" target="_blank">IEEE Privacy Policy</a></div></div><div class="ftr-copy" id="sFooter_0_0_9_0_0_0_0_0_0_1">© Copyright 2022 IEEE — All rights reserved. A not-for-profit organization, IEEE is the world&#39;s largest technical professional organization dedicated to advancing technology for the benefit of humanity.</div></div><div id="sFooter_0_0_9_0_0_0_0_0_1" class=" col sm-mb-2 md-mb-4 s12 m2 l2"><!-- User Code --><svg viewbox="0 0 70 21" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="0 0 21.3639449 0 21.3639449 21 0 21"></polygon></defs><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-IEEE-Bar-/-Signed-out-/-1376" transform="translate(-1274.000000, -14.000000)"><g id="Group-13" transform="translate(1274.000000, 14.000000)"><polygon id="Fill-1" fill="#FEFEFE" points="23.4111174 18.6889405 27.8363724 18.6889405 27.8363724 2.77905063 23.4111174 2.77905063"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="29.7536549 18.6881005 29.7536549 2.77821061 41.9217005 2.77821061 41.9217005 5.8624668 34.17891 5.8624668 34.17891 9.14692664 41.3017712 9.14692664 41.3017712 12.2311828 34.17891 12.2311828 34.17891 15.6024442 41.9217005 15.6024442 41.9217005 18.6881005"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="43.7923126 18.6881005 43.7923126 2.77821061 55.9603583 2.77821061 55.9603583 5.8624668 48.2175677 5.8624668 48.2175677 9.14692664 55.3418347 9.14692664 55.3418347 12.2311828 48.2175677 12.2311828 48.2175677 15.6024442 55.9603583 15.6024442 55.9603583 18.6881005"></polygon><polygon id="Fill-4" fill="#FEFEFE" points="57.8305486 2.77793061 57.8305486 18.6878205 70 18.6878205 70 15.6021642 62.2558037 15.6021642 62.2558037 12.2323028 69.3800707 12.2323028 69.3800707 9.14664663 62.2558037 9.14664663 62.2558037 5.8621868 70 5.8621868 70 2.77793061"></polygon><g id="Group-12"><g id="Group-7"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-6"></g><path d="M20.9520644,9.85449953 L20.8930235,9.84469935 C19.0838421,8.61967703 17.3983653,7.23365178 15.8098843,5.66142314 L14.0555265,3.83578988 C13.3442244,3.05037557 12.6540084,2.18095973 11.9961242,1.35074461 L11.1976665,0.22232405 C11.099265,0.164923005 10.976966,0.0669212192 10.8687244,0.0375206836 C10.6339666,-0.0646811784 10.3795285,0.0571210406 10.1883485,0.202723693 L8.74184673,2.07875787 C6.42378906,4.93900998 3.67838782,7.60885862 0.684171419,9.65429588 C0.448007872,9.84049927 0.0951682866,10.0211026 0.0220700458,10.3235081 C-0.0566511366,10.596513 0.0853281388,10.8219172 0.256827858,10.9913202 C2.65360672,12.6363502 4.94776689,14.5907858 6.98748895,16.8168264 C7.35016869,17.1962333 7.64396739,17.5728401 7.99680697,17.9284466 C8.59424452,18.719461 9.29570648,19.5160755 9.84534902,20.364491 C10.0168487,20.5450943 10.0463692,20.8390996 10.3148646,20.9259012 C10.525725,20.9987026 10.785786,21.0477034 10.9868062,20.9259012 L11.1878263,20.7256976 C13.6675436,17.2256338 16.8149851,14.0825766 20.3293236,11.5429303 C20.6821632,11.2321246 21.3541047,11.1145225 21.3639449,10.5335119 C21.3386417,10.264707 21.182605,10.0015022 20.9520644,9.85449953 M18.5496626,10.7911166 C18.1476223,11.7879348 17.3337015,12.5831492 16.6238051,13.4525651 C15.0845249,15.1017951 13.4623062,16.6992242 11.6432846,17.9718474 C11.2763877,18.2322522 10.7815688,18.4702565 10.3401679,18.2658528 C9.00190778,17.56724 7.87450799,16.4248192 6.7035304,15.3860003 C5.34559001,14.1301774 3.98202667,12.6713508 2.95302836,11.142523 C2.80120893,10.9283191 2.75763114,10.6651143 2.76184834,10.3823091 C2.89398747,9.85449953 3.2566672,9.42049162 3.60107238,8.97668354 C4.81562776,7.43385543 6.30570729,5.96942875 7.80984416,4.63240439 C7.84498755,4.59740376 7.90824564,4.5232024 7.96306932,4.48960179 C8.60970761,3.93379167 9.25212869,3.44098269 9.92828741,2.95657386 C10.6339666,2.41056392 11.5209856,2.86417218 12.114206,3.36678134 C12.7369467,3.83998996 13.383585,4.37759975 13.9529079,4.9236097 L14.0555265,4.98241077 C15.6285445,6.43703727 17.0891035,8.05406673 18.2910073,9.76209785 C18.4864045,10.0603033 18.6579042,10.3963094 18.5496626,10.7911166" id="Fill-5" fill="#FEFEFE" mask="url(#mask-2)"></path></g><path d="M17.8685838,9.92786087 C16.3152462,7.68782006 14.2755241,5.70538394 12.1135031,3.97215236 C11.5554261,3.58154525 10.9087879,2.8983328 10.1876456,3.3869417 C7.9483091,4.92836978 5.79050526,7.01860786 4.05582778,9.15084671 C3.70298819,9.66885615 3.08587035,10.1616651 3.3656117,10.8504777 C3.56663186,11.3586869 4.01646719,11.7240936 4.30604868,12.1735018 C6.00698851,14.2091389 8.01719014,16.1089735 10.1145474,17.6364013 C11.0367098,18.221612 11.6931882,17.2751947 12.4087075,16.8397868 C13.8734838,15.6875658 15.2314242,14.2875403 16.5162664,12.9253155 L16.5162664,12.8917149 C17.0307655,12.2715036 17.5747851,11.6610924 17.9768254,10.9918802 C18.1525424,10.6642743 18.0653868,10.2162661 17.8685838,9.92786087 L17.8685838,9.92786087 Z M10.4477066,5.41697869 L10.6431039,4.79256731 L10.6684071,4.79256731 C11.0704474,5.9391882 11.4865451,7.08300904 11.9181059,8.21422965 L11.0549843,8.22962993 L11.0367098,8.33183179 L11.163226,11.4020877 L11.163226,11.4510886 C10.844124,11.5042896 10.4533296,11.4902893 10.1384449,11.4608888 L10.1145474,11.4258882 L10.2565266,8.26323054 L10.2565266,8.23943011 C10.0161459,8.21422965 9.71250703,8.23943011 9.46790907,8.21422965 L10.4477066,5.41697869 Z M9.93742469,15.6203646 C10.0217688,14.491944 10.0358262,13.4531251 10.0948671,12.3289046 C10.4912844,12.3695053 10.8356896,12.3541051 11.1969636,12.3401048 L11.2222668,12.4913076 L11.3642461,15.6301648 C10.8891076,15.698766 10.3844486,15.6595653 9.93742469,15.6203646 L9.93742469,15.6203646 Z M13.5501647,11.7058933 C11.492168,12.3443049 8.90420917,12.3149044 6.95304844,11.4608888 C6.60020885,11.2900857 6.15459073,11.0268809 6.03650896,10.6166734 C5.94794763,9.86485972 6.75624548,9.44905214 7.30588802,9.17604717 C7.62920717,9.03464459 7.95814925,8.87924176 8.31520604,8.8596414 C8.64836533,9.10324584 8.99698771,9.29924941 9.33998715,9.51765339 C8.67366857,9.69405661 7.87380512,9.84525936 7.56594907,10.5718726 C7.61936702,11.1248827 8.24632501,11.2998859 8.68350872,11.4370884 C10.2565266,11.8514959 11.9574665,11.7968949 13.4672263,11.250885 C13.7511848,11.0842819 14.2024259,10.8840783 14.1630653,10.4752708 C14.1138646,10.0356628 13.6092056,9.84105928 13.256366,9.70245676 C13.0412885,9.73185729 12.8346454,9.78085819 12.6336252,9.84525936 C12.5253836,9.54285385 12.432605,9.23484824 12.3046831,8.94224291 C12.9724074,9.1172461 13.638726,9.29924941 14.3289421,9.41965161 L14.3289421,9.43505189 C14.1869628,9.44905214 14.0309262,9.49805304 13.8931641,9.551254 L13.8931641,9.57645446 C14.2853643,9.77105801 14.8293839,10.0944639 14.8336011,10.6068732 C14.7422283,11.2270845 14.0604466,11.5098897 13.5501647,11.7058933 L13.5501647,11.7058933 Z" id="Fill-8" fill="#FEFEFE"></path><path d="M14.1946944,19.3564726 L14.1946944,19.1646691 L14.3141819,19.1646691 C14.3788457,19.1646691 14.467407,19.1716693 14.467407,19.2528707 C14.467407,19.3410724 14.4224235,19.3564726 14.3465138,19.3564726 L14.1946944,19.3564726 Z M14.1946944,19.4922751 L14.2748213,19.4922751 L14.4603783,19.8268812 L14.6613985,19.8268812 L14.4575669,19.4782749 C14.562997,19.4698747 14.6501526,19.4166737 14.6501526,19.2710711 C14.6501526,19.0890678 14.5278536,19.0302667 14.3226163,19.0302667 L14.0231946,19.0302667 L14.0231946,19.8268812 L14.1946944,19.8268812 L14.1946944,19.4922751 Z M15.0620331,19.429274 C15.0620331,18.9630655 14.7105992,18.6900605 14.3183991,18.6900605 C13.9233874,18.6900605 13.5719536,18.9630655 13.5719536,19.429274 C13.5719536,19.8954825 13.9233874,20.1670874 14.3183991,20.1670874 C14.7105992,20.1670874 15.0620331,19.8954825 15.0620331,19.429274 L15.0620331,19.429274 Z M14.8483613,19.429274 C14.8483613,19.7694802 14.6051691,19.9976843 14.3183991,19.9976843 L14.3183991,19.9962843 C14.0231946,19.9976843 13.7856254,19.7694802 13.7856254,19.429274 C13.7856254,19.0890678 14.0231946,18.8622636 14.3183991,18.8622636 C14.6051691,18.8622636 14.8483613,19.0890678 14.8483613,19.429274 L14.8483613,19.429274 Z" id="Fill-10" fill="#FEFEFE"></path></g></g></g></g></svg><!-- End User Code --></div></div></div></div></div></div></div></div></div><div id="sTop_Bar_0_0_27_0_0_15" data-toggle-property="gdpr" class="gdpr-cookie hidden hidden"><span class="js-scroll-trigger" data-target="#rm-gdpr-sTop_Bar_0_0_27_0_0_15" data-toggle-class="sticky-active"></span><div id="rm-gdpr-sTop_Bar_0_0_27_0_0_15" class="sticky-target legacy rm-gdpr"><div class="gdpr-cookie-wrapper"><div class="gdpr-cookie-content"><p>IEEE websites place cookies on your device to give you the best user experience. By using our websites, you agree to the placement of these cookies. To learn more, read our Privacy Policy.</p></div><div class="gdpr-cookie-controls"><a href="https://www.ieee.org/security-privacy.html" target="_blank" class="gdpr-cookie-info">
                        view privacy policy
                    </a><a href="#toggle-gdpr" class="gdpr-cookie-accept">
                    accept &amp; close
                </a></div></div></div></div><span class="js-brick-description hidden" data-name="__Gated_Popup"></span><div class="gated-popup" id="s__Gated_Popup_0_0_31_0_0_0"><div class="gated-popup__contents" id="s__Gated_Popup_0_0_31_0_0_0_0"><!-- User Code --><a href="javascript:;" class="js--close-gated gated-popup__close icon-close"></a><!-- End User Code --><!-- User Code --><h2 class="popup-gated-h2 popup-heading-h2 for_pdf" style="display:none">Enjoy more free content and benefits by creating an account</h2><h2 class="popup-gated-h2 popup-heading-h2 for_save" style="display:none">Saving articles to read later requires an IEEE Spectrum account</h2><h2 class="popup-gated-h2 popup-heading-h2 for_member_content" style="display:none">The Institute content is only available for members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_pdf_issues" style="display:none">Downloading full PDF issues is exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_nxtbook" style="display:none">Access to <i>Spectrum</i>&#39;s Digital Edition is exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_follow_topics" style="display:none">Following topics is a feature exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_comments" style="display:none">Adding your response to an article requires an IEEE Spectrum account</h2><h2 class="popup-gated-h2 for_pdf for_save for_comments" style="display:none">Create an account to access more content and features on <i>IEEE Spectrum</i>, including the ability to save articles to read later, download Spectrum Collections, and participate in conversations with readers and editors. For more exclusive content and features, consider <a class="ieee_link" href="">Joining IEEE</a>.</h2><h2 class="popup-gated-h2 for_pdf_issues for_nxtbook for_follow_topics for_member_content" style="display:none">Join the world’s largest professional organization devoted to engineering and applied sciences and get access to all of Spectrum’s articles, archives, PDF downloads, and other benefits. <a href="/st/join">Learn more →</a></h2><!-- End User Code --><div class="popup_links for_pdf for_save for_comments create_account" id="s__Gated_Popup_0_0_31_0_0_0_0_2"><div class="list" id="s__Gated_Popup_0_0_31_0_0_0_0_2_0"><a class="list__item" href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fsaml%2Fmain%2Flogin%3Fnext_url%3Dhttps%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fintegrations%2Fieee%2Fchanges%0A&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" target="_self">CREATE AN ACCOUNT</a><a class="list__item" href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" target="_self">SIGN IN</a></div></div><div class="popup_links for_pdf_issues for_nxtbook for_follow_topics for_member_content" id="s__Gated_Popup_0_0_31_0_0_0_0_3"><div class="list" id="s__Gated_Popup_0_0_31_0_0_0_0_3_0"><a class="list__item" href="/st/join" target="_self">JOIN IEEE</a><a class="list__item" href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" target="_self">SIGN IN</a></div></div></div></div><!-- User Code --><script>
  var popupGatedElement=document.querySelector('.gated-popup'),
  closeGated,
  gatedCloseBtn = '.js--close-gated',
  gatedShownClass = 'gated-popup--shown';

  closeGated = function () {
      popupGatedElement.classList.remove(gatedShownClass);
      popupGatedElement.classList.remove('for_save');
      popupGatedElement.classList.remove('for_pdf');
      popupGatedElement.classList.remove('for_pdf_issues');
      popupGatedElement.classList.remove('for_nxtbook');
      popupGatedElement.classList.remove('for_follow_topics');
      popupGatedElement.classList.remove('for_comments');
      popupGatedElement.classList.remove('for_member_content');
  };

  function openGatedPopup(type){
    
    document.querySelectorAll(".popup_links.create_account .list__item")[0].href = 
"https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=" + encodeURIComponent(window.location.origin + "/core/saml/main/login?next_url=" + window.location.origin + "/core/integrations/ieee/changes?redirect=" + window.location.href) + "&url=" + encodeURIComponent(window.location.origin + "/core/saml/main/login?next_url=" + window.location.origin + "/core/integrations/ieee/changes?redirect=" + window.location.href) + "&autoSignin=Y&car=IEEE-Spectrum";
    
    // update popups for_member_content
    document.querySelectorAll(".popup_links.for_member_content .list__item")[1].href =  "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
    
    // update popups for_pdf for_save for_comments
	document.querySelectorAll(".popup_links.for_save .list__item")[1].href =  "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
    
    popupGatedElement.classList.add(type);
  	popupGatedElement.classList.add(gatedShownClass);
  }

  document.querySelector(gatedCloseBtn).onclick= closeGated;
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="__Session_Popup"></span><div class="lightbox-popup" id="s__Session_Popup_0_0_35_0_0_0"><div class="lightbox-popup__contents" id="s__Session_Popup_0_0_35_0_0_0_0"><!-- User Code --><a href="javascript:;" class="js--close-lightbox lightbox-popup__close icon-close hide-text">Close</a><!-- End User Code --><!-- User Code --><h2 class="popup-ligtbox-h2 popup-heading-h2">Access Thousands of Articles — Completely Free</h2><h2 class="popup-ligtbox-h2">Create an account and get exclusive content and features: <strong>Save articles, download collections,</strong> and <strong>talk to tech insiders</strong> — all free! For full access and benefits, <a class="ieee_link" href="">join IEEE</a> as a paying member.</h2><!-- End User Code --><div class="popup_links signin_button" id="s__Session_Popup_0_0_35_0_0_0_0_2"><div class="list" id="s__Session_Popup_0_0_35_0_0_0_0_2_0"><a class="list__item" href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fsaml%2Fmain%2Flogin%3Fnext_url%3Dhttps%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fintegrations%2Fieee%2Fchanges%0A&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" target="_self">CREATE AN ACCOUNT</a><a class="list__item" href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" target="_self">SIGN IN</a></div></div></div></div><!-- User Code --><script>
function addPopSave(){
    var save_post_links = document.querySelectorAll(".like-btn:not(.proc)");
	for (i = 0; i < save_post_links.length; i++) {
      save_post_links[i].removeAttribute("href");
      save_post_links[i].addEventListener("click", function(event){
      	openGatedPopup('for_save');
	  });
      save_post_links[i].classList.add('proc');
    } 
}
</script><!-- End User Code --><!-- User Code --><div class="rblad-ieee_welcome_interstitial"></div><!-- End User Code --><span class="js-brick-description hidden" data-name="SS Feature Post"></span><div class="" id="sSS_Feature_Post_0_0_21_0_0_1"><div class="top-leader-container" id="sSS_Feature_Post_0_0_21_0_0_1_0"><!-- User Code --><div class="rblad-ieee_top_leaderboard"></div><!-- End User Code --></div><div class="" id="sSS_Feature_Post_0_0_21_0_0_1_1"><div class="non_member_follow" id="sSS_Feature_Post_0_0_21_0_0_1_1_0_1_0"><span class="js-brick-description hidden" data-name="Open Current Feature Post"></span><div class="mb-2 feature_post_full current_post" id="sOpen_Current_Feature_Post_0_0_15_0_0_0_1_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-v="2" data-attr-posts_id="sOpen_Current_Feature_Post_0_0_15_0_0_0_1_0_1_0" data-attr-layout_quality="1" data-attr-header_template="jinja/post/custom-css.html" data-attr-node_id="/root/blocks/block[open_current_feature_post]/abtests/abtest[1]/choose/otherwise/choose/otherwise/posts-" data-attr-use_tag_image_for_lead_media="true" data-attr-source_url="current_post" data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,custom_field_pdf_version,post_shares,custom_field_FeaturePostImgPosition,photo_caption,photo_credit,custom_field_FeaturePostColor,body,tags,custom_field_lightbox_img_shortcode_ids,custom_field_TimeofRead,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,date_modified,badges_sponsored,section,snark_line,community_name,primary_tag,follow_button,community_comments,badges,page_views,collection_button,main_author,source_link,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_Editor,custom_field_PodcastVideoTime,custom_field_PodcastEpisode,custom_field_due_date,custom_field_access,custom_field_publication_date,site_field_member_badges,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_copy_editor,custom_field_is_updated_post" data-attr-limit="1" data-attr-layout_headline="top" data-attr-layout_subheadline="top" data-attr-layout_date="top" data-attr-data-rm-advanced="true" data-attr-element_classes="feature_post_full current_post" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-layout_all_image_crop="original" data-attr-data-rm-device-crops="true" data-attr-layout_mobile_image_crop="original" data-attr-layout_like_button="top" data-attr-layout_all_sections="top" data-attr-layout_author="top" data-attr-layout_post_shares="top" data-attr-all_share_buttons="Email,CopyLink,Separator,Slack,Twitter,Facebook,Linkedin,GooglePlus,Whatsapp,Reddit,Tumblr,Flipboard,SMS,Pinterest" data-attr-layout_tumblr="inactive" data-attr-layout_googleplus="inactive" data-attr-layout_pinterest="inactive" data-attr-layout_whatsapp="inactive" data-attr-layout_reddit="inactive" data-attr-layout_flipboard="inactive" data-attr-layout_sms="inactive" data-attr-layout_slack="inactive" data-attr-layout_separator="inactive" data-attr-layout_facebook="active" data-attr-layout_twitter="active" data-attr-layout_linkedin="active" data-attr-layout_copylink="active" data-attr-layout_photo_caption="bottom" data-attr-layout_photo_credit="bottom" data-attr-layout_custom_field_featurepostcolor="bottom" data-attr-layout_body="bottom" data-attr-layout_custom_field_featurepostimgposition="top" data-attr-show_full_post_body="true" data-attr-update_url_on_post_view="true" data-attr-layout_time_to_read="top" data-attr-layout_all_headline_tag="h1" data-attr-layout_all_subheadline_tag="h2" data-attr-show_around_the_web="true" data-attr-layout_tags="bottom" data-attr-layout_custom_field_lightbox_img_shortcode_ids="bottom" data-attr-layout_custom_field_pdf_version="top" data-attr-filters="section" data-attr-section_url="" data-attr-source="" data-attr-format="posts-custom" data-attr-is_current_post="true"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-computer-history tag-alto tag-ivan-sutherland tag-user-interface tag-computer-mouse tag-doug-engelbart tag-xerox-parc tag-apple tag-larry-tesler tag-windows tag-history post-section--topic/tech-history" data-category="History of Technology"><article elid="2658380204" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658380204" data-category="History of Technology"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/tech-history/">History of Technology</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/feature/">Feature</a><a href="https://spectrum.ieee.org/topic/computing/">Computing</a></div><h1 class="widget__headline h1"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/graphical-user-interface" aria-label="How the Graphical User Interface Was Invented" data-type="text">
        How the Graphical User Interface Was Invented
    </a></h1><div class="widget__subheadline"><h2 class="widget__subheadline-text h2" data-type="text"><p>Three decades of UI research came together in the mice, windows, and icons used today</p></h2></div><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/media-library/eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA5NDcwMi9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcyMzA1NDkzNn0.gbFAtEQX36yzfmx_HixIADGZY8vd-q3M-GGzK9mxSrU/image.png?width=210&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/tekla-perry" data-type="text">Tekla S. Perry</a><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/res/avatars/default&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/john-voelcker" data-type="text">John Voelcker</a></div><div class="social-date"><span class="social-date__text">1h</span></div><div class="time-to-read">18 min read</div><div class="like-button" data-post-likes="0"></div><div class="widget__shares share-panel"><!-- EMAIL --><a href="mailto:?subject=How%20the%20Graphical%20User%20Interface%20Was%20Invented&body=https://spectrum.ieee.org/graphical-user-interface" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK --><a href="https://spectrum.ieee.org/graphical-user-interface" data-clipboard-text="https://spectrum.ieee.org/graphical-user-interface" class="share share-copy-link" title="Copy this link to clipboard"><i class="icons-share" style="width: 60%"><svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i></a><!-- TWITTER --><a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/graphical-user-interface&text=How%20the%20Graphical%20User%20Interface%20Was%20Invented&" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK --><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Fgraphical-user-interface%3Fxrs%3DRebelMouse_fb%26ts%3D1668974400" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN --><a href="http://www.linkedin.com/shareArticle?mini=false&url=https://spectrum.ieee.org/graphical-user-interface&" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a></div><div class="custom-field-FeaturePostImgPosition">Horizontal</div></div><div class="widget__head"><picture><source srcset="https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=3600&height=2700 3x, https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=2400&height=1800 2x, https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=1200&height=900 1x"/><img fetchpriority="high" role="img" alt="Stylized drawing of a desktop computer with mouse and keyboard, on the screen are windows, Icons, and menus " aria-label="Stylized drawing of a desktop computer with mouse and keyboard, on the screen are windows, Icons, and menus " src="https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=1200&height=900" style="object-fit: cover;" class="rm-lazyloadable-image rm-hero-media" width="3600" height="2700"/></picture></div><div class="widget__body clearfix sm-mt-1"><div class="photo-credit">
        Getty Images/IEEE Spectrum
    </div><div class="custom-field-FeaturePostColor">DarkGray</div><span class="js-scroll-trigger" data-target="body" data-triggers="render-rebelbar" data-toggle-class="with-floating-shares"></span><div id="utm_campaign"></div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2658380204" data-elid="2658380204" data-post-url="https://spectrum.ieee.org/graphical-user-interface" data-authors="Tekla S. Perry, John Voelcker" data-headline="How the Graphical User Interface Was Invented"><div class="body-description"><p><strong>Mice, windows, icons,</strong> and menus: these are the ingredients of computer interfaces designed to be easy to grasp, simplicity itself to use, and straightforward to describe. The mouse is a pointer. Windows divide up the screen. Icons symbolize application programs and data. Menus list choices of action.</p><p>But the development of today’s graphical user interface was anything but simple. It took some 30 years of effort by engineers and computer scientists in universities, government laboratories, and corporate research groups, piggybacking on each other’s work, trying new ideas, repeating each other’s mistakes.</p><div class="ieee-statbox-left
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem1" data-id="1" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-1" data-published-at="1664824530" data-basename="particle-1" data-post-id="2658380204"><p>This article was first published as “Of Mice and menus: designing the user-friendly interface.” It appeared in the September 1989 issue of <em>IEEE Spectrum</em>. A <a href="https://ieeexplore.ieee.org/document/90184" target="_blank" rel="noopener noreferrer">PDF version</a> is available on IEEE Xplore. The photographs and diagrams appeared in the original print version.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem2" data-id="2" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-2" data-published-at="1664824530" data-basename="particle-2" data-post-id="2658380204"><p>Throughout the 1970s and early 1980s, many of the early concepts for windows, menus, icons, and mice were arduously researched at <a href="https://spectrum.ieee.org/xerox-parc" target="_self">Xerox Corp.’s Palo Alto Research Center (PARC)</a>, Palo Alto, Calif. In 1973, PARC developed the prototype <a href="https://spectrum.ieee.org/the-xerox-alto-struts-its-stuff-on-its-40th-birthday" target="_self">Alto</a>, the first of two computers that would prove seminal in this area. More than 1200 Altos were built and tested. From the Alto’s concepts, starting in 1975, Xerox’s System Development Department then developed the Star and introduced it in 1981—the first such user-friendly machine sold to the public.</p><p>In 1984, the low-cost Macintosh from <a href="https://www.apple.com/" target="_blank">Apple Computer Inc</a>., Cupertino, Calif., brought the friendly interface to thousands of personal computer users. During the next five years, the price of RAM chips fell enough to accommodate the huge memory demands of bit-mapped graphics, and the Mac was followed by dozens of similar interfaces for PCs and workstations of all kinds. By now, application programmers are becoming familiar with the idea of manipulating graphic objects.</p><p>The Mac’s success during the 1980s spurred Apple Computer to pursue legal action over ownership of many features of the graphical user interface. Suits now being litigated could assign those innovations not to the designers and their companies, but to those who first filed for legal protection on them.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem16" data-id="16" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/the-gui-started-with-sketchpad" data-published-at="1668019407" data-basename="the-gui-started-with-sketchpad" data-post-id="2658380204"><h3 data-role="headline">The GUI started with Sketchpad</h3><p>The grandfather of the graphical user interface was Sketchpad [see photograph]. <a href="https://www.mit.edu/" target="_blank">Massachusetts Institute of Technology</a> student Ivan E. Sutherland built it in 1962 as a Ph.D. thesis at MIT’s <a href="https://www.ll.mit.edu/" target="_blank">Lincoln Laboratory</a> in Lexington, Mass. Sketchpad users could not only draw points, line segments, and circular arcs on a cathode ray tube (CRT) with a light pen—they could also assign constraints to, and relationships among, whatever they drew.</p><p>Arcs could have a specified diameter, lines could be horizontal or vertical, and figures could be built up from combinations of elements and shapes. Figures could be moved, copied, shrunk, expanded, and rotated, with their constraints (shown as onscreen icons) dynamically preserved. At a time when a CRT monitor was a novelty in itself, the idea that users could interactively create objects by drawing on a computer was revolutionary.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem4" data-id="4" data-is-image="True" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-4" data-published-at="1664824530" data-basename="particle-4" data-post-id="2658380204"><img id="1e0cc" data-rm-shortcode-id="f44910cabbdb929985f3b187fd87e9a5" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1374 915&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/man-sitting-in-front-of-a-round-cathode-ray-display-with-a-white-square-and-triangle-on-a-black-background.jpg?id=31974122&width=980" width="1374" height="915" alt="Man sitting in front of a round cathode ray display with a white square and triangle on a black background"/><small class="image-media media-caption"><p>Sketchpad, created in 1962 by Ivan Sutherland at Massachusetts Institute of Technology’s Lincoln Laboratory in Lexington, is considered the first computer with a windowing interface.</p></small><small class="image-media media-photo-credit"><p>The Computer Museum</p></small><p>Moreover, to zoom in on objects, Sutherland wrote the first window-drawing program, which required him to come up with the first clipping algorithm. Clipping is a software routine that calculates which part of a graphic object is to be displayed and displays only that part on the screen. The program must calculate where a line is to be drawn, compare that position to the coordinates of the window in use, and prevent the display of any line segment whose coordinates fall outside the window.<br/></p><p>Though films of Sketchpad in operation were widely shown in the computer research community, Sutherland says today that there was little immediate fallout from the project. Running on MIT’s TX-2 mainframe, it demanded too much computing power to be practical for individual use. Many other engineers, however, see Sketchpad’s design and algorithms as a primary influence on an entire generation of research into user interfaces.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem17" data-id="17" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/the-origin-of-the-computer-mouse" data-published-at="1668019407" data-basename="the-origin-of-the-computer-mouse" data-post-id="2658380204"><h3 data-role="headline">The origin of the computer mouse</h3><p>The light pens used to select areas of the screen by interactive computer systems of the 1950s and 1960s—including Sketchpad—had drawbacks. To do the pointing, the user’s arm had to be lifted up from the table, and after a while that got tiring. Picking up the pen required fumbling around on the table or, if it had a holder, taking the time after making a selection to put it back.</p><p>Sensing an object with a light pen was straightforward: the computer displayed spots of light on the screen and interrogated the pen as to whether it sensed a spot, so the program always knew just what was being displayed. Locating the position of the pen on the screen required more sophisticated techniques—like displaying a cross pattern of nine points on the screen, then moving the cross until it centered on the light pen.</p><p>In 1964, <a href="https://dougengelbart.org/" target="_blank" rel="noopener noreferrer">Douglas Engelbart</a>, a research project leader at <a href="https://www.sri.com/" target="_blank" rel="noopener noreferrer">SRI International</a> in Menlo Park, Calif., tested all the commercially available pointing devices, from the still-popular light pen to a joystick and a Graphicon (a curve-tracing device that used a pen mounted on the arm of a potentiometer). But he felt the selection failed to cover the full spectrum of possible pointing devices, and somehow he should fill in the blanks.</p><p>Then he remembered a 1940s college class he had taken that covered the use of a planimeter to calculate area. (A planimeter has two arms, with a wheel on each. The wheels can roll only along their axes; when one of them rolls, the other must slide.)</p><p>If a potentiometer were attached to each wheel to monitor its rotation, he thought, a planimeter could be used as a pointing device. Engelbart explained his roughly sketched idea to engineer William English, who with the help of the SRI machine shop built what they quickly dubbed “the mouse.”</p></div><div class="ieee-sidebar-fullwidth
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem6" data-id="6" data-is-image="True" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-6" data-published-at="1666289660" data-basename="particle-6" data-post-id="2658380204"><img id="b36c0" data-rm-shortcode-id="613abb5ace85ee3af59de4d358e00f8e" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1482 2688&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/image.jpg?id=31974147&width=980" width="1482" height="2688" alt=""/></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem9" data-id="9" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-9" data-published-at="1666289660" data-basename="particle-9" data-post-id="2658380204"><p>This first mouse was big because it used single-turn potentiometers: one rotation of the wheels had to be scaled to move a cursor from one side of the screen to the other. But it was simple to interface with the computer: the processor just read frequent samples of the potentiometer positioning signals through analog-to-digital converters.</p><p>The cursor moved by the mouse was easy to locate, since readings from the potentiometer determined the position of the cursor on the screen-unlike the light pen. But programmers for later windowing systems found that the software necessary to determine which object the mouse had selected was more complex than that for the light pen: they had to compare the mouse’s position with that of all the objects displayed onscreen.</p><h3>The computer mouse gets redesigned—and redesigned again</h3><p>Engelbart’s group at SRI ran controlled experiments with mice and other pointing devices, and the mouse won hands down. People adapted to it quickly, it was easy to grab, and it stayed where they put it. Still, Engelbart wanted to tinker with it. After experimenting, his group had concluded that the proper ratio of cursor movement to mouse movement was about 2:1, but he wanted to try varying that ratio—decreasing it at slow speeds and raising it at fast speeds—to improve user control of fine movements and speed up larger movements. Some modern mouse-control software incorporates this idea, including that of the Macintosh.</p><p>The mouse, still experimental at this stage, did not change until 1971. Several members of Engelbart’s group had moved to the newly established PARC, where many other researchers had seen the SRI mouse and the test report. They decided there was no need to repeat the tests; any experimental systems they designed would use mice.</p><p>Said English, “This was my second chance to build a mouse; it was obvious that it should be a lot smaller, and that it should be digital.” Chuck Thacker, then a member of the research staff, advised PARC to hire <a href="https://patents.justia.com/inventor/jack-s-hawley" target="_blank">inventor Jack Hawley</a> to build it.</p><p>Hawley decided the mouse should use shaft encoders, which measure position by a series of pulses, instead of potentiometers (both were covered in Engelbart’s 1970 patent), to eliminate the expensive analog-to-digital converters. The basic principle, of one wheel rolling while the other slid, was licensed from SRI.</p><p class="pull-quote">The ball mouse was the “easiest patent I ever got. It took me five minutes to think of, half an hour to describe to the attorney, and I was done.”<br/>—Ron Rider</p><p>In 1972, the mouse changed again. Ron Rider, now vice president of systems architecture at PARC but then a new arrival, said he was using the wheel mouse while an engineer made excuses for its asymmetric operation (one wheel dragging while one turned). “I suggested that they turn a trackball upside down, make it small, and use it as a mouse instead,” Rider told <em>IEEE Spectrum</em>. This device came to be known as the ball mouse. “Easiest patent I ever got,” Rider said. “It took me five minutes to think of, half an hour to describe to the attorney, and I was done.”</p></div><div class="ieee-sidebar-list-left
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem3" data-id="3" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/defining-terms" data-published-at="1664824530" data-basename="defining-terms" data-post-id="2658380204"><h3 data-role="headline">Defining terms</h3><p><strong>Bit map</strong></p><p>
	The pixel pattern that makes up the graphic display on a computer screen.
</p><p><strong>Clicking</strong></p><p>
	The motion of pressing a mouse button to Initiate an action by software; some actions require double-clicking.
</p><p><strong>Graphical user interface (GUI)</strong></p><p>
	The combination of windowing displays, menus, icons, and a mouse that is increasingly used on personal computers and workstations.
</p><p><strong>Icon</strong></p><p>
	An onscreen drawing that represents programs or data.
</p><p><strong>Menu</strong></p><p>
	A list of command options currently available to the computer user; some stay onscreen, while pop-up or pull-down menus are requested by the user.
</p><p><strong>Mouse</strong></p><p>
	A device whose motion across a desktop or other surface causes an on-screen cursor to move commensurately; today’s mice move on a ball and have one, two, or three buttons.
</p><p><strong>Raster display</strong></p><p>
	A cathode ray tube on which Images are displayed as patterns of dots, scanned onto the screen sequentially in a predetermined pattern of lines.
</p><p><strong>Vector display</strong></p><p>
	A cathode ray tube whose gun scans lines, or vectors, onto the screen phosphor.
</p><p><strong>Window</strong></p><p>
	An area of a computer display, usually one of several, in which a particular program is executing.
</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem19" data-id="19" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-19" data-published-at="1668019407" data-basename="particle-19" data-post-id="2658380204"><p>In the PARC ball mouse design, the weight of the mouse is transferred to the ball by a swivel device and on one or two casters at the end of the mouse farthest from the wire “tail.” A prototype was built by Xerox’s Electronics Division in El Segundo, Calif., then redesigned by Hawley. The rolling ball turned two perpendicular shafts, with a drum on the end of each that was coated with alternating stripes of conductive and nonconductive material. As the drum turned, the stripes transmitted electrical impulses through metal wipers.</p><p>When Apple Computer decided in 1979 to design a mouse for its Lisa computer, the design mutated yet again. Instead of a metal ball held against the substrate by a swivel, Apple used a rubber ball whose traction depended on the friction of the rubber and the weight of the ball itself. Simple pads on the bottom of the case carried the weight, and optical scanners detected the motion of the internal wheels. The device had loose tolerances and few moving parts, so that it cost perhaps a quarter as much to build as previous ball mice.<br/></p><h3>How the computer mouse gained and lost buttons</h3><p>The first, wooden, SRI mouse had only one button, to test the concept. The plastic batch of SRI mice bad three side-by-side buttons—all there was room for, Engelbart said. The first PARC mouse bad a column of three buttons-again, because that best fit the mechanical design. Today, the Apple mouse has one button, while the rest have two or three. The issue is no longer 1950—a standard 6-by-10-cm mouse could now have dozens of buttons—but human factors, and the experts have strong opinions.</p><p>Said English, now director of internationalization at Sun Microsystems Inc., Mountain View, Calif.: “Two or three buttons, that’s the debate. Apple made a bad choice when they used only one.” He sees two buttons as the minimum because two functions are basic to selecting an object: pointing to its start, then extending the motion to the end of the object.</p><p>William Verplank, a human factors specialist in the group that tested the graphical interface at Xerox from 1978 into the early 1980s, concurred. He told Spectrum that with three buttons, Alto users forgot which button did what. The group’s tests showed that one button was also confusing, because it required actions such as double-clicking to select and then open a file.</p><p>“We have agonizing videos of naive users struggling” with these problems, Verplank said. They concluded that for most users, two buttons (as used on the Star) are optimal, if a button means the same thing in every application. English experimented with one-button mice at PARC before concluding they were a bad idea.</p></div><div class="ieee-pullquote-fullwidth
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem24" data-id="24" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-24" data-published-at="1668626987" data-basename="particle-24" data-post-id="2658380204"><p>“Two or three buttons, that’s the debate. Apple made a bad choice when they used only one.”<br/>—William English</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem7" data-id="7" data-is-image="True" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-7" data-published-at="1666289660" data-basename="particle-7" data-post-id="2658380204"><img id="b9f9c" data-rm-shortcode-id="2d34944349334af3abfd648bb15477f5" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1240 1553&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-computer-monitor-with-a-chunky-white-keyboard-sitting-on-a-desk.jpg?id=31974188&width=980" width="1240" height="1553" alt="A computer monitor with a chunky white keyboard sitting on a desk"/><small class="image-media media-caption"><p>More than 1200 of the experimental Alto, developed in 1973 by the Xerox Palo Alto Research Center, were distributed to test its windows, menus, and mouse.</p></small><small class="image-media media-photo-credit"><p>Xerox Corp.</p></small><p>But many interface designers dislike multiple buttons, saying that double-clicking a single button to select an item is easier than remembering which button points and which extends. <a href="https://spectrum.ieee.org/of-modes-and-men" target="_self">Larry Tesler</a>, formerly a computer scientist at PARC, brought the one-button mouse to Apple, where he is now vice president of advanced technology. The company’s rationale is that to attract novices to its computers one button was as simple as it could get.</p><p>More than two million one-button Apple mice are now in use. The Xerox and <a href="https://www.microsoft.com/en-us/" target="_blank">Microsoft</a> two-button mice are less common than either Apple’s ubiquitous one-button model or the three-button mice found on technical workstations. Dozens of companies manufacture mice today; most are slightly smaller than a pack of cigarettes, with minor variations in shape.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem21" data-id="21" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/how-windows-first-came-to-the-computer-screen" data-published-at="1668019407" data-basename="how-windows-first-came-to-the-computer-screen" data-post-id="2658380204"><h3 data-role="headline">How windows first came to the computer screen</h3><p>In 1962, Sketchpad could split its screen horizontally into two independent sections. One section could, for example, give a close-up view of the object in the other section. Researchers call Sketchpad the first example of tiled windows, which are laid out side by side. They differ from overlapping windows, which can be stacked on top of each other, or overlaid, obscuring all or part of the lower layers.</p><p>Windows were an obvious means of adding functionality to a small screen. In 1969, Engelbart equipped NLS (as the On-Line System he invented at SRI during the 1960s was known, to distinguish it from the Off-Line System known as FLS) with windows. They split the screen into multiple parts horizontally or vertically, and introduced cross-window editing with a mouse.</p><p>By 1972, led by researcher <a href="https://computerhistory.org/profile/alan-kay/" target="_blank">Alan Kay</a>, the <a href="https://spectrum.ieee.org/qa-adele-goldberg-on-the-legacy-of-smalltalk" target="_self">Smalltalk</a> programming language group at Xerox PARC had implemented their version of windows. They were working with far different technology from Sutherland or Engelbart: by deciding that their images had to be displayed as dots on the screen, they led a move from vector to raster displays, to make it simple to map the assigned memory location of each of those spots. This was the bit map invented at PARC, and made viable during the 1980s by continual performance improvements in processor logic and memory speed.</p><p>Experimenting with bit-map manipulation, Smalltalk researcher Dan Ingalls developed the bit-block transfer procedure, known as BitBlt. The BitBlt software enabled application programs to mix and manipulate rectangular arrays of pixel values in on-screen or off-screen memory, or between the two, combining the pixel values and storing the result in the appropriate bit-map location.</p><p>BitBlt made it much easier to write programs to scroll a window (move an image through it), resize (enlarge or contract) it, and drag windows (move them from one location to another on screen). It led Kay to create overlapping windows. They were soon implemented by the Smalltalk group, but made clipping harder.</p><p class="pull-quote">Some researchers question whether overlapping windows offer more benefits than tiled on the grounds that screens with overlapping windows become so messy the user gets lost.<br/></p><p>In a tiling system, explained researcher Peter Deutsch, who worked with the Smalltalk group, the clipping borders are simply horizontal or vertical lines from one screen border to another, and software just tracks the location of those lines. But overlapping windows may appear anywhere on the screen, randomly obscuring bits and pieces of other windows, so that quite irregular regions must be clipped. Thus application software must constantly track which portions of their windows remain visible.</p><p>Some researchers still question whether overlapping windows offer more benefits than tiled, at least above a certain screen size, on the grounds that screens with overlapping windows become so messy the user gets lost. Others argue that overlapping windows more closely match users’ work patterns, since no one arranges the papers on their physical desktop in neat horizontal and vertical rows. Among software engineers, however, overlapping windows seem to have won for the user interface world.</p><p>So has the cut-and-paste editing model that Larry Tesler developed, first for the Gypsy text editor he wrote at PARC and later for Apple. Charles Irby—who worked on Xerox’s windows and is now vice president of development at Metaphor Computer Systems Inc., Mountain View, Calif.—noted, however, that cut-and-paste worked better for pure text-editing than for moving graphic objects from one application to another.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem20" data-id="20" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/the-origin-of-the-computer-menu-bar" data-published-at="1668019407" data-basename="the-origin-of-the-computer-menu-bar" data-post-id="2658380204"><h3 data-role="headline">The origin of the computer menu bar</h3><p>Menus—functions continuously listed onscreen that could be called into action with key combinations—were commonly used in defense computing by the 1960s. But it was only with the advent of BitBlt and windows that menus could be made to appear as needed and to disappear after use. Combined with a pointing device to indicate a user’s selection, they are now an integral part of the user-friendly interface: users no longer need to refer to manuals or memorize available options.<br/></p><p>Instead, the choices can be called up at a moment’s notice whenever needed. And menu design has evolved. Some new systems use nested hierarchies of menus; others offer different menu versions—one with the most commonly used commands for novices, another with all available commands for the experienced user.</p><p>Among the first to test menus on demand was PARC researcher William Newman, in a program called Markup. Hard on his heels, the Smalltalk group built in pop-up menus that appeared on screen at the cursor site when the user pressed one of the mouse buttons.</p><p>Implementation was on the whole straightforward, recalled Deutsch. The one exception was determining whether the menu or the application should keep track of the information temporarily obscured by the menu. In the Smalltalk 76 version, the popup menu saved and restored the screen bits it overwrote. But in today’s multitasking systems, that would not work, because an application may change those bits without the menu’s knowledge. Such systems add another layer to the operating system: a display manager that tracks what is written where.</p><p>The production Xerox Star, in 1981, featured a further advance: a menu bar, essentially a row of words indicating available menus that could be popped up for each window. Human factors engineer Verplank recalled that the bar was at first located at the bottom of its window. But the Star team found users were more likely to associate a bar with the window below it, so it was moved to the top of its window.</p><p>Apple simplified things in its Lisa and Macintosh with a single bar placed at the top of the screen. This menu bar relates only to the window in use: the menus could be ‘‘pulled down” from the bar, to appear below it. Designer William D. Atkinson received a patent (assigned to Apple Computer) in August 1984 for this innovation.</p><p>One new addition that most user interface pioneers consider an advantage is the tear-off menu, which the user can move to a convenient spot on the screen and “pin” there, always visible for ready access.</p><p>Many windowing interfaces now offer command-key or keyboard alternatives for many commands as well. This return to the earliest of user interfaces—key combinations—neatly supplements menus, providing both ease of use for novices and for the less experienced, and speed for those who can type faster than they can point to a menu and click on a selection.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem22" data-id="22" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/how-the-computer-icon-got-its-name" data-published-at="1668019407" data-basename="how-the-computer-icon-got-its-name" data-post-id="2658380204"><h3 data-role="headline">How the computer “icon” got its name</h3><p>Sketchpad had on-screen graphic objects that represented constraints (for example, a rule that lines be the same length), and the Flex machine built in 1967 at the <a href="https://www.utah.edu/" target="_blank" rel="noopener noreferrer">University of Utah</a> by students Alan Kay and Ed Cheadle had squares that represented programs and data (like today’s computer “folders”). Early work on icons was also done by Bell Northern Research, Ottawa, Canada, stemming from efforts to replace the recently legislated bilingual signs with graphic symbols. </p><p>But the concept of the computer “icon” was not formalized until 1975. David Canfield Smith, a computer science graduate student at <a href="https://www.stanford.edu/" target="_blank">Stanford University</a> in California, began work on his Ph.D. thesis in 1973. His advisor was PARC’s Kay, who suggested that he look at using the graphics power of the experimental Alto not just to display text, but rather to help people program.</p><p class="pull-quote">David Canfield Smith took the term icon from the Russian Orthodox church, where an icon is more than an image, because it embodies properties of what it represents.<br/></p><p>Smith took the term icon from the Russian Orthodox church, where an icon is more than an image, because it embodies properties of what it represents: a Russian icon of a saint is holy and is to be venerated. Smith’s computer icons contained all the properties of the programs and data represented, and therefore could be linked or acted on as if they were the real thing.</p><p>After receiving his Ph.D. in 1975, Smith joined Xerox in 1976 to work on Star development. The first thing he did, he said, was to recast his concept of icons in office terms. “I looked around my office and saw papers, folders, file cabinets, a telephone, and bookshelves, and it was an easy translation to icons,” he said.</p><p>Xerox researchers developed, tested, and revised icons for the Star interface for three years before the first version was complete. At first they attempted to make the icons look like a detailed photographic rendering of the object, recalled Irby, who worked on testing and refining the Xerox windows. Trading off label space, legibility, and the number of icons that fit on the screen, they decided to constrain icons to a 1-inch (2.5-centimeter) square of 64 by 64 pixels, or 512 eight-bit bytes.</p><p>Then, Verplank recalls, they discovered that because of a background pattern based on two-pixel dots, the right-hand side of the icons appeared jagged. So they increased the width of the icons to 65 pixels, despite an outcry from programmers who liked the neat 16-bit breakdown. But the increase stuck, Verplank said, because they had already decided to store 72 bits per side to allow for white space around each icon.</p><p>After settling on a size for the icons, the Star developers tested four sets developed by two graphic designers and two software engineers. They discovered that, for example, resizing may cause problems. They shrunk the icon for a person—a head and shoulders—in order to use several of them to represent a group, only to hear one test subject say the screen resolution made the reduced icon look like a cross above a tombstone. Computer graphics artist Norm Cox, now of Cox &amp; Hall, Dallas, Texas, was finally hired to redesign the icons.</p><p>Icon designers today still wrestle with the need to make icons adaptable to the many different system configurations offered by computer makers. Artist Karen Elliott, who has designed icons for Microsoft, Apple, Hewlett-Packard Co., and others, noted that on different systems an icon may be displayed in different colors, several resolutions, and a variety of gray shades, and it may also be inverted (light and dark areas reversed).</p><p>In the past few years, another concern has been added to icon designers’ tasks: internationalization. Icons designed in the United States often lack space for translations into languages other than English. Elliott therefore tries to leave space for both the longer words and the vertical orientation of some languages.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem11" data-id="11" data-is-image="True" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-11" data-published-at="1666292177" data-basename="particle-11" data-post-id="2658380204"><img id="b2123" data-rm-shortcode-id="6c41bc129931f142a96a46f0abb579f0" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1232 1173&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-square-white-macintosh-computer-with-a-white-keyboard-in-a-separate-image-below-computer-icons-and-the-text-address-book-ad.jpg?id=31974217&width=980" width="1232" height="1173" alt="A square white macintosh computer with a white keyboard, in a separate image below, computer icons and the text address book, address, addresses"/><small class="image-media media-caption"><p>More than two million of the Apple Macintosh (top), which brought the graphical user interface to personal computers, have been sold. Much of its application software is inconsistent, however: at least three different icons (bottom) can represent address files. The icons are found in Desktop Express from Dow Jones &amp; Co., HyperCard from Apple Computer Inc., and MS Word from Microsoft Corp.</p></small><small class="image-media media-photo-credit"><p>Apple Computer Inc.</p></small><p>The main rule is to make icons simple, clean, and easily recognizable. Discarded objects are placed in a trash can on the Macintosh. On the NeXT Computer System, from NeXT Inc., Palo Alto, Calif.—the company formed by Apple cofounder Steven Jobs after he left Apple—they are dumped into a Black Hole. Elliott sees NeXT’s black hole as one of the best icons ever designed: ”It is distinct; its roundness stands out from the other, square icons, and this is important on a crowded display. It fits my image of information being sucked away, and it makes it clear that dumping something is serious.<br/></p><p>English disagrees vehemently. The black hole “is fundamentally wrong,” he said. “You can dig paper out of a wastebasket, but you can’t dig it out of a black hole.” Another critic called the black hole familiar only to “computer nerds who read mostly science fiction and comics,” not to general users.</p><p>With the introduction of the Xerox Star in June 1981, the graphical user interface, as it is known today, arrived on the market. Though not a commercial triumph, the Star generated great interest among computer users, as the Alto before it had within the universe of computer designers.</p><p>Even before the Star was introduced, Jobs, then still at Apple, had visited Xerox PARC in November 1979 and asked the Smalltalk researchers dozens of questions about the Alto’s internal design. He later recruited Larry Tesler from Xerox to design the user interface of the Apple Lisa.</p><p>With the Lisa and then the Macintosh, introduced in January 1983 and January 1984 respectively, the graphical user interface reached the low-cost, high-volume computer market.</p><p>At almost $10,000, buyers deemed the Lisa too expensive for the office market. But aided by prizewinning advertising and its lower price, the Macintosh took the world by storm. Early Macs had only 128K bytes of RAM, which made them slow to respond because it was too little memory for heavy graphic manipulation. Also, the time needed for programmers to learn its Toolbox of graphics routines delayed application packages until well into 1985. But the Mac’s ease of use was indisputable, and it generated interest that spilled over into the MS-DOS world of IBM PCs and clones, as well as Unix-based workstations.</p></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem23" data-id="23" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/who-owns-the-graphical-user-interface" data-published-at="1668019407" data-basename="who-owns-the-graphical-user-interface" data-post-id="2658380204"><h3 data-role="headline">Who owns the graphical user interface?</h3><p>The widespread acceptance of such interfaces, however, has led to bitter lawsuits to establish exactly who owns what. So far, none of several litigious companies has definitively established that it owns the software that implements windows, icons, or early versions of menus. But the suits continue.</p><p>Virtually all the companies that make and sell either wheel or ball mice paid license fees to SRI or to Xerox for their patents. Engelbart recalled that SRI patent attorneys inspected all the early work on the interface, but understood only hardware. After looking at developments like the implementation of windows, they told him that none of it was patentable.</p><p>At Xerox, the Star development team proposed 12 patents having to do with the user interface. The company’s patent committee rejected all but two on hardware—one on BitBlt, the other on the Star architecture. At the time, Charles Irby said, it was a good decision. Patenting required full disclosure, and no precedents then existed for winning software patent suits.</p></div><div class="listicle-slideshow listicle-slideshow__init" data-group-id="16" data-current-id="1" data-show-thumbs="true" data-allow-url-update="true"><div class="rebellt-item rebellt-item-fade-in" id="rebelltitem12" data-index="17" data-id="12" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-12" data-basename="particle-12" data-post-id="2658380204"><h3 class="listicle-slideshow-headline" data-role="headline"></h3><div class="rebellt-item-media-container"><div class="listicle-slideshow-media-html"><div class="listicle-slideshow-description"><img id="175a2" data-rm-shortcode-id="afd52dfc1dba5bfccb97bee698745c1d" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1240 904&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-computer-screen-in-blue-and-white-with-multiple-open-windows.jpg?id=31974283&width=980" width="1240" height="904" alt="A computer screen in blue and white with multiple open windows"/></div></div><div class="listicle-slideshow-pager"><a href="javascript: void(0)" class="listicle-slideshow-switch-page-btn listicle-slideshow--prev"><span><i></i><i class="fa fa-play-circle fa-flip-horizontal"></i></span></a><a href="javascript: void(0)" class="listicle-slideshow-switch-page-btn listicle-slideshow--next"><span><i></i><i class="fa fa-play-circle"></i></span></a></div></div><div class="image-media media-photo-credit"><p>Microsoft Corp.</p></div><div class="image-media media-caption"><p>Today more than a dozen separate graphical user interfaces run on a variety of personal computers and workstations. The Presentation Manager component of Operating System/2, jointly developed by Microsoft Corp. and IBM Corp., is intended to run on several million IBM and compatible personal computers; this display shows that too many onscreen windows can impede clarity.</p></div><div class="rebellt-ecommerce--vendor hidden"></div><div class="rebellt-ecommerce--sum hidden"><div class="rebellt-ecommerce--price hidden"><span class="rebellt-ecommerce--compare-at-price hidden"></span><span class="rebellt-ecommerce--price-number"></span></div><div class="rebellt-ecommerce--buy"><a href="#" class="rebellt-ecommerce--btn" target="_blank"></a></div></div><div class="listicle-slideshow__counter"><b class="listicle-slideshow__counter--current">1</b><b class="listicle-slideshow__counter--separator">/</b><b class="listicle-slideshow__counter--length">3</b></div><div class="listicle-slideshow-description"></div></div><div class="listicle-slideshow__thumbnails clearfix"><div class="listicle-slideshow__thumbnail active" data-active-item="1" data-goto-slide="1" data-media-html-id="slide-html-2658380204-16-1" data-text-html-id="slide-text-html-2658380204-16-1" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-12" data-post-id="2658380204"><template id="slide-html-2658380204-16-1"><img id="175a2" data-rm-shortcode-id="afd52dfc1dba5bfccb97bee698745c1d" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1240 904&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-computer-screen-in-blue-and-white-with-multiple-open-windows.jpg?id=31974283&width=980" width="1240" height="904" alt="A computer screen in blue and white with multiple open windows"/></template><script type="application/json" id="slide-text-html-2658380204-16-1">
                    {"product_info": {"product_vendor": false, "product_price": 0, "linkout_url": false, "product_compare_at_price": 0, "caption": "Buy Now"}, "headline": "", "description": "", "credit": "\u003cp\u003eMicrosoft Corp.\u003c/p\u003e", "caption": "\u003cp\u003eToday more than a dozen separate graphical user interfaces run on a variety of personal computers and workstations. The Presentation Manager component of Operating System/2, jointly developed by Microsoft Corp. and IBM Corp., is intended to run on several million IBM and compatible personal computers; this display shows that too many onscreen windows can impede clarity.\u003c/p\u003e"}
                </script><div class="image crop-3x2 widget__image" data-runner-img-hd="https://spectrum.ieee.org/media-library/a-computer-screen-in-blue-and-white-with-multiple-open-windows.jpg?id=31974283&width=210"></div></div><div class="listicle-slideshow__thumbnail " data-active-item="2" data-goto-slide="2" data-media-html-id="slide-html-2658380204-17-2" data-text-html-id="slide-text-html-2658380204-17-2" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-14" data-post-id="2658380204"><template id="slide-html-2658380204-17-2"><img id="be8a0" data-rm-shortcode-id="59fc9b528fa0f0424ed4c03dd851d167" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1240 943&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/three-computer-windows-with-greyscale-images-on-a-dark-grey-background.jpg?id=31974284&width=980" width="1240" height="943" alt="Three computer windows with greyscale images on a dark grey background"/></template><script type="application/json" id="slide-text-html-2658380204-17-2">
                    {"product_info": {"product_vendor": false, "product_price": 0, "linkout_url": false, "product_compare_at_price": 0, "caption": "Buy Now"}, "headline": "", "description": "", "credit": "\u003cp\u003eNeXT Inc.\u003c/p\u003e", "caption": "\u003cp\u003eThe monochrome NextStep interface for the NeXT Computer System from NeXT Inc. offers gray-scale images, but so far no color capability.\u003c/p\u003e"}
                </script><div class="image crop-3x2 widget__image" data-runner-img-hd="https://spectrum.ieee.org/media-library/three-computer-windows-with-greyscale-images-on-a-dark-grey-background.jpg?id=31974284&width=210"></div></div><div class="listicle-slideshow__thumbnail " data-active-item="3" data-goto-slide="3" data-media-html-id="slide-html-2658380204-18-3" data-text-html-id="slide-text-html-2658380204-18-3" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-15" data-post-id="2658380204"><template id="slide-html-2658380204-18-3"><img id="d47ab" data-rm-shortcode-id="d17a5de9e1f57bc4fd3b8b6d440965a9" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1240 935&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/computer-windows-tinted-blue-on-a-black-background-partially-obscuring-a-planet-and-starfield.jpg?id=31974285&width=980" width="1240" height="935" alt="Computer windows tinted blue on a black background partially obscuring a planet and starfield"/></template><script type="application/json" id="slide-text-html-2658380204-18-3">
                    {"product_info": {"product_vendor": false, "product_price": 0, "linkout_url": false, "product_compare_at_price": 0, "caption": "Buy Now"}, "headline": "", "description": "", "credit": "\u003cp\u003eOpen Software Foundation\u003c/p\u003e", "caption": "\u003cp\u003eThe Open Software Foundation\u2019s Motif is the graphical interface for a new version of the Unix operating system developed by the consortium of 150 companies that want to keep Unix an open standard. The first commercial version is to be released in July 1990.\u003c/p\u003e"}
                </script><div class="image crop-3x2 widget__image" data-runner-img-hd="https://spectrum.ieee.org/media-library/computer-windows-tinted-blue-on-a-black-background-partially-obscuring-a-planet-and-starfield.jpg?id=31974285&width=210"></div></div></div></div><div class="
        
        rebellt-item
        is--desktop
        col1
        
        " id="rebelltitem13" data-id="13" data-is-image="False" data-href="https://spectrum.ieee.org/graphical-user-interface/particle-13" data-published-at="1666292177" data-basename="particle-13" data-post-id="2658380204"><p>
	The most recent and most publicized suit was filed in March 1988, by Apple, against both Microsoft and Hewlett-Packard Co., Palo Alto, Calif. Apple alleges that HP’s New Wave interface, requiring version 2.03 of Microsoft’s Windows program, embodies the copyrighted “audio visual computer display” of the Macintosh without permission; that the displays of Windows 2.03 are illegal copies of the Mac’s audiovisual works; and that Windows 2.03 also exceeds the rights granted in a November 198S agreement in which Microsoft acknowledged that the displays in Windows 1.0 were derivatives of those in Apple’s Lisa and Mac.
</p><p>
	In March 1989, U.S. District Judge William W. Schwarzer ruled Microsoft had exceeded the bounds of its license in creating Windows 2.03. Then in July 1989 Schwarzer ruled that all but 11 of the 260 items that Apple cited in its suit were, in fact, acceptable under the 1985 agreement. The larger issue—whether Apple’s copyrights are valid, and whether Microsoft and HP infringed on them—will not now be examined until 1990.
</p><p>
	Among those 11 are overlapping windows and movable icons. According to Pamela Samuelson, a noted software intellectual property expert and visiting professor at Emory University Law School, Atlanta, Ga., many experts would regard both as functional features of an interface that cannot be copyrighted, rather than “expressions” of an idea protectable by copyright.
</p><p>
	But lawyers for Apple—and for other companies that have filed lawsuits to protect the “look and feel’’ of their screen displays—maintain that if such protection is not granted, companies will lose the economic incentive to market technological innovations. How is Apple to protect its investment in developing the Lisa and Macintosh, they argue, if it cannot license its innovations to companies that want to take advantage of them?
</p><p>
	If the Apple-Microsoft case does go to trial on the copyright issues, Samuelson said, the court may have to consider whether Apple can assert copyright protection for overlapping windows-an interface feature on which patents have also been granted. In April 1989, for example, Quarterdeck Office Systems Inc., Santa Monica, Calif., received a patent for a multiple windowing system in its Desq system software, introduced in 1984.
</p><p>
	Adding fuel to the legal fire, Xerox said in May 1989 it would ask for license fees from companies that use the graphical user interface. But it is unclear whether Xerox has an adequate claim to either copyright or patent protection for the early graphical interface work done at PARC. Xerox did obtain design patents on later icons, noted human factors engineer Verplank. Meanwhile, both Metaphor and Sun Microsystems have negotiated licenses with Xerox for their own interfaces.
</p><h3>To Probe Further</h3><p>
	The September 1989 <em data-redactor-tag="em">IEEE Computer</em> contains an article, <a href="https://ieeexplore.ieee.org/document/35211" target="_blank" rel="noopener noreferrer">“The Xerox ‘Star’: A Retrospective,”</a> by Jeff Johnson et al., covering development of the Star. “Designing the Star User Interface,’’ <a href="http://billverplank.com/CiiD/XeroxStar.pdf" target="_blank" rel="noopener noreferrer">[PDF]</a> by David C. Smith et al., appeared in the April 1982 issue of <em data-redactor-tag="em">Byte</em>.
</p><p>
	The Sept. 12, 1989, <em data-redactor-tag="em">PC Magazine</em> contains six articles on graphical user interfaces for personal computers and workstations. The July 1989 <em data-redactor-tag="em">Byte</em> includes <a href="https://guidebookgallery.org/articles/aguidetoguis" target="_blank" rel="noopener noreferrer">‘‘A Guide to [Graphical User Interfaces),”</a> by Frank Hayes and Nick Baran, which describes 12 current interfaces for workstations and personal computers. “The Interface of Tomorrow, Today,’’ by Howard Reingold, in the July 10, 1989, <em data-redactor-tag="em">InfoWorld</em> does the same. “The interface that launched a thousand imitations,” by Richard Rawles, in the March 21, 1989, <em data-redactor-tag="em">MacWeek </em>covers the Macintosh interface.
</p><p>
	The human factors of user interface design are discussed in <a href="https://www.amazon.com/Psychology-Everyday-Things-Don-Norman/dp/0465067093" target="_blank" rel="noopener noreferrer"><em data-redactor-tag="em">The Psychology of Everyday Things</em></a>, by Donald A. Norman (Basic Books Inc., New York, 1988). The January 1989 <a href="https://www.computer.org/csdl/magazine/so/1989/01" target="_blank" rel="noopener noreferrer"><em data-redactor-tag="em">IEEE Software</em></a> contains several articles on methods, techniques, and tools for designing and implementing graphical interfaces. <a href="https://www.amazon.com/Way-Things-Work-David-Macaulay/dp/0395428572" target="_blank" rel="noopener noreferrer"><em data-redactor-tag="em">The Way Things Work</em></a>, by David Macaulay (Houghton Mifflin Co., Boston, 1988), contains a detailed drawing of a ball mouse.
</p><p>
	The October 1985 <em data-redactor-tag="em">IEEE Spectrum</em> covered Xerox PARC’s history in “Research at Xerox PARC: a founder’s assessment,” by George Pake (pp. 54-61) and <a href="https://spectrum.ieee.org/xerox-parc" target="_self">“Inside the PARC: the ‘information architects,’“</a> by Tekla Perry and Paul Wallich (pp. 62-75).
</p><p>
	William Atkinson received <a href="https://uspto.report/patent/grant/4,464,652" target="_blank" rel="noopener noreferrer">patent no. 4,464,652</a> for the pulldown menu system on Aug. 8, 1984, and assigned it to Apple. Gary Pope received <a href="https://patents.google.com/patent/US5847705" target="_blank" rel="noopener noreferrer">patent no. 4,823,108</a>, for an improved system for displaying images in “windows” on a computer screen, on April 18, 1989, and assigned it to Quarterdeck Office Systems.
</p><p>
	The wheel mouse <a href="https://patents.google.com/patent/US3541541A/en" target="_blank" rel="noopener noreferrer">patent, no. 3,541,541</a>, “X-Y position indicator for a display system,” was issued to Douglas Engelbart on Nov. 17, 1970, and assigned to SRI International. The ball mouse <a href="https://uspto.report/patent/grant/3835464" target="_blank" rel="noopener noreferrer">patent, no. 3,835,464</a>, was issued to Ronald Rider on Sept. 10, 1974, and assigned to Xerox.
</p><p>
	The first selection device tests to include a mouse are covered in <a href="https://ieeexplore.ieee.org/document/1698228" target="_blank" rel="noopener noreferrer">“Display-Selection Techniques for Text Manipulation,”</a> by William English, Douglas Engelbart, and Melvyn Berman, in <em data-redactor-tag="em">IEEE Transactions on Human Factors in Electronics</em>, March 1967.
</p><p><a href="https://dspace.mit.edu/handle/1721.1/14979" target="_blank" rel="noopener noreferrer"><em data-redactor-tag="em">Sketchpad: A Man-Machine Graphical Communication System</em></a>, by Ivan E. Sutherland (Garland Publishing Inc., New York City and London, 1980), reprints his 1963 Ph.D. thesis.<span class="ieee-end-mark" data-verified="redactor" data-redactor-tag="span" data-redactor-class="ieee-end-mark"></span></p></div><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div><ul class="around-the-web__list"><li class="from-your-site__item"><a href="https://spectrum.ieee.org/larry-tesler-the-computer-scientist-who-revolutionized-the-user-interface-dies-at-74" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Larry Tesler, the Computer Scientist Who Revolutionized the User ... ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/xerox-parc/smalltalk-history" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Kids and Us: The Story of Smalltalk - IEEE Spectrum ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/thirty-years-later-the-influence-of-the-macintosh-can-still-be-felt" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Thirty Years Later, the Influence of the Macintosh Can Still Be Felt ... ›</a></li></ul><div class="around-the-web__headline">Related Articles Around the Web</div><ul class="around-the-web__list"><li class="around-the-web__item"><a href="https://history-computer.com/sketchpad-guide/" class="around-the-web__link" target="_blank" rel="noopener noreferrer">The History of the Sketchpad Computer Program - A Complete Guide ›</a></li><li class="around-the-web__item"><a href="https://en.wikipedia.org/wiki/Graphical_user_interface" class="around-the-web__link" target="_blank" rel="noopener noreferrer">Graphical user interface - Wikipedia ›</a></li></ul></div></div></div><span class="js-scrolled-url" data-elid="2658380204" data-post-url="https://spectrum.ieee.org/graphical-user-interface" data-authors="Tekla S. Perry, John Voelcker" data-headline="How the Graphical User Interface Was Invented"></span><div class="tags"><a class="tags__item" href="https://spectrum.ieee.org/tag/computer-history">computer history</a><a class="tags__item" href="https://spectrum.ieee.org/tag/alto">Alto</a><a class="tags__item" href="https://spectrum.ieee.org/tag/ivan-sutherland">Ivan Sutherland</a><a class="tags__item" href="https://spectrum.ieee.org/tag/user-interface">user interface</a><a class="tags__item" href="https://spectrum.ieee.org/tag/computer-mouse">computer mouse</a><a class="tags__item" href="https://spectrum.ieee.org/tag/doug-engelbart">Doug Engelbart</a><a class="tags__item" href="https://spectrum.ieee.org/tag/xerox-parc">Xerox Parc</a><a class="tags__item" href="https://spectrum.ieee.org/tag/apple">Apple</a><a class="tags__item" href="https://spectrum.ieee.org/tag/larry-tesler">Larry Tesler</a><a class="tags__item" href="https://spectrum.ieee.org/tag/windows">Windows</a><a class="tags__item" href="https://spectrum.ieee.org/tag/history">history</a></div><div class="custom-field-lightbox-img-shortcode-ids">{&quot;imageShortcodeIds&quot;:[]}</div></div></div></div><script type="application/json" id="post-context-2658380204" class="post-context post-context-2658380204">
    {"customDimensions": {"5":"Tekla S. Perry, John Voelcker","11":2658380204,"7":"computer history, Alto, Ivan Sutherland, user interface, computer mouse, Doug Engelbart, Xerox Parc, Apple, Larry Tesler, Windows, history","10":"history","6":"tech-history","8":"11/20/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 544169516, 544169517, 539617903, 539619441], "buckets": [], "authors": [21075155, 21078857]} }
</script></article></div></div></div></div><div class="container_feature_below" id="sOpen_Current_Feature_Post_0_0_15_0_0_1"><div class="" id="sOpen_Current_Feature_Post_0_0_15_0_0_1_0"><div class="mb-2 post-author-list" id="sOpen_Current_Feature_Post_0_0_15_0_0_1_0_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-v="2" data-attr-posts_id="sOpen_Current_Feature_Post_0_0_15_0_0_1_0_0" data-attr-layout_quality="1" data-attr-node_id="/root/blocks/block[open_current_feature_post]/abtests/abtest[1]/element_wrapper/element_wrapper/current_post-" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_all_headline_tag="h1" data-attr-layout_all_subheadline_tag="h2" data-attr-all_element_order="author,headline,subheadline,section,community_name,date,date_modified,badges,badges_sponsored,photo_credit,photo_caption,body,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,product_prices,product_vendor,product_buy_link,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_Instagram,site_field_member_badges,site_field_Twitter,site_field_LinkedIn,site_field_grade,site_field_Facebook,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_pdf_version,custom_field_copy_editor,custom_field_FullwidthCardColor,custom_field_disable_comments,custom_field_PodcastVideoTime,custom_field_fullwidthbackgroundposition,custom_field_lightbox_img_shortcode_ids,custom_field_access,custom_field_Editor,custom_field_PodcastEpisode,custom_field_publication_date,custom_field_TimeofRead,custom_field_FeaturePostColor,custom_field_FullwidthCardPosition,custom_field_is_updated_post,custom_field_youtube_video" data-attr-layout_author="top" data-attr-layout_remove_image="true" data-attr-show_authors_bio="true" data-attr-element_classes="post-author-list" data-attr-filters="section" data-attr-section_url="" data-attr-source="" data-attr-format="posts-custom" data-attr-is_current_post="true"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-computer-history tag-alto tag-ivan-sutherland tag-user-interface tag-computer-mouse tag-doug-engelbart tag-xerox-parc tag-apple tag-larry-tesler tag-windows tag-history post-section--topic/tech-history" data-category="History of Technology"><article elid="2658380204" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658380204" data-category="History of Technology"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/media-library/eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA5NDcwMi9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcyMzA1NDkzNn0.gbFAtEQX36yzfmx_HixIADGZY8vd-q3M-GGzK9mxSrU/image.png?width=210&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/tekla-perry" data-type="text">Tekla S. Perry</a><div class="social-author__bio"><p><a href="https://twitter.com/TeklaPerry" target="_blank">Tekla S. Perry</a> is a senior editor at <em>IEEE Spectrum</em>. Based in Palo Alto, Calif., she&#39;s been covering the people, companies, and technology that make Silicon Valley a special place for more than 40 years. An IEEE member, she holds a bachelor&#39;s degree in journalism from Michigan State University.
</p></div><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/res/avatars/default&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/john-voelcker" data-type="text">John Voelcker</a></div></div><div class="widget__head"></div></div></div><script type="application/json" id="post-context-2658380204" class="post-context post-context-2658380204">
    {"customDimensions": {"5":"Tekla S. Perry, John Voelcker","11":2658380204,"7":"computer history, Alto, Ivan Sutherland, user interface, computer mouse, Doug Engelbart, Xerox Parc, Apple, Larry Tesler, Windows, history","10":"history","6":"tech-history","8":"11/20/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 544169516, 544169517, 539617903, 539619441], "buckets": [], "authors": [21075155, 21078857]} }
</script></article></div></div></div></div></div><div class="" id="sOpen_Current_Feature_Post_0_0_15_0_0_1_1_1_0"><div class="post-partial article__comments"><div class="article-content__comments-wrapper"><div id="comments-widget"><div class="talk-comments-wrp community-native-wrp " data-talk_id="post:2658380204:comments" data-limit="3" data-order="best" data-is_amp="" data-count_top_level="0" data-count_featured="0" data-show_rating="False" data-all_element_order="avatar,title,date,site_field_member_badges,site_field_grade,message,update_author_rating,update_avatar,follow,bio,review" data-words-per-message="{&quot;min&quot;: 1, &quot;max&quot;: 100}" data-inactive_layout_attributes="update_avatar,follow,bio,review" data-active_layout_attributes="site_field_member_badges,site_field_grade"><div class="editmode-section-title"></div><a href="#" class="hidden new-comments-notification" aria-label="New coments notification"></a><div class="comment-headline">The Conversation (0)</div><div class="add-comment"><div class="comment_placeholder-wrp"><div class="animated-background"><div class="placeholder__textarea_top"></div><div class="placeholder__textarea_botmiddle_left"></div><div class="placeholder__textarea_botmiddle_right"></div><div class="placeholder__textarea_bottom"></div><div class="placeholder__button_b"></div><div class="placeholder__button_i"></div><div class="placeholder__button_publish"></div></div><div class="comment-login-wrp"></div></div></div><div class="comment-header"></div><div class="talk--messages"><div class="talk--messages__featured"></div><div class="talk--messages__top_level"></div></div><script type="rm-preact-state">{"authors": {}, "forcedComments": [], "topLevelComments": [], "featuredComments": []}
        </script><div class="talk--load_more-wrp "></div></div></div></div></div><!-- User Code --><script>
    var clickeableItems = [
      ".talk-comments-wrp .add-comment",
      ".talk-comments-wrp .comment-item--publish",
      ".talk-comments-wrp .comment--item__reply",
      ".talk-comments-wrp .comment--item__like",
      ".talk-comments-wrp .comment--item__dislike",
      ".talk-comments-wrp .replies"];
    var talkItems = document.querySelectorAll(clickeableItems.join(",")) || [];
    talkItems.forEach(function(item) {
      item.addEventListener("click", function(event){
        event.preventDefault();
        event.stopPropagation();
        openGatedPopup('for_comments');
        }, true);
    });
</script><!-- End User Code --></div><div class="mb-2 read_also_posts" id="sOpen_Current_Feature_Post_0_0_15_0_0_1_2_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_1" data-format="posts-custom" data-source="filtered_parent_site" data-source-type="page" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-v="2" data-attr-posts_id="sOpen_Current_Feature_Post_0_0_15_0_0_1_2_1_0" data-attr-source_unique="true" data-attr-without_current="true" data-attr-layout_quality="1" data-attr-node_id="/root/blocks/block[open_current_feature_post]/abtests/abtest[1]/element_wrapper/choose[2]/otherwise/posts-" data-attr-use_tag_image_for_lead_media="true" data-attr-source="filtered" data-attr-from_regular_sections_of_current_post="true" data-attr-from_regular_sections_other_than="webinar,whitepaper,sponsored,podcast,video,tests,issue-cover-posts" data-attr-all_element_order="all_sections,headline,date,time_to_read,like_button,custom_field_TimeofRead,section,primary_tag,author,badges,badges_sponsored,photo_credit,community_name,subheadline,snark_line,page_views,photo_caption,follow_button,community_comments,body,collection_button,tags,source_link,main_author,post_shares,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_lightbox_img_shortcode_ids" data-attr-limit="3" data-attr-layout_headline="right" data-attr-data-rm-device-crops="true" data-attr-layout_desktop_image_crop="original" data-attr-layout_image_column_width="28" data-attr-data-rm-advanced="true" data-attr-element_classes="read_also_posts" data-attr-layout_date="right" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-layout_all_image_crop="original" data-attr-layout_like_button="right" data-attr-layout_all_sections="right" data-attr-layout_time_to_read="right" data-attr-format="posts-custom" data-attr-source_site="parent_site"><div class="posts-wrapper clearfix"><div class="widget tag-explainer tag-invention-of-the-transistor tag-point-contact-transistor tag-semiconductor-electronics tag-transistors post-section--topic/semiconductors" elid="2658669320" data-category="Semiconductors"><article elid="2658669320" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658669320"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/transistor-history" aria-label="How the First Transistor Worked"><img role="img" type="lazy-image" alt="A phot of an outstretched hand with several transistors in the palm of it.  " aria-label="A phot of an outstretched hand with several transistors in the palm of it.  " src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2119 1622&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-phot-of-an-outstretched-hand-with-several-transistors-in-the-palm-of-it.png?id=32107129&width=1200&height=918" style="object-fit: cover;" class="rm-lazyloadable-image" width="2119" height="1622"/></a></div></div><div id="col-right" class="rm-col-right col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/semiconductors/">Semiconductors</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/magazine/2022/december/">December 2022</a><a href="https://spectrum.ieee.org/magazine/">Magazine</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/feature/">Feature</a><a href="https://spectrum.ieee.org/type/explainer/">Explainer</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/transistor-history" aria-label="How the First Transistor Worked" data-type="text">
        How the First Transistor Worked
    </a></h2><div class="social-date"><span class="social-date__text">5h</span></div><div class="time-to-read">12 min read</div><div class="like-button" data-post-likes="1"></div></div></div></div><script type="application/json" id="post-context-2658669320" class="post-context post-context-2658669320">
    {"customDimensions": {"5":"Glenn Zorpette","11":2658669320,"7":"explainer, invention of the transistor, point-contact transistor, semiconductor electronics, transistors","10":"semiconductor electronics","6":"semiconductors","8":"11/20/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 564919488, 539626628, 555118571, 544169516, 544169517, 539621009, 544169529], "buckets": [], "authors": [20372185]} }
</script></article></div><div class="widget tag-electric-vehicles tag-batteries tag-supply-chain tag-engineering-jobs tag-skills-gap post-section--internal" elid="2658463682" data-category="Topic"><article elid="2658463682" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658463682"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/the-ev-transition-explained-2658463682" aria-label="The EV Transition Explained: Battery Challenges"><img role="img" type="lazy-image" alt="A General Motors Hummer EV chassis sits in front of an Hummer EV outside of an event " aria-label="A General Motors Hummer EV chassis sits in front of an Hummer EV outside of an event " src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 3000 2000&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-general-motors-hummer-ev-chassis-sits-in-front-of-an-hummer-ev-outside-of-an-event.jpg?id=32122904&width=1200&height=800" style="object-fit: cover;" class="rm-lazyloadable-image" width="3000" height="2000"/></a></div></div><div id="col-right" class="rm-col-right col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/topic/energy/">Energy</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/transportation/">Transportation</a><a href="https://spectrum.ieee.org/type/analysis/">Analysis</a><a href="https://spectrum.ieee.org/topic/careers/">Careers</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/the-ev-transition-explained-2658463682" aria-label="The EV Transition Explained: Battery Challenges" data-type="text">
        The EV Transition Explained: Battery Challenges
    </a></h2><div class="social-date"><span class="social-date__text">19 Nov 2022</span></div><div class="time-to-read">6 min read</div><div class="like-button" data-post-likes="1"></div></div></div></div><script type="application/json" id="post-context-2658463682" class="post-context post-context-2658463682">
    {"customDimensions": {"5":"Robert N. Charette","11":2658463682,"7":"electric vehicles, batteries, supply chain, engineering jobs, skills gap","10":"electric vehicles","6":"topic","8":"11/19/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 539619077, 544169516, 539622579, 544169524, 539628627, 550122300, 550122302], "buckets": [], "authors": [21075158]} }
</script></article></div><div class="widget tag-neurotechnology tag-eeg tag-neuroethics tag-productivity tag-workplace post-section--topic/biomedical" elid="2658651459" data-category="Biomedical"><article elid="2658651459" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658651459"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/neurotech-workplace-innereye-emotiv" aria-label="Are You Ready for Workplace Brain Scanning?"><img role="img" type="lazy-image" alt="A photo collage showing a man wearing a eeg headset while looking at a computer screen." aria-label="A photo collage showing a man wearing a eeg headset while looking at a computer screen." src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2455 1841&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-collage-showing-a-man-wearing-a-eeg-headset-while-looking-at-a-computer-screen.jpg?id=32111383&width=2455&height=1841&quality=85&coordinates=0%2C0%2C0%2C0" style="object-fit: cover;" class="rm-lazyloadable-image" width="2455" height="1841"/></a></div></div><div id="col-right" class="rm-col-right col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/biomedical/">Biomedical</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/magazine/2022/december/">December 2022</a><a href="https://spectrum.ieee.org/magazine/">Magazine</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/feature/">Feature</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/neurotech-workplace-innereye-emotiv" aria-label="Are You Ready for Workplace Brain Scanning?" data-type="text">
        Are You Ready for Workplace Brain Scanning?
    </a></h2><div class="social-date"><span class="social-date__text">19 Nov 2022</span></div><div class="time-to-read">11 min read</div><div class="like-button" data-post-likes="1"></div></div></div></div><script type="application/json" id="post-context-2658651459" class="post-context post-context-2658651459">
    {"customDimensions": {"5":"Evan Ackerman, Eliza Strickland","11":2658651459,"7":"neurotechnology, EEG, neuroethics, productivity, workplace","10":"neurotechnology","6":"biomedical","8":"11/19/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 564919488, 539626628, 539266149, 555118571, 544169516, 544169517], "buckets": [], "authors": [21075149, 21075161]} }
</script></article></div></div></div></div></div></div></div><div id="sSS_Feature_Post_0_0_21_0_0_1_2" class="featured_columns row-wrapper clearfix "><div class="row "><div id="sSS_Feature_Post_0_0_21_0_0_1_2_0" class=" col sm-mb-2 md-mb-4 s12 m12 l12"><div class="" id="sSS_Feature_Post_0_0_21_0_0_1_2_0_0"><!-- User Code --><div class="rblad-ieee_infinite_leaderboard"></div><!-- End User Code --></div></div></div></div><div id="sSS_Feature_Post_0_0_21_0_0_1_3" class="featured_columns row-wrapper clearfix "><div class="row "><div id="sSS_Feature_Post_0_0_21_0_0_1_3_0" class="article_column col sm-mb-2 md-mb-4 s12 m12 l9"><div class="mb-2 article_post infinite_scroll" id="sSS_Feature_Post_0_0_21_0_0_1_3_0_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_2" data-format="posts-custom" data-source="post_most_sections" data-source-type="page" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-v="2" data-attr-posts_id="sSS_Feature_Post_0_0_21_0_0_1_3_0_0" data-attr-source_unique="true" data-attr-without_current="true" data-attr-layout_quality="4" data-attr-header_template="jinja/post/custom-css.html" data-attr-node_id="/root/blocks/block[ss_feature_post]/abtests/abtest[1]/element_wrapper/row[2]/column[1]/posts[1]-" data-attr-use_tag_image_for_lead_media="true" data-attr-source="filtered" data-attr-source_id="post_most_sections" data-attr-from_regular_sections_of_current_post="true" data-attr-from_regular_sections_other_than="tests, issue-cover-posts, feature, sponsored, webinar, whitepaper, podcast, video, slideshow, the-big-picture" data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,photo_caption,photo_credit,post_shares,custom_field_pdf_version,tags,body,custom_field_lightbox_img_shortcode_ids,main_author,custom_field_TimeofRead,primary_tag,page_views,badges,badges_sponsored,source_link,community_name,snark_line,collection_button,community_comments,section,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_Editor,custom_field_PodcastTime,custom_field_PodcastEpisode,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_copy_editor,custom_field_is_updated_post,custom_field_youtube_video" data-attr-layout_headline="top" data-attr-data-rm-device-crops="true" data-attr-layout_all_image_crop="original" data-attr-layout_image_column_width="33" data-attr-limit="1" data-attr-data-rm-advanced="true" data-attr-element_classes="article_post infinite_scroll" data-attr-layout_subheadline="top" data-attr-layout_date="top" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-layout_like_button="top" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Email,CopyLink,Whatsapp,Twitter,Facebook,Linkedin,Separator,Tumblr,GooglePlus,Pinterest,Reddit,Flipboard,SMS,Slack" data-attr-layout_separator="inactive" data-attr-layout_tumblr="inactive" data-attr-layout_googleplus="inactive" data-attr-layout_pinterest="inactive" data-attr-layout_reddit="inactive" data-attr-layout_flipboard="inactive" data-attr-layout_sms="inactive" data-attr-layout_slack="inactive" data-attr-layout_facebook="active" data-attr-layout_twitter="active" data-attr-layout_linkedin="active" data-attr-layout_copylink="active" data-attr-layout_all_sections="top" data-attr-layout_photo_caption="bottom" data-attr-layout_photo_credit="bottom" data-attr-layout_post_shares="bottom" data-attr-layout_tags="bottom" data-attr-layout_body="bottom" data-attr-layout_all_show_video="true" data-attr-use_smart_keep_reading="true" data-attr-show_more_button_text="Keep Reading ↓" data-attr-layout_whatsapp="inactive" data-attr-layout_author="top" data-attr-layout_time_to_read="top" data-attr-show_authors_bio="true" data-attr-show_around_the_web="true" data-attr-layout_custom_field_lightbox_img_shortcode_ids="bottom" data-attr-layout_custom_field_pdf_version="bottom" data-attr-format="posts-custom" data-attr-source_site="parent_site"><div class="posts-wrapper clearfix"><div class="widget tag-github tag-software-development tag-openai tag-programming tag-coding tag-artificial-intelligence tag-software tag-copyright tag-intellectual-property tag-open-source post-section--topic/computing" elid="2658687697" data-category="Computing"><article elid="2658687697" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658687697"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/computing/">Computing</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/ai-code-generation-ownership" aria-label="Ownership of AI-Generated Code Hotly Disputed" data-type="text">
        Ownership of AI-Generated Code Hotly Disputed
    </a></h2><div class="widget__subheadline"><h3 class="widget__subheadline-text h3" data-type="text"><p>A copyright storm may be brewing for GitHub Copilot</p></h3></div><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/res/avatars/default&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/rina-diane-caballar" data-type="text">Rina Diane Caballar</a><div class="social-author__bio"><p><a href="https://rinacaballar.com/">Rina Diane Caballar</a> is a journalist and former software engineer based in Wellington, New Zealand.
</p></div></div><div class="social-date"><span class="social-date__text">19 Nov 2022</span></div><div class="time-to-read">4 min read</div><div class="like-button" data-post-likes="0"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/ai-code-generation-ownership" aria-label="Ownership of AI-Generated Code Hotly Disputed"><img role="img" type="lazy-image" alt="An illustration of a pixilated person on a ladder placing code." aria-label="An illustration of a pixilated person on a ladder placing code." src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1240 930&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/an-illustration-of-a-pixilated-person-on-a-ladder-placing-code.jpg?id=32124070&width=1200&height=900" style="object-fit: cover;" class="rm-lazyloadable-image" width="1240" height="930"/></a></div><div class="widget__body clearfix sm-mt-1"><div class="photo-credit">
        Edmon De Haro
    </div><div class="widget__shares share-panel"><!-- EMAIL --><a href="mailto:?subject=Ownership%20of%20AI-Generated%20Code%20Hotly%20Disputed&body=https://spectrum.ieee.org/ai-code-generation-ownership" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK --><a href="https://spectrum.ieee.org/ai-code-generation-ownership" data-clipboard-text="https://spectrum.ieee.org/ai-code-generation-ownership" class="share share-copy-link" title="Copy this link to clipboard"><i class="icons-share" style="width: 60%"><svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i></a><!-- TWITTER --><a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/ai-code-generation-ownership&text=Ownership%20of%20AI-Generated%20Code%20Hotly%20Disputed&" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK --><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Fai-code-generation-ownership%3Fxrs%3DRebelMouse_fb%26ts%3D1668877122" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN --><a href="http://www.linkedin.com/shareArticle?mini=false&url=https://spectrum.ieee.org/ai-code-generation-ownership&" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a></div><div class="tags"><a class="tags__item" href="https://spectrum.ieee.org/tag/github">Github</a><a class="tags__item" href="https://spectrum.ieee.org/tag/software-development">software development</a><a class="tags__item" href="https://spectrum.ieee.org/tag/openai">OpenAI</a><a class="tags__item" href="https://spectrum.ieee.org/tag/programming">programming</a><a class="tags__item" href="https://spectrum.ieee.org/tag/coding">coding</a><a class="tags__item" href="https://spectrum.ieee.org/tag/artificial-intelligence">artificial intelligence</a><a class="tags__item" href="https://spectrum.ieee.org/tag/software">software</a><a class="tags__item" href="https://spectrum.ieee.org/tag/copyright">copyright</a><a class="tags__item" href="https://spectrum.ieee.org/tag/intellectual-property">intellectual property</a><a class="tags__item" href="https://spectrum.ieee.org/tag/open-source">open source</a></div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2658687697" data-elid="2658687697" data-post-url="https://spectrum.ieee.org/ai-code-generation-ownership" data-authors="Rina Diane Caballar" data-headline="Ownership of AI-Generated Code Hotly Disputed"><div class="body-description"><div class="widget__brief"><p><a href="https://github.com/features/copilot" rel="noopener noreferrer" target="_blank">GitHub Copilot</a> dubs itself as an “AI pair programmer” for software developers, automatically suggesting code in real time. According to GitHub, Copilot is “powered by <a href="https://openai.com/blog/openai-codex/" rel="noopener noreferrer" target="_blank">Codex</a>, a generative pretrained AI model created by <a href="https://openai.com/" rel="noopener noreferrer" target="_blank">OpenAI</a>” and has been trained on “natural language text and source code from publicly available sources, including code in public repositories on GitHub.”</p><p>However, a <a href="https://www.prnewswire.com/news-releases/joseph-saveri-law-firm-and-matthew-butterick-file-class-action-lawsuit-against-github-microsoft-and-openai-over-violations-of-open-source-licenses-arising-from-github-copilot-an-ai-based-product-301668255.html" rel="noopener noreferrer" target="_blank">class-action lawsuit</a> filed against GitHub Copilot, its parent company <a href="https://www.microsoft.com/" rel="noopener noreferrer" target="_blank">Microsoft</a>, and OpenAI <a href="https://githubcopilotlitigation.com/" rel="noopener noreferrer" target="_blank">claims open-source software piracy and violations of open-source licenses</a>. Specifically, the lawsuit states that code generated by Copilot does not include any attribution of the original author of the code, copyright notices, and a copy of the license, which most open-source licenses require.</p></div><div class="content-container"></div><div class="js-appear-on-expand"><template><p>“The spirit of open source is not just a space where people want to keep it open,” says <a href="https://www.linkedin.com/in/salkimmich/" rel="noopener noreferrer" target="_blank">Sal Kimmich</a>, an open-source developer advocate at <a href="https://www.sonatype.com/" rel="noopener noreferrer" target="_blank">Sonatype</a>, machine learning engineer, and open source contributor and maintainer. “We have developed processes in order to keep open source secure, and that requires traceability, observability, and verification. Copilot is obscuring the original provenance of those [code] snippets.”</p><p class="pull-quote">“I very much hope that what comes out of this lawsuit will be something I can rely on when making decisions about training models in the future.”<br/>—Stella Biderman, EleutherAI</p><p>In an attempt to address the issues with open-source licensing, GitHub plans to introduce a new Copilot feature that will “provide a <a href="https://github.blog/2022-11-01-preview-referencing-public-code-in-github-copilot/" rel="noopener noreferrer" target="_blank">reference for suggestions that resemble public code</a> on GitHub so that you can make a more informed decision about whether and how to use that code,” including “providing attribution where appropriate.” GitHub also has a configurable <a href="https://docs.github.com/en/copilot/configuring-github-copilot/configuring-github-copilot-settings-on-githubcom" rel="noopener noreferrer" target="_blank">filter to block suggestions matching public code</a>.</p><p><div class="rblad-ieee_in_content"></div></p><p>The onus, however, still falls on developers, as GitHub states in <a href="https://docs.github.com/en/site-policy/github-terms/github-terms-for-additional-products-and-features#github-copilot" rel="noopener noreferrer" target="_blank">Copilot’s terms and conditions</a>: “GitHub does not claim any rights in Suggestions, and you retain ownership of and responsibility for Your Code, including Suggestions you include in Your Code.”</p><p>In addition to open-source licensing issues, Copilot raises concerns in terms of the legality of training the system on publicly available code, as well as whether generated code could result in copyright infringement.</p><p>Kimmich points out the <a href="https://spectrum.ieee.org/google-v-oracle-explained-supreme-court-news-apis-software" target="_self">Google v. Oracle case</a>, wherein “taking the names of methods, but not the functional implementation is OK. You’re replacing the functional content but still keeping some of the template.” In the case of Copilot, it might generate copyrighted code verbatim. (See related tweet below from <a href="https://engineering.tamu.edu/cse/profiles/davis-tim.html" target="_blank">Tim Davis</a>, computer science professor at Texas A&amp;M University, as an illustration of Copilot generating copyrighted code.) </p><div id="82991" class="rm-shortcode" data-rm-shortcode-id="83af94d7805fabe42bd207cafc2dc055"><div class="rm-embed-container rm-embed-twitter rm-loading"><span class="rm-embed-spacer rm-embed-spacer-mobile" style="padding-bottom: 170%"></span><span class="rm-embed-spacer rm-embed-spacer-desktop" style="padding-bottom: 114%"></span><div class="rm-embed-holder"><blockquote class="rm-embed twitter-custom-tweet" data-twitter-tweet-id="1581461734665367554" data-partner="rebelmouse"><div style="margin:1em 0">\u201c@github copilot, with &quot;public code&quot; blocked, emits large chunks of my  copyrighted code, with no attribution, no LGPL license.  For example, the simple prompt &quot;sparse matrix transpose, cs_&quot; produces my cs_transpose in CSparse. My code on left, github on right. Not OK.\u201d</div> — Tim Davis (@Tim Davis)
        <a href="https://twitter.com/DocSparse/statuses/1581461734665367554">1665884834</a></blockquote></div></div></div><p><a href="https://www.eff.org/about/staff/kit-walsh" rel="noopener noreferrer" target="_blank">Kit Walsh</a>, a senior staff attorney at the <a href="https://www.eff.org/" target="_blank">Electronic Frontier Foundation</a>, argues that training Copilot on public repositories is fair use. “Fair use protects analytical uses of copyrighted work. Copilot is ingesting code and creating associations in its own neural net about what tends to follow and appear in what contexts, and that factual analysis of the underlying works is the kind of fair use that cases involving video game consoles, search engines, and APIs have supported.”<br/></p><p>But when it comes to generated code, Walsh says it boils down to “how much [Copilot] is reproducing from any given element of the training data” and if it encompasses creative expression that is copyrightable. “If so, there could be infringement happening,” she says.</p><p>The lawsuit against GitHub Copilot is the first of its kind to challenge generative AI. “It’s setting a legal precedent that has implications for other generative tools,” Walsh says. “It’s the type of work that if a person authored [it, they] could qualify for copyright protection, and it could embody someone else’s copyrighted work like snippets of code.”</p><p class="pull-quote">“If I as an engineer would like to use Copilot, I will need to be able to restrict what it provides me to code that’s attributed to the license.”<br/>—Sal Kimmich, Sonatype</p><p>For <a href="https://www.stellabiderman.com/" target="_blank">Stella Biderman</a>, an AI researcher at <a href="https://www.boozallen.com/" rel="noopener noreferrer" target="_blank">Booz Allen Hamilton</a> and <a href="https://www.eleuther.ai/" rel="noopener noreferrer" target="_blank">EleutherAI</a>, the lawsuit is a welcome development. “It’s going to, I hope, provide clarity and guidance as to what is actually legal, which is one of the big issues for those working on open-source AI,” she says. “I very much hope that what comes out of this lawsuit will be something I can rely on when making decisions about training models in the future.”</p><p>The open-source community seems divided on the lawsuit and GitHub Copilot itself. For instance, the <a href="https://sfconservancy.org/blog/2022/jun/30/give-up-github-launch/" rel="noopener noreferrer" target="_blank">Software Freedom Conservancy has been vocal about its concerns with Copilot</a>—even calling for a boycott of GitHub—but is <a href="https://sfconservancy.org/news/2022/nov/04/class-action-lawsuit-filing-copilot/" rel="noopener noreferrer" target="_blank">cautious about joining the class-action lawsuit</a>. Kimmich says they know of open-source developers taking an ethical stance in choosing not to use Copilot, but also others who are enjoying it. “They’re learning while developing and executing code on the fly.”</p><p><div class="rblad-ieee_in_content"></div></p><p>Kimmich themself is on a waitlist for Copilot and recognizes the benefits it offers developers. “The neural network behind it is using more than just code to help you—it’s providing much more contextual information,” they said. “It means I as a developer now have an extended intelligence, which is giving me a contextualized recommendation. I think that’s excellent. It’s the most powerful generative intelligence that we’ve had so far for this application.”</p><p>Yet unless the open-source licensing issue is solved, Kimmich envisions using GitHub Copilot only for pet projects and exploring new packages. “It stops short of production code because of the licensing issue,” they said. “If I as an engineer would like to use Copilot, I will need to be able to restrict what it provides me to code that’s attributed to the license, or have a license which states that it was codeveloped. If I can’t locate the provenance of the original licenses or the original intellectual property, then I need to be able to know if I want to avoid it.”</p>Another solution would be for GitHub Copilot to modify its AI model so that it traces attribution and gives credit to the original authors of the code, adding the associated copyright notices and license terms in the process, which Biderman says is technologically feasible. “The position that OpenAI and Microsoft seems to have taken is that it is unduly onerous on them to filter by license when other models successfully do it.” She points to academic models such as <a href="https://github.com/dpfried/incoder" rel="noopener noreferrer" target="_blank">InCoder</a> as an example, which is <a href="https://www.researchgate.net/publication/359937857_InCoder_A_Generative_Model_for_Code_Infilling_and_Synthesis" rel="noopener noreferrer" target="_blank">trained on code that it has a license for</a>. “There are other options and other models that are both more ethical and more likely to be legal,” Biderman says.<div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div><ul class="around-the-web__list"><li class="from-your-site__item"><a href="https://spectrum.ieee.org/programming-without-code-no-code-software-development" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Programming Without Code: The Rise of No-Code Software Development ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/ai-code-generation-language-models" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Coding Made AI—Now, How Will AI Unmake Coding? ›</a></li></ul><div class="around-the-web__headline">Related Articles Around the Web</div><ul class="around-the-web__list"><li class="around-the-web__item"><a href="https://openai.com/blog/openai-codex/" class="around-the-web__link" target="_blank" rel="noopener noreferrer">OpenAI Codex ›</a></li><li class="around-the-web__item"><a href="https://github.com/features/copilot" class="around-the-web__link" target="_blank" rel="noopener noreferrer">GitHub Copilot · Your AI pair programmer · GitHub ›</a></li></ul></div></template></div><div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds"><span class="show-more js-expand">Keep Reading ↓</span><span class="show-less js-contract">Show less</span></div></div></div><span class="js-scrolled-url" data-elid="2658687697" data-post-url="https://spectrum.ieee.org/ai-code-generation-ownership" data-authors="Rina Diane Caballar" data-headline="Ownership of AI-Generated Code Hotly Disputed"></span></div></div></div><script type="application/json" id="post-context-2658687697" class="post-context post-context-2658687697">
    {"customDimensions": {"5":"Rina Diane Caballar","11":2658687697,"7":"Github, software development, OpenAI, programming, coding, artificial intelligence, software, copyright, intellectual property, open source","10":"coding","6":"computing","8":"11/19/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [497728257, 544169516, 539617903, 544169523, 550122300, 550122302], "buckets": [], "authors": [21081423]} }
</script></article></div></div></div></div><!-- User Code --><div class="rblad-ieee_infinite_new"></div><!-- End User Code --><div class="mb-2 article_post infinite_scroll" id="sSS_Feature_Post_0_0_21_0_0_1_3_0_2"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_3" data-format="posts-custom" data-source="post_most_sections" data-source-type="page" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-v="2" data-attr-posts_id="sSS_Feature_Post_0_0_21_0_0_1_3_0_2" data-attr-source_unique="true" data-attr-without_current="true" data-attr-layout_quality="4" data-attr-header_template="jinja/post/custom-css.html" data-attr-node_id="/root/blocks/block[ss_feature_post]/abtests/abtest[1]/element_wrapper/row[2]/column[1]/posts[2]-" data-attr-use_tag_image_for_lead_media="true" data-attr-source="filtered" data-attr-source_id="post_most_sections" data-attr-from_regular_sections_of_current_post="true" data-attr-from_regular_sections_other_than="tests, issue-cover-posts, feature, sponsored, webinar, whitepaper, podcast, video, slideshow, the-big-picture" data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,photo_caption,photo_credit,post_shares,custom_field_pdf_version,tags,body,custom_field_lightbox_img_shortcode_ids,main_author,custom_field_TimeofRead,primary_tag,page_views,badges,badges_sponsored,source_link,community_name,snark_line,collection_button,community_comments,section,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_Editor,custom_field_PodcastTime,custom_field_PodcastEpisode,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_copy_editor,custom_field_is_updated_post,custom_field_youtube_video" data-attr-layout_headline="top" data-attr-data-rm-device-crops="true" data-attr-layout_all_image_crop="original" data-attr-layout_image_column_width="33" data-attr-limit="1" data-attr-data-rm-advanced="true" data-attr-element_classes="article_post infinite_scroll" data-attr-layout_subheadline="top" data-attr-layout_date="top" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-layout_like_button="top" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Email,CopyLink,Whatsapp,Twitter,Facebook,Linkedin,Separator,Tumblr,GooglePlus,Pinterest,Reddit,Flipboard,SMS,Slack" data-attr-layout_separator="inactive" data-attr-layout_tumblr="inactive" data-attr-layout_googleplus="inactive" data-attr-layout_pinterest="inactive" data-attr-layout_reddit="inactive" data-attr-layout_flipboard="inactive" data-attr-layout_sms="inactive" data-attr-layout_slack="inactive" data-attr-layout_facebook="active" data-attr-layout_twitter="active" data-attr-layout_linkedin="active" data-attr-layout_copylink="active" data-attr-layout_all_sections="top" data-attr-layout_photo_caption="bottom" data-attr-layout_photo_credit="bottom" data-attr-layout_post_shares="bottom" data-attr-layout_tags="bottom" data-attr-layout_body="bottom" data-attr-layout_all_show_video="true" data-attr-use_smart_keep_reading="true" data-attr-show_more_button_text="Keep Reading ↓" data-attr-layout_whatsapp="inactive" data-attr-layout_author="top" data-attr-layout_time_to_read="top" data-attr-show_authors_bio="true" data-attr-show_around_the_web="true" data-attr-layout_custom_field_lightbox_img_shortcode_ids="bottom" data-attr-layout_custom_field_pdf_version="bottom" data-attr-format="posts-custom" data-attr-source_site="parent_site"><div class="posts-wrapper clearfix"><div class="widget tag-ieee-products-services tag-ieee-standards-association tag-standards tag-entity-membership tag-education tag-careers tag-type-ti post-section--topic/the-institute" elid="2658649885" data-category="The Institute"><article elid="2658649885" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658649885"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/the-institute/">The Institute</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/article/">Article</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/careers/">Careers</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/join-the-ieee-standards-association" aria-label="Why Your Organization Should Join the IEEE Standards Association" data-type="text">
        Why Your Organization Should Join the IEEE Standards Association
    </a></h2><div class="widget__subheadline"><h3 class="widget__subheadline-text h3" data-type="text"><p>Benefits include developing standards for AI, blockchain, and IoT</p></h3></div><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/res/avatars/default&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/the_ieee_standards_association" data-type="text">The IEEE Standards Association</a></div><div class="social-date"><span class="social-date__text">18 Nov 2022</span></div><div class="time-to-read">2 min read</div><div class="like-button" data-post-likes="0"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/join-the-ieee-standards-association" aria-label="Why Your Organization Should Join the IEEE Standards Association"><img role="img" type="lazy-image" alt="Aerial photograph of a group of people working at a table." aria-label="Aerial photograph of a group of people working at a table." src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 3000 2250&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/aerial-photograph-of-a-group-of-people-working-at-a-table.jpg?id=32108345&width=1200&height=900" style="object-fit: cover;" class="rm-lazyloadable-image" width="3000" height="2250"/></a></div><div class="widget__body clearfix sm-mt-1"><div class="photo-credit">
        Getty Images
    </div><div class="widget__shares share-panel"><!-- EMAIL --><a href="mailto:?subject=Why%20Your%20Organization%20Should%20Join%20the%20IEEE%20Standards%20Association&body=https://spectrum.ieee.org/join-the-ieee-standards-association" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK --><a href="https://spectrum.ieee.org/join-the-ieee-standards-association" data-clipboard-text="https://spectrum.ieee.org/join-the-ieee-standards-association" class="share share-copy-link" title="Copy this link to clipboard"><i class="icons-share" style="width: 60%"><svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i></a><!-- TWITTER --><a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/join-the-ieee-standards-association&text=Why%20Your%20Organization%20Should%20Join%20the%20IEEE%20Standards%20Association&" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK --><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Fjoin-the-ieee-standards-association%3Fxrs%3DRebelMouse_fb%26ts%3D1668798026" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN --><a href="http://www.linkedin.com/shareArticle?mini=false&url=https://spectrum.ieee.org/join-the-ieee-standards-association&" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a></div><div class="tags"><a class="tags__item" href="https://spectrum.ieee.org/tag/ieee-products-services">ieee products services</a><a class="tags__item" href="https://spectrum.ieee.org/tag/ieee-standards-association">IEEE Standards Association</a><a class="tags__item" href="https://spectrum.ieee.org/tag/standards">standards</a><a class="tags__item" href="https://spectrum.ieee.org/tag/entity-membership">entity membership</a><a class="tags__item" href="https://spectrum.ieee.org/tag/education">education</a><a class="tags__item" href="https://spectrum.ieee.org/tag/careers">careers</a><a class="tags__item" href="https://spectrum.ieee.org/tag/type-ti">type:ti</a></div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2658649885" data-elid="2658649885" data-post-url="https://spectrum.ieee.org/join-the-ieee-standards-association" data-authors="The IEEE Standards Association" data-headline="Why Your Organization Should Join the IEEE Standards Association"><div class="body-description"><div class="widget__brief"><p>The global business landscape is constantly evolving. Digital transformation— compounded by the challenges of globalization, supply-chain stability, demographic shifts, and climate change—is pressuring companies and government agencies to innovate and safely deploy sustainable technologies.</p><p>As digital transformation continues, the pervasive growth of technology increasingly intersects with industry, government, and societal interests. Companies and organizations need access to technologies that can enhance efficiencies, productivity, and competitive advantage.</p></div><div class="content-container"></div><div class="js-appear-on-expand"><template><p>Governments seek influence over emerging technologies to preserve economic interests, advance global trade, and protect their citizens. Consumers are demanding more transparency regarding organizational motives, practices, and processes.</p><p>For those and other reasons, new types of stakeholders are seeking a voice in the technology standardization process. </p><h2>How organizations benefit from developing standards</h2><p>The need is evidenced in the membership gains at the <a href="https://standards.ieee.org/?utm_source=ieeeorg&utm_medium=the-institute&utm_campaign=entitymembership" rel="noopener noreferrer" target="_blank">IEEE Standards Association</a>. IEEE SA <a href="https://standards.ieee.org/about/membership/organizations/?utm_source=ieeeorg&utm_medium=the-institute&utm_campaign=entitymembership" rel="noopener noreferrer" target="_blank">membership for organizations</a>, also known as <em>entity membership</em>, has increased by more than 150 percent in the past six years. Academic institutions, government agencies, and other types of organizations now account for more than 30 percent of the member base. </p><p>Entity membership offers the ability to help shape technology development and ensure your organization’s interests are represented in the standards development process. Other benefits include balloting privileges, leadership eligibility, and networking opportunities.</p><p>IEEE SA welcomes different types of organizations because they bring varied perspectives and they voice concerns that need to be addressed during the standards development process. Engaging diverse viewpoints from companies of all sizes and types also helps to identify and address changing market needs. </p><p>From a geographic standpoint, IEEE SA welcomes participation from all regions of the world. Diverse perspectives and contributions to the development cycle enable innovation to be shared and realized by all stakeholders. </p><p><div class="rblad-ieee_in_content"></div></p><h2>Programs on blockchain, IoT, and other emerging technology</h2><p>IEEE SA has introduced new industry-engagement programs such as <a href="https://standards.ieee.org/initiatives/opensource/?utm_source=ieeeorg&utm_medium=the-institute&utm_campaign=entitymembership" rel="noopener noreferrer" target="_blank">open-source</a> and <a href="https://standards.ieee.org/products-programs/industry-affiliate-network/?utm_source=ieeeorg&utm_medium=the-institute&utm_campaign=entitymembership" rel="noopener noreferrer" target="_blank">industry-alliance</a> offerings designed to speed innovation and adoption. In addition, industry participants have access to the full IEEE SA ecosystem of programs and services including <a href="https://standards.ieee.org/industry-connections/?utm_source=ieeeorg&utm_medium=the-institute&utm_campaign=entitymembership" rel="noopener noreferrer" target="_blank">technology incubation</a>, pre-standardization work, <a href="https://standards.ieee.org/develop/?utm_source=ieeeorg&utm_medium=the-institute&utm_campaign=entitymembership" rel="noopener noreferrer" target="_blank">standards development</a>, and <a href="https://standards.ieee.org/products-programs/icap/?utm_source=ieeeorg&utm_medium=the-institute&utm_campaign=entitymembership" rel="noopener noreferrer" target="_blank">conformity assessment</a> activities. <a href="https://standards.ieee.org/about/training/?utm_source=ieeeorg&utm_medium=the-institute&utm_campaign=entitymembership" rel="noopener noreferrer" target="_blank">Training</a> and <a href="https://brandfolder.com/portals/ieee-sa-community-resources" rel="noopener noreferrer" target="_blank">marketing tools</a> support working groups at every stage of the process.</p><p>An increasing number of <a href="https://standards.ieee.org/search/?q=Corporate%20Entity&type=%7CProject" rel="noopener noreferrer" target="_blank">new standards projects</a> from emerging technology areas have created a more robust and diversified portfolio of work. The technologies include artificial intelligence and machine learning, blockchain and distributed ledger technologies, quantum computing, cloud computing, the Internet of Things, smart cities, smart factories and online gaming. There is also more participation from the health care, automotive, and financial services sectors. </p><p>IEEE SA has grown and evolved its programs to address market needs, but its purpose has not changed. The organization is focused on empowering innovators to raise the world’s standards for the benefit of humanity.</p><p>Those innovators might be individuals or organizations looking to make a difference in the world, but it can be accomplished only when we all work together. </p><p>Learn more about IEEE SA membership for organizations and how your organization can play a key role in advancing future technologies.</p><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div><ul class="around-the-web__list"><li class="from-your-site__item"><a href="https://spectrum.ieee.org/ieees-microwave-society-new-name" class="from-your-site__link" target="_blank" rel="noopener noreferrer">IEEE’s Microwave Society Gets a New Name ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/why-iot-sensors-need-standards" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Why IoT Sensors Need Standards ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/ieee-standards-association-launches-a-platform-for-open-source-collaboration" class="from-your-site__link" target="_blank" rel="noopener noreferrer">IEEE Standards Association Launches a Platform for Open Source Collaboration ›</a></li></ul></div></template></div><div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds"><span class="show-more js-expand">Keep Reading ↓</span><span class="show-less js-contract">Show less</span></div></div></div><span class="js-scrolled-url" data-elid="2658649885" data-post-url="https://spectrum.ieee.org/join-the-ieee-standards-association" data-authors="The IEEE Standards Association" data-headline="Why Your Organization Should Join the IEEE Standards Association"></span></div></div></div><script type="application/json" id="post-context-2658649885" class="post-context post-context-2658649885">
    {"customDimensions": {"5":"The IEEE Standards Association","11":2658649885,"7":"ieee products services, IEEE Standards Association, standards, entity membership, education, careers, type:ti","10":"ieee products services","6":"the-institute","8":"11/18/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 544175596, 544169516, 539628627, 539626938], "buckets": [], "authors": [25299311]} }
</script></article></div></div></div></div><!-- User Code --><div class="rblad-ieee_infinite_new"></div><!-- End User Code --><div class="mb-2 article_post infinite_scroll" id="sSS_Feature_Post_0_0_21_0_0_1_3_0_4"></div></div><div id="sSS_Feature_Post_0_0_21_0_0_1_3_1" class="widget_column col sm-mb-2 md-mb-4 s12 m12 l3"><div class="" id="sSS_Feature_Post_0_0_21_0_0_1_3_1_0_1_0"><!-- User Code --><div class="sidebar_sticky_parent"><div class="stick_in_parent"><div class="sidebar_repeat_ad rblad-ieee_sidebar"></div></div></div><!-- End User Code --></div></div></div></div><span class="js-brick-description hidden" data-name="Trending Stories"></span><div id="sTrending_Stories_0_0_28_0_0_0" class=" row-wrapper clearfix  content sm-cp-2 md-cp-4"><div class="row "><div id="sTrending_Stories_0_0_28_0_0_0_0" class=" col sm-mb-2 md-mb-4 s12 m12 l12"><div class="trending-stories__headline-wrapper" id="sTrending_Stories_0_0_28_0_0_0_0_1"><div id="sTrending_Stories_0_0_28_0_0_0_0_1_0"><div class="module-headline"><h2 class="module-headline__text h2">
        Trending Stories
    </h2></div></div><div class="text-element" id="sTrending_Stories_0_0_28_0_0_0_0_1_1">The most-read stories on <em>IEEE Spectrum</em> right now</div></div><div class="mb-2 trending_stories_carousel " id="sTrending_Stories_0_0_28_0_0_0_0_2_2_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_5" data-format="posts-custom" data-source="trending_posts_id" data-source-type="page" data-source-unique="false" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-layout_carousel="true" data-attr-v="2" data-attr-posts_id="sTrending_Stories_0_0_28_0_0_0_0_2_2_0" data-attr-without_current="true" data-attr-layout_quality="4" data-attr-node_id="/root/blocks/block[trending_stories]/abtests/abtest/row/column/choose/otherwise/posts-" data-attr-use_tag_image_for_lead_media="true" data-attr-source="filtered" data-attr-source_id="trending_posts_id" data-attr-from_regular_sections="feature, news, analysis, opinion, interview, profile, explainer, review, hands-on, article" data-attr-order="page-views" data-attr-order_period="12h" data-attr-all_element_order="all_sections,headline,date,time_to_read,like_button,custom_field_TimeofRead,section,primary_tag,author,badges,badges_sponsored,photo_credit,community_name,body,snark_line,page_views,photo_caption,follow_button,community_comments,post_shares,collection_button,tags,source_link,main_author,subheadline,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_PodcastVideoTime,custom_field_access,custom_field_Editor,custom_field_PodcastEpisode,custom_field_FeaturePostColor,words_count,site_field_first_name,site_field_last_name,site_field_member_badges,site_field_grade,custom_field_pdf_version,custom_field_publication_date,custom_field_fullwidthbackgroundposition,custom_field_lightbox_img_shortcode_ids" data-attr-limit="8" data-attr-layout_headline="top" data-attr-data-rm-device-crops="true" data-attr-layout_image_column_width="50" data-attr-data-rm-advanced="true" data-attr-element_classes="trending_stories_carousel " data-attr-allow_duplicates="true" data-attr-layout_date="top" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-layout_columns="4" data-attr-layout_all_show_video="true" data-attr-layout_all_carousel="true" data-attr-layout_like_button="top" data-attr-layout_all_image_crop="3x2" data-attr-layout_all_sections="top" data-attr-layout_time_to_read="top" data-attr-format="posts-custom" data-attr-source_site="parent_site"><div class="posts-wrapper clearfix"><div class="widget tag-explainer tag-invention-of-the-transistor tag-point-contact-transistor tag-semiconductor-electronics tag-transistors post-section--topic/semiconductors" elid="2658669320" data-category="Semiconductors"><article elid="2658669320" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658669320"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/semiconductors/">Semiconductors</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/magazine/2022/december/">December 2022</a><a href="https://spectrum.ieee.org/magazine/">Magazine</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/feature/">Feature</a><a href="https://spectrum.ieee.org/type/explainer/">Explainer</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/transistor-history" aria-label="How the First Transistor Worked" data-type="text">
        How the First Transistor Worked
    </a></h2><div class="social-date"><span class="social-date__text">5h</span></div><div class="time-to-read">12 min read</div><div class="like-button" data-post-likes="1"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/transistor-history" aria-label="How the First Transistor Worked"><img role="img" type="lazy-image" alt="A phot of an outstretched hand with several transistors in the palm of it.  " aria-label="A phot of an outstretched hand with several transistors in the palm of it.  " src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-phot-of-an-outstretched-hand-with-several-transistors-in-the-palm-of-it.png?id=32107129&width=1200&height=800&quality=85&coordinates=0%2C105%2C0%2C105" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div></div></div><script type="application/json" id="post-context-2658669320" class="post-context post-context-2658669320">
    {"customDimensions": {"5":"Glenn Zorpette","11":2658669320,"7":"explainer, invention of the transistor, point-contact transistor, semiconductor electronics, transistors","10":"semiconductor electronics","6":"semiconductors","8":"11/20/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 564919488, 539626628, 555118571, 544169516, 544169517, 539621009, 544169529], "buckets": [], "authors": [20372185]} }
</script></article></div><div class="widget tag-neurotechnology tag-eeg tag-neuroethics tag-productivity tag-workplace post-section--topic/biomedical" elid="2658651459" data-category="Biomedical"><article elid="2658651459" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658651459"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/biomedical/">Biomedical</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/magazine/2022/december/">December 2022</a><a href="https://spectrum.ieee.org/magazine/">Magazine</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/feature/">Feature</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/neurotech-workplace-innereye-emotiv" aria-label="Are You Ready for Workplace Brain Scanning?" data-type="text">
        Are You Ready for Workplace Brain Scanning?
    </a></h2><div class="social-date"><span class="social-date__text">19 Nov 2022</span></div><div class="time-to-read">11 min read</div><div class="like-button" data-post-likes="1"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/neurotech-workplace-innereye-emotiv" aria-label="Are You Ready for Workplace Brain Scanning?"><img role="img" type="lazy-image" alt="A photo collage showing a man wearing a eeg headset while looking at a computer screen." aria-label="A photo collage showing a man wearing a eeg headset while looking at a computer screen." src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-collage-showing-a-man-wearing-a-eeg-headset-while-looking-at-a-computer-screen.jpg?id=32111383&width=1200&height=800&quality=85&coordinates=0%2C102%2C0%2C103" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div></div></div><script type="application/json" id="post-context-2658651459" class="post-context post-context-2658651459">
    {"customDimensions": {"5":"Evan Ackerman, Eliza Strickland","11":2658651459,"7":"neurotechnology, EEG, neuroethics, productivity, workplace","10":"neurotechnology","6":"biomedical","8":"11/19/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 564919488, 539626628, 539266149, 555118571, 544169516, 544169517], "buckets": [], "authors": [21075149, 21075161]} }
</script></article></div><div class="widget tag-blood tag-smartphones tag-healthcare tag-medical-devices tag-medical-technology post-section--topic/biomedical" elid="2658683418" data-category="Biomedical"><article elid="2658683418" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658683418"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/biomedical/">Biomedical</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/smartphone-blood-test" aria-label="Blood Test Only Needs a Drop and a Smartphone for Results" data-type="text">
        Blood Test Only Needs a Drop and a Smartphone for Results
    </a></h2><div class="social-date"><span class="social-date__text">17 Nov 2022</span></div><div class="time-to-read">4 min read</div><div class="like-button" data-post-likes="0"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/smartphone-blood-test" aria-label="Blood Test Only Needs a Drop and a Smartphone for Results"><img role="img" type="lazy-image" alt="Close up of a phone showing a tight view of a small vial of red liquid encased in a cup holder below it." aria-label="Close up of a phone showing a tight view of a small vial of red liquid encased in a cup holder below it." src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/close-up-of-a-phone-showing-a-tight-view-of-a-small-vial-of-red-liquid-encased-in-a-cup-holder-below-it.jpg?id=32112099&width=1200&height=800&quality=85&coordinates=0%2C55%2C0%2C55" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div></div></div><script type="application/json" id="post-context-2658683418" class="post-context post-context-2658683418">
    {"customDimensions": {"5":"Greg Goth","11":2658683418,"7":"blood, smartphones, healthcare, medical devices, medical technology","10":"smartphones","6":"biomedical","8":"11/17/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 539266149, 544169516, 544169523], "buckets": [], "authors": [23016054]} }
</script></article></div><div class="widget tag-electric-vehicles tag-batteries tag-supply-chain tag-engineering-jobs tag-skills-gap post-section--internal" elid="2658463682" data-category="Topic"><article elid="2658463682" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658463682"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/topic/energy/">Energy</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/transportation/">Transportation</a><a href="https://spectrum.ieee.org/type/analysis/">Analysis</a><a href="https://spectrum.ieee.org/topic/careers/">Careers</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/the-ev-transition-explained-2658463682" aria-label="The EV Transition Explained: Battery Challenges" data-type="text">
        The EV Transition Explained: Battery Challenges
    </a></h2><div class="social-date"><span class="social-date__text">19 Nov 2022</span></div><div class="time-to-read">6 min read</div><div class="like-button" data-post-likes="1"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/the-ev-transition-explained-2658463682" aria-label="The EV Transition Explained: Battery Challenges"><img role="img" type="lazy-image" alt="A General Motors Hummer EV chassis sits in front of an Hummer EV outside of an event " aria-label="A General Motors Hummer EV chassis sits in front of an Hummer EV outside of an event " src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-general-motors-hummer-ev-chassis-sits-in-front-of-an-hummer-ev-outside-of-an-event.jpg?id=32122904&width=1200&height=800&quality=85&coordinates=0%2C0%2C0%2C0" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div></div></div><script type="application/json" id="post-context-2658463682" class="post-context post-context-2658463682">
    {"customDimensions": {"5":"Robert N. Charette","11":2658463682,"7":"electric vehicles, batteries, supply chain, engineering jobs, skills gap","10":"electric vehicles","6":"topic","8":"11/19/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 539619077, 544169516, 539622579, 544169524, 539628627, 550122300, 550122302], "buckets": [], "authors": [21075158]} }
</script></article></div><div class="widget tag-video-friday tag-robotics post-section--topic/robotics" elid="2658687388" data-category="Robotics"><article elid="2658687388" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658687388"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/video-friday-little-robot-big-stairs" aria-label="Video Friday: Little Robot, Big Stairs" data-type="text">
        Video Friday: Little Robot, Big Stairs
    </a></h2><div class="social-date"><span class="social-date__text">18 Nov 2022</span></div><div class="time-to-read">4 min read</div><div class="like-button" data-post-likes="0"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/video-friday-little-robot-big-stairs" aria-label="Video Friday: Little Robot, Big Stairs"><img role="img" type="lazy-image" alt="A small black quadrupedal robot climbs steep stairs" aria-label="A small black quadrupedal robot climbs steep stairs" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-small-black-quadrupedal-robot-climbs-steep-stairs.png?id=32119922&width=1200&height=800&quality=85&coordinates=150%2C0%2C150%2C0" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div></div></div><script type="application/json" id="post-context-2658687388" class="post-context post-context-2658687388">
    {"customDimensions": {"5":"Evan Ackerman","11":2658687388,"7":"video friday, robotics","10":"robotics","6":"robotics","8":"11/18/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 544169516, 539266128, 544169523], "buckets": [], "authors": [21075149]} }
</script></article></div><div class="widget tag-github tag-software-development tag-openai tag-programming tag-coding tag-artificial-intelligence tag-software tag-copyright tag-intellectual-property tag-open-source post-section--topic/computing" elid="2658687697" data-category="Computing"><article elid="2658687697" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658687697"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/computing/">Computing</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/ai-code-generation-ownership" aria-label="Ownership of AI-Generated Code Hotly Disputed" data-type="text">
        Ownership of AI-Generated Code Hotly Disputed
    </a></h2><div class="social-date"><span class="social-date__text">19 Nov 2022</span></div><div class="time-to-read">4 min read</div><div class="like-button" data-post-likes="0"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/ai-code-generation-ownership" aria-label="Ownership of AI-Generated Code Hotly Disputed"><img role="img" type="lazy-image" alt="An illustration of a pixilated person on a ladder placing code." aria-label="An illustration of a pixilated person on a ladder placing code." src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/an-illustration-of-a-pixilated-person-on-a-ladder-placing-code.jpg?id=32124070&width=1200&height=800&quality=85&coordinates=0%2C52%2C0%2C52" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div></div></div><script type="application/json" id="post-context-2658687697" class="post-context post-context-2658687697">
    {"customDimensions": {"5":"Rina Diane Caballar","11":2658687697,"7":"Github, software development, OpenAI, programming, coding, artificial intelligence, software, copyright, intellectual property, open source","10":"coding","6":"computing","8":"11/19/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [497728257, 544169516, 539617903, 544169523, 550122300, 550122302], "buckets": [], "authors": [21081423]} }
</script></article></div><div class="widget tag-rockets tag-india tag-private-spaceflight tag-space post-section--topic/aerospace" elid="2658688879" data-category="Aerospace"><article elid="2658688879" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658688879"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/aerospace/">Aerospace</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/indian-space-private-launch" aria-label="India’s First Private Space Rocket Blasts Off" data-type="text">
        India’s First Private Space Rocket Blasts Off
    </a></h2><div class="social-date"><span class="social-date__text">18 Nov 2022</span></div><div class="time-to-read">4 min read</div><div class="like-button" data-post-likes="1"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/indian-space-private-launch" aria-label="India’s First Private Space Rocket Blasts Off"><img role="img" type="lazy-image" alt="rocket taking off into space with Earth behind it" aria-label="rocket taking off into space with Earth behind it" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/rocket-taking-off-into-space-with-earth-behind-it.jpg?id=32121793&width=1200&height=800&quality=85&coordinates=0%2C80%2C0%2C80" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div></div></div><script type="application/json" id="post-context-2658688879" class="post-context post-context-2658688879">
    {"customDimensions": {"5":"Edd Gent","11":2658688879,"7":"rockets, India, private spaceflight, space","10":"private spaceflight","6":"aerospace","8":"11/18/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [497728257, 497728258, 544169516, 544169523, 550122300, 550122302], "buckets": [], "authors": [21081576]} }
</script></article></div><div class="widget tag-artificial-intelligence tag-supercomputers tag-training tag-nvidia tag-intel tag-microsoft tag-cloud-computing tag-benchmarks tag-inferencing tag-mlperf tag-machine-learning post-section--topic/computing" elid="2658635732" data-category="Computing"><article elid="2658635732" data-frozen-sections="[]" class="clearfix page-article sm-mb-1 quality-HD post-2658635732"><div class="row px10"><div id="col-center" class="rm-col-center col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/computing/">Computing</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/topic/artificial-intelligence/">Artificial Intelligence</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/semiconductors/">Semiconductors</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/mlperf-training" aria-label="New Records for the Biggest and Smallest AI Computers" data-type="text">
        New Records for the Biggest and Smallest AI Computers
    </a></h2><div class="social-date"><span class="social-date__text">17 Nov 2022</span></div><div class="time-to-read">6 min read</div><div class="like-button" data-post-likes="1"></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/mlperf-training" aria-label="New Records for the Biggest and Smallest AI Computers"><img role="img" type="lazy-image" alt="A black board with rainbow colored chip and electronics" aria-label="A black board with rainbow colored chip and electronics" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-black-board-with-rainbow-colored-chip-and-electronics.jpg?id=32111793&width=1200&height=800&quality=85&coordinates=0%2C52%2C0%2C52" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div></div></div><script type="application/json" id="post-context-2658635732" class="post-context post-context-2658635732">
    {"customDimensions": {"5":"Samuel K. Moore","11":2658635732,"7":"artificial intelligence, supercomputers, training, Nvidia, Intel, Microsoft, cloud computing, benchmarks, inferencing, MLPerf, machine learning","10":"machine learning","6":"computing","8":"11/17/2022"}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 497728259, 544169516, 539617903, 539621009, 544169523], "buckets": [], "authors": [21075160]} }
</script></article></div></div></div><script type="text/lazy-javascript" priority="0">
            window.REBELMOUSE_STDLIB.rebelSlider({
                selector: '#sTrending_Stories_0_0_28_0_0_0_0_2_2_0 .posts-wrapper',
                infinite : true,
                dots : false,
                slidesToShow : 4,
                slidesToScroll : 4,
                initialSlide : 0,
                autoplay : false,
                autoplaySpeed : 3000,
                prevArrow : '<div class="slick-prev fa fa-chevron-left"></div>',
                nextArrow : '<div class="slick-next fa fa-chevron-right"></div>'
            })
        </script></div></div></div></div><div class="wrapper-lazy-loading infinite-scroll-wrapper next-page-wrapper" style="display: block !important;" data-skl-id="/root/blocks/block[ss_feature_post]/abtests/abtest[1]/element_wrapper/lazyload-" data-has-more="false" data-more-posts-exists="false" data-posts-sources="multi_filtered_parent_site_filtered_parent_site,post_most_sections,post_sponsor_webinar_whitepaper" data-ignore-page-number="true"></div></div><span class="js-brick-description hidden" data-name="JS post functions"></span><!-- User Code --><script>
  function feature_post_full_style(){
    var feature_post_full = document.querySelectorAll(".feature_post_full:not(.proc)");
	for (i = 0; i < feature_post_full.length; i++) {
      var style_post_color = feature_post_full[i].querySelector(".custom-field-FeaturePostColor");
      var style_post_position = feature_post_full[i].querySelector(".custom-field-FeaturePostImgPosition");
      if(style_post_color){
         feature_post_full[i].classList.add(style_post_color.innerText);
      }else{
      	 feature_post_full[i].classList.add('DarkGray');
      }
      if(style_post_position){
         feature_post_full[i].classList.add(style_post_position.innerText);
      }
      feature_post_full[i].classList.add('proc');
    }  
  }
</script><!-- End User Code --></div><span class="js-brick-description hidden" data-name="Parsely Spectrum Tags"></span><span class="js-brick-description hidden" data-name="__Lightbox_Functionality"></span><div class="lightbox-layout" id="s__Lightbox_Functionality_0_0_33_0_0_1_1_1"><!-- User Code --><div class="lightbox__close hm__close"></div><!-- End User Code --></div></div></div><ul id="notification" class="notification"></ul><script class="rm-i-script" defer="defer" src="https://www.googletagmanager.com/gtag/js?id=UA-747464-1"></script><script class="rm-i-script">

            (function (i, s, o, g, r, a, m) {
                i["GoogleAnalyticsObject"] = r;
                (i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments);}),(i[r].l = 1 * new Date());
            })(window, document, "script", "/", "ga");
            ga('create', 'UA-747464-1', 'auto', {'name': 'b'});

            window.dataLayer = window.dataLayer || [];
            window.gtag = function(){dataLayer.push(arguments);}
            gtag('js', new Date());

            var utmCampaignData = null;// ADD REFERRER AS SOURCE IF SOURCE IS NOT PRESENT OR IF ISN'T URL UTM
            if(utmCampaignData && (utmCampaignData.dataSource != "url" || !utmCampaignData['campaignSource'])) {
                var referrerAnchor = document.createElement('a');
                referrerAnchor.setAttribute('href', document.referrer);
                if(referrerAnchor.href && referrerAnchor.host) {
                    var splitHost = referrerAnchor.host.split(".");
                    var nakedDomain = splitHost.length < 3 ? splitHost[0] : splitHost[1];
                    if (nakedDomain) {
                        nakedDomain = nakedDomain[0].toUpperCase() + nakedDomain.substring(1);
                        utmCampaignData['campaignSource'] = nakedDomain;
                    }
                }
            }

            var configParams = { transport: 'beacon', send_page_view: false };
            // DEFAULTS
            if (utmCampaignData) {
                configParams.campaignName = utmCampaignData.campaignName;
                configParams.campaignSource = utmCampaignData.campaignSource;
                configParams.campaignMedium = utmCampaignData.campaignMedium;
                configParams.campaignContent = utmCampaignData.campaignContent;
                if (utmCampaignData.campaignKeyword) {
                    configParams.campaignKeyword = utmCampaignData.campaignKeyword;
                }
            }

            gtag('config', 'UA-747464-1', configParams);gtag('config', 'G-DPQFLXZCWN', configParams);
  window._ga_cd_params = window._ga_cd_params || {};

    

    window._ga_cd_params["dimension9"] = 'IEEE,1955';window._ga_cd_params["dimension5"] = "Tekla S. Perry, John Voelcker";

          window._ga_cd_params["dimension11"] = '2658380204';

          window._ga_cd_params["dimension7"] = "computer history, Alto, Ivan Sutherland, user interface, computer mouse, Doug Engelbart, Xerox Parc, Apple, Larry Tesler, Windows, history";

          window._ga_cd_params["dimension10"] = 'history';

          window._ga_cd_params["dimension6"] = 'tech-history';

          

          window._ga_cd_params["dimension8"] = '11/20/2022';

          

          

          

          
            if(window._ga_cd_params && Object.keys(window._ga_cd_params).length){
                gtag('event', 'page_view', window._ga_cd_params);
            }else{
                gtag('event', 'page_view');
            }
        </script><script class="rm-i-script">
        if (typeof window.gtag === 'function') {
            var anchors = document.getElementsByTagName('a');
            for(var i = 0; i < anchors.length; i++) {
                var elem = anchors[i];
                elem.addEventListener('click', function (evnt) {
                    if (document.location.hostname === evnt.currentTarget.hostname) {
                        return;
                    }
                    if (!evnt.currentTarget.href) {
                        return;
                    }
                    if (evnt.currentTarget.href.lastIndexOf('javascript:', 0) === 0) {
                        return;
                    }
                    window.gtag('event', 'click', {
                        'event_category': 'outgoing_links',
                        'event_action': 'click',
                        'event_label': evnt.currentTarget.href,
                        'nonInteraction': 1,
                    });
                }, false);
            }
        }
    </script><script type="application/ld+json">
    {
        "@context": "https://schema.org",
        "@type":  "NewsArticle" ,
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://spectrum.ieee.org/graphical-user-interface"
        },
        "url": "https://spectrum.ieee.org/graphical-user-interface",
        "headline": "How the Graphical User Interface Was Invented",
        "thumbnailUrl": "https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&amp;width=210",
        "image": {
            "@type": "ImageObject",
            "url": "https://spectrum.ieee.org/media-library/stylized-drawing-of-a-desktop-computer-with-mouse-and-keyboard-on-the-screen-are-windows-icons-and-menus.jpg?id=32068593&width=1200&height=600&coordinates=0%2C450%2C0%2C450",
            "width": 1200,
            "height": 600
        },
        "datePublished": "2022-11-20T20:00:00Z",
        "dateModified": "2022-11-20T20:00:00Z",
        "author": [{
                "@type": "Person",
                "name": "Tekla S. Perry",
                "identifier": "21075155",
                "url": "https://spectrum.ieee.org/u/tekla-perry",
                "description": "\u003cp\u003e\n\t\u003ca href=\"https://twitter.com/TeklaPerry\" target=\"_blank\"\u003eTekla S. Perry\u003c/a\u003e is a senior editor at \u003cem\u003eIEEE Spectrum\u003c/em\u003e. Based in Palo Alto, Calif., she's been covering the people, companies, and technology that make Silicon Valley a special place for more than 40 years. An IEEE member, she holds a bachelor's degree in journalism from Michigan State University.\n\u003c/p\u003e",
                "image": {
                    "@type": "ImageObject",
                    "url": "https://spectrum.ieee.org/media-library/eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA5NDcwMi9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcyMzA1NDkzNn0.gbFAtEQX36yzfmx_HixIADGZY8vd-q3M-GGzK9mxSrU/image.png?width=210"
                }
            }
            ,{
                "@type": "Person",
                "name": "John Voelcker",
                "identifier": "21078857",
                "url": "https://spectrum.ieee.org/u/john-voelcker",
                "description": "",
                "image": {
                    "@type": "ImageObject",
                    "url": "https://spectrum.ieee.org/res/avatars/default"
                }
            }
            ],
        "publisher": {
        "@type": "Organization",
        "name": "IEEE Spectrum",
        "logo": {
            "@type": "ImageObject",
            "url": "https://spectrum.ieee.org/media-library/eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjg4NDUyMC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY5OTk5OTQzOX0.aimbeagNFKGtififsLPFvztNYGr1_NMvLOOT1mPOjEU/image.png?width=210"
            }
        },
        "articleSection": "History of Technology",
        "description": "Mice, windows, icons, and menus: these are the ingredients of computer interfaces designed to be simplicity itself to use. But the development was anything but simple. It took some 30 years of effort.",
        "keywords": ["computer history", "Alto", "Ivan Sutherland", "user interface", "computer mouse", "Doug Engelbart", "Xerox Parc", "Apple", "Larry Tesler", "Windows", "history"]}
</script><script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "ItemList",
                "itemListElement": [
                            {
                                "@type": "ListItem",
                                "position": "1",
                                "url": "https://spectrum.ieee.org/graphical-user-interface/the-gui-started-with-sketchpad",
                                "name": "The GUI started with Sketchpad"},
                            {
                                "@type": "ListItem",
                                "position": "2",
                                "url": "https://spectrum.ieee.org/graphical-user-interface/the-origin-of-the-computer-mouse",
                                "name": "The origin of the computer mouse"},
                            {
                                "@type": "ListItem",
                                "position": "3",
                                "url": "https://spectrum.ieee.org/graphical-user-interface/defining-terms",
                                "name": "Defining terms"},
                            {
                                "@type": "ListItem",
                                "position": "4",
                                "url": "https://spectrum.ieee.org/graphical-user-interface/how-windows-first-came-to-the-computer-screen",
                                "name": "How windows first came to the computer screen"},
                            {
                                "@type": "ListItem",
                                "position": "5",
                                "url": "https://spectrum.ieee.org/graphical-user-interface/the-origin-of-the-computer-menu-bar",
                                "name": "The origin of the computer menu bar"},
                            {
                                "@type": "ListItem",
                                "position": "6",
                                "url": "https://spectrum.ieee.org/graphical-user-interface/how-the-computer-icon-got-its-name",
                                "name": "How the computer\u00a0\u201cicon\u201d\u00a0got its name"},
                            {
                                "@type": "ListItem",
                                "position": "7",
                                "url": "https://spectrum.ieee.org/graphical-user-interface/who-owns-the-graphical-user-interface",
                                "name": "Who owns the graphical user\u00a0interface?"}]
            }
        </script><script class="lazy-style" type="css">
        

    </script><script class="rm-i-script" id="parsely-cfg" src="//cdn.parsely.com/keys/spectrum.ieee.org/p.js"></script><script class="rm-i-script" id="user-javascript-medium-normal">
        window.REBELMOUSE_TASKS_QUEUE.push(function loadFonts(){
window.REBELMOUSE_STDLIB.loadFontFace('IvarText', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Regular.woff2', {selector: '',
  weight: '400',
  style: 'normal'
});
window.REBELMOUSE_STDLIB.loadFontFace('IvarTextItalic', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Italic.woff2', {selector: '',
  weight: '400',
  style: 'italic'
});
window.REBELMOUSE_STDLIB.loadFontFace('IvarText', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Bold.woff2', {selector: '',
  weight: '700',
  style: 'normal'
});});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
    window.REBELMOUSE_STDLIB.loadExternalScript("https://htlbid.com/v3/spectrum.ieee.org/rblbid.js", function() {
        
    });
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        REBELMOUSE_STDLIB
  .createElementChangeListener('.rm-shortcode[href*=".pdf"]', function(pdfLink){
    pdfLink.href = 'javascript:void(0);';
    pdfLink.classList.add('pdf-link-nonmember');
    pdfLink.addEventListener('click', function(){
      openGatedPopup('for_pdf_issues');
    });
});
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        //var ssoValidatorUrl = 'https://oamssoqae.ieee.org/ieeevendorsso/rest/auth/validatePFToken?_=' + (+ new Date());

var ssoValidatorUrl = 'https://securesso.ieee.org/ieeevendorsso/rest/auth/validatePFToken?_=' + (+ new Date());

function getCookie(name) {
  const value = `; ${document.cookie}`;
  const parts = value.split(`; ${name}=`);
  if (parts.length === 2) return parts.pop().split(';').shift();
}

fetch(ssoValidatorUrl, {
    method: 'GET',
    mode: 'cors',
    credentials: 'include',
}).then(function (response) {
	// The API call was successful!
	if (response.ok) {
		response.json().then(function(result) {
          if (typeof result == 'object' && result.cookieValid && getCookie('user_logged_in') !== "1") { 		//SSO
              console.log('we should be logged in, redirect to SSO iDP');
              //window.location.href = 'https://spectrumtest.ieee.org/core/saml/main/login?next_url=' + window.location.href;
              window.location.href = "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
          } else if (typeof result == 'object' && !result.cookieValid) {		//SLO
              console.log('we should be logged out, remove cookie and do not show user');
              //document.cookie = "sessionid= ; expires = Thu, 01 Jan 1970 00:00:00 GMT";
          }
        });
      
	} else {
		return Promise.reject(response);
	}
}).then(function (data) {
	// This is the JSON from our response
	console.log(data);
}).catch(function (err) {
	// There was an error
	console.warn('Something went wrong.', err);
});
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        function changeDateFormat(widget){
  var dates_toChange=widget.querySelectorAll('.widget .social-date__text:not(.processed),.widget .social-date-modified__text:not(.processed)');
  if(dates_toChange){
    dates_toChange.forEach(function(date) {

      if(!date.innerHTML.trim()==""){
        date.classList.add('processed')
        var date_string=date.innerHTML.toString();
        var slpit_dateText=date_string.split(" ");


        if(slpit_dateText.length==1){
          let plural=true;
          if(slpit_dateText[0].length==2){
            if(slpit_dateText[0].charAt(0)=="1"){
              plural=false;
            }
          }
          let modifier=plural ? 'hours ago':'hour ago';

          if(slpit_dateText[0].substr(-1)=='m'){
            modifier=plural ? 'minutes ago':'minute ago';
          }
          if(slpit_dateText[0].substr(-1)=='s'){
            modifier=plural ? 'seconds ago':'second ago';
          }
          var new_dateText=slpit_dateText[0].slice(0,-1);
          date.innerHTML=  new_dateText+" "+ modifier;
          date.classList.add("modified");
        }
      }
    });

  }
}
_createElementChangeListener= function (selector, callback) {
  const initializedNodes = new Set([]);

  document.querySelectorAll(selector).forEach((node) => {
    callback(node);
    initializedNodes.add(node);
  });

  const mutationObserver = new MutationObserver(() => {
    const nodes = document.querySelectorAll(selector);
    nodes.forEach((node) => {
      if (!initializedNodes.has(node)) {
        callback(node);
        initializedNodes.add(node);
      }
    });
  });

  mutationObserver.observe(document.body, {
    childList: true,
    subtree: true,
  });
}
_createElementChangeListener(".widget",changeDateFormat);
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        feature_post_full_style();
    

});</script><script class="rm-i-script" id="user-javascript-active" type="text">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</script><script class="rm-i-script" id="user-javascript-lowest" type="text">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</script></body></html>