<!DOCTYPE html><!-- Powered by RebelMouse. https://www.rebelmouse.com --><html lang="en"><head prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#"><script type="application/ld+json">
        {
            "@context": "https://schema.org",
            "@type": "VideoObject",
            "name": "Necrobotics: Dead Spiders Reincarnated as Robot Grippers",
            "description": "Video",
            "thumbnailUrl": "https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&amp;width=980",
            "uploadDate": "2022-07-26T21:34:29Z",
            "url": "https://www.youtube.com/watch?v=1JOS6hMHIUM",
            "contentUrl": "https://www.youtube.com/watch?v=1JOS6hMHIUM"
        }
    </script><script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type":  "NewsArticle" ,
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://spectrum.ieee.org/robot-bugs"
        },
        "url": "https://spectrum.ieee.org/robot-bugs",
        "headline": "Necrobotics: Dead Spiders Reincarnated as Robot Grippers",
        "thumbnailUrl": "https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&amp;width=210",
        "image": {
            "@type": "ImageObject",
            "url": "https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.jpg?id=30273287&width=1200&coordinates=107%2C0%2C108%2C0&height=600",
            "width": 1200,
            "height": 600
        },
        "datePublished": "2022-07-26T21:34:29Z",
        "dateModified": "2022-07-26T22:00:13Z",
        "author": {
            "@type": "Person",
            "name": "Evan Ackerman",
            "identifier": "21075149",
            "url": "https://spectrum.ieee.org/u/evan-ackerman",
            "description": "\u003ca href=\"https://twitter.com/BotJunkie\" target=\"_blank\"\u003eEvan Ackerman\u003c/a\u003e is a senior editor at \u003ci\u003eIEEE Spectrum\u003c/i\u003e. Since 2007, he has written over 6,000 articles on robotics and technology. He has a degree in Martian geology and is excellent at playing bagpipes.",
            "image": {
                "@type": "ImageObject",
                "url": "https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA3MjAwNS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcxNjgyMTgzOH0.5h5h13MlPw_GqfVeUNmZJ-jRmGXDoMaAXy3U2vtNBxM/image.png?width=210"
            }
        },
        "publisher": {
        "@type": "Organization",
        "name": "IEEE Spectrum",
        "logo": {
            "@type": "ImageObject",
            "url": "https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjg4NDUyMC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY5OTk5OTQzOX0.301VTCew4TbjvOr--sy6SCzN7qjjXsjyR9O35w43oZo/image.png?width=210"
            }
        },
        "articleSection": "Robotics",
        "description": "Bugs have long taunted roboticists with how utterly incredible they are. Astonishingly mobile, amazingly efficient, super robust, and in some cases literally dirt cheap. But making an insect-equivalent robot is immensely difficult\u2014so hard that it\u2019s easier to just living insects. Or dead ones.",
        "keywords": ["actuators", "insects", "bioinspired robots", "robotics"]}
</script><link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script"/><link as="font" href="https://partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Light.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Light.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Bold.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Bold.woff2" type="font/woff2" crossorigin="" rel="preload"/><meta name="robots" content="max-image-preview:large"/><link fetchpriority="high" rel="preload" imagesrcset="https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&width=3600&height=2833 3x, https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&width=2400&height=1889 2x, https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&width=1200&height=944 1x" as="image"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@"/><meta name="twitter:site:id" content=""/><meta name="twitter:image" content="https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.jpg?id=30273287&width=1200&coordinates=107%2C0%2C108%2C0&height=600"/><meta property="fb:app_id" content="525370847662646"/><meta property="og:type" content="article"/><meta property="article:section" content="Robotics"/><meta property="og:url" content="https://spectrum.ieee.org/robot-bugs"/><link rel="canonical" href="https://spectrum.ieee.org/robot-bugs"/><meta property="og:site_name" content="IEEE Spectrum"/><meta property="og:image" content="https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.jpg?id=30273287&width=1200&coordinates=107%2C0%2C108%2C0&height=600"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="600"/><meta property="og:title" content="Necrobotics: Dead Spiders Reincarnated as Robot Grippers"/><meta property="og:description" content="Bugs have long taunted roboticists with how utterly incredible they are. Astonishingly mobile, amazingly efficient, super robust, and in some cases literally dirt cheap. But making an insect-equivalent robot is immensely difficult—so hard that it’s easier to just living insects. Or dead ones."/><meta name="description" content="That micro-hydraulic gripper you’ve always wanted, thanks to an ex-spider"/><meta name="referrer" content="always"/><meta charset="utf-8"/><link rel="preconnect" href="https://assets.rebelmouse.io/" crossorigin="crossorigin"/><link rel="preconnect" href="https://user-stats.rbl.ms/" crossorigin="crossorigin"/><link rel="preconnect" href="https://pages-stats.rbl.ms/" crossorigin="crossorigin"/><!--link rel="preload" href="https://static.rbl.ms/static/fonts/fontawesome/fontawesome-mini.woff" as="font" type="font/woff2" crossorigin--><script>window.REBELMOUSE_BOOTSTRAP_DATA = {"engine": {"changeParticleUrlScroll": false, "lazyLoadShortcodeImages": true, "theoPlayerLibraryLocation": "", "defaultVideoPlayer": "", "backButtonGoToPage": true, "webVitalsSampleRate": 100, "countKeepReadingAsPageview": true, "trackPageViewOnParticleUrlScroll": false}, "runner": {"id": 20265424}, "resourceId": "pp_2657727687", "fbId": "525370847662646", "site": {"id": 20265424, "isCommunitySite": false}, "tag": {"slug": "robotics"}, "whitelabel_menu": {}, "post": {"status": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "shareUrl": "https%3A%2F%2Fspectrum.ieee.org%2Frobot-bugs", "id": 2657727687, "tags": ["actuators", "insects", "bioinspired robots", "robotics"]}, "isUserLoggedIn": false, "messageBusUri": "wss://messages.rebelmouse.io", "section": {"id": null}, "pathParams": {"slug": "robot-bugs"}, "clientGaId": "UA-747464-1", "fbAppVersion": "v2.5", "useRiver": true, "fullBootstrapUrl": "/res/bootstrap/data.js?path_params=%7B%22slug%22%3A%22robot-bugs%22%7D\u0026override_device=desktop\u0026resource_id=pp_2657727687\u0026site_id=20265424\u0026post_id=2657727687\u0026warehouse10x=1"};
    </script><script>
        window.REBELMOUSE_BASE_ASSETS_URL = "https://spectrum.ieee.org/static/dist/social-ux/";
        window.REBELMOUSE_BASE_SSL_DOMAIN = "https://spectrum.ieee.org";
        window.REBELMOUSE_TASKS_QUEUE = [];
        window.REBELMOUSE_LOW_TASKS_QUEUE = [];
        window.REBELMOUSE_LOWEST_TASKS_QUEUE = [];
        window.REBELMOUSE_ACTIVE_TASKS_QUEUE = [];
        window.REBELMOUSE_STDLIB = {};
        window.RM_OVERRIDES = {};
        window.RM_AD_LOADER = [];
    </script><script src="https://spectrum.ieee.org/static/dist/social-ux/main.ed9eb228af0fa11b932c.bundle.mjs" type="module" async="async" src="https://spectrum.ieee.org/static/dist/social-ux/main.ed9eb228af0fa11b932c.bundle.mjs" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="main.mjs"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/main.9293a2c982b451eba73a.bundle.js" nomodule="nomodule" defer="defer" src="https://spectrum.ieee.org/static/dist/social-ux/main.9293a2c982b451eba73a.bundle.js" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="main.js"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/runtime.815b3c4942c54cf84c32.bundle.mjs" type="module" async="async" src="https://spectrum.ieee.org/static/dist/social-ux/runtime.815b3c4942c54cf84c32.bundle.mjs" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="runtime.mjs"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/runtime.84d1cb96c6797df78386.bundle.js" nomodule="nomodule" defer="defer" src="https://spectrum.ieee.org/static/dist/social-ux/runtime.84d1cb96c6797df78386.bundle.js" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="runtime.js"></script><!-- we collected enough need to fix it first before turn in back on--><!--script src="//cdn.ravenjs.com/3.16.0/raven.min.js" crossorigin="anonymous"></script--><!--script type="text/javascript">
        Raven.config('https://6b64f5cc8af542cbb920e0238864390a@sentry.io/147999').install();
    </script--><link rel="manifest" href="/manifest.json"/><meta name="theme-color" content="#647187"/><script>
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/sw.js').then(function(registration) {
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }, function(err) {
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        } else {
          console.log('ServiceWorker not enabled');
        }
    </script><script>
        // fallback error prone google tag setup
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/><link rel="alternate" type="application/rss+xml" title="IEEE Spectrum" href="/feeds/topic/robotics.rss"/><!-- Mobile viewport optimized: h5bp.com/viewport --><meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1.0,maximum-scale=1.0,user-scalable=no"/><title>Necrobotics: Dead Spiders Reincarnated as Robot Grippers - IEEE Spectrum</title><style>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</style><script>
        window.REBELMOUSE_LOW_TASKS_QUEUE.push(function() {
            window.REBELMOUSE_STDLIB.loadExternalStylesheet("/static/css-build/roar/runner/social-ux-non-critical.css?v=rmxassets27ce01474a075144b0ac916a2195413a", function(){
                document.body.classList.add("rm-non-critical-loaded");
            });
        });
    </script><script>
        var __RUNNER_PUBLIC__ = {
          root: '#runner-root',
          events: {
            PAGE_VIEW: 'page_view.url_change.listicle_switch_page',
            URL_CHANGE_PAGE_VIEW: 'page_view.url_change',
            LISTICLE_CHANGE_PAGE_VIEW: 'page_view.listicle_switch_page'
          }
        }
    </script><script>
        window.__rebelmouseJsBaseUrl = "/static/js-build/";
        
        window.__rebelmousePrimaryColor = "#FF4C00";
        
    </script><link rel="apple-touch-icon" href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjU5NjY0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1OTYwMjUwNn0.83ww7bkGqpGwDJ0lJUQ9t40jCxvzIiI09EEqwNcU8HE/img.png?width=192&height=192" sizes="192x192"/><link rel="icon" type="image/png" href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjU5NjY0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1OTYwMjUwNn0.83ww7bkGqpGwDJ0lJUQ9t40jCxvzIiI09EEqwNcU8HE/img.png?width=32&height=32" sizes="16x16"/><meta property="article:published_time" content="2022-07-26T21:34:29+00:00"/><meta property="article:modified_time" content="2022-07-26T22:00:13+00:00"/><meta property="article:author" content="https://www.facebook.com/48576411181"/><meta name="keywords" content="actuators, insects, bioinspired robots, robotics"/><link rel="amphtml" href="https://spectrum.ieee.org/amp/robot-bugs-2657727687"/><script data-abtest-name="ieee" data-abtest-value="1784" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1482" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1939" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1904" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1892" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1830" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1242" type="application/json"></script><script async="async" type="text/javascript" src="//c.jsrdn.com/s/cs.js?p=23069"></script><script>
window.postid = "2657727687";
window.category = ["robotics", "news", "type", "topic"];
window.tags = ["actuators", "insects", "bioinspired-robots", "robotics"];

</script><script data-abtest-name="IEEE" data-abtest-value="1761" type="application/json"></script><script data-abtest-name="test" data-abtest-value="greek" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1016" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1883" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1933" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1891" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1885" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1715" type="application/json"></script><script data-abtest-name="pdf" data-abtest-value="button2" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1326" type="application/json"></script><script data-abtest-name="test" data-abtest-value="2" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1872" type="application/json"></script><script data-abtest-name="test" data-abtest-value="badge" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1719" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1386" type="application/json"></script><script data-abtest-name="anbar" data-abtest-value="off" type="application/json"></script><script data-abtest-name="anbar" data-abtest-value="3" type="application/json"></script><script data-abtest-name="anbar" data-abtest-value="on" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1422" type="application/json"></script><script data-abtest-name="final" data-abtest-value="2" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="209" type="application/json"></script><script data-abtest-name="test" data-abtest-value="collections" type="application/json"></script><script data-abtest-name="test" data-abtest-value="tiarchive" type="application/json"></script><script data-abtest-name="h1" data-abtest-value="fix" type="application/json"></script><script data-abtest-name="footer" data-abtest-value="test" type="application/json"></script><script data-abtest-name="pdf" data-abtest-value="button2" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="gate" type="application/json"></script><script data-abtest-name="pdf" data-abtest-value="button" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1811" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1843" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1842" type="application/json"></script><script data-abtest-name="test" data-abtest-value="noaipopup" type="application/json"></script><meta name="google-site-verification" content="TL2pz9TZSlPds24a3mqZClMC79zWmgOKFwO4aYRjdXk"/><meta name="facebook-domain-verification" content="bgsalp9vtqx07wdoczkh2jq79qvonr"/><meta property="fb:pages" content="48576411181"/><script data-abtest-name="test" data-abtest-value="structureddata" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1830" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1879" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1780" type="application/json"></script><script data-abtest-name="date" data-abtest-value="mod" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1482" type="application/json"></script><script data-abtest-name="image" data-abtest-value="32" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="gate" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1922" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1907" type="application/json"></script><script data-abtest-name="authors" data-abtest-value="new" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1808" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1436" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1482" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1436test" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="gateold" type="application/json"></script><style id="custom-post-styles-2657727687">
</style><script data-abtest-name="socialux" data-abtest-value="1" type="application/json"></script><style id="custom-post-styles-2657170650">
										.css-listicle-body-2657170650 #rebelltitem1  {
													min-width: 100vw;;
										}
										.css-listicle-body-2657170650 #rebelltitem1 .share-tab-img img {
													min-width: 100vw;;
										}
										.css-listicle-body-2657170650 #rebelltitem1 p {
										}
</style><script data-abtest-name="final" data-abtest-value="3" type="application/json"></script><script data-abtest-name="" data-abtest-value="" type="application/json"></script><script data-abtest-name="" data-abtest-value="3" type="application/json"></script><meta name="parsely-section" content="Robotics"/><meta name="parsely-tags" content="actuators,insects,bioinspired robots,robotics,SpectrumType.News"/><meta name="parsely-author" content="Evan Ackerman"/><script data-abtest-name="ieee" data-abtest-value="1436" type="application/json"></script><script data-abtest-name="test" data-abtest-value="old" type="application/json"></script><script data-abtest-name="test" data-abtest-value="oldarrows" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1436test" type="application/json"></script><script>
    
        (function() {
    var cookie = 'rebelmouse_abtests=';
        cookie += "v1:165477109-A:3";
    document.cookie = cookie + '; Path=/; SameSite=None; Secure';
})();
    
    </script><!--[if IE]>
        <script type="text/javascript" src="/static/js-build/libs/html5shiv/html5shiv.js"></script>
    <![endif]--></head><body class="logged-out-user section-robotics"><div id="fb-root"></div><div id="runner-root"></div><div id="curtain" class="curtain"></div><nav class="menu-global"><div class="main-menu-wrapper"><div class="menu-global__search-form hide-tablet-and-desktop"><form action="/search/"><button aria-label="Submit" type="submit" class="menu-global__submit fa fa-search" value=""></button><input aria-label="Search" placeholder="Search..." type="text" name="q" class="menu-global__text-input"/></form></div><div class="divider hide-tablet-and-desktop"></div><ul class="sections-list"></ul><div class="divider"></div><ul id="main-menu" class="main-menu"></ul></div></nav><cookie_variants><cookie_variant id="a"></cookie_variant><cookie_variant id="b"></cookie_variant><cookie_variant id="c"></cookie_variant><cookie_variant id="d"></cookie_variant><cookie_variant id="e"></cookie_variant><cookie_variant id="f"></cookie_variant><cookie_variant id="g"></cookie_variant><cookie_variant id="h"></cookie_variant></cookie_variants><extra_asset_fields></extra_asset_fields><extra_section_fields></extra_section_fields><post_types_supported></post_types_supported><site_specific_data_schema><site_specific_data_property name="first_name" default="" description="SSO First Name" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="last_name" default="" description="SSO Last Name" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Instagram" default="" description="Add the link to your Instagram account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="member_badges" default="" description="Membership Badges" enum="STAFF EDITOR,CONTRIBUTOR" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Twitter" default="" description="Add the link to your Twitter account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="LinkedIn" default="" description="Add the link to your LinkedIn account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="grade" default="" description="SSO Grade" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Facebook" default="" description="Add the link to your Facebook account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property></site_specific_data_schema><post_image_settings _3x2="true" _1x1="true" _3x1="true" _3x4="true" _2x1="true" _9x16="true" _16x9="true" _4x3="true"></post_image_settings><div class="all-content-wrapper"><div class="main v-sep"><span class="js-brick-description hidden" data-name="Post"></span><div data-share-status-id="menu-toggle" data-toggle-class="menu-opened" class="menu-overlay js-toggle" data-target="body"></div><!-- User Code --><script>
    window.PARSELY = window.PARSELY || {};

  	function isPublished(post){
    	return [0,1,2].includes(post.status)
    }
  
  	window.PARSELY.autotrack = false;
    window.PARSELY.onload = function () {
      
      	
        if(Object.keys(window.REBELMOUSE_BOOTSTRAP_DATA.post).length > 0 && !isPublished(window.REBELMOUSE_BOOTSTRAP_DATA.post)){
        	return;
        }
      
        var event = {
          url: location.href,
          urlref: document.referrer,
          js: 1
        };
        window.PARSELY.updateDefaults({
            data: {
                level: localStorage.getItem("userMembershipStatus") || "anonymous"
            }
        });
        window.PARSELY.beacon.trackPageView(event);
    };
</script><!-- End User Code --><!-- User Code --><!-- Google Tag Manager (noscript) --><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5WJB5X2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><!-- End Google Tag Manager (noscript) --><!-- End User Code --><span class="js-brick-description hidden" data-name="CSS Fonts"></span><span class="js-brick-description hidden" data-name="CSS Spectrum"></span><span class="js-brick-description hidden" data-name="CSS for Posts"></span><span class="js-brick-description hidden" data-name="CSS Article Components"></span><span class="js-brick-description hidden" data-name="CSS for Comments"></span><div class="topbar topbar--static" id="sTop_Bar_0_0_27_0_0_13"><div class="" id="sTop_Bar_0_0_27_0_0_13_0"><span class="js-brick-description hidden" data-name="Element Bar"></span><div class="dark_top_bar" id="sElement_Bar_0_0_7_0_0_1"><div class="" id="sElement_Bar_0_0_7_0_0_1_0"><div class="top_menu_links" id="sElement_Bar_0_0_7_0_0_1_0_0"><div class="list" id="sElement_Bar_0_0_7_0_0_1_0_0_0"><a href="https://www.ieee.org/" class="list__item" target="_blank">IEEE.org</a><a href="https://ieeexplore.ieee.org/Xplore/home.jsp" class="list__item" target="_blank">IEEE Xplore Digital Library</a><a href="https://standards.ieee.org/" class="list__item" target="_blank">IEEE Standards</a><a href="https://www.ieee.org/sitemap.html" class="list__item" target="_blank">More Sites</a></div></div><div class="" id="sElement_Bar_0_0_7_0_0_1_0_1"><div class="access_links" id="sElement_Bar_0_0_7_0_0_1_0_1_0_1_1"><div class="list" id="sElement_Bar_0_0_7_0_0_1_0_1_0_1_1_0"><a href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https://spectrum.ieee.org/core/saml/main/login&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">Sign In</a><a href="/st/join" class="list__item" target="_self">Join IEEE</a></div></div><div class="" id="sElement_Bar_0_0_7_0_0_1_0_1_1"><!-- User Code --><svg width="70px" height="21px" viewbox="0 0 70 21" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="0 0 21.3639449 0 21.3639449 21 0 21"></polygon></defs><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-IEEE-Bar-/-Signed-out-/-1376" transform="translate(-1274.000000, -14.000000)"><g id="Group-13" transform="translate(1274.000000, 14.000000)"><polygon id="Fill-1" fill="#FEFEFE" points="23.4111174 18.6889405 27.8363724 18.6889405 27.8363724 2.77905063 23.4111174 2.77905063"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="29.7536549 18.6881005 29.7536549 2.77821061 41.9217005 2.77821061 41.9217005 5.8624668 34.17891 5.8624668 34.17891 9.14692664 41.3017712 9.14692664 41.3017712 12.2311828 34.17891 12.2311828 34.17891 15.6024442 41.9217005 15.6024442 41.9217005 18.6881005"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="43.7923126 18.6881005 43.7923126 2.77821061 55.9603583 2.77821061 55.9603583 5.8624668 48.2175677 5.8624668 48.2175677 9.14692664 55.3418347 9.14692664 55.3418347 12.2311828 48.2175677 12.2311828 48.2175677 15.6024442 55.9603583 15.6024442 55.9603583 18.6881005"></polygon><polygon id="Fill-4" fill="#FEFEFE" points="57.8305486 2.77793061 57.8305486 18.6878205 70 18.6878205 70 15.6021642 62.2558037 15.6021642 62.2558037 12.2323028 69.3800707 12.2323028 69.3800707 9.14664663 62.2558037 9.14664663 62.2558037 5.8621868 70 5.8621868 70 2.77793061"></polygon><g id="Group-12"><g id="Group-7"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-6"></g><path d="M20.9520644,9.85449953 L20.8930235,9.84469935 C19.0838421,8.61967703 17.3983653,7.23365178 15.8098843,5.66142314 L14.0555265,3.83578988 C13.3442244,3.05037557 12.6540084,2.18095973 11.9961242,1.35074461 L11.1976665,0.22232405 C11.099265,0.164923005 10.976966,0.0669212192 10.8687244,0.0375206836 C10.6339666,-0.0646811784 10.3795285,0.0571210406 10.1883485,0.202723693 L8.74184673,2.07875787 C6.42378906,4.93900998 3.67838782,7.60885862 0.684171419,9.65429588 C0.448007872,9.84049927 0.0951682866,10.0211026 0.0220700458,10.3235081 C-0.0566511366,10.596513 0.0853281388,10.8219172 0.256827858,10.9913202 C2.65360672,12.6363502 4.94776689,14.5907858 6.98748895,16.8168264 C7.35016869,17.1962333 7.64396739,17.5728401 7.99680697,17.9284466 C8.59424452,18.719461 9.29570648,19.5160755 9.84534902,20.364491 C10.0168487,20.5450943 10.0463692,20.8390996 10.3148646,20.9259012 C10.525725,20.9987026 10.785786,21.0477034 10.9868062,20.9259012 L11.1878263,20.7256976 C13.6675436,17.2256338 16.8149851,14.0825766 20.3293236,11.5429303 C20.6821632,11.2321246 21.3541047,11.1145225 21.3639449,10.5335119 C21.3386417,10.264707 21.182605,10.0015022 20.9520644,9.85449953 M18.5496626,10.7911166 C18.1476223,11.7879348 17.3337015,12.5831492 16.6238051,13.4525651 C15.0845249,15.1017951 13.4623062,16.6992242 11.6432846,17.9718474 C11.2763877,18.2322522 10.7815688,18.4702565 10.3401679,18.2658528 C9.00190778,17.56724 7.87450799,16.4248192 6.7035304,15.3860003 C5.34559001,14.1301774 3.98202667,12.6713508 2.95302836,11.142523 C2.80120893,10.9283191 2.75763114,10.6651143 2.76184834,10.3823091 C2.89398747,9.85449953 3.2566672,9.42049162 3.60107238,8.97668354 C4.81562776,7.43385543 6.30570729,5.96942875 7.80984416,4.63240439 C7.84498755,4.59740376 7.90824564,4.5232024 7.96306932,4.48960179 C8.60970761,3.93379167 9.25212869,3.44098269 9.92828741,2.95657386 C10.6339666,2.41056392 11.5209856,2.86417218 12.114206,3.36678134 C12.7369467,3.83998996 13.383585,4.37759975 13.9529079,4.9236097 L14.0555265,4.98241077 C15.6285445,6.43703727 17.0891035,8.05406673 18.2910073,9.76209785 C18.4864045,10.0603033 18.6579042,10.3963094 18.5496626,10.7911166" id="Fill-5" fill="#FEFEFE" mask="url(#mask-2)"></path></g><path d="M17.8685838,9.92786087 C16.3152462,7.68782006 14.2755241,5.70538394 12.1135031,3.97215236 C11.5554261,3.58154525 10.9087879,2.8983328 10.1876456,3.3869417 C7.9483091,4.92836978 5.79050526,7.01860786 4.05582778,9.15084671 C3.70298819,9.66885615 3.08587035,10.1616651 3.3656117,10.8504777 C3.56663186,11.3586869 4.01646719,11.7240936 4.30604868,12.1735018 C6.00698851,14.2091389 8.01719014,16.1089735 10.1145474,17.6364013 C11.0367098,18.221612 11.6931882,17.2751947 12.4087075,16.8397868 C13.8734838,15.6875658 15.2314242,14.2875403 16.5162664,12.9253155 L16.5162664,12.8917149 C17.0307655,12.2715036 17.5747851,11.6610924 17.9768254,10.9918802 C18.1525424,10.6642743 18.0653868,10.2162661 17.8685838,9.92786087 L17.8685838,9.92786087 Z M10.4477066,5.41697869 L10.6431039,4.79256731 L10.6684071,4.79256731 C11.0704474,5.9391882 11.4865451,7.08300904 11.9181059,8.21422965 L11.0549843,8.22962993 L11.0367098,8.33183179 L11.163226,11.4020877 L11.163226,11.4510886 C10.844124,11.5042896 10.4533296,11.4902893 10.1384449,11.4608888 L10.1145474,11.4258882 L10.2565266,8.26323054 L10.2565266,8.23943011 C10.0161459,8.21422965 9.71250703,8.23943011 9.46790907,8.21422965 L10.4477066,5.41697869 Z M9.93742469,15.6203646 C10.0217688,14.491944 10.0358262,13.4531251 10.0948671,12.3289046 C10.4912844,12.3695053 10.8356896,12.3541051 11.1969636,12.3401048 L11.2222668,12.4913076 L11.3642461,15.6301648 C10.8891076,15.698766 10.3844486,15.6595653 9.93742469,15.6203646 L9.93742469,15.6203646 Z M13.5501647,11.7058933 C11.492168,12.3443049 8.90420917,12.3149044 6.95304844,11.4608888 C6.60020885,11.2900857 6.15459073,11.0268809 6.03650896,10.6166734 C5.94794763,9.86485972 6.75624548,9.44905214 7.30588802,9.17604717 C7.62920717,9.03464459 7.95814925,8.87924176 8.31520604,8.8596414 C8.64836533,9.10324584 8.99698771,9.29924941 9.33998715,9.51765339 C8.67366857,9.69405661 7.87380512,9.84525936 7.56594907,10.5718726 C7.61936702,11.1248827 8.24632501,11.2998859 8.68350872,11.4370884 C10.2565266,11.8514959 11.9574665,11.7968949 13.4672263,11.250885 C13.7511848,11.0842819 14.2024259,10.8840783 14.1630653,10.4752708 C14.1138646,10.0356628 13.6092056,9.84105928 13.256366,9.70245676 C13.0412885,9.73185729 12.8346454,9.78085819 12.6336252,9.84525936 C12.5253836,9.54285385 12.432605,9.23484824 12.3046831,8.94224291 C12.9724074,9.1172461 13.638726,9.29924941 14.3289421,9.41965161 L14.3289421,9.43505189 C14.1869628,9.44905214 14.0309262,9.49805304 13.8931641,9.551254 L13.8931641,9.57645446 C14.2853643,9.77105801 14.8293839,10.0944639 14.8336011,10.6068732 C14.7422283,11.2270845 14.0604466,11.5098897 13.5501647,11.7058933 L13.5501647,11.7058933 Z" id="Fill-8" fill="#FEFEFE"></path><path d="M14.1946944,19.3564726 L14.1946944,19.1646691 L14.3141819,19.1646691 C14.3788457,19.1646691 14.467407,19.1716693 14.467407,19.2528707 C14.467407,19.3410724 14.4224235,19.3564726 14.3465138,19.3564726 L14.1946944,19.3564726 Z M14.1946944,19.4922751 L14.2748213,19.4922751 L14.4603783,19.8268812 L14.6613985,19.8268812 L14.4575669,19.4782749 C14.562997,19.4698747 14.6501526,19.4166737 14.6501526,19.2710711 C14.6501526,19.0890678 14.5278536,19.0302667 14.3226163,19.0302667 L14.0231946,19.0302667 L14.0231946,19.8268812 L14.1946944,19.8268812 L14.1946944,19.4922751 Z M15.0620331,19.429274 C15.0620331,18.9630655 14.7105992,18.6900605 14.3183991,18.6900605 C13.9233874,18.6900605 13.5719536,18.9630655 13.5719536,19.429274 C13.5719536,19.8954825 13.9233874,20.1670874 14.3183991,20.1670874 C14.7105992,20.1670874 15.0620331,19.8954825 15.0620331,19.429274 L15.0620331,19.429274 Z M14.8483613,19.429274 C14.8483613,19.7694802 14.6051691,19.9976843 14.3183991,19.9976843 L14.3183991,19.9962843 C14.0231946,19.9976843 13.7856254,19.7694802 13.7856254,19.429274 C13.7856254,19.0890678 14.0231946,18.8622636 14.3183991,18.8622636 C14.6051691,18.8622636 14.8483613,19.0890678 14.8483613,19.429274 L14.8483613,19.429274 Z" id="Fill-10" fill="#FEFEFE"></path></g></g></g></g></svg><!-- End User Code --></div></div></div></div><div class="topbar-sticky announcement-show" id="sTop_Bar_0_0_27_0_0_13_0_1"><div id="sTop_Bar_0_0_27_0_0_13_0_1_0" class="js-hidden-panel" data-offset="0"></div><div class="rebelbar-wrapper_static announcement-show" id="sTop_Bar_0_0_27_0_0_13_0_1_1"><span class="js-brick-description hidden" data-name="Announcement Bar"></span><span class="js-brick-description hidden" data-name="__TopBar Second Bar"></span><div class="" id="s__TopBar_Second_Bar_0_0_36_0_0_0"><div class="site_logo" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0"><!-- User Code --><a href="/" title="Spectrum Logo"><svg width="214px" height="30px" viewbox="0 0 214 30" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-Sticky-Site-Header-/-1376" transform="translate(-33.000000, -17.000000)" fill="#0D0D0D" fill-rule="nonzero"><g id="IEEE-Spectrum-Logo" transform="translate(32.000000, 15.000000)"><g id="IEEESpectrum-LogoFinal-Black" transform="translate(1.454545, 2.909091)"><path d="M67.5731087,15.3769418 C67.7375958,17.1915012 68.9067885,18.8411007 71.9786975,18.8411007 C74.7749795,18.8411007 75.8285865,17.851341 75.8285865,16.3310345 C75.8285865,14.882062 74.9750314,14.1553466 73.3301597,13.923511 L68.5600317,13.3974225 C64.6123396,12.9515848 62.3361928,10.6911877 62.3361928,6.96398467 C62.3361928,2.83552769 65.4481122,6.3357346e-15 71.7475264,6.3357346e-15 C78.4915004,6.3357346e-15 81.1899792,3.23232323 81.4833887,7.133403 L75.7485657,7.133403 C75.5173945,5.38126088 74.2014972,4.22654127 71.7475264,4.22654127 C69.5247267,4.22654127 68.191047,5.11821665 68.191047,6.57164751 C68.191047,7.6907001 68.8489957,8.51549983 70.5294322,8.71612679 L74.7082955,9.16196447 C79.5095427,9.60780216 81.6834407,11.8994079 81.6834407,15.8495298 C81.6834407,20.1741553 78.984962,23.0765587 71.8764488,23.0765587 C64.6701324,23.0765587 62.1717056,19.3136886 61.9405344,15.390317 L67.5731087,15.3769418 Z" id="Path"></path><path d="M101.439684,14.266806 C101.439684,18.8544758 99.3013506,23.0141414 93.8821651,23.0141414 C91.0858831,23.0141414 89.2098403,21.9575061 88.102886,20.1741553 L88.102886,29.0909091 L82.456975,29.0909091 L82.456975,6.00543365 L88.1162228,6.00543365 L88.1162228,8.23462208 C89.2320682,6.48693835 91.1081111,5.46597005 93.8955019,5.46597005 C99.3013506,5.47934518 101.439684,9.53646813 101.439684,14.266806 Z M95.7804359,14.266806 C95.7804359,11.1994427 94.7935129,9.91097179 91.997231,9.91097179 C89.1031459,9.91097179 88.1162228,11.3287356 88.1162228,14.266806 C88.1162228,17.2048763 89.1031459,18.6226402 91.997231,18.6226402 C94.7935129,18.6092651 95.7804359,17.3207941 95.7804359,14.266806 Z" id="Shape"></path><path d="M114.367486,17.5214211 L119.862247,17.5214211 C119.302102,20.3569488 117.065965,23.0319749 111.077743,23.0319749 C104.364888,23.0319749 101.995384,18.7430164 101.995384,14.2222222 C101.995384,9.43838384 104.760546,5.47934518 111.077743,5.47934518 C117.790598,5.47934518 119.928931,9.73263671 119.928931,14.3203065 C119.934228,14.7845667 119.900021,15.2484337 119.826682,15.7068617 L107.490144,15.7068617 C107.819119,18.3462208 109.103897,19.2378962 111.211111,19.2378962 C112.887102,19.2378962 113.905144,18.5111808 114.367486,17.5214211 Z M107.556828,12.4076628 L114.563093,12.4076628 C114.367486,10.3256008 113.349444,9.20654824 111.144427,9.20654824 C109.103897,9.20654824 107.921368,10.031348 107.556828,12.4076628 Z" id="Shape"></path><path d="M129.811498,5.47934518 C135.764156,5.47934518 138.662686,8.84096134 138.791609,12.9649599 L133.247946,12.9649599 C133.083459,11.0211076 132.096536,9.89759666 129.895965,9.89759666 C127.52646,9.89759666 126.174998,10.954232 126.174998,14.2534309 C126.174998,17.5526297 127.459776,18.6092651 129.793716,18.6092651 C132.127655,18.6092651 133.119024,17.3207941 133.31463,15.4884013 L138.876075,15.4884013 C138.742707,19.4162313 136.013109,23.0141966 129.895965,23.0141966 C123.085307,23.0319749 120.520196,18.7251829 120.520196,14.266806 C120.520196,9.80842912 123.018623,5.47934518 129.811498,5.47934518 Z" id="Path"></path><path d="M141.77016,16.0011146 L141.77016,10.2542668 L138.876075,10.2542668 L138.876075,7.62382445 L142.228057,6.13472658 L144.566442,2.01072797 L147.429408,2.01072797 L147.429408,6.02326715 L151.901681,6.02326715 L151.901681,10.2542668 L147.429408,10.2542668 L147.429408,18.0163009 L151.3771,18.0163009 L151.3771,22.5014281 L148.380766,22.5014281 C143.348348,22.5014281 141.77016,20.2588645 141.77016,16.0011146 Z" id="Path"></path><path d="M164.304903,5.74238941 L164.304903,11.2529432 L162.299938,11.2529432 C159.565894,11.2529432 158.414484,12.5904563 158.414484,15.9030303 L158.414484,22.5014281 L152.755236,22.5014281 L152.755236,6.00543365 L158.263333,6.00543365 L158.263333,9.36259143 C158.921282,7.0174852 160.272744,5.73347266 162.935658,5.73347266 L164.304903,5.74238941 Z" id="Path"></path><path d="M182.989757,6.00543365 L182.989757,22.5014281 L177.330509,22.5014281 L177.330509,19.5009404 C176.281347,21.6454197 174.405304,23.0319749 171.511219,23.0319749 C167.198988,23.0319749 165.256261,20.3569488 165.256261,16.0367816 L165.256261,6.00543365 L170.915509,6.00543365 L170.915509,15.0470219 C170.915509,17.2762104 171.804629,18.4443051 173.81404,18.4443051 C176.014611,18.4443051 177.330509,16.9239986 177.330509,13.758551 L177.330509,6.00543365 L182.989757,6.00543365 Z" id="Path"></path><path d="M213.090909,12.4834552 L213.090909,22.5148032 L207.431661,22.5148032 L207.431661,13.3305468 C207.431661,11.2172762 206.613671,10.0625566 204.737628,10.0625566 C202.514828,10.0625566 201.479004,11.5159875 201.479004,14.7483107 L201.479004,22.5014281 L195.917559,22.5014281 L195.917559,13.3305468 C195.917559,11.2172762 195.095123,10.0625566 193.223526,10.0625566 C191.000726,10.0625566 189.964902,11.5159875 189.964902,14.7483107 L189.964902,22.5014281 L184.305654,22.5014281 L184.305654,6.00543365 L189.964902,6.00543365 L189.964902,8.8097527 C190.982944,6.76335772 192.725619,5.47934518 195.557466,5.47934518 C198.389312,5.47934518 200.163106,6.81685824 200.985542,9.13967259 C202.003585,6.91048415 203.812943,5.47934518 206.809277,5.47934518 C211.117063,5.47934518 213.090909,8.14991292 213.090909,12.4834552 Z" id="Path"></path><polygon id="Path" points="11.9408796 7.10219436 11.9408796 3.0450714 0 3.0450714 0 7.10219436 3.14303867 7.10219436 3.14303867 18.4086381 0 18.4086381 0 22.4702194 11.9408796 22.4702194 11.9408796 18.4086381 8.80228652 18.4086381 8.80228652 7.10219436"></polygon><polygon id="Path" points="18.8537864 18.4086381 18.8537864 14.467433 26.0378748 14.467433 26.0378748 10.6956461 18.8537864 10.6956461 18.8537864 7.10219436 26.9136579 7.10219436 26.9136579 3.0450714 18.8537864 3.0450714 13.1945386 3.0450714 13.1945386 22.4613027 13.1945386 22.4702194 27.0025699 22.4702194 27.0025699 18.4086381"></polygon><polygon id="Path" points="33.6487408 18.4086381 33.6487408 14.467433 40.8372748 14.467433 40.8372748 10.6956461 33.6487408 10.6956461 33.6487408 7.10219436 41.7086122 7.10219436 41.7086122 3.0450714 33.6487408 3.0450714 27.9939385 3.0450714 27.9939385 22.4613027 27.9939385 22.4702194 41.7975242 22.4702194 41.7975242 18.4086381"></polygon><polygon id="Path" points="48.4481407 18.4086381 48.4481407 14.467433 55.6322291 14.467433 55.6322291 10.6956461 48.4481407 10.6956461 48.4481407 7.10219436 56.5080121 7.10219436 56.5080121 3.0450714 48.4481407 3.0450714 42.7888928 3.0450714 42.7888928 22.4613027 42.7888928 22.4702194 56.5924785 22.4702194 56.5924785 18.4086381"></polygon></g></g></g></g></svg></a><!-- End User Code --><div class="topbar__sticky-headline topbar__sticky-headline--post" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0_1_0_1"><div class="text-element" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0_1_0_1_0">Necrobotics: Dead Spiders Reincarnated as Robot Grippers</div></div><!-- User Code --><span class="floating-shares hide-desktop">Share</span><!-- End User Code --><!-- User Code --><script>
  function createElementChangeListener(selector, callback, oneTime) {
    const initializedNodes = new Set([]);
    let reported = false;

    document.querySelectorAll(selector).forEach((node) => {
      if (oneTime && reported) {
        return;
      }
      reported = true;
      callback(node);
      initializedNodes.add(node);
    });

    const mutationObserver = new MutationObserver(() => {
      const nodes = document.querySelectorAll(selector);
      nodes.forEach((node) => {
        if (oneTime && reported) {
          return;
        }

        if (!initializedNodes.has(node)) {
          reported = true;
          callback(node);
          initializedNodes.add(node);
          if (oneTime) {
            mutationObserver.disconnect();
          }
        }
      });
    });

    if (!oneTime || !reported) {
      mutationObserver.observe(document.body, {
        childList: true,
        subtree: true,
      });
    }
    return mutationObserver;
  }
  
</script><!-- End User Code --><div class="topbar__static-headline" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0_2"><div class="text-element" id="s__TopBar_Second_Bar_0_0_36_0_0_0_0_2_0">FOR THE TECHNOLOGY INSIDER</div></div></div><div class="" id="s__TopBar_Second_Bar_0_0_36_0_0_0_1"><div class="search-form"><form action="/search/"><label for="q" class="hide-text">Search: </label><input placeholder="Type to search" type="text" name="q" id="q" class="search-form__text-input"/><button aria-label="Search" type="submit" class="search-form__submit" value="Search"><svg width="18px" height="19px" viewbox="0 0 18 19" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="1376---Sample-Front-Page" transform="translate(-826.000000, -102.000000)" stroke="#0D0D0D" stroke-width="1.5"><g id="Light-/-Nav" transform="translate(816.857864, 96.000000)"><g id="Search-Icon" transform="translate(7.307612, 5.000000)"><path d="M11.631728,14.6819805 C15.2215789,14.6819805 18.131728,11.7718314 18.131728,8.18198052 C18.131728,4.59212964 15.2215789,1.68198052 11.631728,1.68198052 C8.04187711,1.68198052 5.13172798,4.59212964 5.13172798,8.18198052 C5.13172798,11.7718314 8.04187711,14.6819805 11.631728,14.6819805 Z M11.631728,14.5814755 L11.631728,21.5814755" id="Combined-Shape" transform="translate(11.631728, 11.631728) rotate(-45.000000) translate(-11.631728, -11.631728) "></path></g></g></g></g></svg></button></form></div><span class="js-brick-description hidden" data-name="Element Menu"></span><div class="main-menu-el" id="sElement_Menu_0_0_8_0_0_0"><div class="menu-item" id="sElement_Menu_0_0_8_0_0_0_0"><!-- User Code --><div class="menu-item__title">Explore by topic</div><!-- End User Code --><div class="menu-dropdown" id="sElement_Menu_0_0_8_0_0_0_0_1"><div class="list" id="sElement_Menu_0_0_8_0_0_0_0_1_0"><a href="/topic/aerospace/" class="list__item" target="_self">Aerospace</a><a href="/topic/artificial-intelligence/" class="list__item" target="_self">Artificial Intelligence</a><a href="/topic/biomedical/" class="list__item" target="_self">Biomedical</a><a href="/topic/computing/" class="list__item" target="_self">Computing</a><a href="/topic/consumer-electronics/" class="list__item" target="_self">Consumer Electronics</a><a href="/topic/energy/" class="list__item" target="_self">Energy</a><a href="/topic/tech-history/" class="list__item" target="_self">History of Technology</a><a href="/topic/robotics/" class="list__item" target="_self">Robotics</a><a href="/topic/semiconductors/" class="list__item" target="_self">Semiconductors</a><a href="/topic/sensors/" class="list__item" target="_self">Sensors</a><a href="/topic/telecommunications/" class="list__item" target="_self">Telecommunications</a><a href="/topic/transportation/" class="list__item" target="_self">Transportation</a></div></div></div></div><!-- User Code --><div data-share-status-id="huge-menu-toggle" data-toggle-class="huge-menu-opened" class="rebelbar__menu-toggle js-toggle hambg-btn" data-target="body"><svg width="32px" height="18px" viewbox="0 0 32 18" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="992---Search---Open-filters---selected" transform="translate(-928.000000, -75.000000)"><g id="Light-/-Collapsed-Site-Header" transform="translate(0.000000, 56.000000)"><g id="Light-/-Nav" transform="translate(432.857864, 12.000000)"><g id="Group" transform="translate(495.142136, 7.000000)"><rect id="Rectangle" x="0" y="0" width="32" height="2"></rect><rect id="Rectangle-Copy" x="0" y="8" width="32" height="2"></rect><rect id="Rectangle-Copy-2" x="0" y="16" width="32" height="2"></rect></g></g></g></g></g></svg></div><!-- End User Code --></div></div></div></div></div></div><div class="huge-menu" id="sTop_Bar_0_0_27_0_0_14"><span class="js-brick-description hidden" data-name="__Huge Menu Links"></span><div id="s__Huge_Menu_Links_0_0_32_0_0_1" class="dark_layout row-wrapper clearfix  content sm-cp-2 md-cp-4"><div class="row px20"><div id="s__Huge_Menu_Links_0_0_32_0_0_1_0" class="Top_hugeMenu col sm-mb-2 md-mb-4 s12 m12 l12"><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_0_0"><!-- User Code --><a href="/" class="hide-text">IEEE Spectrum<svg width="214px" height="30px" class="site_logo_menu" viewbox="0 0 214 30" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-Sticky-Site-Header-/-1376" transform="translate(-33.000000, -17.000000)" fill="#F2F2F2" fill-rule="nonzero"><g id="IEEE-Spectrum-Logo" transform="translate(32.000000, 15.000000)"><g id="IEEESpectrum-LogoFinal-Black" transform="translate(1.454545, 2.909091)"><path d="M67.5731087,15.3769418 C67.7375958,17.1915012 68.9067885,18.8411007 71.9786975,18.8411007 C74.7749795,18.8411007 75.8285865,17.851341 75.8285865,16.3310345 C75.8285865,14.882062 74.9750314,14.1553466 73.3301597,13.923511 L68.5600317,13.3974225 C64.6123396,12.9515848 62.3361928,10.6911877 62.3361928,6.96398467 C62.3361928,2.83552769 65.4481122,6.3357346e-15 71.7475264,6.3357346e-15 C78.4915004,6.3357346e-15 81.1899792,3.23232323 81.4833887,7.133403 L75.7485657,7.133403 C75.5173945,5.38126088 74.2014972,4.22654127 71.7475264,4.22654127 C69.5247267,4.22654127 68.191047,5.11821665 68.191047,6.57164751 C68.191047,7.6907001 68.8489957,8.51549983 70.5294322,8.71612679 L74.7082955,9.16196447 C79.5095427,9.60780216 81.6834407,11.8994079 81.6834407,15.8495298 C81.6834407,20.1741553 78.984962,23.0765587 71.8764488,23.0765587 C64.6701324,23.0765587 62.1717056,19.3136886 61.9405344,15.390317 L67.5731087,15.3769418 Z" id="Path"></path><path d="M101.439684,14.266806 C101.439684,18.8544758 99.3013506,23.0141414 93.8821651,23.0141414 C91.0858831,23.0141414 89.2098403,21.9575061 88.102886,20.1741553 L88.102886,29.0909091 L82.456975,29.0909091 L82.456975,6.00543365 L88.1162228,6.00543365 L88.1162228,8.23462208 C89.2320682,6.48693835 91.1081111,5.46597005 93.8955019,5.46597005 C99.3013506,5.47934518 101.439684,9.53646813 101.439684,14.266806 Z M95.7804359,14.266806 C95.7804359,11.1994427 94.7935129,9.91097179 91.997231,9.91097179 C89.1031459,9.91097179 88.1162228,11.3287356 88.1162228,14.266806 C88.1162228,17.2048763 89.1031459,18.6226402 91.997231,18.6226402 C94.7935129,18.6092651 95.7804359,17.3207941 95.7804359,14.266806 Z" id="Shape"></path><path d="M114.367486,17.5214211 L119.862247,17.5214211 C119.302102,20.3569488 117.065965,23.0319749 111.077743,23.0319749 C104.364888,23.0319749 101.995384,18.7430164 101.995384,14.2222222 C101.995384,9.43838384 104.760546,5.47934518 111.077743,5.47934518 C117.790598,5.47934518 119.928931,9.73263671 119.928931,14.3203065 C119.934228,14.7845667 119.900021,15.2484337 119.826682,15.7068617 L107.490144,15.7068617 C107.819119,18.3462208 109.103897,19.2378962 111.211111,19.2378962 C112.887102,19.2378962 113.905144,18.5111808 114.367486,17.5214211 Z M107.556828,12.4076628 L114.563093,12.4076628 C114.367486,10.3256008 113.349444,9.20654824 111.144427,9.20654824 C109.103897,9.20654824 107.921368,10.031348 107.556828,12.4076628 Z" id="Shape"></path><path d="M129.811498,5.47934518 C135.764156,5.47934518 138.662686,8.84096134 138.791609,12.9649599 L133.247946,12.9649599 C133.083459,11.0211076 132.096536,9.89759666 129.895965,9.89759666 C127.52646,9.89759666 126.174998,10.954232 126.174998,14.2534309 C126.174998,17.5526297 127.459776,18.6092651 129.793716,18.6092651 C132.127655,18.6092651 133.119024,17.3207941 133.31463,15.4884013 L138.876075,15.4884013 C138.742707,19.4162313 136.013109,23.0141966 129.895965,23.0141966 C123.085307,23.0319749 120.520196,18.7251829 120.520196,14.266806 C120.520196,9.80842912 123.018623,5.47934518 129.811498,5.47934518 Z" id="Path"></path><path d="M141.77016,16.0011146 L141.77016,10.2542668 L138.876075,10.2542668 L138.876075,7.62382445 L142.228057,6.13472658 L144.566442,2.01072797 L147.429408,2.01072797 L147.429408,6.02326715 L151.901681,6.02326715 L151.901681,10.2542668 L147.429408,10.2542668 L147.429408,18.0163009 L151.3771,18.0163009 L151.3771,22.5014281 L148.380766,22.5014281 C143.348348,22.5014281 141.77016,20.2588645 141.77016,16.0011146 Z" id="Path"></path><path d="M164.304903,5.74238941 L164.304903,11.2529432 L162.299938,11.2529432 C159.565894,11.2529432 158.414484,12.5904563 158.414484,15.9030303 L158.414484,22.5014281 L152.755236,22.5014281 L152.755236,6.00543365 L158.263333,6.00543365 L158.263333,9.36259143 C158.921282,7.0174852 160.272744,5.73347266 162.935658,5.73347266 L164.304903,5.74238941 Z" id="Path"></path><path d="M182.989757,6.00543365 L182.989757,22.5014281 L177.330509,22.5014281 L177.330509,19.5009404 C176.281347,21.6454197 174.405304,23.0319749 171.511219,23.0319749 C167.198988,23.0319749 165.256261,20.3569488 165.256261,16.0367816 L165.256261,6.00543365 L170.915509,6.00543365 L170.915509,15.0470219 C170.915509,17.2762104 171.804629,18.4443051 173.81404,18.4443051 C176.014611,18.4443051 177.330509,16.9239986 177.330509,13.758551 L177.330509,6.00543365 L182.989757,6.00543365 Z" id="Path"></path><path d="M213.090909,12.4834552 L213.090909,22.5148032 L207.431661,22.5148032 L207.431661,13.3305468 C207.431661,11.2172762 206.613671,10.0625566 204.737628,10.0625566 C202.514828,10.0625566 201.479004,11.5159875 201.479004,14.7483107 L201.479004,22.5014281 L195.917559,22.5014281 L195.917559,13.3305468 C195.917559,11.2172762 195.095123,10.0625566 193.223526,10.0625566 C191.000726,10.0625566 189.964902,11.5159875 189.964902,14.7483107 L189.964902,22.5014281 L184.305654,22.5014281 L184.305654,6.00543365 L189.964902,6.00543365 L189.964902,8.8097527 C190.982944,6.76335772 192.725619,5.47934518 195.557466,5.47934518 C198.389312,5.47934518 200.163106,6.81685824 200.985542,9.13967259 C202.003585,6.91048415 203.812943,5.47934518 206.809277,5.47934518 C211.117063,5.47934518 213.090909,8.14991292 213.090909,12.4834552 Z" id="Path"></path><polygon id="Path" points="11.9408796 7.10219436 11.9408796 3.0450714 0 3.0450714 0 7.10219436 3.14303867 7.10219436 3.14303867 18.4086381 0 18.4086381 0 22.4702194 11.9408796 22.4702194 11.9408796 18.4086381 8.80228652 18.4086381 8.80228652 7.10219436"></polygon><polygon id="Path" points="18.8537864 18.4086381 18.8537864 14.467433 26.0378748 14.467433 26.0378748 10.6956461 18.8537864 10.6956461 18.8537864 7.10219436 26.9136579 7.10219436 26.9136579 3.0450714 18.8537864 3.0450714 13.1945386 3.0450714 13.1945386 22.4613027 13.1945386 22.4702194 27.0025699 22.4702194 27.0025699 18.4086381"></polygon><polygon id="Path" points="33.6487408 18.4086381 33.6487408 14.467433 40.8372748 14.467433 40.8372748 10.6956461 33.6487408 10.6956461 33.6487408 7.10219436 41.7086122 7.10219436 41.7086122 3.0450714 33.6487408 3.0450714 27.9939385 3.0450714 27.9939385 22.4613027 27.9939385 22.4702194 41.7975242 22.4702194 41.7975242 18.4086381"></polygon><polygon id="Path" points="48.4481407 18.4086381 48.4481407 14.467433 55.6322291 14.467433 55.6322291 10.6956461 48.4481407 10.6956461 48.4481407 7.10219436 56.5080121 7.10219436 56.5080121 3.0450714 48.4481407 3.0450714 42.7888928 3.0450714 42.7888928 22.4613027 42.7888928 22.4702194 56.5924785 22.4702194 56.5924785 18.4086381"></polygon></g></g></g></g></svg></a><!-- End User Code --><div class="text-element" id="s__Huge_Menu_Links_0_0_32_0_0_1_0_0_1">FOR THE TECHNOLOGY INSIDER</div><!-- User Code --><div data-share-status-id="huge-menu-toggle" data-toggle-class="huge-menu-opened" class="rebelbar__menu-toggle js-toggle hm__close js--active" data-target="body" data-loaded="true"></div><!-- End User Code --></div></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_1" class="top-menu top-menu--big-links col sm-mb-2 md-mb-4 s12 m12 l6"><!-- User Code --><h3 class="module-headline__text">Topics</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_1_1"><a href="/topic/aerospace/" class="list__item" target="_self">Aerospace</a><a href="/topic/artificial-intelligence/" class="list__item" target="_self">Artificial Intelligence</a><a href="/topic/biomedical/" class="list__item" target="_self">Biomedical</a><a href="/topic/computing/" class="list__item" target="_self">Computing</a><a href="/topic/consumer-electronics/" class="list__item" target="_self">Consumer Electronics</a><a href="/topic/energy/" class="list__item" target="_self">Energy</a><a href="/topic/tech-history/" class="list__item" target="_self">History of Technology</a><a href="/topic/robotics/" class="list__item" target="_self">Robotics</a><a href="/topic/semiconductors/" class="list__item" target="_self">Semiconductors</a><a href="/topic/sensors/" class="list__item" target="_self">Sensors</a><a href="/topic/telecommunications/" class="list__item" target="_self">Telecommunications</a><a href="/topic/transportation/" class="list__item" target="_self">Transportation</a></div></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_2" class="top-menu top-menu--sm-links col sm-mb-2 md-mb-4 s6 m12 l3"><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_0"><!-- User Code --><h3 class="module-headline__text">Sections</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_0_1"><a href="/type/feature/" class="list__item" target="_self">Features</a><a href="/type/news/" class="list__item" target="_self">News</a><a href="/type/opinion/" class="list__item" target="_self">Opinion</a><a href="/topic/careers/" class="list__item" target="_self">Careers</a><a href="/topic/diy/" class="list__item" target="_self">DIY</a><a href="/type/the-big-picture/" class="list__item" target="_self">The Big Picture</a><a href="/engineering-resources/" class="list__item" target="_self">Engineering Resources</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_1"><!-- User Code --><h3 class="module-headline__text">More</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_1_1"><a href="/special-reports/" class="list__item" target="_self">Special Reports</a><a href="/collections/" class="list__item" target="_self">Collections</a><a href="/type/explainer/" class="list__item" target="_self">Explainers</a><a href="/type/podcast/" class="list__item" target="_self">Podcasts</a><a href="/type/video/" class="list__item" target="_self">Videos</a><a href="/newsletters/" class="list__item" target="_self">Newsletters</a><a href="/top-programming-languages" class="list__item" target="_self">Top Programming Languages</a><a href="https://robots.ieee.org/" class="list__item" target="_blank">Robots Guide</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_2"><!-- User Code --><h3 class="module-headline__text">For IEEE Members</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_2_2_1"><a href="/magazine/current-issue" class="list__item" target="_self">Current Issue</a><a href="/magazine/" class="list__item" target="_self">Magazine Archive</a><a href="/the-institute/" class="list__item" target="_self">The Institute</a><a href="/the-institute/ti-archive/" class="list__item" target="_self">TI Archive</a></div></div></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_3" class="top-menu top-menu--sm-links col sm-mb-2 md-mb-4 s6 m12 l3"><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_0"><!-- User Code --><h3 class="module-headline__text">For IEEE Members</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_0_1"><a href="/magazine/current-issue" class="list__item" target="_self">Current Issue</a><a href="/magazine/" class="list__item" target="_self">Magazine Archive</a><a href="/the-institute/" class="list__item" target="_self">The Institute</a><a href="/the-institute/ti-archive/" class="list__item" target="_self">TI Archive</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_1"><!-- User Code --><h3 class="module-headline__text">IEEE Spectrum</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_1_1"><a href="/st/about" class="list__item" target="_self">About Us</a><a href="/st/contact" class="list__item" target="_self">Contact Us</a><a href="https://www.parsintl.com/publications/ieee-media/" class="list__item" target="_blank">Reprints &amp; Permissions</a><a href="https://advertise.ieee.org/ " class="list__item" target="_blank">Advertising</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_2"><!-- User Code --><h3 class="module-headline__text">Follow IEEE Spectrum</h3><!-- End User Code --><div class="sm-mb-2" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_2_1"><div class="social-links"><a class="social-links__link share-twitter" href="https://twitter.com/ieeespectrum" target="_blank" rel="noopener noreferrer" aria-label="Open twitter"><span aria-hidden="true" class="fa fa-twitter"></span></a><a class="social-links__link share-facebook" href="https://www.facebook.com/IEEE.Spectrum" target="_blank" rel="noopener noreferrer" aria-label="Open facebook"><span aria-hidden="true" class="fa fa-facebook"></span></a><a class="social-links__link share-instagram" href="https://www.instagram.com/ieeespectrum/" target="_blank" rel="noopener noreferrer" aria-label="Open instagram"><span aria-hidden="true" class="fa fa-instagram"></span></a><a class="social-links__link share-linkedin" href="https://www.linkedin.com/company/ieee-spectrum/" target="_blank" rel="noopener noreferrer" aria-label="Open linkedin"><span aria-hidden="true" class="fa fa-linkedin"></span></a><a class="social-links__link share-tumblr" href="/feeds/feed.rss" target="_blank" rel="noopener noreferrer" aria-label="Open tumblr"><span aria-hidden="true" class="fa fa-tumblr"></span></a></div></div></div><div class="" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_3"><!-- User Code --><h3 class="module-headline__text">Support IEEE Spectrum</h3><!-- End User Code --><div class="text-element" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_3_1"><i>IEEE Spectrum</i> is the flagship publication of the IEEE — the world’s largest professional organization devoted to engineering and applied sciences. Our articles, podcasts, and infographics inform our readers about developments in technology, engineering, and science.</div><div class="text-element" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_3_2"><a href="/st/join" class="color-inherit" rel="orange_button" target="_self">Join IEEE</a></div><div class="text-element" id="s__Huge_Menu_Links_0_0_32_0_0_1_3_3_3"><a href="https://ieee.omeda.com/ieee/r-main.do" class="color-inherit" rel="orange_button" target="_blank">Subscribe</a></div></div></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_4" class=" col sm-mb-2 md-mb-4 s12 m12 l12"></div><div id="s__Huge_Menu_Links_0_0_32_0_0_1_5" class=" col sm-mb-2 md-mb-4 s12 m12 l12"><span class="js-brick-description hidden" data-name="Footer"></span><div class="footer" id="sFooter_0_0_9_0_0_0"><div class="" id="sFooter_0_0_9_0_0_0_0"><div id="sFooter_0_0_9_0_0_0_0_0" class=" row-wrapper clearfix  content sm-cp-2 md-cp-4"><div class="row "><div id="sFooter_0_0_9_0_0_0_0_0_0" class=" col sm-mb-2 md-mb-4 s12 m10 l10"><div class="bottom_menu_links" id="sFooter_0_0_9_0_0_0_0_0_0_0"><div class="list" id="sFooter_0_0_9_0_0_0_0_0_0_0_0"><a href="https://www.ieee.org/about/" class="list__item" target="_blank">About IEEE</a><a href="https://www.ieee.org/about/contact.html" class="list__item" target="_blank">Contact &amp; Support</a><a href="https://www.ieee.org/accessibility-statement.html" class="list__item" target="_blank">Accessibility</a><a href="https://www.ieee.org/about/corporate/governance/p9-26.html" class="list__item" target="_blank">Nondiscrimination Policy</a><a href="https://www.ieee.org/about/help/site-terms-conditions.html" class="list__item" target="_blank">Terms</a><a href="https://www.ieee.org/security-privacy.html" class="list__item" target="_blank">IEEE Privacy Policy</a></div></div><div class="ftr-copy" id="sFooter_0_0_9_0_0_0_0_0_0_1">© Copyright 2022 IEEE — All rights reserved. A not-for-profit organization, IEEE is the world&#39;s largest technical professional organization dedicated to advancing technology for the benefit of humanity.</div></div><div id="sFooter_0_0_9_0_0_0_0_0_1" class=" col sm-mb-2 md-mb-4 s12 m2 l2"><!-- User Code --><svg viewbox="0 0 70 21" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="0 0 21.3639449 0 21.3639449 21 0 21"></polygon></defs><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-IEEE-Bar-/-Signed-out-/-1376" transform="translate(-1274.000000, -14.000000)"><g id="Group-13" transform="translate(1274.000000, 14.000000)"><polygon id="Fill-1" fill="#FEFEFE" points="23.4111174 18.6889405 27.8363724 18.6889405 27.8363724 2.77905063 23.4111174 2.77905063"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="29.7536549 18.6881005 29.7536549 2.77821061 41.9217005 2.77821061 41.9217005 5.8624668 34.17891 5.8624668 34.17891 9.14692664 41.3017712 9.14692664 41.3017712 12.2311828 34.17891 12.2311828 34.17891 15.6024442 41.9217005 15.6024442 41.9217005 18.6881005"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="43.7923126 18.6881005 43.7923126 2.77821061 55.9603583 2.77821061 55.9603583 5.8624668 48.2175677 5.8624668 48.2175677 9.14692664 55.3418347 9.14692664 55.3418347 12.2311828 48.2175677 12.2311828 48.2175677 15.6024442 55.9603583 15.6024442 55.9603583 18.6881005"></polygon><polygon id="Fill-4" fill="#FEFEFE" points="57.8305486 2.77793061 57.8305486 18.6878205 70 18.6878205 70 15.6021642 62.2558037 15.6021642 62.2558037 12.2323028 69.3800707 12.2323028 69.3800707 9.14664663 62.2558037 9.14664663 62.2558037 5.8621868 70 5.8621868 70 2.77793061"></polygon><g id="Group-12"><g id="Group-7"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-6"></g><path d="M20.9520644,9.85449953 L20.8930235,9.84469935 C19.0838421,8.61967703 17.3983653,7.23365178 15.8098843,5.66142314 L14.0555265,3.83578988 C13.3442244,3.05037557 12.6540084,2.18095973 11.9961242,1.35074461 L11.1976665,0.22232405 C11.099265,0.164923005 10.976966,0.0669212192 10.8687244,0.0375206836 C10.6339666,-0.0646811784 10.3795285,0.0571210406 10.1883485,0.202723693 L8.74184673,2.07875787 C6.42378906,4.93900998 3.67838782,7.60885862 0.684171419,9.65429588 C0.448007872,9.84049927 0.0951682866,10.0211026 0.0220700458,10.3235081 C-0.0566511366,10.596513 0.0853281388,10.8219172 0.256827858,10.9913202 C2.65360672,12.6363502 4.94776689,14.5907858 6.98748895,16.8168264 C7.35016869,17.1962333 7.64396739,17.5728401 7.99680697,17.9284466 C8.59424452,18.719461 9.29570648,19.5160755 9.84534902,20.364491 C10.0168487,20.5450943 10.0463692,20.8390996 10.3148646,20.9259012 C10.525725,20.9987026 10.785786,21.0477034 10.9868062,20.9259012 L11.1878263,20.7256976 C13.6675436,17.2256338 16.8149851,14.0825766 20.3293236,11.5429303 C20.6821632,11.2321246 21.3541047,11.1145225 21.3639449,10.5335119 C21.3386417,10.264707 21.182605,10.0015022 20.9520644,9.85449953 M18.5496626,10.7911166 C18.1476223,11.7879348 17.3337015,12.5831492 16.6238051,13.4525651 C15.0845249,15.1017951 13.4623062,16.6992242 11.6432846,17.9718474 C11.2763877,18.2322522 10.7815688,18.4702565 10.3401679,18.2658528 C9.00190778,17.56724 7.87450799,16.4248192 6.7035304,15.3860003 C5.34559001,14.1301774 3.98202667,12.6713508 2.95302836,11.142523 C2.80120893,10.9283191 2.75763114,10.6651143 2.76184834,10.3823091 C2.89398747,9.85449953 3.2566672,9.42049162 3.60107238,8.97668354 C4.81562776,7.43385543 6.30570729,5.96942875 7.80984416,4.63240439 C7.84498755,4.59740376 7.90824564,4.5232024 7.96306932,4.48960179 C8.60970761,3.93379167 9.25212869,3.44098269 9.92828741,2.95657386 C10.6339666,2.41056392 11.5209856,2.86417218 12.114206,3.36678134 C12.7369467,3.83998996 13.383585,4.37759975 13.9529079,4.9236097 L14.0555265,4.98241077 C15.6285445,6.43703727 17.0891035,8.05406673 18.2910073,9.76209785 C18.4864045,10.0603033 18.6579042,10.3963094 18.5496626,10.7911166" id="Fill-5" fill="#FEFEFE" mask="url(#mask-2)"></path></g><path d="M17.8685838,9.92786087 C16.3152462,7.68782006 14.2755241,5.70538394 12.1135031,3.97215236 C11.5554261,3.58154525 10.9087879,2.8983328 10.1876456,3.3869417 C7.9483091,4.92836978 5.79050526,7.01860786 4.05582778,9.15084671 C3.70298819,9.66885615 3.08587035,10.1616651 3.3656117,10.8504777 C3.56663186,11.3586869 4.01646719,11.7240936 4.30604868,12.1735018 C6.00698851,14.2091389 8.01719014,16.1089735 10.1145474,17.6364013 C11.0367098,18.221612 11.6931882,17.2751947 12.4087075,16.8397868 C13.8734838,15.6875658 15.2314242,14.2875403 16.5162664,12.9253155 L16.5162664,12.8917149 C17.0307655,12.2715036 17.5747851,11.6610924 17.9768254,10.9918802 C18.1525424,10.6642743 18.0653868,10.2162661 17.8685838,9.92786087 L17.8685838,9.92786087 Z M10.4477066,5.41697869 L10.6431039,4.79256731 L10.6684071,4.79256731 C11.0704474,5.9391882 11.4865451,7.08300904 11.9181059,8.21422965 L11.0549843,8.22962993 L11.0367098,8.33183179 L11.163226,11.4020877 L11.163226,11.4510886 C10.844124,11.5042896 10.4533296,11.4902893 10.1384449,11.4608888 L10.1145474,11.4258882 L10.2565266,8.26323054 L10.2565266,8.23943011 C10.0161459,8.21422965 9.71250703,8.23943011 9.46790907,8.21422965 L10.4477066,5.41697869 Z M9.93742469,15.6203646 C10.0217688,14.491944 10.0358262,13.4531251 10.0948671,12.3289046 C10.4912844,12.3695053 10.8356896,12.3541051 11.1969636,12.3401048 L11.2222668,12.4913076 L11.3642461,15.6301648 C10.8891076,15.698766 10.3844486,15.6595653 9.93742469,15.6203646 L9.93742469,15.6203646 Z M13.5501647,11.7058933 C11.492168,12.3443049 8.90420917,12.3149044 6.95304844,11.4608888 C6.60020885,11.2900857 6.15459073,11.0268809 6.03650896,10.6166734 C5.94794763,9.86485972 6.75624548,9.44905214 7.30588802,9.17604717 C7.62920717,9.03464459 7.95814925,8.87924176 8.31520604,8.8596414 C8.64836533,9.10324584 8.99698771,9.29924941 9.33998715,9.51765339 C8.67366857,9.69405661 7.87380512,9.84525936 7.56594907,10.5718726 C7.61936702,11.1248827 8.24632501,11.2998859 8.68350872,11.4370884 C10.2565266,11.8514959 11.9574665,11.7968949 13.4672263,11.250885 C13.7511848,11.0842819 14.2024259,10.8840783 14.1630653,10.4752708 C14.1138646,10.0356628 13.6092056,9.84105928 13.256366,9.70245676 C13.0412885,9.73185729 12.8346454,9.78085819 12.6336252,9.84525936 C12.5253836,9.54285385 12.432605,9.23484824 12.3046831,8.94224291 C12.9724074,9.1172461 13.638726,9.29924941 14.3289421,9.41965161 L14.3289421,9.43505189 C14.1869628,9.44905214 14.0309262,9.49805304 13.8931641,9.551254 L13.8931641,9.57645446 C14.2853643,9.77105801 14.8293839,10.0944639 14.8336011,10.6068732 C14.7422283,11.2270845 14.0604466,11.5098897 13.5501647,11.7058933 L13.5501647,11.7058933 Z" id="Fill-8" fill="#FEFEFE"></path><path d="M14.1946944,19.3564726 L14.1946944,19.1646691 L14.3141819,19.1646691 C14.3788457,19.1646691 14.467407,19.1716693 14.467407,19.2528707 C14.467407,19.3410724 14.4224235,19.3564726 14.3465138,19.3564726 L14.1946944,19.3564726 Z M14.1946944,19.4922751 L14.2748213,19.4922751 L14.4603783,19.8268812 L14.6613985,19.8268812 L14.4575669,19.4782749 C14.562997,19.4698747 14.6501526,19.4166737 14.6501526,19.2710711 C14.6501526,19.0890678 14.5278536,19.0302667 14.3226163,19.0302667 L14.0231946,19.0302667 L14.0231946,19.8268812 L14.1946944,19.8268812 L14.1946944,19.4922751 Z M15.0620331,19.429274 C15.0620331,18.9630655 14.7105992,18.6900605 14.3183991,18.6900605 C13.9233874,18.6900605 13.5719536,18.9630655 13.5719536,19.429274 C13.5719536,19.8954825 13.9233874,20.1670874 14.3183991,20.1670874 C14.7105992,20.1670874 15.0620331,19.8954825 15.0620331,19.429274 L15.0620331,19.429274 Z M14.8483613,19.429274 C14.8483613,19.7694802 14.6051691,19.9976843 14.3183991,19.9976843 L14.3183991,19.9962843 C14.0231946,19.9976843 13.7856254,19.7694802 13.7856254,19.429274 C13.7856254,19.0890678 14.0231946,18.8622636 14.3183991,18.8622636 C14.6051691,18.8622636 14.8483613,19.0890678 14.8483613,19.429274 L14.8483613,19.429274 Z" id="Fill-10" fill="#FEFEFE"></path></g></g></g></g></svg><!-- End User Code --></div></div></div></div></div></div></div></div></div><div id="sTop_Bar_0_0_27_0_0_15" data-toggle-property="gdpr" class="gdpr-cookie hidden hidden"><span class="js-scroll-trigger" data-target="#rm-gdpr-sTop_Bar_0_0_27_0_0_15" data-toggle-class="sticky-active"></span><div id="rm-gdpr-sTop_Bar_0_0_27_0_0_15" class="sticky-target legacy rm-gdpr"><div class="gdpr-cookie-wrapper"><div class="gdpr-cookie-content"><p>IEEE websites place cookies on your device to give you the best user experience. By using our websites, you agree to the placement of these cookies. To learn more, read our Privacy Policy.</p></div><div class="gdpr-cookie-controls"><a href="https://www.ieee.org/security-privacy.html" target="_blank" class="gdpr-cookie-info">
                        view privacy policy
                    </a><a href="#toggle-gdpr" class="gdpr-cookie-accept">
                    accept &amp; close
                </a></div></div></div></div><span class="js-brick-description hidden" data-name="__Gated_Popup"></span><div class="gated-popup" id="s__Gated_Popup_0_0_31_0_0_0"><div class="gated-popup__contents" id="s__Gated_Popup_0_0_31_0_0_0_0"><!-- User Code --><a href="javascript:;" class="js--close-gated gated-popup__close icon-close"></a><!-- End User Code --><!-- User Code --><h2 class="popup-gated-h2 popup-heading-h2 for_pdf" style="display:none">Enjoy more free content and benefits by creating an account</h2><h2 class="popup-gated-h2 popup-heading-h2 for_save" style="display:none">Saving articles to read later requires an IEEE Spectrum account</h2><h2 class="popup-gated-h2 popup-heading-h2 for_member_content" style="display:none">The Institute content is only available for members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_pdf_issues" style="display:none">Downloading full PDF issues is exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_nxtbook" style="display:none">Access to <i>Spectrum</i>&#39;s Digital Edition is exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_follow_topics" style="display:none">Following topics is a feature exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_comments" style="display:none">Adding your response to an article requires an IEEE Spectrum account</h2><h2 class="popup-gated-h2 for_pdf for_save for_comments" style="display:none">Create an account to access more content and features on <i>IEEE Spectrum</i>, including the ability to save articles to read later, download Spectrum Collections, and participate in conversations with readers and editors. For more exclusive content and features, consider <a class="ieee_link" href="">Joining IEEE</a>.</h2><h2 class="popup-gated-h2 for_pdf_issues for_nxtbook for_follow_topics for_member_content" style="display:none">Join the world’s largest professional organization devoted to engineering and applied sciences and get access to all of Spectrum’s articles, archives, PDF downloads, and other benefits. <a href="/st/join">Learn more →</a></h2><!-- End User Code --><div class="popup_links for_pdf for_save for_comments create_account" id="s__Gated_Popup_0_0_31_0_0_0_0_2"><div class="list" id="s__Gated_Popup_0_0_31_0_0_0_0_2_0"><a href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fsaml%2Fmain%2Flogin%3Fnext_url%3Dhttps%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fintegrations%2Fieee%2Fchanges%0A&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">CREATE AN ACCOUNT</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div><div class="popup_links for_pdf_issues for_nxtbook for_follow_topics for_member_content" id="s__Gated_Popup_0_0_31_0_0_0_0_3"><div class="list" id="s__Gated_Popup_0_0_31_0_0_0_0_3_0"><a href="/st/join" class="list__item" target="_self">JOIN IEEE</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div></div></div><!-- User Code --><script>
  var popupGatedElement=document.querySelector('.gated-popup'),
  closeGated,
  gatedCloseBtn = '.js--close-gated',
  gatedShownClass = 'gated-popup--shown';

  closeGated = function () {
      popupGatedElement.classList.remove(gatedShownClass);
      popupGatedElement.classList.remove('for_save');
      popupGatedElement.classList.remove('for_pdf');
      popupGatedElement.classList.remove('for_pdf_issues');
      popupGatedElement.classList.remove('for_nxtbook');
      popupGatedElement.classList.remove('for_follow_topics');
      popupGatedElement.classList.remove('for_comments');
      popupGatedElement.classList.remove('for_member_content');
  };

  function openGatedPopup(type){
    
    document.querySelectorAll(".popup_links.create_account .list__item")[0].href = 
"https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=" + encodeURIComponent(window.location.origin + "/core/saml/main/login?next_url=" + window.location.origin + "/core/integrations/ieee/changes?redirect=" + window.location.href) + "&url=" + encodeURIComponent(window.location.origin + "/core/saml/main/login?next_url=" + window.location.origin + "/core/integrations/ieee/changes?redirect=" + window.location.href) + "&autoSignin=Y&car=IEEE-Spectrum";
    
    // update popups for_member_content
    document.querySelectorAll(".popup_links.for_member_content .list__item")[1].href =  "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
    
    // update popups for_pdf for_save for_comments
	document.querySelectorAll(".popup_links.for_save .list__item")[1].href =  "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
    
    popupGatedElement.classList.add(type);
  	popupGatedElement.classList.add(gatedShownClass);
  }

  document.querySelector(gatedCloseBtn).onclick= closeGated;
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="__Session_Popup"></span><div class="lightbox-popup" id="s__Session_Popup_0_0_35_0_2_0"><div class="lightbox-popup__contents" id="s__Session_Popup_0_0_35_0_2_0_0"><!-- User Code --><a href="javascript:;" class="js--close-lightbox lightbox-popup__close icon-close hide-text">Close</a><!-- End User Code --><!-- User Code --><h2 class="popup-ligtbox-h2 popup-heading-h2">Access Thousands of Articles — Completely Free</h2><h2 class="popup-ligtbox-h2">Create an account and get exclusive content and features: <strong>Save articles, download collections,</strong> and <strong>talk to tech insiders</strong> — all free! For full access and benefits, <a class="ieee_link" href="">join IEEE</a> as a paying member.</h2><!-- End User Code --><div class="popup_links signin_button" id="s__Session_Popup_0_0_35_0_2_0_0_2"><div class="list" id="s__Session_Popup_0_0_35_0_2_0_0_2_0"><a href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum50&signinurl=https%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fsaml%2Fmain%2Flogin%3Fnext_url%3Dhttps%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fintegrations%2Fieee%2Fchanges%0A&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">CREATE AN ACCOUNT</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div></div></div><!-- User Code --><script>
function addPopSave(){
    var save_post_links = document.querySelectorAll(".like-btn:not(.proc)");
	for (i = 0; i < save_post_links.length; i++) {
      save_post_links[i].removeAttribute("href");
      save_post_links[i].addEventListener("click", function(event){
      	openGatedPopup('for_save');
	  });
      save_post_links[i].classList.add('proc');
    } 
}
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="SS Default Post"></span><div class="" id="sSS_Default_Post_0_0_20_0_0_1"><div class="top-leader-container" id="sSS_Default_Post_0_0_20_0_0_1_1"><!-- User Code --><div id="top_leaderboard"></div><!-- End User Code --></div><div id="sSS_Default_Post_0_0_20_0_0_1_2" class="featured_columns row-wrapper clearfix "><div class="row "><div id="sSS_Default_Post_0_0_20_0_0_1_2_0" class="article_column col sm-mb-2 md-mb-4 s12 m12 l9"><div class="mb-2 article_post current_post_media current_post" id="sSS_Default_Post_0_0_20_0_0_1_2_0_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-layout_separator="inactive" data-attr-filters="section" data-attr-layout_all_sections="top" data-attr-layout_slack="inactive" data-attr-layout_flipboard="inactive" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_time_to_read="top" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-layout_pinterest="inactive" data-attr-layout_date="top" data-attr-layout_author="top" data-attr-element_classes="article_post current_post_media current_post" data-attr-posts_id="sSS_Default_Post_0_0_20_0_0_1_2_0_0_1_0" data-attr-layout_headline="top" data-attr-section_url="" data-attr-layout_twitter="inactive" data-attr-layout_tumblr="inactive" data-attr-layout_subheadline="top" data-attr-source="" data-attr-is_current_post="true" data-attr-layout_sms="inactive" data-attr-layout_photo_caption="bottom" data-attr-layout_image_column_width="33" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Email,CopyLink,Whatsapp,Facebook,Twitter,Linkedin,Separator,Tumblr,GooglePlus,Pinterest,Reddit,Flipboard,SMS,Slack" data-attr-format="posts-custom" data-attr-layout_all_image_crop="original" data-attr-data-rm-advanced="true" data-attr-layout_all_subheadline_tag="h2" data-attr-node_id="/root/blocks/block[ss_default_post]/abtests/abtest[1]/element_wrapper/row/column[1]/choose/otherwise/posts-" data-attr-layout_linkedin="inactive" data-attr-layout_googleplus="inactive" data-attr-layout_like_button="top" data-attr-source_url="current_post" data-attr-layout_copylink="active" data-attr-layout_facebook="inactive" data-attr-data-rm-device-crops="true" data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,photo_caption,photo_credit,date_modified,custom_field_TimeofRead,post_shares,body,section,primary_tag,page_views,badges,badges_sponsored,source_link,community_name,snark_line,collection_button,community_comments,main_author,tags,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,custom_field_lightbox_img_shortcode_ids,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_Editor,custom_field_PodcastTime,custom_field_PodcastEpisode,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,site_field_member_badges,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_copy_editor,custom_field_is_updated_post" data-attr-layout_photo_credit="bottom" data-attr-layout_reddit="inactive" data-attr-layout_all_headline_tag="h1" data-attr-limit="1" data-attr-v="2" data-attr-layout_quality="4"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-actuators tag-insects tag-bioinspired-robots tag-robotics post-section--topic/robotics" data-category="Robotics"><article elid="2657727687" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657727687" data-category="Robotics"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/type/news/">News</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/">Topic</a></div><h1 class="widget__headline h1"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/robot-bugs" aria-label="Necrobotics: Dead Spiders Reincarnated as Robot Grippers" data-type="text">
        Necrobotics: Dead Spiders Reincarnated as Robot Grippers
    </a></h1><div class="widget__subheadline"><h2 class="widget__subheadline-text h2" data-type="text"><p>That micro-hydraulic gripper you’ve always wanted, thanks to an ex-spider</p></h2></div><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA3MjAwNS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcxNjgyMTgzOH0.5h5h13MlPw_GqfVeUNmZJ-jRmGXDoMaAXy3U2vtNBxM/image.png?width=210&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/evan-ackerman" data-type="text">Evan Ackerman</a></div><div class="social-date"><span class="social-date__text">3h</span></div><div class="time-to-read">3 min read</div><div class="like-button" data-post-likes="0"></div></div><div class="widget__head"><picture><source srcset="https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&width=3600&height=2833 3x, https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&width=2400&height=1889 2x, https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&width=1200&height=944 1x"/><img fetchpriority="high" role="img" alt="Animated gif of a dead spider attached to a syringe picking up another dead spider" aria-label="Animated gif of a dead spider attached to a syringe picking up another dead spider" src="https://spectrum.ieee.org/media-library/animated-gif-of-a-dead-spider-attached-to-a-syringe-picking-up-another-dead-spider.gif?id=30273265&width=1200&height=944" style="object-fit: cover;" class="rm-lazyloadable-image" width="620" height="488"/></picture></div><div class="widget__body clearfix sm-mt-1"><div class="photo-credit">
        Preston Innovation Laboratory/Rice University
    </div></div></div></div><script type="application/json" id="post-context-2657727687">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"actuators, insects, bioinspired robots, robotics, ~rmsc:rebelmouse-image:30273265, ~rmsc:rebelmouse-image:30265286, ~rmsc:rebelmouse-image:30273287","8":"07/26/2022","10":"robotics","11":2657727687}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075149]} }
</script></article></div></div></div></div><div id="sSS_Default_Post_0_0_20_0_0_1_2_0_1" class=" row-wrapper clearfix "><div class="row "><div id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_0" class="tag_column col sm-mb-2 md-mb-4 s12 m12 l3"><div class="mb-2 article_post article_post-shares-and-tags" id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_0_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-layout_whatsapp="inactive" data-attr-layout_tags="top" data-attr-layout_separator="inactive" data-attr-layout_remove_image="true" data-attr-filters="section" data-attr-layout_slack="inactive" data-attr-layout_post_shares="top" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_all_date_full_format="false" data-attr-layout_pinterest="inactive" data-attr-element_classes="article_post article_post-shares-and-tags" data-attr-posts_id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_0_0_1_0" data-attr-section_url="" data-attr-layout_twitter="active" data-attr-layout_tumblr="inactive" data-attr-source="" data-attr-is_current_post="true" data-attr-layout_sms="inactive" data-attr-layout_image_column_width="33" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Email,CopyLink,Twitter,Facebook,Separator,Linkedin,GooglePlus,Whatsapp,Tumblr,Slack,Pinterest,Reddit,Flipboard,SMS" data-attr-format="posts-custom" data-attr-layout_all_image_crop="3x2" data-attr-data-rm-advanced="true" data-attr-source_url="current_post" data-attr-node_id="/root/blocks/block[ss_default_post]/abtests/abtest[1]/element_wrapper/row/column[1]/row/column[1]/choose/otherwise/posts-" data-attr-layout_linkedin="active" data-attr-layout_googleplus="inactive" data-attr-layout_custom_field_pdf_version="top" data-attr-layout_flipboard="inactive" data-attr-layout_copylink="active" data-attr-layout_facebook="active" data-attr-data-rm-device-crops="true" data-attr-all_element_order="post_shares,custom_field_pdf_version,tags,all_sections,headline,subheadline,custom_field_PodcastEpisode,date,custom_field_PodcastTime,like_button,body,author,custom_field_TimeofRead,page_views,badges,section,primary_tag,community_name,badges_sponsored,source_link,photo_caption,photo_credit,community_comments,snark_line,collection_button,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,main_author,custom_field_FullwidthCardPosition,product_prices,custom_field_Issue,custom_field_FullwidthCardColor,site_field_Twitter,product_vendor,product_buy_link,site_field_LinkedIn,custom_field_Editor,site_field_Instagram,site_field_Facebook,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_lightbox_img_shortcode_ids,custom_field_copy_editor,custom_field_is_updated_post" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_reddit="inactive" data-attr-limit="1" data-attr-v="2" data-attr-headline_text="" data-attr-layout_quality="13"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-actuators tag-insects tag-bioinspired-robots tag-robotics post-section--topic/robotics" data-category="Robotics"><article elid="2657727687" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-SD post-2657727687" data-category="Robotics"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="widget__shares share-panel"><!-- EMAIL --><a href="mailto:?subject=Necrobotics%3A%20Dead%20Spiders%20Reincarnated%20as%20Robot%20Grippers&body=https://spectrum.ieee.org/robot-bugs" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK --><a href="https://spectrum.ieee.org/robot-bugs" data-clipboard-text="https://spectrum.ieee.org/robot-bugs" class="share share-copy-link" title="Copy this link to clipboard"><i class="icons-share" style="width: 60%"><svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i></a><!-- TWITTER --><a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/robot-bugs&text=Necrobotics%3A%20Dead%20Spiders%20Reincarnated%20as%20Robot%20Grippers&" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK --><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Frobot-bugs%3Fxrs%3DRebelMouse_fb%26ts%3D1658872813" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN --><a href="http://www.linkedin.com/shareArticle?mini=false&url=https://spectrum.ieee.org/robot-bugs&" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a></div><div class="tags"><a class="tags__item" href="https://spectrum.ieee.org/tag/actuators">actuators</a><a class="tags__item" href="https://spectrum.ieee.org/tag/insects">insects</a><a class="tags__item" href="https://spectrum.ieee.org/tag/bioinspired-robots">bioinspired robots</a><a class="tags__item" href="https://spectrum.ieee.org/tag/robotics">robotics</a></div></div><div class="widget__head"></div></div></div><script type="application/json" id="post-context-2657727687">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"actuators, insects, bioinspired robots, robotics, ~rmsc:rebelmouse-image:30273265, ~rmsc:rebelmouse-image:30265286, ~rmsc:rebelmouse-image:30273287","8":"07/26/2022","10":"robotics","11":2657727687}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075149]} }
</script></article></div></div></div></div></div><div id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_1" class="current_post_content col sm-mb-2 md-mb-4 s12 m12 l9"><div class="" id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_1_0"><div class="non_member_follow" id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_1_0_0_1_0"><span class="js-brick-description hidden" data-name="Open Current Default Post"></span><div class="mb-2 article_post article_post--body-and-tags" id="sOpen_Current_Default_Post_0_0_14_0_0_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-layout_tags="bottom" data-attr-layout_separator="inactive" data-attr-layout_remove_image="true" data-attr-filters="section" data-attr-layout_all_image_crop="3x2" data-attr-layout_slack="inactive" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_body="top" data-attr-layout_all_date_full_format="false" data-attr-layout_pinterest="inactive" data-attr-element_classes="article_post article_post--body-and-tags" data-attr-posts_id="sOpen_Current_Default_Post_0_0_14_0_0_0_1_0" data-attr-section_url="" data-attr-layout_twitter="inactive" data-attr-layout_tumblr="inactive" data-attr-source="" data-attr-is_current_post="true" data-attr-layout_sms="inactive" data-attr-layout_image_column_width="33" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Email,CopyLink,Whatsapp,Facebook,Twitter,Linkedin,Separator,Tumblr,GooglePlus,Pinterest,Reddit,Flipboard,SMS,Slack" data-attr-format="posts-custom" data-attr-layout_flipboard="inactive" data-attr-data-rm-advanced="true" data-attr-node_id="/root/blocks/block[open_current_default_post]/abtests/abtest[1]/choose[1]/otherwise/current_post-" data-attr-layout_linkedin="inactive" data-attr-layout_googleplus="inactive" data-attr-layout_copylink="active" data-attr-layout_facebook="inactive" data-attr-show_around_the_web="true" data-attr-data-rm-device-crops="true" data-attr-all_element_order="body,tags,custom_field_lightbox_img_shortcode_ids,author,all_sections,headline,subheadline,custom_field_PodcastEpisode,date,custom_field_PodcastTime,like_button,post_shares,custom_field_TimeofRead,page_views,badges,section,primary_tag,community_name,badges_sponsored,source_link,photo_caption,photo_credit,community_comments,snark_line,collection_button,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,main_author,custom_field_FullwidthCardPosition,product_prices,custom_field_Issue,custom_field_FullwidthCardColor,site_field_Twitter,product_vendor,product_buy_link,site_field_LinkedIn,custom_field_Editor,site_field_Instagram,site_field_Facebook,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_copy_editor" data-attr-show_full_post_body="true" data-attr-layout_custom_field_lightbox_img_shortcode_ids="bottom" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_reddit="inactive" data-attr-limit="1" data-attr-v="2" data-attr-layout_quality="1" data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-actuators tag-insects tag-bioinspired-robots tag-robotics post-section--topic/robotics" data-category="Robotics"><article elid="2657727687" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657727687" data-category="Robotics"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><span class="js-scroll-trigger" data-target="body" data-triggers="render-rebelbar" data-toggle-class="with-floating-shares"></span><div id="utm_campaign"></div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2657727687" data-elid="2657727687" data-post-url="https://spectrum.ieee.org/robot-bugs" data-authors="Evan Ackerman" data-headline="Necrobotics: Dead Spiders Reincarnated as Robot Grippers"><div class="body-description"><p>Bugs have long taunted roboticists with how utterly incredible they are. Astonishingly mobile, amazingly efficient, super robust, and in some cases, literally dirt cheap. But making a robot that&#39;s insect equivalent is extremely hard—so hard that it’s frequently easier to just <a href="https://spectrum.ieee.org/cyborg-beetles-for-swarming-search-and-rescue" target="_blank">hijack living insects themselves</a> and put them to work for us. You know what’s even easier than that, though?</p><p>Hijacking and repurposing dead bugs. <a href="https://news.rice.edu/news/2022/rice-engineers-get-grip-necrobotic-spiders" rel="noopener noreferrer" target="_blank">Welcome to necrobotics</a>.</p><hr/><p>Spiders are basically hydraulic (or pneumatic) grippers. Living spiders control their limbs by adjusting blood pressure on a limb-by-limb basis through an internal valve system. Higher pressure extends the limb, acting against an antagonistic flexor muscle that curls the limb when the blood pressure within is reduced. This, incidentally, is why spider legs all curl up when the spider shuffles off the mortal coil: There&#39;s a lack of blood pressure to balance the force of the flexors.</p><p>This means that actuating all eight limbs of a spider that has joined the choir invisible is relatively straightforward. Simply stab it in the middle of that valve system, inject some air, and poof, all of the legs inflate and straighten.</p><p class="shortcode-media shortcode-media-youtube"><span class="rm-shortcode" data-rm-shortcode-id="b84307268f1f6ccc9847ca7d1e038907" style="display:block;position:relative;padding-top:56.25%;"><iframe frameborder="0" height="auto" type="lazy-iframe" scrolling="no" data-runner-src="https://www.youtube.com/embed/1JOS6hMHIUM?rel=0" style="position:absolute;top:0;left:0;width:100%;height:100%;" width="100%"></iframe></span></p><blockquote>Our strategy contrasts with bioinspired approaches in which researchers look to the spider’s physical morphology for design ideas that are subsequently implemented in complex engineered systems, and also differs from biohybrid systems in which live or active biological materials serve as the basis for a system, demanding careful and precise maintenance.<br/><br/>
We repurposed the cadaver of a spider to create a pneumatically actuated gripper that is fully functional following only one simple assembly step, allowing us to circumvent the usual tedious and constraining fabrication steps required for fluidically driven actuators and grippers</blockquote><p><a href="https://news.rice.edu/news/2022/rice-engineers-get-grip-necrobotic-spiders" rel="noopener noreferrer" target="_blank">This work</a>, from researchers at the <a href="https://pi.rice.edu/" rel="noopener noreferrer" target="_blank">Preston Innovation Lab at Rice University</a> is described in a paper just published in <em>Advanced Science. In the paper, the team</em> does a little bit of characterization of the performance of the deceased-spider gripper, and it’s impressive: It can lift 1.3 times its own weight, exert a peak gripping force of 0.35 millinewton, and can actuate at least 700 times before the limbs or the valve system start to degrade in any significant way. After 1000 cycles, some cracks appear in the dead spider’s joins, likely because of dehydration. But the researchers think that by coating the spider in something like beeswax, they could likely forestall this breakdown a great deal. The demised-spider gripper is able to successfully pick up a variety of objects, likely because of a combination of the inherent compliance of the legs as well as hairlike microstructures on the legs that work kind of like a directional adhesive. </p><div class="ad-in-content"></div><p>We are, unfortunately (although somewhat obviously), unable to say that no spiders were harmed over the course of this research. According to the paper, “the raw biotic material (i.e., the spider cadaver) was obtained by euthanizing a wolf spider through exposure to freezing temperature (approximately -4 °C) for a period of 5–7 days.” The researchers note that “there are currently no clear guidelines in the literature regarding ethical sourcing and humane euthanasia of spiders,” which is really something that should be figured out, considering <a href="https://www.youtube.com/watch?v=5qkzwG2lLPc" rel="noopener noreferrer" target="_blank">how much we know about the cute-but-still-terrifying personalities some spiders have</a>.</p><p>The wolf spider was a convenient choice because it exerts a gripping force approximately equal to its own weight, which raises the interesting question of what kind of performance could be expected from spiders of different sizes. Based on a scaling analysis, the researchers suggest that itty bitty 10 milligram jumping spiders could exert a gripping force exceeding 200 percent of their body weight, while very much <em>not</em> itty bitty 200- gram goliath spiders may only be able to grasp with a force that is 10 percent of their body weight. But that works out to 20 g, which is still kind of terrifying. Goliath spiders are <em>big</em>.</p><p>For better or worse, insects seem likely to offer the most necrobotic potential, because fabricating pneumatics and joints and muscles at that scale can be very challenging, if not impossible. And spiders (as well as other spider-like insects) in particular offer biodegradable, eco-friendly on-demand actuation with capabilities that the researchers hope to extend significantly. A capacitive proximity sensor could enable autonomy, for example, to “discreetly capture small biological creatures for sample collection in real-world scenarios.” Independent actuation of limbs could result in necrobotic locomotion. And the researchers are also planning to explore high-speed articulation with whip scorpions as well as true microscale manipulation with patu digua spiders. I’ll let you Google whip scorpion on your own because they kind of freak me out, but here’s a picture of a patu digua, with a body measuring about  a quarter of a millimeter:</p><p class="shortcode-media shortcode-media-rebelmouse-image"><img alt="A very close up picture of a tiny white spider on a green leaf" class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="81653da4b3a962365c1d24e29b3ba321" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/a-very-close-up-picture-of-a-tiny-white-spider-on-a-green-leaf.jpg?id=30265286&width=980" height="628" id="f9a43" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 628&#39;%3E%3C/svg%3E" width="1200"/></p><p>Squee!</p><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div><ul class="around-the-web__list"><li class="from-your-site__item"><a href="https://spectrum.ieee.org/video-friday-nanotubepowered-insect-robots" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Video Friday: Nanotube-Powered Insect Robots - IEEE Spectrum ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/darpa-wants-your-insect-scale-robots-for-a-micro-olympics" class="from-your-site__link" target="_blank" rel="noopener noreferrer">DARPA Wants Your Insect-Scale Robots for a Micro-Olympics - IEEE ... ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/micro-energy-harvesters-will-make-cyborg-insects-unstoppable" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Micro Energy Harvesters Will Make Cyborg Insects Unstoppable ... ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/cyborg-fly-pilots-robot-through-obstacle-course" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Cyborg Fly Pilots Robot Through Obstacle Course - IEEE Spectrum ›</a></li></ul><div class="around-the-web__headline">Related Articles Around the Web</div><ul class="around-the-web__list"><li class="around-the-web__item"><a href="https://news.engineering.pitt.edu/robot-bugs-that-can-go-just-about-anywhere/" class="around-the-web__link" target="_blank" rel="noopener noreferrer">Robot “Bugs” That Can Go Just About Anywhere ›</a></li></ul></div></div></div><span class="js-scrolled-url" data-elid="2657727687" data-post-url="https://spectrum.ieee.org/robot-bugs" data-authors="Evan Ackerman" data-headline="Necrobotics: Dead Spiders Reincarnated as Robot Grippers"></span></div><div class="widget__head"></div><div class="widget__body clearfix sm-mt-1"><div class="tags"><a class="tags__item" href="https://spectrum.ieee.org/tag/actuators">actuators</a><a class="tags__item" href="https://spectrum.ieee.org/tag/insects">insects</a><a class="tags__item" href="https://spectrum.ieee.org/tag/bioinspired-robots">bioinspired robots</a><a class="tags__item" href="https://spectrum.ieee.org/tag/robotics">robotics</a></div></div></div></div><script type="application/json" id="post-context-2657727687">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"actuators, insects, bioinspired robots, robotics, ~rmsc:rebelmouse-image:30273265, ~rmsc:rebelmouse-image:30265286, ~rmsc:rebelmouse-image:30273287","8":"07/26/2022","10":"robotics","11":2657727687}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075149]} }
</script></article></div></div></div></div><div class="" id="sOpen_Current_Default_Post_0_0_14_0_0_1"><div class="mb-2 post-author-list" id="sOpen_Current_Default_Post_0_0_14_0_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-layout_remove_image="true" data-attr-filters="section" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_all_subheadline_tag="h2" data-attr-layout_author="top" data-attr-element_classes="post-author-list" data-attr-posts_id="sOpen_Current_Default_Post_0_0_14_0_0_1_0" data-attr-section_url="" data-attr-source="" data-attr-is_current_post="true" data-attr-show_authors_bio="true" data-attr-format="posts-custom" data-attr-node_id="/root/blocks/block[open_current_default_post]/abtests/abtest[1]/element_wrapper/current_post-" data-attr-all_element_order="author,headline,subheadline,section,community_name,date,date_modified,badges,badges_sponsored,photo_credit,photo_caption,body,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,product_prices,product_vendor,product_buy_link,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_Instagram,site_field_member_badges,site_field_Twitter,site_field_LinkedIn,site_field_grade,site_field_Facebook,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_pdf_version,custom_field_copy_editor,custom_field_FullwidthCardColor,custom_field_disable_comments,custom_field_PodcastVideoTime,custom_field_fullwidthbackgroundposition,custom_field_lightbox_img_shortcode_ids,custom_field_access,custom_field_Editor,custom_field_PodcastEpisode,custom_field_publication_date,custom_field_TimeofRead,custom_field_FeaturePostColor,custom_field_FullwidthCardPosition,custom_field_is_updated_post" data-attr-layout_all_headline_tag="h1" data-attr-v="2" data-attr-layout_quality="1"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-actuators tag-insects tag-bioinspired-robots tag-robotics post-section--topic/robotics" data-category="Robotics"><article elid="2657727687" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657727687" data-category="Robotics"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA3MjAwNS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcxNjgyMTgzOH0.5h5h13MlPw_GqfVeUNmZJ-jRmGXDoMaAXy3U2vtNBxM/image.png?width=210&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/evan-ackerman" data-type="text">Evan Ackerman</a><div class="social-author__bio"><a href="https://twitter.com/BotJunkie" target="_blank">Evan Ackerman</a> is a senior editor at <i>IEEE Spectrum</i>. Since 2007, he has written over 6,000 articles on robotics and technology. He has a degree in Martian geology and is excellent at playing bagpipes.</div></div></div><div class="widget__head"></div></div></div><script type="application/json" id="post-context-2657727687">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"actuators, insects, bioinspired robots, robotics, ~rmsc:rebelmouse-image:30273265, ~rmsc:rebelmouse-image:30265286, ~rmsc:rebelmouse-image:30273287","8":"07/26/2022","10":"robotics","11":2657727687}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075149]} }
</script></article></div></div></div></div></div><div class="" id="sOpen_Current_Default_Post_0_0_14_0_0_2_1_0"><div class="post-partial article__comments"><div class="article-content__comments-wrapper"><div id="comments-widget"><div class="talk-comments-wrp community-native-wrp " data-talk_id="post:2657727687:comments" data-limit="3" data-order="best" data-is_amp="" data-count_top_level="0" data-count_featured="0" data-show_rating="False" data-all_element_order="avatar,title,date,site_field_member_badges,site_field_grade,message,update_avatar,follow,bio,review" data-words-per-message="{&quot;max&quot;: 250, &quot;min&quot;: 1}" data-inactive_layout_attributes="update_avatar,follow,bio,review" data-active_layout_attributes="site_field_member_badges,site_field_grade"><div class="editmode-section-title"></div><a href="#" class="hidden new-comments-notification" aria-label="New coments notification"></a><div class="comment-headline">The Conversation (0)</div><div class="add-comment"><div class="comment_placeholder-wrp"><div class="animated-background"><div class="placeholder__textarea_top"></div><div class="placeholder__textarea_botmiddle_left"></div><div class="placeholder__textarea_botmiddle_right"></div><div class="placeholder__textarea_bottom"></div><div class="placeholder__button_b"></div><div class="placeholder__button_i"></div><div class="placeholder__button_publish"></div></div><div class="comment-login-wrp"></div></div></div><div class="comment-header"></div><div class="talk--messages"><div class="talk--messages__featured"></div><div class="talk--messages__top_level"></div></div><script type="rm-preact-state">{"featuredComments": [], "authors": {}, "forcedComments": [], "topLevelComments": []}
        </script><div class="talk--load_more-wrp "></div></div></div></div></div><!-- User Code --><script>
    var clickeableItems = [
      ".talk-comments-wrp .add-comment",
      ".talk-comments-wrp .comment-item--publish",
      ".talk-comments-wrp .comment--item__reply",
      ".talk-comments-wrp .comment--item__like",
      ".talk-comments-wrp .comment--item__dislike",
      ".talk-comments-wrp .replies"];
    var talkItems = document.querySelectorAll(clickeableItems.join(",")) || [];
    talkItems.forEach(function(item) {
      item.addEventListener("click", function(event){
        event.preventDefault();
        event.stopPropagation();
        openGatedPopup('for_comments');
        }, true);
    });
</script><!-- End User Code --></div><div class="mb-2 read_also_posts" id="sOpen_Current_Default_Post_0_0_14_0_0_3_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_1" data-format="posts-custom" data-source="filtered_parent_site" data-source-type="page" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-source_site="parent_site" data-attr-layout_all_sections="right" data-attr-from_regular_sections_other_than="webinar,whitepaper,sponsored,podcast,video,tests,issue-cover-posts,feature" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_time_to_read="right" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-source_unique="true" data-attr-element_classes="read_also_posts" data-attr-posts_id="sOpen_Current_Default_Post_0_0_14_0_0_3_1_0" data-attr-layout_headline="right" data-attr-from_regular_sections_of_current_post="true" data-attr-source="filtered" data-attr-layout_date="right" data-attr-all_element_order="all_sections,headline,date,time_to_read,like_button,custom_field_TimeofRead,section,primary_tag,author,badges,badges_sponsored,photo_credit,community_name,subheadline,snark_line,page_views,photo_caption,follow_button,community_comments,body,collection_button,tags,source_link,main_author,post_shares,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition,custom_field_copy_editor,custom_field_lightbox_img_shortcode_ids,custom_field_disable_comments,custom_field_is_updated_post" data-attr-layout_image_column_width="28" data-attr-format="posts-custom" data-attr-layout_all_image_crop="original" data-attr-data-rm-advanced="true" data-attr-node_id="/root/blocks/block[open_current_default_post]/abtests/abtest[1]/choose[3]/otherwise/posts-" data-attr-layout_like_button="right" data-attr-layout_desktop_image_crop="original" data-attr-without_current="true" data-attr-data-rm-device-crops="true" data-attr-limit="3" data-attr-v="2" data-attr-layout_quality="1"><div class="posts-wrapper clearfix"><div class="widget tag-flash-memory tag-nand-flash-memory tag-micron-technologies post-section--topic/semiconductors" elid="2657727147" data-category="Semiconductors"><article elid="2657727147" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657727147"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/micron-is-first-to-deliver-3d-flash-chips-with-more-than-200-layers" aria-label="Micron Is First to Deliver 3D Flash Chips With More Than 200 Layers"><img fetchpriority="high" role="img" type="lazy-image" alt="A gold rectangle resembling a tall apartment building." aria-label="A gold rectangle resembling a tall apartment building." src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2005 1504&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-gold-rectangle-resembling-a-tall-apartment-building.jpg?id=30263105&width=1200&height=900" style="object-fit: cover;" class="rm-lazyloadable-image" width="2005" height="1504"/></a></div></div><div id="col-right" class="col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/semiconductors/">Semiconductors</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/computing/">Computing</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/micron-is-first-to-deliver-3d-flash-chips-with-more-than-200-layers" aria-label="Micron Is First to Deliver 3D Flash Chips With More Than 200 Layers" data-type="text">
        Micron Is First to Deliver 3D Flash Chips With More Than 200 Layers
    </a></h2><div class="social-date"><span class="social-date__text">7h</span></div><div class="time-to-read">2 min read</div><div class="like-button" data-post-likes="0"></div></div></div></div><script type="application/json" id="post-context-2657727147">
    {"customDimensions": {"5":"Samuel K. Moore","6":"semiconductors","7":"Flash memory, NAND Flash Memory, Micron Technologies, ~rmsc:rebelmouse-image:30263105","8":"07/26/2022","10":"Flash memory","11":2657727147}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 544169516, 539617903, 539621009, 544169523, 550122300, 550122302], "buckets": [], "authors": [21075160]} }
</script></article></div><div class="widget tag-type-departments tag-retrocomputing post-section--topic/diy" elid="2657708356" data-category="DIY"><article elid="2657708356" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657708356"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/weave-your-own-apollo-era-memory" aria-label="Weave Your Own Apollo-Era Memory"><img fetchpriority="high" role="img" type="lazy-image" alt="Weave Your Own Apollo-Era Memory" aria-label="Weave Your Own Apollo-Era Memory" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2160 1437&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/image.png?id=30222247&width=2160&quality=85&coordinates=0%2C0%2C0%2C0&height=1437" style="object-fit: cover;" class="rm-lazyloadable-image" width="2160" height="1437"/></a></div></div><div id="col-right" class="col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/diy/">DIY</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/hands-on/">Hands On</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/magazine/">Magazine</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/weave-your-own-apollo-era-memory" aria-label="Weave Your Own Apollo-Era Memory" data-type="text">
        Weave Your Own Apollo-Era Memory
    </a></h2><div class="social-date"><span class="social-date__text">10h</span></div><div class="time-to-read">4 min read</div><div class="like-button" data-post-likes="0"></div></div></div></div><script type="application/json" id="post-context-2657708356">
    {"customDimensions": {"5":"Stephen Cass","6":"diy","7":"type:departments, retrocomputing, ~rmsc:rebelmouse-image:30222323, ~rmsc:rebelmouse-image:30222252, ~rmsc:rebelmouse-image:30222281, ~rmsc:rebelmouse-image:30222247","8":"07/26/2022","10":"retrocomputing","11":2657708356}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 544169540, 547191404, 555118571, 544169516, 539626628, 539748506, 564919484], "buckets": [], "authors": [20372187]} }
</script></article></div><div class="widget tag-video-friday tag-robotics post-section--topic/robotics" elid="2657711440" data-category="Robotics"><article elid="2657711440" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657711440"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/video-friday-artemis" aria-label="Video Friday: ARTEMIS"><img fetchpriority="high" role="img" type="lazy-image" alt="A photo of the lower torso and legs of a humanoid robot in a dynamic running position suspended on a test stand in a lab" aria-label="A photo of the lower torso and legs of a humanoid robot in a dynamic running position suspended on a test stand in a lab" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1280 720&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-the-lower-torso-and-legs-of-a-humanoid-robot-in-a-dynamic-running-position-suspended-on-a-test-stand-in-a-lab.png?id=30209481&width=1200&height=675" style="object-fit: cover;" class="rm-lazyloadable-image" width="1280" height="720"/></a></div></div><div id="col-right" class="col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/video-friday-artemis" aria-label="Video Friday: ARTEMIS" data-type="text">
        Video Friday: ARTEMIS
    </a></h2><div class="social-date"><span class="social-date__text">22 Jul 2022</span></div><div class="time-to-read">3 min read</div><div class="like-button" data-post-likes="0"></div></div></div></div><script type="application/json" id="post-context-2657711440">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"video friday, robotics, ~rmsc:rebelmouse-image:30209481","8":"07/22/2022","10":"robotics","11":2657711440}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 572343881, 544169516, 539266128, 544169523, 550122300], "buckets": [], "authors": [21075149]} }
</script></article></div></div></div></div></div></div></div></div></div></div><div id="sSS_Default_Post_0_0_20_0_0_1_2_1" class="widget_column col sm-mb-2 md-mb-4 s12 m12 l3"><span class="js-brick-description hidden" data-name="Popular widget"></span><div class="popular_widget" id="sPopular_widget_0_0_18_0_0_1_3_0_2_0"><div class="" id="sPopular_widget_0_0_18_0_0_1_3_0_2_0_0"><div id="sPopular_widget_0_0_18_0_0_1_3_0_2_0_0_0"><div class="module-headline"><h2 class="module-headline__text h2">
        Related Stories
    </h2></div></div></div><div class="mb-2 " id="sPopular_widget_0_0_18_0_0_1_3_0_2_0_1"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_2" data-format="posts-custom" data-source="filtered_parent_site_newest" data-source-type="page" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-posts_id="sPopular_widget_0_0_18_0_0_1_3_0_2_0_1" data-attr-layout_remove_image="true" data-attr-layout_all_sections="top" data-attr-layout_headline="top" data-attr-format="posts-custom" data-attr-all_element_order="all_sections,headline,subheadline,section,author,community_name,date,date_modified,badges,badges_sponsored,photo_credit,photo_caption,body,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_FullwidthCardColor,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,custom_field_TimeofRead,custom_field_Issue,custom_field_FullwidthCardPosition,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,custom_field_publication_date,custom_field_FeaturePostColor,site_field_member_badges,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version" data-attr-without_current="true" data-attr-source="filtered" data-attr-from_regular_sections_other_than="webinar,whitepaper,sponsored,podcast,video,slideshow,tests,issue-cover-posts,topic/the-institute" data-attr-limit="3" data-attr-source_unique="true" data-attr-v="2" data-attr-source_site="parent_site" data-attr-node_id="/root/blocks/block[popular_widget]/abtests/abtest/choose/when[post_page==true]/choose/otherwise/element_wrapper/posts-" data-attr-order="newest" data-attr-layout_quality="1" data-attr-from_regular_tags_of_current_post="true"><div class="posts-wrapper clearfix"><div class="widget tag-gill-pratt tag-toyota tag-tri tag-elder-care tag-robotics post-section--topic/robotics" elid="2657695108" data-category="Robotics"><article elid="2657695108" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657695108"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/magazine/">Magazine</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/feature/">Feature</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/gill-pratt-toyota-elder-care-robots" aria-label="How Robots Can Help Us Act and Feel Younger" data-type="text">
        How Robots Can Help Us Act and Feel Younger
    </a></h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/gill-pratt-toyota-elder-care-robots" aria-label="How Robots Can Help Us Act and Feel Younger"></a></div></div></div><script type="application/json" id="post-context-2657695108">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"Gill Pratt, Toyota, TRI, elder care, robotics, ~rmsc:rebelmouse-image:30174445, ~rmsc:rebelmouse-image:30174627, ~rmsc:rebelmouse-image:30178723, ~rmsc:rebelmouse-image:30179031, ~rmsc:rebelmouse-image:30179107","8":"07/23/2022","10":"robotics","11":2657695108}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 539626628, 555118571, 544169516, 544169517, 539266128, 564919484], "buckets": [], "authors": [21075149]} }
</script></article></div><div class="widget tag-amrs tag-robust-ai tag-rodney-brooks tag-robotics post-section--topic/robotics" elid="2657691708" data-category="Robotics"><article elid="2657691708" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657691708"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/robust-ai-rodney-brooks" aria-label="Rodney Brooks Explains What Robust.AI Is Actually Doing" data-type="text">
        Rodney Brooks Explains What Robust.AI Is Actually Doing
    </a></h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/robust-ai-rodney-brooks" aria-label="Rodney Brooks Explains What Robust.AI Is Actually Doing"></a></div></div></div><script type="application/json" id="post-context-2657691708">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"amrs, robust.ai, Rodney Brooks, robotics, ~rmsc:rebelmouse-image:30150818, ~rmsc:rebelmouse-image:30196827, ~rmsc:rebelmouse-image:30156721, ~rmsc:rebelmouse-image:30157033","8":"07/21/2022","10":"robotics","11":2657691708}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 572343881, 544169516, 539266128, 544169523, 550122300], "buckets": [], "authors": [21075149]} }
</script></article></div><div class="widget tag-video-friday tag-robotics post-section--topic/robotics" elid="2657676851" data-category="Robotics"><article elid="2657676851" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657676851"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/type/news/">News</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/">Topic</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/video-friday-iss-robot-arms" aria-label="Video Friday: Robot Arms for the ISS" data-type="text">
        Video Friday: Robot Arms for the ISS
    </a></h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/video-friday-iss-robot-arms" aria-label="Video Friday: Robot Arms for the ISS"></a></div></div></div><script type="application/json" id="post-context-2657676851">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"video friday, robotics, ~rmsc:rebelmouse-image:30129560","8":"07/15/2022","10":"robotics","11":2657676851}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075149]} }
</script></article></div></div></div></div></div><div class="sidebar_ad_container" id="sSS_Default_Post_0_0_20_0_0_1_2_1_0_1_1"><!-- User Code --><div class="sidebar_sticky_parent"><div class="stick_in_parent"><div class="sidebar_repeat_ad"></div></div></div><!-- End User Code --></div></div></div></div><div class="" id="sSS_Default_Post_0_0_20_0_0_1_3"><div class="non_member_follow" id="sSS_Default_Post_0_0_20_0_0_1_3_0_0_0"></div></div><div class="mb-2 feature_post_full" id="sSS_Default_Post_0_0_20_0_0_1_5"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_3" data-format="posts-custom" data-source="multi_filtered_parent_site_filtered_parent_site" data-source-type="multi" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-layout_whatsapp="inactive" data-attr-layout_separator="inactive" data-attr-layout_all_sections="top" data-attr-layout_slack="inactive" data-attr-layout_post_shares="top" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_time_to_read="top" data-attr-strategy="mutually-exclusive" data-attr-layout_all_date_full_format="false" data-attr-layout_body="bottom" data-attr-source_unique="true" data-attr-layout_author="top" data-attr-element_classes="feature_post_full" data-attr-posts_id="sSS_Default_Post_0_0_20_0_0_1_5" data-attr-layout_headline="top" data-attr-layout_custom_field_featurepostcolor="bottom" data-attr-layout_tumblr="inactive" data-attr-layout_subheadline="top" data-attr-source="multi" data-attr-layout_date="top" data-attr-layout_sms="inactive" data-attr-layout_photo_caption="bottom" data-attr-layout_image_column_width="20" data-attr-update_url_on_post_view="true" data-attr-layout_custom_field_featurepostimgposition="top" data-attr-all_share_buttons="Email,CopyLink,Twitter,Facebook,Linkedin,Tumblr,GooglePlus,Pinterest,Whatsapp,Reddit,Separator,Flipboard,SMS,Slack" data-attr-format="posts-custom" data-attr-layout_all_image_crop="3x2" data-attr-data-rm-advanced="true" data-attr-show_more_button_text="Keep Reading ↓" data-attr-layout_photo_credit="bottom" data-attr-node_id="/root/blocks/block[ss_default_post]/abtests/abtest[1]/element_wrapper/posts-" data-attr-layout_linkedin="active" data-attr-layout_googleplus="inactive" data-attr-layout_custom_field_pdf_version="top" data-attr-layout_like_button="top" data-attr-without_current="true" data-attr-use_smart_keep_reading="true" data-attr-layout_copylink="active" data-attr-layout_pinterest="inactive" data-attr-show_around_the_web="true" data-attr-data-rm-device-crops="true" data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,custom_field_pdf_version,post_shares,custom_field_FeaturePostImgPosition,photo_caption,photo_credit,custom_field_FeaturePostColor,body,custom_field_lightbox_img_shortcode_ids,primary_tag,community_name,badges,section,custom_field_TimeofRead,snark_line,follow_button,community_comments,page_views,collection_button,badges_sponsored,source_link,main_author,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,tags,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,product_vendor,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,custom_field_due_date,site_field_first_name,site_field_last_name,site_field_grade,custom_field_fullwidthbackgroundposition,custom_field_disable_comments" data-attr-layout_flipboard="inactive" data-attr-layout_custom_field_lightbox_img_shortcode_ids="bottom" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_reddit="inactive" data-attr-limit="1" data-attr-v="2" data-attr-layout_quality="1" data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix"><div class="widget tag-darpa tag-subt tag-robotics tag-type-cover post-section--topic/robotics" elid="2657170650" data-category="Robotics"><article elid="2657170650" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657170650"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/magazine/">Magazine</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/feature/">Feature</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650" aria-label="Inside DARPA’s Subterranean Challenge" data-type="text">
        Inside DARPA’s Subterranean Challenge
    </a></h2><div class="widget__subheadline"><h3 class="widget__subheadline-text h3" data-type="text"><p>What SubT means for the future of autonomous robots</p></h3></div><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA3MjAwNS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcxNjgyMTgzOH0.5h5h13MlPw_GqfVeUNmZJ-jRmGXDoMaAXy3U2vtNBxM/image.png?width=210&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/evan-ackerman" data-type="text">Evan Ackerman</a></div><div class="social-date"><span class="social-date__text">24 Apr 2022</span></div><div class="time-to-read">14 min read</div><div class="like-button" data-post-likes="7"></div><div class="widget__shares share-panel"><!-- EMAIL --><a href="mailto:?subject=Inside%20DARPA%E2%80%99s%20Subterranean%20Challenge&body=https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK --><a href="https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650" data-clipboard-text="https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650" class="share share-copy-link" title="Copy this link to clipboard"><i class="icons-share" style="width: 60%"><svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i></a><!-- TWITTER --><a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650&text=Inside%20DARPA%E2%80%99s%20Subterranean%20Challenge&" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK --><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Fdarpa-subterranean-challenge-2657170650%3Fxrs%3DRebelMouse_fb%26ts%3D1657597452" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN --><a href="http://www.linkedin.com/shareArticle?mini=false&url=https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650&" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650" aria-label="Inside DARPA’s Subterranean Challenge"><img fetchpriority="high" role="img" type="lazy-image" alt="A photo of a robot lighting up a stone tunnel." aria-label="A photo of a robot lighting up a stone tunnel." src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-a-robot-lighting-up-a-stone-tunnel.png?id=29692504&width=1200&quality=85&coordinates=1%2C0%2C2%2C0&height=800" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div><div class="widget__body clearfix sm-mt-1"><div class="photo-caption"><p>An ANYmal robot from Team Cerberus autonomously explores a cave on DARPA’s Subterranean Challenge course.</p></div><div class="photo-credit">
        Evan Ackerman
    </div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2657170650" data-elid="2657170650" data-post-url="https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650" data-authors="Evan Ackerman" data-headline="Inside DARPA’s Subterranean Challenge"><div class="body-description"><div class="widget__brief"><p><strong>Deep below the</strong> Louisville, Ky., zoo lies a network of enormous caverns carved out of limestone. The caverns are dark. They’re dusty. They’re humid. And during one week in September 2021, they were full of the most sophisticated robots in the world. The robots (along with their human teammates) were there to tackle a massive underground course designed by DARPA, the Defense Advanced Research Projects Agency, as the culmination of its three-year Subterranean Challenge.
</p><p>
	The SubT was first announced in early 2018. DARPA designed the competition to advance practical robotics in extreme conditions, based around three distinct underground environments: human-made tunnels, the urban underground, and natural caves. To do well, the robots would have to work in teams to traverse and map completely unknown areas spanning kilometers, search out a variety of artifacts, and identify their locations with pinpoint accuracy under strict time constraints. To more closely mimic the scenarios in which first responders might utilize autonomous robots, robots experienced darkness, dust and smoke, and even DARPA-controlled rockfalls that occasionally blocked their progress.
</p></div><div class="content-container"></div><div class="js-appear-on-expand"><template><p>
	With direct funding plus prize money that reached into the millions, DARPA encouraged international collaborations among top academic institutions as well as industry. A series of three preliminary circuit events would give teams experience with each environment.
</p><p>
	During the Tunnel Circuit event, which took place in August 2019 in the National Institute for Occupational Safety and Health’s experimental coal mine, on the outskirts of Pittsburgh, many teams lost communication with their robots after the first bend in the tunnel. Six months later, at the Urban Circuit event, held at an unfinished nuclear power station in Satsop, Wash., teams beefed up their communications with everything from a straightforward tethered Ethernet cable to battery-powered mesh network nodes that robots would drop like breadcrumbs as they went along, ideally just before they passed out of communication range. The Cave Circuit, scheduled for the fall of 2020, was canceled due to COVID-19.
</p><div class="ieee-sidebar-medium"><p class="shortcode-media shortcode-media-rebelmouse-image rm-resized-container rm-resized-container-25 rm-float-left" data-rm-resized-container="25%" style="float: left;"><img id="694c1" data-rm-shortcode-id="072935a4025dbe4d7cc5a5670354781f" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image rm-resized-image" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 3000 2253&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-people-looking-over-wheeled-robots-in-a-large-rocky-open-area.png?id=29692612&width=980" width="3000" height="2253" style="max-width: 100%" alt="A photo of people looking over wheeled robots in a large rocky open area.  "/></p><p class="shortcode-media shortcode-media-rebelmouse-image rm-resized-container rm-resized-container-25 rm-float-left" data-rm-resized-container="25%" style="float: left;"><img id="7b70d" data-rm-shortcode-id="24da0b458b0d0caafc538464872c9cad" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image rm-resized-image" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 3001 2201&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-three-yellow-four-legged-robots-lined-up-with-their-lights-on-in-a-dimmer-area.png?id=29692640&width=980" width="3001" height="2201" style="max-width: 100%" alt="A photo of three yellow four-legged robots lined up with their lights on in a dimmer area "/></p><p class="shortcode-media shortcode-media-rebelmouse-image rm-resized-container rm-resized-container-25 rm-float-left" data-rm-resized-container="25%" style="float: left;"><img id="2e463" data-rm-shortcode-id="f28d7607b1a4de8c4786ffca099b16f1" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image rm-resized-image" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 3600 2400&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-two-people-checking-out-the-back-of-a-robot.png?id=29692645&width=980" width="3600" height="2400" style="max-width: 100%" alt="A photo of two people checking out the back of a robot."/><small class="image-media media-caption" placeholder="Add Photo Caption...">Team CoSTAR, a collaboration between NASA’s JPL, MIT, Caltech, KAIST,
and LTU, inspects the communications-node deployment system on their
Husky wheeled robots [top]. CoSTAR’s pack of quadrupeds, consisting
of Spot robots from Boston Dynamics modified with customized autonomy
payloads [middle], undergo a hardware check before their final
competition run. The Spots are wearing “socks” made from cut-up
mountain-bike tires, cable ties, and black tape. Despite the ruggedness
of many of the robots, as research platforms, most demanded careful
attention from their human teammates, including Team Cerberus [bottom].
		</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Evan Ackerman</small></p></div><p>
	By the time teams reached the SubT Final Event in the Louisville Mega Cavern, the focus was on autonomy rather than communications. As in the preliminary events, humans weren’t permitted on the course, and only one person from each team was allowed to interact remotely with the team’s robots, so direct remote control was impractical. It was clear that teams of robots able to make their own decisions about where to go and how to get there would be the only viable way to traverse the course quickly.
</p><p>
	DARPA outdid itself for the final event, constructing an enormous kilometer-long course within the existing caverns. Shipping containers connected end-to-end formed complex networks, and many of them were carefully sculpted and decorated to resemble mining tunnels and natural caves. Offices, storage rooms, and even a subway station, all built from scratch, comprised the urban segment of the course. Teams had one hour to find as many of the 40 artifacts as possible. To score a point, the robot would have to report the artifact’s location back to the base station at the course entrance, which would be a challenge in the far reaches of the course where direct communication was impossible.
</p><p>
	Eight teams competed in the SubT Final, and most brought a carefully curated mix of robots designed to work together. Wheeled vehicles offered the most reliable mobility, but quadrupedal robots proved surprisingly capable, especially over tricky terrain. Drones allowed complete exploration of some of the larger caverns.
</p><p>
	By the end of the final competition, two teams had each found 23 artifacts: Team Cerberus—a collaboration of the University of Nevada, Reno; ETH Zurich; the Norwegian University of Science and Technology; the University of California, Berkeley; the Oxford Robotics Institute; Flyability; and the Sierra Nevada Corp.—and Team CSIRO Data61—consisting of CSIRO’s Data61; Emesent; and Georgia Tech. The equal scores triggered a tie-breaker rule: Which team had been the quickest to its final artifact? That gave first place to Cerberus, which had been just 46 seconds faster than CSIRO.
</p><p>
	Despite coming in second, Team CSIRO’s robots achieved the astonishing feat of creating a map of the course that differed from DARPA’s ground-truth map by less than 1 percent, effectively matching what a team of expert humans spent many days creating. That’s the kind of tangible, fundamental advance SubT was intended to inspire, according to Tim Chung, the DARPA program manager who ran the challenge.
</p><p>
	“There’s so much that happens underground that we don’t often give a lot of thought to, but if you look at the amount of infrastructure that we’ve built underground, it’s just massive,” Chung told 
	<em>IEEE Spectrum</em>. “There’s a lot of opportunity in being able to perceive, understand, and navigate in subterranean environments—there are engineering integration challenges, as well as foundational design challenges and theoretical questions that we have not yet answered. And those are the questions DARPA is most interested in, because that’s what’s going to change the face of robotics in 5 or 10 or 15 years, if not sooner.”
</p><div id="rebelltitem1" class=" rebellt-item parallax is--desktop has-description" style="background-image: url(https://assets.rbl.ms/29692789/origin.png)" data-id="1" data-is-image="True"><p style="text-align: center;">
This point cloud assembled by Team CSIRO Data61 shows a robotic view of nearly the entire SubT course, with each dot in the cloud representing a point in 3D space measured by a sensor on a robot. Team CSIRO’s point cloud differed from DARPA’s official map by less than 1 percent
</p><p class="caption" style="text-align: center;">
	CSIRO DATA61
</p></div><p><em>IEEE Spectrum</em> was in Louisville to cover the Subterranean Final, and we spoke recently with Chung, as well as CSIRO Data61 team lead Navinda Kottege and Cerberus team lead Kostas Alexis and about their SubT experience and the influence the event is having on the future of robotics.
</p><p><strong>DARPA has <a href="https://www.darpa.mil/our-research" rel="noopener noreferrer" target="_blank">hundreds of programs</a>, but most of them don’t involve multiyear international competitions with million-dollar prizes. What was special about the Subterranean Challenge? </strong></p><p class="shortcode-media shortcode-media-rebelmouse-image rm-resized-container rm-resized-container-25 rm-float-left" data-rm-resized-container="25%" style="float: left;"><img id="dd693" data-rm-shortcode-id="26187d9d275227ef6db792a129a2de71" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image rm-resized-image" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1032 960&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/an-illustration-of-tim-chung.png?id=29693692&width=980" width="1032" height="960" style="max-width: 100%" alt="An illustration of Tim Chung"/><small class="image-media media-caption" placeholder="Add Photo Caption..."><strong>TIM CHUNG | </strong>DARPA program manager </small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">MCKIBILLO</small></p><p><strong>Tim Chung: </strong>Every now and then, one of DARPA’s concepts warrants a different model for seeking out innovation. It’s when you know you have an impending breakthrough in a field, but you don’t know exactly how that breakthrough is going to happen, and where the traditional DARPA program model, with a broad announcement followed by proposal selection, might restrict innovation. DARPA saw the SubT Challenge as a way of attracting the robotics community to solving problems that we anticipate being impactful, like resiliency, autonomy, and sensing in austere environments. And one place where you can find those technical challenges coming together is underground.
</p><p><strong>The skill that these teams had at autonomously mapping their environments was impressive. Can you talk about that?</strong></p><p><strong>T.C.: </strong>We brought in a team of experts with professional survey equipment who spent many days making a precisely calibrated ground-truth map of the SubT course. And then during the competition, we saw these robots delivering nearly complete coverage of the course in under an hour—I couldn’t believe how beautiful those point clouds were! I think that’s really an accelerant. When you can trust your map, you have so much more actionable situational awareness. It’s not a solved problem, but when you can attain the level of fidelity that we’ve seen in SubT, that’s a gateway technology with the potential to unlock all sorts of future innovation.
</p><p><strong>Autonomy was a necessary part of SubT, but having a human in the loop was critical as well. Do you think that humans will continue to be a necessary part of effective robotic teams, or is full autonomy the future?</strong></p><p><strong>T.C.: </strong>Early in the competition, we saw a lot of hand-holding, with humans giving robots low-level commands. But teams quickly realized that they needed a more autonomous approach. Full autonomy is hard, though, and I think humans will continue to play a pretty big role, just a role that needs to evolve and change into something that focuses on what humans do best.
</p><p>
	I think that progressing from human operators to human supervisors will enhance the types of missions that human-robot teams will be able to conduct. In the final event, we saw robots on the course exploring and finding artifacts, while the human supervisor was focused on other stuff and not even paying attention to the robots. That was so cool. The robots were doing what they needed to do, leaving the human free to make high-level decisions. That’s a big change: from what was basically remote teleoperation to “you robots go off and do your thing and I’ll do mine.” And it’s incumbent on the robots to become even more capable so that the transition [of the human] from operator to supervisor can occur.
</p><p class="shortcode-media shortcode-media-rebelmouse-image"><img id="7be81" data-rm-shortcode-id="2685712125e64ccf07658249142c864c" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2500 1668&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-a-dark-area-with-a-quad-legged-robot-lighting-up-a-shaft-of-stone.png?id=29693391&width=980" width="2500" height="1668" alt="A photo of a dark area with a quad legged robot lighting up a shaft of stone.  "/></p><p class="shortcode-media shortcode-media-rebelmouse-image"><img id="c5d92" data-rm-shortcode-id="6c47b55e59c97fc0941ae38f9f349b3a" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2500 1668&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-a-quadruped-moving-through-an-underground-tunnel-with-wood-on-the-wall.png?id=29693390&width=980" width="2500" height="1668" alt="A photo of a quadruped moving through an underground tunnel with wood on the wall.  "/><small class="image-media media-caption" placeholder="Add Photo Caption...">An ANYmal quadruped from Team Cerberus enters the course [top]. During
the competition, only robots and DARPA staff were allowed to cross
this threshold. The visual markers surrounding the course entrance
provided a precise origin point from which the robots would base the
maps they created. This allowed DARPA to measure the accuracy of the
artifact locations that teams reported to score points. Cerberus’s
ANYmal exits the urban section of the course, modeled after a subway
station [bottom], and enters the tunnel section of the course, based
on an abandoned mine. 
	</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Evan Ackerman </small></p><p><strong>What are some remaining challenges for robots in underground environments?</strong></p><p><strong>T.C.: </strong>Traversability analysis and reasoning about the environment are still a problem. Robots will be able to move through these environments at a faster clip if they can understand a little bit more about where they’re stepping or what they’re flying around. So, despite the fact that they were one to two orders of magnitude faster than humans for mapping purposes, the robots are still relatively slow. Shaving off another order of magnitude would really help change the game. Speed would be the ultimate enabler and have a dramatic impact on first-response scenarios, where every minute counts.
</p><p><strong>What difference do you think SubT has made, or will make, to robotics?</strong></p><p><strong>T.C.:</strong> The fact that many of the technologies being used in the SubT Challenge are now being productized and commercialized means that the time horizon for robots to make it into the hands of first responders has been far shortened, in my opinion. It’s already happened, and was happening, even during the competition itself, and that’s a really great impact.
</p><p><strong>What’s difficult and important about operating robots underground?</strong></p><p class="shortcode-media shortcode-media-rebelmouse-image rm-resized-container rm-resized-container-25 rm-float-left" data-rm-resized-container="25%" style="float: left;"><img id="8d713" data-rm-shortcode-id="ca67693067b8533e2fc9da68b403b40a" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image rm-resized-image" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 961 998&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/navinda-kottege-csiro-data61-team-lead.png?id=29693766&width=980" width="961" height="998" style="max-width: 100%"/><small class="image-media media-caption" placeholder="Add Photo Caption...">NAVINDA KOTTEGE CSIRO | Data61 team lead</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">
            MCKIBILLO
        </small></p><p><strong>Navinda Kottege: </strong>The fact that we were in a subterranean environment was one aspect of the challenge, and a very important aspect, but if you break it down, what the SubT Challenge meant was that we were in a GPS-denied environment, where you can’t rely on communications, with very difficult mobility challenges. There are many other scenarios where you might encounter these things—the Fukushima nuclear disaster, for example, wasn’t underground, but communication was a massive issue for the robots they tried to send in. The Amazon Rainforest is another example where you’d encounter similar difficulties in communication and mobility. So we saw how each of these component technologies that we would have to develop and mature would have applications in many other domains beyond the subterranean.</p><p><strong>Where is the right place for a human in a human-robot team?</strong></p><p><strong>N.K.: </strong>There are two extremes. One is that you push a button and the robots go and do their thing. The other is what we call “human in the loop,” where it’s essentially remote control through high-level commands. But if the human is taken out of the loop, the loop breaks and the system stops, and we were experiencing that with brittle communications. The middle ground is a “human on the loop” concept, where you have a human supervisor who sets mission-level goals, but if the human is taken off of the loop, the loop can still run. The human added value because they had a better overview of what was happening across the whole scenario, and that’s the sort of thing that humans are super, super good at.
</p><p class="shortcode-media shortcode-media-rebelmouse-image"><img id="34696" data-rm-shortcode-id="9bf2cd73476ac8edf43993c86e08ffef" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2500 1667&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-a-robot-approaching-a-pair-of-people-and-near-an-underground-train-station.png?id=29693468&width=980" width="2500" height="1667" alt="A photo of a robot approaching a pair of people and near an underground train station"/></p><p class="shortcode-media shortcode-media-rebelmouse-image"><img id="5907b" data-rm-shortcode-id="92d024fbafd5ed5c5a98ce747b12a772" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2500 1668&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-a-quadruped-robot-lighting-up-a-cavern.png?id=29693464&width=980" width="2500" height="1668" alt="A photo of a quadruped robot lighting up a cavern. "/><small class="image-media media-caption" placeholder="Add Photo Caption...">The subway station platform [top] incorporated many challenges
for robots. Wheeled and tracked robots had particular difficulty
with the rails. DARPA hid artifacts in the ceiling of the subway
station (accessible only by drone), as well as under a grate in the
platform floor. In addition to building many customized tunnels
and structures inside the Louisville Mega Cavern, DARPA also
incorporated the cavern itself into the course. This massive room
[bottom] rewarded robots that managed to explore it with several
additional artifacts.
	</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Evan Ackerman</small></p><p><strong>How did SubT advance the field of robotics?</strong></p><p><strong>N.K.:</strong> For field robots to succeed, you need multiple things to work together. And I think that’s what was forced upon us by the level of complexity of the SubT Challenge. This whole notion of being able to reliably deploy robots in real-world scenarios was, to me, the key thing. Looking back at our team, three years ago we had some cool bits and pieces of technology, but we didn’t have robot systems that could reliably work for an hour or more without a human having to go and fix something. That was one of the biggest advances we had, because now, as we continue this work, we don’t even have to think twice about deploying our robots and whether they’ll destroy themselves if we leave them alone for 10 minutes. It’s that level of maturity that we’ve achieved, thanks to the robustness and reliability that we had to engineer into our systems to be successful at SubT, and now we can start focusing on the next step: What can you do when you have a fleet of autonomous robots that you can rely on?
</p><p><strong>Your team of robots created a map of the course that matched DARPA’s official map with an accuracy of better than 1 percent. That’s amazing.</strong></p><p><strong>N.K.:</strong> I got contacted immediately after the final event by the company that DARPA brought in to do the ground-truth mapping of the SubT course. They’d spent 100 person-hours using very expensive equipment to make their map, and they wanted to know how in the world we got our map in under an hour with a bunch of robots. It’s a good question! But the context is that our one hour of mapping took us 15 years of development to get to that stage.
</p><p>
	There’s a difference in what’s theoretically possible and what actually works in the real world. In its early stages, our software worked, in that it hit all of the theoretical milestones it was supposed to. But then we started taking it out to the real world and testing it in very difficult environments, and that’s where we started finding all the edge cases of where it breaks. Essentially, for the last 10-plus years, we were trying to break our mapping system as much as possible, and that turned it into a really well-engineered solution. Honestly, whenever we see the results of our mapping system, it still surprises us!
</p><p><strong>What made you decide to participate in the SubT Challenge?</strong></p><p class="shortcode-media shortcode-media-rebelmouse-image rm-resized-container rm-resized-container-25 rm-float-left" data-rm-resized-container="25%" style="float: left;"><img id="8a465" data-rm-shortcode-id="96ac81f862409787b065cee2a69565ea" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image rm-resized-image" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1084 960&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/an-illustration-of-kostas-alexis.png?id=29693827&width=980" width="1084" height="960" style="max-width: 100%" alt="An illustration of Kostas Alexis"/><small class="image-media media-caption" placeholder="Add Photo Caption...">KOSTAS ALEXIS | Cerberus team lead</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">
            MCKIBILLO
        </small></p><p><strong>Kostas Alexis: </strong>What motivated everyone was the understanding that for autonomous robots, this challenge was extremely difficult and relevant. We knew that robotic systems could operate in these environments if humans accompanied them or teleoperated them, but we also knew that we were very far away from enabling autonomy. And we understood the value of being able to send robots instead of humans into danger. It was this combination of societal impact and technical challenge that was appealing to us, especially in the context of a competition where you can’t just do work in the lab, write a paper, and call it a day—you had to develop something that would work all the way through the finals.
</p><p class="shortcode-media shortcode-media-rebelmouse-image"><img id="7406a" data-rm-shortcode-id="fa4f4116bccec82c49c0cdf12274b508" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2501 1709&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-a-quadruped-robot-moving-through-a-cavern.png?id=29693512&width=980" width="2501" height="1709" alt="A photo of a quadruped robot moving through a cavern.  "/></p><p class="shortcode-media shortcode-media-rebelmouse-image"><img id="bec4d" data-rm-shortcode-id="2c3ac991e55024feccbcd31f99c5b279" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2502 1666&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-a-quadruped-moving-through-a-cavern-next-to-a-sign-that-says-u201cdanger-enter-at-your-own-risk-u201d.png?id=29693504&width=980" width="2502" height="1666" alt="A photo of a quadruped moving through a cavern next to a sign that says \u201cDANGER, Enter at your own risk.\u201d"/><small class="image-media media-caption" placeholder="Add Photo Caption...">Tight cave sections [top] required careful navigation by ground
robots. Stalactites and stalagmites were especially treacherous for
drones in flight. At the right of the picture, partially hidden by a
column, is a blue coil of rope, one of the artifacts. A Team Cerberus
ANYmal [bottom] walks past a decorative (but not inaccurate) warning
sign, next to a drill artifact.
	</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Evan Ackerman</small></p><p><strong>What was the most challenging part of SubT for your team?</strong></p><p><strong>K.A.: </strong>We are at the stage where we can navigate robots in normal officelike environments, but SubT had many challenges. First, relying on communications with our robots was not possible. Second, the terrain was not easy. Typically, even terrain that is hard for robots is easy for humans, but the natural cave terrain has been the only time I’ve felt like the terrain was a challenge for humans too. And third, there’s the scale of kilometer-size environments. The robots had to demonstrate a level of robustness and resourcefulness in their autonomy and functionality that the current state-of-the-art in robotics could not demonstrate. The great thing about the SubT Challenge was that DARPA started it <em>knowing</em> that robotics did not have that capacity, but asked us to deliver a competitive team of robots three years down the road. And I think that approach went well for all the teams. It was a great push that accelerated research.
</p><p><strong>As robots get more autonomous, where will humans fit in?</strong></p><p><strong>K.A.:</strong> It is a fact now that we can have very good maps from robots, and it is a fact that we have object detection, and so on. However, we do not have a way of correlating all the objects in the environment and their possible interactions. So, although we can create awesome, beautiful, accurate maps, we are not equally good at reasoning.
</p><p>
	This is really about time. If we were performing a mission where we wanted to guarantee full exploration and coverage of a place with no time limit, we likely wouldn’t need a human in the loop—we can automate this fully. But when time is a factor and you want to explore as much as you can, then the human ability to reason through data is very valuable. And even if we can make robots that sometimes perform as well as humans, that doesn’t necessarily translate to novel environments.
</p><p>
	The other aspect is societal. We make robots to serve us, and in all of these critical operations, as a roboticist myself, I would like to know that there is a human making the final calls.
</p><p class="shortcode-media shortcode-media-rebelmouse-image"><img id="4aaf2" data-rm-shortcode-id="b51759f07d5db2a24103bcd02cffd04d" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2501 1787&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-photo-of-a-flying-drone-hovering-in-a-dark-area.png?id=29693539&width=980" width="2501" height="1787" alt="A photo of a flying drone hovering in a dark area.  "/><small class="image-media media-caption" placeholder="Add Photo Caption...">While most of the course was designed to look as much like real
underground environments as possible, DARPA also included sections
that posed very robot-specific challenges. Robots had the potential
to get disoriented in this blank white hallway (part of the urban
section of the course) if they couldn’t identify unique features to
differentiate one part of the hallway from another.
	</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Evan Ackerman</small></p><p><strong>Do you think SubT was able to solve any significant challenges in robotics?</strong><br/></p><p><strong>K.A.: </strong>One thing, of which I’m very proud for my team, is that SubT established that legged robotic systems can be deployed under the most arbitrary of conditions. [Team Cerberus deployed four ANYmal C quadrupedal robots from Swiss robotics company ANYbotics in the final competition.] We knew before SubT that legged robots were magnificent in the research domain, but now we also know that if you have to deal with complex environments on the ground or underground, you can take legged robots combined with drones and you should be good to go.
</p><p><strong>When will we see practical applications of some of the developments made through SubT?</strong></p><p><strong>K.A.:</strong> I think commercialization will happen much faster through SubT than what we would normally expect from a research activity. My opinion is that the time scale is counted in terms of months—it might be a year or so, but it’s not a matter of multiple years, and typically I’m conservative on that front.
</p><p>
	In terms of disaster response, now we’re talking about responsibility. We’re talking about systems with virtually 100 percent reliability. This is much more involved, because you need to be able to demonstrate, certify, and guarantee that your system works across so many diverse use cases. And the key question: Can you trust it? This will take a lot of time. With SubT, DARPA created a broad vision. I believe we will find our way toward that vision, but before disaster response, we will first see these robots in industry. 
	<span class="ieee-end-mark"></span></p><p><em>This article appears in the May 2022 print issue as “Robots Conquer the Underground</em><em>.”</em></p><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div><ul class="around-the-web__list"><li class="from-your-site__item"><a href="https://spectrum.ieee.org/late-nights-cool-hacks-and-more-stories-from-the-darpa-subt-urban-circuit" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Late Nights, Cool Hacks, and More Stories From the DARPA SubT ... ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/nasa-jpl-team-costar-darpa-subt-urban-circuit-systems-track" class="from-your-site__link" target="_blank" rel="noopener noreferrer">How JPL&#39;s Team CoSTAR Won the DARPA SubT Challenge: Urban ... ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/darpa-subterranean-challenge" class="from-your-site__link" target="_blank" rel="noopener noreferrer">DARPA SubT Finals: Meet the Teams - IEEE Spectrum ›</a></li></ul><div class="around-the-web__headline">Related Articles Around the Web</div><ul class="around-the-web__list"><li class="around-the-web__item"><a href="https://www.darpa.mil/program/darpa-subterranean-challenge" class="around-the-web__link" target="_blank" rel="noopener noreferrer">DARPA Subterranean (SubT) Challenge ›</a></li><li class="around-the-web__item"><a href="https://www.subtchallenge.com/" class="around-the-web__link" target="_blank" rel="noopener noreferrer">DARPA Subterranean Challenge ›</a></li></ul></div></template></div><div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds"><span class="show-more js-expand">Keep Reading ↓</span><span class="show-less js-contract">Show less</span></div></div></div><span class="js-scrolled-url" data-elid="2657170650" data-post-url="https://spectrum.ieee.org/darpa-subterranean-challenge-2657170650" data-authors="Evan Ackerman" data-headline="Inside DARPA’s Subterranean Challenge"></span><div class="custom-field-lightbox-img-shortcode-ids">{&quot;imageShortcodeIds&quot;:[&quot;29692645&quot;,&quot;29692640&quot;,&quot;29692612&quot;]}</div></div></div></div><script type="application/json" id="post-context-2657170650">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"DARPA, SubT, robotics, type:cover, ~rmsc:rebelmouse-image:29692504, ~rmsc:rebelmouse-image:29692612, ~rmsc:rebelmouse-image:29692640, ~rmsc:rebelmouse-image:29692645, ~rmsc:rebelmouse-image:29693692, ~rmsc:rebelmouse-image:29693391, ~rmsc:rebelmouse-image:29693390, ~rmsc:rebelmouse-image:29693766, ~rmsc:rebelmouse-image:29693468, ~rmsc:rebelmouse-image:29693464, ~rmsc:rebelmouse-image:29693827, ~rmsc:rebelmouse-image:29693512, ~rmsc:rebelmouse-image:29693504, ~rmsc:rebelmouse-image:29693539, ~rmsc:rebelmouse-image:29692789","8":"04/24/2022","10":"robotics","11":2657170650}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 539626628, 544169537, 539266128, 555118571, 544169516, 544169517, 555118576], "buckets": [], "authors": [21075149]} }
</script></article></div></div></div></div><div class="" id="sSS_Default_Post_0_0_20_0_0_1_6"><!-- User Code --><!-- div id='infinite_leaderboard_1'><script>
    googletag.cmd.push(function() { googletag.display('infinite_leaderboard_1'); });
  </script></div --><div class="infinite-leaderboard"></div><!-- End User Code --></div><div class="wrapper-lazy-loading infinite-scroll-wrapper next-page-wrapper" style="display: block !important;" data-skl-id="/root/blocks/block[ss_default_post]/abtests/abtest[1]/element_wrapper/lazyload-" data-has-more="true" data-more-posts-exists="true" data-posts-sources="post_most_sections,post_sponsor_webinar_whitepaper,multi_filtered_parent_site_filtered_parent_site,frontpage_parent_site_podcast" data-ignore-page-number="false"></div></div><span class="js-brick-description hidden" data-name="JS post functions"></span><!-- User Code --><script>
  function feature_post_full_style(){
    var feature_post_full = document.querySelectorAll(".feature_post_full:not(.proc)");
	for (i = 0; i < feature_post_full.length; i++) {
      var style_post_color = feature_post_full[i].querySelector(".custom-field-FeaturePostColor");
      var style_post_position = feature_post_full[i].querySelector(".custom-field-FeaturePostImgPosition");
      if(style_post_color){
         feature_post_full[i].classList.add(style_post_color.innerText);
      }else{
      	 feature_post_full[i].classList.add('DarkGray');
      }
      if(style_post_position){
         feature_post_full[i].classList.add(style_post_position.innerText);
      }
      feature_post_full[i].classList.add('proc');
    }  
  }
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="Parsely Spectrum Tags"></span><span class="js-brick-description hidden" data-name="__Lightbox_Functionality"></span><div class="lightbox-layout" id="s__Lightbox_Functionality_0_0_33_0_0_1_1_1"><!-- User Code --><div class="lightbox__close hm__close"></div><!-- End User Code --></div></div></div><ul id="notification" class="notification"></ul><script defer="defer" src="https://www.googletagmanager.com/gtag/js?id=UA-747464-1"></script><script>

            (function (i, s, o, g, r, a, m) {
                i["GoogleAnalyticsObject"] = r;
                (i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments);}),(i[r].l = 1 * new Date());
            })(window, document, "script", "/", "ga");
            ga('create', 'UA-747464-1', 'auto', {'name': 'b'});

            window.dataLayer = window.dataLayer || [];
            window.gtag = function(){dataLayer.push(arguments);}
            gtag('js', new Date());

            var utmCampaignData = null;// ADD REFERRER AS SOURCE IF SOURCE IS NOT PRESENT OR IF ISN'T URL UTM
            if(utmCampaignData && (utmCampaignData.dataSource != "url" || !utmCampaignData['campaignSource'])) {
                var referrerAnchor = document.createElement('a');
                referrerAnchor.setAttribute('href', document.referrer);
                if(referrerAnchor.href && referrerAnchor.host) {
                    var splitHost = referrerAnchor.host.split(".");
                    var nakedDomain = splitHost.length < 3 ? splitHost[0] : splitHost[1];
                    if (nakedDomain) {
                        nakedDomain = nakedDomain[0].toUpperCase() + nakedDomain.substring(1);
                        utmCampaignData['campaignSource'] = nakedDomain;
                    }
                }
            }

            var configParams = { transport: 'beacon', send_page_view: false };
            // DEFAULTS
            if (utmCampaignData) {
                configParams.campaignName = utmCampaignData.campaignName;
                configParams.campaignSource = utmCampaignData.campaignSource;
                configParams.campaignMedium = utmCampaignData.campaignMedium;
                configParams.campaignContent = utmCampaignData.campaignContent;
                if (utmCampaignData.campaignKeyword) {
                    configParams.campaignKeyword = utmCampaignData.campaignKeyword;
                }
            }

            gtag('config', 'UA-747464-1', configParams);gtag('config', 'G-DPQFLXZCWN', configParams);
  window._ga_cd_params = window._ga_cd_params || {};

    

    window._ga_cd_params["dimension9"] = 'ieee,1784';window._ga_cd_params["dimension5"] = "Evan Ackerman";

          window._ga_cd_params["dimension11"] = '2657727687';

          window._ga_cd_params["dimension7"] = "actuators, insects, bioinspired robots, robotics, ~rmsc:rebelmouse-image:30273265, ~rmsc:rebelmouse-image:30265286, ~rmsc:rebelmouse-image:30273287";

          window._ga_cd_params["dimension10"] = 'robotics';

          window._ga_cd_params["dimension6"] = 'robotics';

          

          window._ga_cd_params["dimension8"] = '07/26/2022';

          

          

          

          
            if(window._ga_cd_params && Object.keys(window._ga_cd_params).length){
                gtag('event', 'page_view', window._ga_cd_params);
            }else{
                gtag('event', 'page_view');
            }
        </script><script>
        if (typeof window.gtag === 'function') {
            var anchors = document.getElementsByTagName('a');
            for(var i = 0; i < anchors.length; i++) {
                var elem = anchors[i];
                elem.addEventListener('click', function (evnt) {
                    if (document.location.hostname === evnt.currentTarget.hostname) {
                        return;
                    }
                    if (!evnt.currentTarget.href) {
                        return;
                    }
                    if (evnt.currentTarget.href.lastIndexOf('javascript:', 0) === 0) {
                        return;
                    }
                    window.gtag('event', 'click', {
                        'event_category': 'outgoing_links',
                        'event_action': 'click',
                        'event_label': evnt.currentTarget.href,
                        'nonInteraction': 1,
                    });
                }, false);
            }
        }
    </script><script class="lazy-style" type="css">
        

    </script><script id="parsely-cfg" src="//cdn.parsely.com/keys/spectrum.ieee.org/p.js"></script><script id="user-javascript-medium-normal">
        window.REBELMOUSE_TASKS_QUEUE.push(function loadFonts(){
window.REBELMOUSE_STDLIB.loadFontFace('IvarText', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Regular.woff2', {selector: '',
  weight: '400',
  style: 'normal'
});
window.REBELMOUSE_STDLIB.loadFontFace('IvarTextItalic', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Italic.woff2', {selector: '',
  weight: '400',
  style: 'italic'
});
window.REBELMOUSE_STDLIB.loadFontFace('IvarText', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Bold.woff2', {selector: '',
  weight: '700',
  style: 'normal'
});});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        REBELMOUSE_STDLIB
  .createElementChangeListener('.rm-shortcode[href*=".pdf"]', function(pdfLink){
    pdfLink.href = 'javascript:void(0);';
    pdfLink.classList.add('pdf-link-nonmember');
    pdfLink.addEventListener('click', function(){
      openGatedPopup('for_pdf_issues');
    });
});
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        //var ssoValidatorUrl = 'https://oamssoqae.ieee.org/ieeevendorsso/rest/auth/validatePFToken?_=' + (+ new Date());

var ssoValidatorUrl = 'https://securesso.ieee.org/ieeevendorsso/rest/auth/validatePFToken?_=' + (+ new Date());

function getCookie(name) {
  const value = `; ${document.cookie}`;
  const parts = value.split(`; ${name}=`);
  if (parts.length === 2) return parts.pop().split(';').shift();
}

fetch(ssoValidatorUrl, {
    method: 'GET',
    mode: 'cors',
    credentials: 'include',
}).then(function (response) {
	// The API call was successful!
	if (response.ok) {
		response.json().then(function(result) {
          if (typeof result == 'object' && result.cookieValid && getCookie('user_logged_in') !== "1") { 		//SSO
              console.log('we should be logged in, redirect to SSO iDP');
              //window.location.href = 'https://spectrumtest.ieee.org/core/saml/main/login?next_url=' + window.location.href;
              window.location.href = "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
          } else if (typeof result == 'object' && !result.cookieValid) {		//SLO
              console.log('we should be logged out, remove cookie and do not show user');
              //document.cookie = "sessionid= ; expires = Thu, 01 Jan 1970 00:00:00 GMT";
          }
        });
      
	} else {
		return Promise.reject(response);
	}
}).then(function (data) {
	// This is the JSON from our response
	console.log(data);
}).catch(function (err) {
	// There was an error
	console.warn('Something went wrong.', err);
});
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        function changeDateFormat(widget){
  var dates_toChange=widget.querySelectorAll('.widget .social-date__text:not(.processed),.widget .social-date-modified__text:not(.processed)');
  if(dates_toChange){
    dates_toChange.forEach(function(date) {

      if(!date.innerHTML.trim()==""){
        date.classList.add('processed')
        var date_string=date.innerHTML.toString();
        var slpit_dateText=date_string.split(" ");


        if(slpit_dateText.length==1){
          let plural=true;
          if(slpit_dateText[0].length==2){
            if(slpit_dateText[0].charAt(0)=="1"){
              plural=false;
            }
          }
          let modifier=plural ? 'hours ago':'hour ago';

          if(slpit_dateText[0].substr(-1)=='m'){
            modifier=plural ? 'minutes ago':'minute ago';
          }
          if(slpit_dateText[0].substr(-1)=='s'){
            modifier=plural ? 'seconds ago':'second ago';
          }
          var new_dateText=slpit_dateText[0].slice(0,-1);
          date.innerHTML=  new_dateText+" "+ modifier;
          date.classList.add("modified");
        }
      }
    });

  }
}
_createElementChangeListener= function (selector, callback) {
  const initializedNodes = new Set([]);

  document.querySelectorAll(selector).forEach((node) => {
    callback(node);
    initializedNodes.add(node);
  });

  const mutationObserver = new MutationObserver(() => {
    const nodes = document.querySelectorAll(selector);
    nodes.forEach((node) => {
      if (!initializedNodes.has(node)) {
        callback(node);
        initializedNodes.add(node);
      }
    });
  });

  mutationObserver.observe(document.body, {
    childList: true,
    subtree: true,
  });
}
_createElementChangeListener(".widget",changeDateFormat);
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        feature_post_full_style();
    

});</script><script id="user-javascript-active" type="text">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</script><script id="user-javascript-lowest" type="text">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</script></body></html>