<!DOCTYPE html><!-- Powered by RebelMouse. https://www.rebelmouse.com --><html lang="en"><head prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#"><link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script"/><link as="font" href="https://partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Light.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Light.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Bold.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Bold.woff2" type="font/woff2" crossorigin="" rel="preload"/><meta name="robots" content="max-image-preview:large"/><link fetchpriority="high" rel="preload" imagesrcset="https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=3600&height=2700 3x, https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=2400&height=1800 2x, https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=1200&height=900 1x" as="image"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@"/><meta name="twitter:site:id" content=""/><meta name="twitter:image" content="https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=1200&coordinates=0%2C300%2C0%2C300&height=600"/><meta property="fb:app_id" content="525370847662646"/><meta property="og:type" content="article"/><meta property="article:section" content="Robotics"/><meta property="og:url" content="https://spectrum.ieee.org/microrobots-walking"/><link rel="canonical" href="https://spectrum.ieee.org/microrobots-walking"/><meta property="og:site_name" content="IEEE Spectrum"/><meta property="og:image" content="https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=1200&coordinates=0%2C300%2C0%2C300&height=600"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="600"/><meta property="og:title" content="Flea-Sized Robots Walk a Coin-Edge-Sized Path"/><meta property="og:description" content="The tiny robot moves with a scuttling motion thanks to shape memory alloys (SMAs). Laser heating the SMA triggers a shape change, which moves the legs. “So you create material in an initial geometry, deform it, and then when you heat it up, it’ll go back,” says a researcher on the team."/><meta name="description" content="These crab-inspired crawlers are just half a millimeter wide"/><meta name="referrer" content="always"/><meta charset="utf-8"/><link rel="preconnect" href="https://assets.rebelmouse.io/" crossorigin="crossorigin"/><link rel="preconnect" href="https://user-stats.rbl.ms/" crossorigin="crossorigin"/><link rel="preconnect" href="https://pages-stats.rbl.ms/" crossorigin="crossorigin"/><!--link rel="preload" href="https://static.rbl.ms/static/fonts/fontawesome/fontawesome-mini.woff" as="font" type="font/woff2" crossorigin--><script>window.REBELMOUSE_BOOTSTRAP_DATA = {"engine": {"changeParticleUrlScroll": false, "lazyLoadShortcodeImages": true, "theoPlayerLibraryLocation": "", "defaultVideoPlayer": "", "backButtonGoToPage": true, "webVitalsSampleRate": 100, "countKeepReadingAsPageview": true, "trackPageViewOnParticleUrlScroll": false}, "runner": {"id": 20265424}, "resourceId": "pp_2657489115", "fbId": "525370847662646", "site": {"id": 20265424, "isCommunitySite": false}, "tag": {"slug": "microrobots"}, "whitelabel_menu": {}, "post": {"status": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "shareUrl": "https%3A%2F%2Fspectrum.ieee.org%2Fmicrorobots-walking", "id": 2657489115, "tags": ["microrobots", "biomemetic robots", "shape memory alloy"]}, "isUserLoggedIn": false, "messageBusUri": "wss://messages.rebelmouse.io", "section": {"id": null}, "pathParams": {"slug": "microrobots-walking"}, "clientGaId": "UA-747464-1", "fbAppVersion": "v2.5", "useRiver": true, "fullBootstrapUrl": "/res/bootstrap/data.js?path_params=%7B%22slug%22%3A%22microrobots-walking%22%7D\u0026override_device=desktop\u0026resource_id=pp_2657489115\u0026site_id=20265424\u0026post_id=2657489115\u0026warehouse10x=1"};
    </script><script>
        window.REBELMOUSE_BASE_ASSETS_URL = "https://spectrum.ieee.org/static/dist/social-ux/";
        window.REBELMOUSE_BASE_SSL_DOMAIN = "https://spectrum.ieee.org";
        window.REBELMOUSE_TASKS_QUEUE = [];
        window.REBELMOUSE_LOW_TASKS_QUEUE = [];
        window.REBELMOUSE_LOWEST_TASKS_QUEUE = [];
        window.REBELMOUSE_ACTIVE_TASKS_QUEUE = [];
        window.REBELMOUSE_STDLIB = {};
        window.RM_OVERRIDES = {};
        window.RM_AD_LOADER = [];
    </script><script src="https://spectrum.ieee.org/static/dist/social-ux/main.a5e595e6e583ae305157.bundle.mjs" type="module" async="async" src="https://spectrum.ieee.org/static/dist/social-ux/main.a5e595e6e583ae305157.bundle.mjs" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="main.mjs"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/main.56e26972d8282e743c48.bundle.js" nomodule="nomodule" defer="defer" src="https://spectrum.ieee.org/static/dist/social-ux/main.56e26972d8282e743c48.bundle.js" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="main.js"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/runtime.5714be37dfe6cfcdfaba.bundle.mjs" type="module" async="async" src="https://spectrum.ieee.org/static/dist/social-ux/runtime.5714be37dfe6cfcdfaba.bundle.mjs" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="runtime.mjs"></script><script src="https://spectrum.ieee.org/static/dist/social-ux/runtime.54df51d429a2819b1959.bundle.js" nomodule="nomodule" defer="defer" src="https://spectrum.ieee.org/static/dist/social-ux/runtime.54df51d429a2819b1959.bundle.js" data-js-app="true" data-src-host="https://spectrum.ieee.org" data-src-file="runtime.js"></script><!-- we collected enough need to fix it first before turn in back on--><!--script src="//cdn.ravenjs.com/3.16.0/raven.min.js" crossorigin="anonymous"></script--><!--script type="text/javascript">
        Raven.config('https://6b64f5cc8af542cbb920e0238864390a@sentry.io/147999').install();
    </script--><link rel="manifest" href="/manifest.json"/><meta name="theme-color" content="#647187"/><script>
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/sw.js').then(function(registration) {
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }, function(err) {
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        } else {
          console.log('ServiceWorker not enabled');
        }
    </script><script>
        // fallback error prone google tag setup
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/><link rel="alternate" type="application/rss+xml" title="IEEE Spectrum" href="/feeds/topic/robotics.rss"/><!-- Mobile viewport optimized: h5bp.com/viewport --><meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1.0,maximum-scale=1.0,user-scalable=no"/><title>Flea-Sized Robots Walk a Coin-Edge-Sized Path - IEEE Spectrum</title><style>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</style><script>
        window.REBELMOUSE_LOW_TASKS_QUEUE.push(function() {
            window.REBELMOUSE_STDLIB.loadExternalStylesheet("/static/css-build/roar/runner/social-ux-non-critical.css?v=rmxassets27ce01474a075144b0ac916a2195413a", function(){
                document.body.classList.add("rm-non-critical-loaded");
            });
        });
    </script><script>
        var __RUNNER_PUBLIC__ = {
          root: '#runner-root',
          events: {
            PAGE_VIEW: 'page_view.url_change.listicle_switch_page',
            URL_CHANGE_PAGE_VIEW: 'page_view.url_change',
            LISTICLE_CHANGE_PAGE_VIEW: 'page_view.listicle_switch_page'
          }
        }
    </script><script>
        window.__rebelmouseJsBaseUrl = "/static/js-build/";
        
        window.__rebelmousePrimaryColor = "#FF4C00";
        
    </script><link rel="apple-touch-icon" href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjU5NjY0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1OTYwMjUwNn0.83ww7bkGqpGwDJ0lJUQ9t40jCxvzIiI09EEqwNcU8HE/img.png?width=192&height=192" sizes="192x192"/><link rel="icon" type="image/png" href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjU5NjY0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1OTYwMjUwNn0.83ww7bkGqpGwDJ0lJUQ9t40jCxvzIiI09EEqwNcU8HE/img.png?width=32&height=32" sizes="16x16"/><meta property="article:published_time" content="2022-06-11T13:00:01+00:00"/><meta property="article:modified_time" content="2022-06-11T13:00:01+00:00"/><meta property="article:author" content="https://www.facebook.com/48576411181"/><meta name="keywords" content="microrobots, biomemetic robots, shape memory alloy"/><link rel="amphtml" href="https://spectrum.ieee.org/amp/microrobots-walking-2657489115"/><script data-abtest-name="ieee" data-abtest-value="1784" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1482" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1830" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1242" type="application/json"></script><script>
window.postid = "2657489115";
window.category = ["robotics", "news", "type", "topic"];
window.tags = ["microrobots", "biomemetic-robots", "shape-memory-alloy"];

</script><script data-abtest-name="IEEE" data-abtest-value="1761" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1016" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1885" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1891" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1715" type="application/json"></script><script data-abtest-name="pdf" data-abtest-value="button2" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1326" type="application/json"></script><script data-abtest-name="test" data-abtest-value="2" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1872" type="application/json"></script><script data-abtest-name="test" data-abtest-value="badge" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1719" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1386" type="application/json"></script><script data-abtest-name="anbar" data-abtest-value="3" type="application/json"></script><script data-abtest-name="anbar" data-abtest-value="off" type="application/json"></script><script data-abtest-name="anbar" data-abtest-value="on" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1422" type="application/json"></script><script data-abtest-name="final" data-abtest-value="2" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="209" type="application/json"></script><script data-abtest-name="test" data-abtest-value="tiarchive" type="application/json"></script><script data-abtest-name="h1" data-abtest-value="fix" type="application/json"></script><script data-abtest-name="footer" data-abtest-value="test" type="application/json"></script><script data-abtest-name="pdf" data-abtest-value="button2" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="gate" type="application/json"></script><script data-abtest-name="pdf" data-abtest-value="button" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1811" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1843" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1842" type="application/json"></script><script data-abtest-name="test" data-abtest-value="noaipopup" type="application/json"></script><meta name="google-site-verification" content="TL2pz9TZSlPds24a3mqZClMC79zWmgOKFwO4aYRjdXk"/><meta name="facebook-domain-verification" content="bgsalp9vtqx07wdoczkh2jq79qvonr"/><meta property="fb:pages" content="48576411181"/><script data-abtest-name="IEEE" data-abtest-value="1830" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1879" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1780" type="application/json"></script><script data-abtest-name="date" data-abtest-value="mod" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1482" type="application/json"></script><script data-abtest-name="image" data-abtest-value="32" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="gate" type="application/json"></script><script data-abtest-name="ads" data-abtest-value="cut" type="application/json"></script><script data-abtest-name="authors" data-abtest-value="new" type="application/json"></script><script data-abtest-name="IEEE" data-abtest-value="1808" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1436" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1482" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1436test" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="gateold" type="application/json"></script><style id="custom-post-styles-2657489115">
</style><script data-abtest-name="socialux" data-abtest-value="1" type="application/json"></script><style id="custom-post-styles-2655067972">
</style><script data-abtest-name="final" data-abtest-value="3" type="application/json"></script><script data-abtest-name="" data-abtest-value="" type="application/json"></script><script data-abtest-name="" data-abtest-value="3" type="application/json"></script><meta name="parsely-section" content="Robotics"/><meta name="parsely-tags" content="microrobots,biomemetic robots,shape memory alloy,SpectrumType.News"/><meta name="parsely-author" content="Payal Dhar"/><script data-abtest-name="ieee" data-abtest-value="1436" type="application/json"></script><script data-abtest-name="test" data-abtest-value="old" type="application/json"></script><script data-abtest-name="test" data-abtest-value="oldarrows" type="application/json"></script><script data-abtest-name="ieee" data-abtest-value="1436test" type="application/json"></script><script>
    
        (function() {
    var cookie = 'rebelmouse_abtests=';
        cookie += "v1:165477109-A:2";
    document.cookie = cookie + '; Path=/; SameSite=None; Secure';
})();
    
    </script><!--[if IE]>
        <script type="text/javascript" src="/static/js-build/libs/html5shiv/html5shiv.js"></script>
    <![endif]--></head><body class="logged-out-user section-robotics"><div id="fb-root"></div><div id="runner-root"></div><div id="curtain" class="curtain"></div><nav class="menu-global"><div class="main-menu-wrapper"><div class="menu-global__search-form hide-tablet-and-desktop"><form action="/search/"><button aria-label="Submit" type="submit" class="menu-global__submit fa fa-search" value=""></button><input aria-label="Search" placeholder="Search..." type="text" name="q" class="menu-global__text-input"/></form></div><div class="divider hide-tablet-and-desktop"></div><ul class="sections-list"></ul><div class="divider"></div><ul id="main-menu" class="main-menu"></ul></div></nav><cookie_variants><cookie_variant id="a"></cookie_variant><cookie_variant id="b"></cookie_variant><cookie_variant id="c"></cookie_variant><cookie_variant id="d"></cookie_variant><cookie_variant id="e"></cookie_variant><cookie_variant id="f"></cookie_variant><cookie_variant id="g"></cookie_variant><cookie_variant id="h"></cookie_variant></cookie_variants><extra_asset_fields></extra_asset_fields><extra_section_fields></extra_section_fields><post_types_supported></post_types_supported><site_specific_data_schema><site_specific_data_property name="first_name" default="" description="SSO First Name" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="last_name" default="" description="SSO Last Name" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Instagram" default="" description="Add the link to your Instagram account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="member_badges" default="" description="Membership Badges" enum="STAFF EDITOR,CONTRIBUTOR" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Twitter" default="" description="Add the link to your Twitter account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="LinkedIn" default="" description="Add the link to your LinkedIn account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="grade" default="" description="SSO Grade" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Facebook" default="" description="Add the link to your Facebook account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property></site_specific_data_schema><post_image_settings _3x2="true" _1x1="true" _3x1="true" _3x4="true" _2x1="true" _9x16="true" _16x9="true" _4x3="true"></post_image_settings><div class="all-content-wrapper"><div class="main v-sep"><span class="js-brick-description hidden" data-name="Post"></span><div data-share-status-id="menu-toggle" data-toggle-class="menu-opened" class="menu-overlay js-toggle" data-target="body"></div><!-- User Code --><script>
    window.PARSELY = window.PARSELY || {};

  	function isPublished(post){
    	return [0,1,2].includes(post.status)
    }
  
  	window.PARSELY.autotrack = false;
    window.PARSELY.onload = function () {
      
      	
        if(Object.keys(window.REBELMOUSE_BOOTSTRAP_DATA.post).length > 0 && !isPublished(window.REBELMOUSE_BOOTSTRAP_DATA.post)){
        	return;
        }
      
        var event = {
          url: location.href,
          urlref: document.referrer,
          js: 1
        };
        window.PARSELY.updateDefaults({
            data: {
                level: localStorage.getItem("userMembershipStatus") || "anonymous"
            }
        });
        window.PARSELY.beacon.trackPageView(event);
    };
</script><!-- End User Code --><!-- User Code --><!-- Google Tag Manager (noscript) --><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5WJB5X2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><!-- End Google Tag Manager (noscript) --><!-- End User Code --><span class="js-brick-description hidden" data-name="CSS Fonts"></span><span class="js-brick-description hidden" data-name="CSS Spectrum"></span><span class="js-brick-description hidden" data-name="CSS for Posts"></span><span class="js-brick-description hidden" data-name="CSS Article Components"></span><span class="js-brick-description hidden" data-name="CSS for Comments"></span><div class="topbar topbar--static" id="sTop_Bar_0_0_25_0_0_12"><div class="" id="sTop_Bar_0_0_25_0_0_12_0"><span class="js-brick-description hidden" data-name="Element Bar"></span><div class="dark_top_bar" id="sElement_Bar_0_0_7_0_0_1"><div class="" id="sElement_Bar_0_0_7_0_0_1_0"><div class="top_menu_links" id="sElement_Bar_0_0_7_0_0_1_0_0"><div class="list" id="sElement_Bar_0_0_7_0_0_1_0_0_0"><a href="https://www.ieee.org/" class="list__item" target="_blank">IEEE.org</a><a href="https://ieeexplore.ieee.org/Xplore/home.jsp" class="list__item" target="_blank">IEEE Xplore Digital Library</a><a href="https://standards.ieee.org/" class="list__item" target="_blank">IEEE Standards</a><a href="https://www.ieee.org/sitemap.html" class="list__item" target="_blank">More Sites</a></div></div><div class="" id="sElement_Bar_0_0_7_0_0_1_0_1"><div class="access_links" id="sElement_Bar_0_0_7_0_0_1_0_1_0_1_1"><div class="list" id="sElement_Bar_0_0_7_0_0_1_0_1_0_1_1_0"><a href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https://spectrum.ieee.org/core/saml/main/login&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">Sign In</a><a href="/st/join" class="list__item" target="_self">Join IEEE</a></div></div><div class="" id="sElement_Bar_0_0_7_0_0_1_0_1_1"><!-- User Code --><svg width="70px" height="21px" viewbox="0 0 70 21" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="0 0 21.3639449 0 21.3639449 21 0 21"></polygon></defs><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-IEEE-Bar-/-Signed-out-/-1376" transform="translate(-1274.000000, -14.000000)"><g id="Group-13" transform="translate(1274.000000, 14.000000)"><polygon id="Fill-1" fill="#FEFEFE" points="23.4111174 18.6889405 27.8363724 18.6889405 27.8363724 2.77905063 23.4111174 2.77905063"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="29.7536549 18.6881005 29.7536549 2.77821061 41.9217005 2.77821061 41.9217005 5.8624668 34.17891 5.8624668 34.17891 9.14692664 41.3017712 9.14692664 41.3017712 12.2311828 34.17891 12.2311828 34.17891 15.6024442 41.9217005 15.6024442 41.9217005 18.6881005"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="43.7923126 18.6881005 43.7923126 2.77821061 55.9603583 2.77821061 55.9603583 5.8624668 48.2175677 5.8624668 48.2175677 9.14692664 55.3418347 9.14692664 55.3418347 12.2311828 48.2175677 12.2311828 48.2175677 15.6024442 55.9603583 15.6024442 55.9603583 18.6881005"></polygon><polygon id="Fill-4" fill="#FEFEFE" points="57.8305486 2.77793061 57.8305486 18.6878205 70 18.6878205 70 15.6021642 62.2558037 15.6021642 62.2558037 12.2323028 69.3800707 12.2323028 69.3800707 9.14664663 62.2558037 9.14664663 62.2558037 5.8621868 70 5.8621868 70 2.77793061"></polygon><g id="Group-12"><g id="Group-7"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-6"></g><path d="M20.9520644,9.85449953 L20.8930235,9.84469935 C19.0838421,8.61967703 17.3983653,7.23365178 15.8098843,5.66142314 L14.0555265,3.83578988 C13.3442244,3.05037557 12.6540084,2.18095973 11.9961242,1.35074461 L11.1976665,0.22232405 C11.099265,0.164923005 10.976966,0.0669212192 10.8687244,0.0375206836 C10.6339666,-0.0646811784 10.3795285,0.0571210406 10.1883485,0.202723693 L8.74184673,2.07875787 C6.42378906,4.93900998 3.67838782,7.60885862 0.684171419,9.65429588 C0.448007872,9.84049927 0.0951682866,10.0211026 0.0220700458,10.3235081 C-0.0566511366,10.596513 0.0853281388,10.8219172 0.256827858,10.9913202 C2.65360672,12.6363502 4.94776689,14.5907858 6.98748895,16.8168264 C7.35016869,17.1962333 7.64396739,17.5728401 7.99680697,17.9284466 C8.59424452,18.719461 9.29570648,19.5160755 9.84534902,20.364491 C10.0168487,20.5450943 10.0463692,20.8390996 10.3148646,20.9259012 C10.525725,20.9987026 10.785786,21.0477034 10.9868062,20.9259012 L11.1878263,20.7256976 C13.6675436,17.2256338 16.8149851,14.0825766 20.3293236,11.5429303 C20.6821632,11.2321246 21.3541047,11.1145225 21.3639449,10.5335119 C21.3386417,10.264707 21.182605,10.0015022 20.9520644,9.85449953 M18.5496626,10.7911166 C18.1476223,11.7879348 17.3337015,12.5831492 16.6238051,13.4525651 C15.0845249,15.1017951 13.4623062,16.6992242 11.6432846,17.9718474 C11.2763877,18.2322522 10.7815688,18.4702565 10.3401679,18.2658528 C9.00190778,17.56724 7.87450799,16.4248192 6.7035304,15.3860003 C5.34559001,14.1301774 3.98202667,12.6713508 2.95302836,11.142523 C2.80120893,10.9283191 2.75763114,10.6651143 2.76184834,10.3823091 C2.89398747,9.85449953 3.2566672,9.42049162 3.60107238,8.97668354 C4.81562776,7.43385543 6.30570729,5.96942875 7.80984416,4.63240439 C7.84498755,4.59740376 7.90824564,4.5232024 7.96306932,4.48960179 C8.60970761,3.93379167 9.25212869,3.44098269 9.92828741,2.95657386 C10.6339666,2.41056392 11.5209856,2.86417218 12.114206,3.36678134 C12.7369467,3.83998996 13.383585,4.37759975 13.9529079,4.9236097 L14.0555265,4.98241077 C15.6285445,6.43703727 17.0891035,8.05406673 18.2910073,9.76209785 C18.4864045,10.0603033 18.6579042,10.3963094 18.5496626,10.7911166" id="Fill-5" fill="#FEFEFE" mask="url(#mask-2)"></path></g><path d="M17.8685838,9.92786087 C16.3152462,7.68782006 14.2755241,5.70538394 12.1135031,3.97215236 C11.5554261,3.58154525 10.9087879,2.8983328 10.1876456,3.3869417 C7.9483091,4.92836978 5.79050526,7.01860786 4.05582778,9.15084671 C3.70298819,9.66885615 3.08587035,10.1616651 3.3656117,10.8504777 C3.56663186,11.3586869 4.01646719,11.7240936 4.30604868,12.1735018 C6.00698851,14.2091389 8.01719014,16.1089735 10.1145474,17.6364013 C11.0367098,18.221612 11.6931882,17.2751947 12.4087075,16.8397868 C13.8734838,15.6875658 15.2314242,14.2875403 16.5162664,12.9253155 L16.5162664,12.8917149 C17.0307655,12.2715036 17.5747851,11.6610924 17.9768254,10.9918802 C18.1525424,10.6642743 18.0653868,10.2162661 17.8685838,9.92786087 L17.8685838,9.92786087 Z M10.4477066,5.41697869 L10.6431039,4.79256731 L10.6684071,4.79256731 C11.0704474,5.9391882 11.4865451,7.08300904 11.9181059,8.21422965 L11.0549843,8.22962993 L11.0367098,8.33183179 L11.163226,11.4020877 L11.163226,11.4510886 C10.844124,11.5042896 10.4533296,11.4902893 10.1384449,11.4608888 L10.1145474,11.4258882 L10.2565266,8.26323054 L10.2565266,8.23943011 C10.0161459,8.21422965 9.71250703,8.23943011 9.46790907,8.21422965 L10.4477066,5.41697869 Z M9.93742469,15.6203646 C10.0217688,14.491944 10.0358262,13.4531251 10.0948671,12.3289046 C10.4912844,12.3695053 10.8356896,12.3541051 11.1969636,12.3401048 L11.2222668,12.4913076 L11.3642461,15.6301648 C10.8891076,15.698766 10.3844486,15.6595653 9.93742469,15.6203646 L9.93742469,15.6203646 Z M13.5501647,11.7058933 C11.492168,12.3443049 8.90420917,12.3149044 6.95304844,11.4608888 C6.60020885,11.2900857 6.15459073,11.0268809 6.03650896,10.6166734 C5.94794763,9.86485972 6.75624548,9.44905214 7.30588802,9.17604717 C7.62920717,9.03464459 7.95814925,8.87924176 8.31520604,8.8596414 C8.64836533,9.10324584 8.99698771,9.29924941 9.33998715,9.51765339 C8.67366857,9.69405661 7.87380512,9.84525936 7.56594907,10.5718726 C7.61936702,11.1248827 8.24632501,11.2998859 8.68350872,11.4370884 C10.2565266,11.8514959 11.9574665,11.7968949 13.4672263,11.250885 C13.7511848,11.0842819 14.2024259,10.8840783 14.1630653,10.4752708 C14.1138646,10.0356628 13.6092056,9.84105928 13.256366,9.70245676 C13.0412885,9.73185729 12.8346454,9.78085819 12.6336252,9.84525936 C12.5253836,9.54285385 12.432605,9.23484824 12.3046831,8.94224291 C12.9724074,9.1172461 13.638726,9.29924941 14.3289421,9.41965161 L14.3289421,9.43505189 C14.1869628,9.44905214 14.0309262,9.49805304 13.8931641,9.551254 L13.8931641,9.57645446 C14.2853643,9.77105801 14.8293839,10.0944639 14.8336011,10.6068732 C14.7422283,11.2270845 14.0604466,11.5098897 13.5501647,11.7058933 L13.5501647,11.7058933 Z" id="Fill-8" fill="#FEFEFE"></path><path d="M14.1946944,19.3564726 L14.1946944,19.1646691 L14.3141819,19.1646691 C14.3788457,19.1646691 14.467407,19.1716693 14.467407,19.2528707 C14.467407,19.3410724 14.4224235,19.3564726 14.3465138,19.3564726 L14.1946944,19.3564726 Z M14.1946944,19.4922751 L14.2748213,19.4922751 L14.4603783,19.8268812 L14.6613985,19.8268812 L14.4575669,19.4782749 C14.562997,19.4698747 14.6501526,19.4166737 14.6501526,19.2710711 C14.6501526,19.0890678 14.5278536,19.0302667 14.3226163,19.0302667 L14.0231946,19.0302667 L14.0231946,19.8268812 L14.1946944,19.8268812 L14.1946944,19.4922751 Z M15.0620331,19.429274 C15.0620331,18.9630655 14.7105992,18.6900605 14.3183991,18.6900605 C13.9233874,18.6900605 13.5719536,18.9630655 13.5719536,19.429274 C13.5719536,19.8954825 13.9233874,20.1670874 14.3183991,20.1670874 C14.7105992,20.1670874 15.0620331,19.8954825 15.0620331,19.429274 L15.0620331,19.429274 Z M14.8483613,19.429274 C14.8483613,19.7694802 14.6051691,19.9976843 14.3183991,19.9976843 L14.3183991,19.9962843 C14.0231946,19.9976843 13.7856254,19.7694802 13.7856254,19.429274 C13.7856254,19.0890678 14.0231946,18.8622636 14.3183991,18.8622636 C14.6051691,18.8622636 14.8483613,19.0890678 14.8483613,19.429274 L14.8483613,19.429274 Z" id="Fill-10" fill="#FEFEFE"></path></g></g></g></g></svg><!-- End User Code --></div></div></div></div><div class="topbar-sticky announcement-show" id="sTop_Bar_0_0_25_0_0_12_0_1"><div id="sTop_Bar_0_0_25_0_0_12_0_1_0" class="js-hidden-panel" data-offset="0"></div><div class="rebelbar-wrapper_static announcement-show" id="sTop_Bar_0_0_25_0_0_12_0_1_1"><span class="js-brick-description hidden" data-name="Announcement Bar"></span><div class="announcement-bar" id="sAnnouncement_Bar_0_0_0_0_0_0"><!-- Formatted Text --><div class="formatted-text ql-editor"><p>The June 2022 issue of <em>IEEE Spectrum</em> is here!</p></div><!-- End Formatted Text --><div class="download_pdf_button" id="sAnnouncement_Bar_0_0_0_0_0_0_1_1_1"><div class="text-element" id="sAnnouncement_Bar_0_0_0_0_0_0_1_1_1_0"><a href="#" class="color-inherit" target="">Download PDF <span>↓</span></a></div></div><!-- User Code --><script>
  	document.querySelector(".download_pdf_button .text-element").addEventListener("click", function(event){
  		event.preventDefault();
      	openGatedPopup('for_pdf_issues');
	}); 
</script><!-- End User Code --><!-- User Code --><a href="javascript:void(0);" class="icon-close announcement-close" onclick="document.querySelector(&#39;.rebelbar-wrapper_static&#39;).classList.toggle(&#39;announcement-show&#39;); document.querySelector(&#39;.topbar-sticky &#39;).classList.toggle(&#39;announcement-show&#39;); document.querySelector(&#39;.topbar-sticky &#39;).style.height = &#39;64px&#39;; document.querySelector(&#39;.section-frontpage .topbar-sticky &#39;).style.height = &#39;111px&#39;;">Close bar</a><!-- End User Code --></div><span class="js-brick-description hidden" data-name="__TopBar Second Bar"></span><div class="" id="s__TopBar_Second_Bar_0_0_34_0_0_0"><div class="site_logo" id="s__TopBar_Second_Bar_0_0_34_0_0_0_0"><!-- User Code --><a href="/" title="Spectrum Logo"><svg width="214px" height="30px" viewbox="0 0 214 30" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-Sticky-Site-Header-/-1376" transform="translate(-33.000000, -17.000000)" fill="#0D0D0D" fill-rule="nonzero"><g id="IEEE-Spectrum-Logo" transform="translate(32.000000, 15.000000)"><g id="IEEESpectrum-LogoFinal-Black" transform="translate(1.454545, 2.909091)"><path d="M67.5731087,15.3769418 C67.7375958,17.1915012 68.9067885,18.8411007 71.9786975,18.8411007 C74.7749795,18.8411007 75.8285865,17.851341 75.8285865,16.3310345 C75.8285865,14.882062 74.9750314,14.1553466 73.3301597,13.923511 L68.5600317,13.3974225 C64.6123396,12.9515848 62.3361928,10.6911877 62.3361928,6.96398467 C62.3361928,2.83552769 65.4481122,6.3357346e-15 71.7475264,6.3357346e-15 C78.4915004,6.3357346e-15 81.1899792,3.23232323 81.4833887,7.133403 L75.7485657,7.133403 C75.5173945,5.38126088 74.2014972,4.22654127 71.7475264,4.22654127 C69.5247267,4.22654127 68.191047,5.11821665 68.191047,6.57164751 C68.191047,7.6907001 68.8489957,8.51549983 70.5294322,8.71612679 L74.7082955,9.16196447 C79.5095427,9.60780216 81.6834407,11.8994079 81.6834407,15.8495298 C81.6834407,20.1741553 78.984962,23.0765587 71.8764488,23.0765587 C64.6701324,23.0765587 62.1717056,19.3136886 61.9405344,15.390317 L67.5731087,15.3769418 Z" id="Path"></path><path d="M101.439684,14.266806 C101.439684,18.8544758 99.3013506,23.0141414 93.8821651,23.0141414 C91.0858831,23.0141414 89.2098403,21.9575061 88.102886,20.1741553 L88.102886,29.0909091 L82.456975,29.0909091 L82.456975,6.00543365 L88.1162228,6.00543365 L88.1162228,8.23462208 C89.2320682,6.48693835 91.1081111,5.46597005 93.8955019,5.46597005 C99.3013506,5.47934518 101.439684,9.53646813 101.439684,14.266806 Z M95.7804359,14.266806 C95.7804359,11.1994427 94.7935129,9.91097179 91.997231,9.91097179 C89.1031459,9.91097179 88.1162228,11.3287356 88.1162228,14.266806 C88.1162228,17.2048763 89.1031459,18.6226402 91.997231,18.6226402 C94.7935129,18.6092651 95.7804359,17.3207941 95.7804359,14.266806 Z" id="Shape"></path><path d="M114.367486,17.5214211 L119.862247,17.5214211 C119.302102,20.3569488 117.065965,23.0319749 111.077743,23.0319749 C104.364888,23.0319749 101.995384,18.7430164 101.995384,14.2222222 C101.995384,9.43838384 104.760546,5.47934518 111.077743,5.47934518 C117.790598,5.47934518 119.928931,9.73263671 119.928931,14.3203065 C119.934228,14.7845667 119.900021,15.2484337 119.826682,15.7068617 L107.490144,15.7068617 C107.819119,18.3462208 109.103897,19.2378962 111.211111,19.2378962 C112.887102,19.2378962 113.905144,18.5111808 114.367486,17.5214211 Z M107.556828,12.4076628 L114.563093,12.4076628 C114.367486,10.3256008 113.349444,9.20654824 111.144427,9.20654824 C109.103897,9.20654824 107.921368,10.031348 107.556828,12.4076628 Z" id="Shape"></path><path d="M129.811498,5.47934518 C135.764156,5.47934518 138.662686,8.84096134 138.791609,12.9649599 L133.247946,12.9649599 C133.083459,11.0211076 132.096536,9.89759666 129.895965,9.89759666 C127.52646,9.89759666 126.174998,10.954232 126.174998,14.2534309 C126.174998,17.5526297 127.459776,18.6092651 129.793716,18.6092651 C132.127655,18.6092651 133.119024,17.3207941 133.31463,15.4884013 L138.876075,15.4884013 C138.742707,19.4162313 136.013109,23.0141966 129.895965,23.0141966 C123.085307,23.0319749 120.520196,18.7251829 120.520196,14.266806 C120.520196,9.80842912 123.018623,5.47934518 129.811498,5.47934518 Z" id="Path"></path><path d="M141.77016,16.0011146 L141.77016,10.2542668 L138.876075,10.2542668 L138.876075,7.62382445 L142.228057,6.13472658 L144.566442,2.01072797 L147.429408,2.01072797 L147.429408,6.02326715 L151.901681,6.02326715 L151.901681,10.2542668 L147.429408,10.2542668 L147.429408,18.0163009 L151.3771,18.0163009 L151.3771,22.5014281 L148.380766,22.5014281 C143.348348,22.5014281 141.77016,20.2588645 141.77016,16.0011146 Z" id="Path"></path><path d="M164.304903,5.74238941 L164.304903,11.2529432 L162.299938,11.2529432 C159.565894,11.2529432 158.414484,12.5904563 158.414484,15.9030303 L158.414484,22.5014281 L152.755236,22.5014281 L152.755236,6.00543365 L158.263333,6.00543365 L158.263333,9.36259143 C158.921282,7.0174852 160.272744,5.73347266 162.935658,5.73347266 L164.304903,5.74238941 Z" id="Path"></path><path d="M182.989757,6.00543365 L182.989757,22.5014281 L177.330509,22.5014281 L177.330509,19.5009404 C176.281347,21.6454197 174.405304,23.0319749 171.511219,23.0319749 C167.198988,23.0319749 165.256261,20.3569488 165.256261,16.0367816 L165.256261,6.00543365 L170.915509,6.00543365 L170.915509,15.0470219 C170.915509,17.2762104 171.804629,18.4443051 173.81404,18.4443051 C176.014611,18.4443051 177.330509,16.9239986 177.330509,13.758551 L177.330509,6.00543365 L182.989757,6.00543365 Z" id="Path"></path><path d="M213.090909,12.4834552 L213.090909,22.5148032 L207.431661,22.5148032 L207.431661,13.3305468 C207.431661,11.2172762 206.613671,10.0625566 204.737628,10.0625566 C202.514828,10.0625566 201.479004,11.5159875 201.479004,14.7483107 L201.479004,22.5014281 L195.917559,22.5014281 L195.917559,13.3305468 C195.917559,11.2172762 195.095123,10.0625566 193.223526,10.0625566 C191.000726,10.0625566 189.964902,11.5159875 189.964902,14.7483107 L189.964902,22.5014281 L184.305654,22.5014281 L184.305654,6.00543365 L189.964902,6.00543365 L189.964902,8.8097527 C190.982944,6.76335772 192.725619,5.47934518 195.557466,5.47934518 C198.389312,5.47934518 200.163106,6.81685824 200.985542,9.13967259 C202.003585,6.91048415 203.812943,5.47934518 206.809277,5.47934518 C211.117063,5.47934518 213.090909,8.14991292 213.090909,12.4834552 Z" id="Path"></path><polygon id="Path" points="11.9408796 7.10219436 11.9408796 3.0450714 0 3.0450714 0 7.10219436 3.14303867 7.10219436 3.14303867 18.4086381 0 18.4086381 0 22.4702194 11.9408796 22.4702194 11.9408796 18.4086381 8.80228652 18.4086381 8.80228652 7.10219436"></polygon><polygon id="Path" points="18.8537864 18.4086381 18.8537864 14.467433 26.0378748 14.467433 26.0378748 10.6956461 18.8537864 10.6956461 18.8537864 7.10219436 26.9136579 7.10219436 26.9136579 3.0450714 18.8537864 3.0450714 13.1945386 3.0450714 13.1945386 22.4613027 13.1945386 22.4702194 27.0025699 22.4702194 27.0025699 18.4086381"></polygon><polygon id="Path" points="33.6487408 18.4086381 33.6487408 14.467433 40.8372748 14.467433 40.8372748 10.6956461 33.6487408 10.6956461 33.6487408 7.10219436 41.7086122 7.10219436 41.7086122 3.0450714 33.6487408 3.0450714 27.9939385 3.0450714 27.9939385 22.4613027 27.9939385 22.4702194 41.7975242 22.4702194 41.7975242 18.4086381"></polygon><polygon id="Path" points="48.4481407 18.4086381 48.4481407 14.467433 55.6322291 14.467433 55.6322291 10.6956461 48.4481407 10.6956461 48.4481407 7.10219436 56.5080121 7.10219436 56.5080121 3.0450714 48.4481407 3.0450714 42.7888928 3.0450714 42.7888928 22.4613027 42.7888928 22.4702194 56.5924785 22.4702194 56.5924785 18.4086381"></polygon></g></g></g></g></svg></a><!-- End User Code --><div class="topbar__sticky-headline topbar__sticky-headline--post" id="s__TopBar_Second_Bar_0_0_34_0_0_0_0_1_0_1"><div class="text-element" id="s__TopBar_Second_Bar_0_0_34_0_0_0_0_1_0_1_0">Flea-Sized Robots Walk a Coin-Edge-Sized Path</div></div><!-- User Code --><span class="floating-shares hide-desktop">Share</span><!-- End User Code --><!-- User Code --><script>
  function createElementChangeListener(selector, callback, oneTime) {
    const initializedNodes = new Set([]);
    let reported = false;

    document.querySelectorAll(selector).forEach((node) => {
      if (oneTime && reported) {
        return;
      }
      reported = true;
      callback(node);
      initializedNodes.add(node);
    });

    const mutationObserver = new MutationObserver(() => {
      const nodes = document.querySelectorAll(selector);
      nodes.forEach((node) => {
        if (oneTime && reported) {
          return;
        }

        if (!initializedNodes.has(node)) {
          reported = true;
          callback(node);
          initializedNodes.add(node);
          if (oneTime) {
            mutationObserver.disconnect();
          }
        }
      });
    });

    if (!oneTime || !reported) {
      mutationObserver.observe(document.body, {
        childList: true,
        subtree: true,
      });
    }
    return mutationObserver;
  }
  
</script><!-- End User Code --><div class="topbar__static-headline" id="s__TopBar_Second_Bar_0_0_34_0_0_0_0_2"><div class="text-element" id="s__TopBar_Second_Bar_0_0_34_0_0_0_0_2_0">FOR THE TECHNOLOGY INSIDER</div></div></div><div class="" id="s__TopBar_Second_Bar_0_0_34_0_0_0_1"><div class="search-form"><form action="/search/"><label for="q" class="hide-text">Search: </label><input placeholder="Type to search" type="text" name="q" id="q" class="search-form__text-input"/><button aria-label="Search" type="submit" class="search-form__submit" value="Search"><svg width="18px" height="19px" viewbox="0 0 18 19" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="1376---Sample-Front-Page" transform="translate(-826.000000, -102.000000)" stroke="#0D0D0D" stroke-width="1.5"><g id="Light-/-Nav" transform="translate(816.857864, 96.000000)"><g id="Search-Icon" transform="translate(7.307612, 5.000000)"><path d="M11.631728,14.6819805 C15.2215789,14.6819805 18.131728,11.7718314 18.131728,8.18198052 C18.131728,4.59212964 15.2215789,1.68198052 11.631728,1.68198052 C8.04187711,1.68198052 5.13172798,4.59212964 5.13172798,8.18198052 C5.13172798,11.7718314 8.04187711,14.6819805 11.631728,14.6819805 Z M11.631728,14.5814755 L11.631728,21.5814755" id="Combined-Shape" transform="translate(11.631728, 11.631728) rotate(-45.000000) translate(-11.631728, -11.631728) "></path></g></g></g></g></svg></button></form></div><span class="js-brick-description hidden" data-name="Element Menu"></span><div class="main-menu-el" id="sElement_Menu_0_0_8_0_0_0"><div class="menu-item" id="sElement_Menu_0_0_8_0_0_0_0"><!-- User Code --><div class="menu-item__title">Explore by topic</div><!-- End User Code --><div class="menu-dropdown" id="sElement_Menu_0_0_8_0_0_0_0_1"><div class="list" id="sElement_Menu_0_0_8_0_0_0_0_1_0"><a href="/topic/aerospace/" class="list__item" target="_self">Aerospace</a><a href="/topic/artificial-intelligence/" class="list__item" target="_self">Artificial Intelligence</a><a href="/topic/biomedical/" class="list__item" target="_self">Biomedical</a><a href="/topic/computing/" class="list__item" target="_self">Computing</a><a href="/topic/consumer-electronics/" class="list__item" target="_self">Consumer Electronics</a><a href="/topic/energy/" class="list__item" target="_self">Energy</a><a href="/topic/tech-history/" class="list__item" target="_self">History of Technology</a><a href="/topic/robotics/" class="list__item" target="_self">Robotics</a><a href="/topic/semiconductors/" class="list__item" target="_self">Semiconductors</a><a href="/topic/sensors/" class="list__item" target="_self">Sensors</a><a href="/topic/telecommunications/" class="list__item" target="_self">Telecommunications</a><a href="/topic/transportation/" class="list__item" target="_self">Transportation</a></div></div></div></div><!-- User Code --><div data-share-status-id="huge-menu-toggle" data-toggle-class="huge-menu-opened" class="rebelbar__menu-toggle js-toggle hambg-btn" data-target="body"><svg width="32px" height="18px" viewbox="0 0 32 18" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="992---Search---Open-filters---selected" transform="translate(-928.000000, -75.000000)"><g id="Light-/-Collapsed-Site-Header" transform="translate(0.000000, 56.000000)"><g id="Light-/-Nav" transform="translate(432.857864, 12.000000)"><g id="Group" transform="translate(495.142136, 7.000000)"><rect id="Rectangle" x="0" y="0" width="32" height="2"></rect><rect id="Rectangle-Copy" x="0" y="8" width="32" height="2"></rect><rect id="Rectangle-Copy-2" x="0" y="16" width="32" height="2"></rect></g></g></g></g></g></svg></div><!-- End User Code --></div></div></div></div></div></div><div class="huge-menu" id="sTop_Bar_0_0_25_0_0_13"><span class="js-brick-description hidden" data-name="__Huge Menu Links"></span><div id="s__Huge_Menu_Links_0_0_30_0_0_1" class="dark_layout row-wrapper clearfix  content sm-cp-2 md-cp-4"><div class="row px20"><div id="s__Huge_Menu_Links_0_0_30_0_0_1_0" class="Top_hugeMenu col sm-mb-2 md-mb-4 s12 m12 l12"><div class="" id="s__Huge_Menu_Links_0_0_30_0_0_1_0_0"><!-- User Code --><a href="/" class="hide-text">IEEE Spectrum<svg width="214px" height="30px" class="site_logo_menu" viewbox="0 0 214 30" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-Sticky-Site-Header-/-1376" transform="translate(-33.000000, -17.000000)" fill="#F2F2F2" fill-rule="nonzero"><g id="IEEE-Spectrum-Logo" transform="translate(32.000000, 15.000000)"><g id="IEEESpectrum-LogoFinal-Black" transform="translate(1.454545, 2.909091)"><path d="M67.5731087,15.3769418 C67.7375958,17.1915012 68.9067885,18.8411007 71.9786975,18.8411007 C74.7749795,18.8411007 75.8285865,17.851341 75.8285865,16.3310345 C75.8285865,14.882062 74.9750314,14.1553466 73.3301597,13.923511 L68.5600317,13.3974225 C64.6123396,12.9515848 62.3361928,10.6911877 62.3361928,6.96398467 C62.3361928,2.83552769 65.4481122,6.3357346e-15 71.7475264,6.3357346e-15 C78.4915004,6.3357346e-15 81.1899792,3.23232323 81.4833887,7.133403 L75.7485657,7.133403 C75.5173945,5.38126088 74.2014972,4.22654127 71.7475264,4.22654127 C69.5247267,4.22654127 68.191047,5.11821665 68.191047,6.57164751 C68.191047,7.6907001 68.8489957,8.51549983 70.5294322,8.71612679 L74.7082955,9.16196447 C79.5095427,9.60780216 81.6834407,11.8994079 81.6834407,15.8495298 C81.6834407,20.1741553 78.984962,23.0765587 71.8764488,23.0765587 C64.6701324,23.0765587 62.1717056,19.3136886 61.9405344,15.390317 L67.5731087,15.3769418 Z" id="Path"></path><path d="M101.439684,14.266806 C101.439684,18.8544758 99.3013506,23.0141414 93.8821651,23.0141414 C91.0858831,23.0141414 89.2098403,21.9575061 88.102886,20.1741553 L88.102886,29.0909091 L82.456975,29.0909091 L82.456975,6.00543365 L88.1162228,6.00543365 L88.1162228,8.23462208 C89.2320682,6.48693835 91.1081111,5.46597005 93.8955019,5.46597005 C99.3013506,5.47934518 101.439684,9.53646813 101.439684,14.266806 Z M95.7804359,14.266806 C95.7804359,11.1994427 94.7935129,9.91097179 91.997231,9.91097179 C89.1031459,9.91097179 88.1162228,11.3287356 88.1162228,14.266806 C88.1162228,17.2048763 89.1031459,18.6226402 91.997231,18.6226402 C94.7935129,18.6092651 95.7804359,17.3207941 95.7804359,14.266806 Z" id="Shape"></path><path d="M114.367486,17.5214211 L119.862247,17.5214211 C119.302102,20.3569488 117.065965,23.0319749 111.077743,23.0319749 C104.364888,23.0319749 101.995384,18.7430164 101.995384,14.2222222 C101.995384,9.43838384 104.760546,5.47934518 111.077743,5.47934518 C117.790598,5.47934518 119.928931,9.73263671 119.928931,14.3203065 C119.934228,14.7845667 119.900021,15.2484337 119.826682,15.7068617 L107.490144,15.7068617 C107.819119,18.3462208 109.103897,19.2378962 111.211111,19.2378962 C112.887102,19.2378962 113.905144,18.5111808 114.367486,17.5214211 Z M107.556828,12.4076628 L114.563093,12.4076628 C114.367486,10.3256008 113.349444,9.20654824 111.144427,9.20654824 C109.103897,9.20654824 107.921368,10.031348 107.556828,12.4076628 Z" id="Shape"></path><path d="M129.811498,5.47934518 C135.764156,5.47934518 138.662686,8.84096134 138.791609,12.9649599 L133.247946,12.9649599 C133.083459,11.0211076 132.096536,9.89759666 129.895965,9.89759666 C127.52646,9.89759666 126.174998,10.954232 126.174998,14.2534309 C126.174998,17.5526297 127.459776,18.6092651 129.793716,18.6092651 C132.127655,18.6092651 133.119024,17.3207941 133.31463,15.4884013 L138.876075,15.4884013 C138.742707,19.4162313 136.013109,23.0141966 129.895965,23.0141966 C123.085307,23.0319749 120.520196,18.7251829 120.520196,14.266806 C120.520196,9.80842912 123.018623,5.47934518 129.811498,5.47934518 Z" id="Path"></path><path d="M141.77016,16.0011146 L141.77016,10.2542668 L138.876075,10.2542668 L138.876075,7.62382445 L142.228057,6.13472658 L144.566442,2.01072797 L147.429408,2.01072797 L147.429408,6.02326715 L151.901681,6.02326715 L151.901681,10.2542668 L147.429408,10.2542668 L147.429408,18.0163009 L151.3771,18.0163009 L151.3771,22.5014281 L148.380766,22.5014281 C143.348348,22.5014281 141.77016,20.2588645 141.77016,16.0011146 Z" id="Path"></path><path d="M164.304903,5.74238941 L164.304903,11.2529432 L162.299938,11.2529432 C159.565894,11.2529432 158.414484,12.5904563 158.414484,15.9030303 L158.414484,22.5014281 L152.755236,22.5014281 L152.755236,6.00543365 L158.263333,6.00543365 L158.263333,9.36259143 C158.921282,7.0174852 160.272744,5.73347266 162.935658,5.73347266 L164.304903,5.74238941 Z" id="Path"></path><path d="M182.989757,6.00543365 L182.989757,22.5014281 L177.330509,22.5014281 L177.330509,19.5009404 C176.281347,21.6454197 174.405304,23.0319749 171.511219,23.0319749 C167.198988,23.0319749 165.256261,20.3569488 165.256261,16.0367816 L165.256261,6.00543365 L170.915509,6.00543365 L170.915509,15.0470219 C170.915509,17.2762104 171.804629,18.4443051 173.81404,18.4443051 C176.014611,18.4443051 177.330509,16.9239986 177.330509,13.758551 L177.330509,6.00543365 L182.989757,6.00543365 Z" id="Path"></path><path d="M213.090909,12.4834552 L213.090909,22.5148032 L207.431661,22.5148032 L207.431661,13.3305468 C207.431661,11.2172762 206.613671,10.0625566 204.737628,10.0625566 C202.514828,10.0625566 201.479004,11.5159875 201.479004,14.7483107 L201.479004,22.5014281 L195.917559,22.5014281 L195.917559,13.3305468 C195.917559,11.2172762 195.095123,10.0625566 193.223526,10.0625566 C191.000726,10.0625566 189.964902,11.5159875 189.964902,14.7483107 L189.964902,22.5014281 L184.305654,22.5014281 L184.305654,6.00543365 L189.964902,6.00543365 L189.964902,8.8097527 C190.982944,6.76335772 192.725619,5.47934518 195.557466,5.47934518 C198.389312,5.47934518 200.163106,6.81685824 200.985542,9.13967259 C202.003585,6.91048415 203.812943,5.47934518 206.809277,5.47934518 C211.117063,5.47934518 213.090909,8.14991292 213.090909,12.4834552 Z" id="Path"></path><polygon id="Path" points="11.9408796 7.10219436 11.9408796 3.0450714 0 3.0450714 0 7.10219436 3.14303867 7.10219436 3.14303867 18.4086381 0 18.4086381 0 22.4702194 11.9408796 22.4702194 11.9408796 18.4086381 8.80228652 18.4086381 8.80228652 7.10219436"></polygon><polygon id="Path" points="18.8537864 18.4086381 18.8537864 14.467433 26.0378748 14.467433 26.0378748 10.6956461 18.8537864 10.6956461 18.8537864 7.10219436 26.9136579 7.10219436 26.9136579 3.0450714 18.8537864 3.0450714 13.1945386 3.0450714 13.1945386 22.4613027 13.1945386 22.4702194 27.0025699 22.4702194 27.0025699 18.4086381"></polygon><polygon id="Path" points="33.6487408 18.4086381 33.6487408 14.467433 40.8372748 14.467433 40.8372748 10.6956461 33.6487408 10.6956461 33.6487408 7.10219436 41.7086122 7.10219436 41.7086122 3.0450714 33.6487408 3.0450714 27.9939385 3.0450714 27.9939385 22.4613027 27.9939385 22.4702194 41.7975242 22.4702194 41.7975242 18.4086381"></polygon><polygon id="Path" points="48.4481407 18.4086381 48.4481407 14.467433 55.6322291 14.467433 55.6322291 10.6956461 48.4481407 10.6956461 48.4481407 7.10219436 56.5080121 7.10219436 56.5080121 3.0450714 48.4481407 3.0450714 42.7888928 3.0450714 42.7888928 22.4613027 42.7888928 22.4702194 56.5924785 22.4702194 56.5924785 18.4086381"></polygon></g></g></g></g></svg></a><!-- End User Code --><div class="text-element" id="s__Huge_Menu_Links_0_0_30_0_0_1_0_0_1">FOR THE TECHNOLOGY INSIDER</div><!-- User Code --><div data-share-status-id="huge-menu-toggle" data-toggle-class="huge-menu-opened" class="rebelbar__menu-toggle js-toggle hm__close js--active" data-target="body" data-loaded="true"></div><!-- End User Code --></div></div><div id="s__Huge_Menu_Links_0_0_30_0_0_1_1" class="top-menu top-menu--big-links col sm-mb-2 md-mb-4 s12 m12 l6"><!-- User Code --><h3 class="module-headline__text">Topics</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_30_0_0_1_1_1"><a href="/topic/aerospace/" class="list__item" target="_self">Aerospace</a><a href="/topic/artificial-intelligence/" class="list__item" target="_self">Artificial Intelligence</a><a href="/topic/biomedical/" class="list__item" target="_self">Biomedical</a><a href="/topic/computing/" class="list__item" target="_self">Computing</a><a href="/topic/consumer-electronics/" class="list__item" target="_self">Consumer Electronics</a><a href="/topic/energy/" class="list__item" target="_self">Energy</a><a href="/topic/tech-history/" class="list__item" target="_self">History of Technology</a><a href="/topic/robotics/" class="list__item" target="_self">Robotics</a><a href="/topic/semiconductors/" class="list__item" target="_self">Semiconductors</a><a href="/topic/sensors/" class="list__item" target="_self">Sensors</a><a href="/topic/telecommunications/" class="list__item" target="_self">Telecommunications</a><a href="/topic/transportation/" class="list__item" target="_self">Transportation</a></div></div><div id="s__Huge_Menu_Links_0_0_30_0_0_1_2" class="top-menu top-menu--sm-links col sm-mb-2 md-mb-4 s6 m12 l3"><div class="" id="s__Huge_Menu_Links_0_0_30_0_0_1_2_0"><!-- User Code --><h3 class="module-headline__text">Sections</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_30_0_0_1_2_0_1"><a href="/type/feature/" class="list__item" target="_self">Features</a><a href="/type/news/" class="list__item" target="_self">News</a><a href="/type/opinion/" class="list__item" target="_self">Opinion</a><a href="/topic/careers/" class="list__item" target="_self">Careers</a><a href="/topic/diy/" class="list__item" target="_self">DIY</a><a href="/engineering-resources/" class="list__item" target="_self">Engineering Resources</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_30_0_0_1_2_1"><!-- User Code --><h3 class="module-headline__text">More</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_30_0_0_1_2_1_1"><a href="/special-reports/" class="list__item" target="_self">Special Reports</a><a href="/type/explainer/" class="list__item" target="_self">Explainers</a><a href="/type/podcast/" class="list__item" target="_self">Podcasts</a><a href="/type/video/" class="list__item" target="_self">Videos</a><a href="/newsletters/" class="list__item" target="_self">Newsletters</a><a href="/top-programming-languages" class="list__item" target="_self">Top Programming Languages</a><a href="https://robots.ieee.org/" class="list__item" target="_blank">Robots Guide</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_30_0_0_1_2_2"><!-- User Code --><h3 class="module-headline__text">For IEEE Members</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_30_0_0_1_2_2_1"><a href="/magazine/current-issue" class="list__item" target="_self">Current Issue</a><a href="/magazine/" class="list__item" target="_self">Magazine Archive</a><a href="/the-institute/" class="list__item" target="_self">The Institute</a><a href="/the-institute/ti-archive/" class="list__item" target="_self">TI Archive</a></div></div></div><div id="s__Huge_Menu_Links_0_0_30_0_0_1_3" class="top-menu top-menu--sm-links col sm-mb-2 md-mb-4 s6 m12 l3"><div class="" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_0"><!-- User Code --><h3 class="module-headline__text">For IEEE Members</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_0_1"><a href="/magazine/current-issue" class="list__item" target="_self">Current Issue</a><a href="/magazine/" class="list__item" target="_self">Magazine Archive</a><a href="/the-institute/" class="list__item" target="_self">The Institute</a><a href="/the-institute/ti-archive/" class="list__item" target="_self">TI Archive</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_1"><!-- User Code --><h3 class="module-headline__text">IEEE Spectrum</h3><!-- End User Code --><div class="list" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_1_1"><a href="/st/about" class="list__item" target="_self">About Us</a><a href="/st/contact" class="list__item" target="_self">Contact Us</a><a href="https://www.parsintl.com/publications/ieee-media/" class="list__item" target="_blank">Reprints &amp; Permissions</a><a href="https://advertise.ieee.org/ " class="list__item" target="_blank">Advertising</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_2"><!-- User Code --><h3 class="module-headline__text">Follow IEEE Spectrum</h3><!-- End User Code --><div class="sm-mb-2" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_2_1"><div class="social-links"><a class="social-links__link share-twitter" href="https://twitter.com/ieeespectrum" target="_blank" rel="noopener noreferrer" aria-label="Open twitter"><span aria-hidden="true" class="fa fa-twitter"></span></a><a class="social-links__link share-facebook" href="https://www.facebook.com/IEEE.Spectrum" target="_blank" rel="noopener noreferrer" aria-label="Open facebook"><span aria-hidden="true" class="fa fa-facebook"></span></a><a class="social-links__link share-instagram" href="https://www.instagram.com/ieeespectrum/" target="_blank" rel="noopener noreferrer" aria-label="Open instagram"><span aria-hidden="true" class="fa fa-instagram"></span></a><a class="social-links__link share-linkedin" href="https://www.linkedin.com/company/ieee-spectrum/" target="_blank" rel="noopener noreferrer" aria-label="Open linkedin"><span aria-hidden="true" class="fa fa-linkedin"></span></a><a class="social-links__link share-tumblr" href="/feeds/feed.rss" target="_blank" rel="noopener noreferrer" aria-label="Open tumblr"><span aria-hidden="true" class="fa fa-tumblr"></span></a></div></div></div><div class="" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_3"><!-- User Code --><h3 class="module-headline__text">Support IEEE Spectrum</h3><!-- End User Code --><div class="text-element" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_3_1"><i>IEEE Spectrum</i> is the flagship publication of the IEEE — the world’s largest professional organization devoted to engineering and applied sciences. Our articles, podcasts, and infographics inform our readers about developments in technology, engineering, and science.</div><div class="text-element" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_3_2"><a href="/st/join" class="color-inherit" rel="orange_button" target="_self">Join IEEE</a></div><div class="text-element" id="s__Huge_Menu_Links_0_0_30_0_0_1_3_3_3"><a href="https://ieee.omeda.com/ieee/r-main.do" class="color-inherit" rel="orange_button" target="_blank">Subscribe</a></div></div></div><div id="s__Huge_Menu_Links_0_0_30_0_0_1_4" class=" col sm-mb-2 md-mb-4 s12 m12 l12"></div><div id="s__Huge_Menu_Links_0_0_30_0_0_1_5" class=" col sm-mb-2 md-mb-4 s12 m12 l12"><span class="js-brick-description hidden" data-name="Footer"></span><div class="footer" id="sFooter_0_0_9_0_0_0"><div class="" id="sFooter_0_0_9_0_0_0_0"><div id="sFooter_0_0_9_0_0_0_0_0" class=" row-wrapper clearfix  content sm-cp-2 md-cp-4"><div class="row "><div id="sFooter_0_0_9_0_0_0_0_0_0" class=" col sm-mb-2 md-mb-4 s12 m10 l10"><div class="bottom_menu_links" id="sFooter_0_0_9_0_0_0_0_0_0_0"><div class="list" id="sFooter_0_0_9_0_0_0_0_0_0_0_0"><a href="https://www.ieee.org/about/" class="list__item" target="_blank">About IEEE</a><a href="https://www.ieee.org/about/contact.html" class="list__item" target="_blank">Contact &amp; Support</a><a href="https://www.ieee.org/accessibility-statement.html" class="list__item" target="_blank">Accessibility</a><a href="https://www.ieee.org/about/corporate/governance/p9-26.html" class="list__item" target="_blank">Nondiscrimination Policy</a><a href="https://www.ieee.org/about/help/site-terms-conditions.html" class="list__item" target="_blank">Terms</a><a href="https://www.ieee.org/security-privacy.html" class="list__item" target="_blank">IEEE Privacy Policy</a></div></div><div class="ftr-copy" id="sFooter_0_0_9_0_0_0_0_0_0_1">© Copyright 2022 IEEE — All rights reserved. A not-for-profit organization, IEEE is the world&#39;s largest technical professional organization dedicated to advancing technology for the benefit of humanity.</div></div><div id="sFooter_0_0_9_0_0_0_0_0_1" class=" col sm-mb-2 md-mb-4 s12 m2 l2"><!-- User Code --><svg viewbox="0 0 70 21" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="0 0 21.3639449 0 21.3639449 21 0 21"></polygon></defs><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-IEEE-Bar-/-Signed-out-/-1376" transform="translate(-1274.000000, -14.000000)"><g id="Group-13" transform="translate(1274.000000, 14.000000)"><polygon id="Fill-1" fill="#FEFEFE" points="23.4111174 18.6889405 27.8363724 18.6889405 27.8363724 2.77905063 23.4111174 2.77905063"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="29.7536549 18.6881005 29.7536549 2.77821061 41.9217005 2.77821061 41.9217005 5.8624668 34.17891 5.8624668 34.17891 9.14692664 41.3017712 9.14692664 41.3017712 12.2311828 34.17891 12.2311828 34.17891 15.6024442 41.9217005 15.6024442 41.9217005 18.6881005"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="43.7923126 18.6881005 43.7923126 2.77821061 55.9603583 2.77821061 55.9603583 5.8624668 48.2175677 5.8624668 48.2175677 9.14692664 55.3418347 9.14692664 55.3418347 12.2311828 48.2175677 12.2311828 48.2175677 15.6024442 55.9603583 15.6024442 55.9603583 18.6881005"></polygon><polygon id="Fill-4" fill="#FEFEFE" points="57.8305486 2.77793061 57.8305486 18.6878205 70 18.6878205 70 15.6021642 62.2558037 15.6021642 62.2558037 12.2323028 69.3800707 12.2323028 69.3800707 9.14664663 62.2558037 9.14664663 62.2558037 5.8621868 70 5.8621868 70 2.77793061"></polygon><g id="Group-12"><g id="Group-7"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-6"></g><path d="M20.9520644,9.85449953 L20.8930235,9.84469935 C19.0838421,8.61967703 17.3983653,7.23365178 15.8098843,5.66142314 L14.0555265,3.83578988 C13.3442244,3.05037557 12.6540084,2.18095973 11.9961242,1.35074461 L11.1976665,0.22232405 C11.099265,0.164923005 10.976966,0.0669212192 10.8687244,0.0375206836 C10.6339666,-0.0646811784 10.3795285,0.0571210406 10.1883485,0.202723693 L8.74184673,2.07875787 C6.42378906,4.93900998 3.67838782,7.60885862 0.684171419,9.65429588 C0.448007872,9.84049927 0.0951682866,10.0211026 0.0220700458,10.3235081 C-0.0566511366,10.596513 0.0853281388,10.8219172 0.256827858,10.9913202 C2.65360672,12.6363502 4.94776689,14.5907858 6.98748895,16.8168264 C7.35016869,17.1962333 7.64396739,17.5728401 7.99680697,17.9284466 C8.59424452,18.719461 9.29570648,19.5160755 9.84534902,20.364491 C10.0168487,20.5450943 10.0463692,20.8390996 10.3148646,20.9259012 C10.525725,20.9987026 10.785786,21.0477034 10.9868062,20.9259012 L11.1878263,20.7256976 C13.6675436,17.2256338 16.8149851,14.0825766 20.3293236,11.5429303 C20.6821632,11.2321246 21.3541047,11.1145225 21.3639449,10.5335119 C21.3386417,10.264707 21.182605,10.0015022 20.9520644,9.85449953 M18.5496626,10.7911166 C18.1476223,11.7879348 17.3337015,12.5831492 16.6238051,13.4525651 C15.0845249,15.1017951 13.4623062,16.6992242 11.6432846,17.9718474 C11.2763877,18.2322522 10.7815688,18.4702565 10.3401679,18.2658528 C9.00190778,17.56724 7.87450799,16.4248192 6.7035304,15.3860003 C5.34559001,14.1301774 3.98202667,12.6713508 2.95302836,11.142523 C2.80120893,10.9283191 2.75763114,10.6651143 2.76184834,10.3823091 C2.89398747,9.85449953 3.2566672,9.42049162 3.60107238,8.97668354 C4.81562776,7.43385543 6.30570729,5.96942875 7.80984416,4.63240439 C7.84498755,4.59740376 7.90824564,4.5232024 7.96306932,4.48960179 C8.60970761,3.93379167 9.25212869,3.44098269 9.92828741,2.95657386 C10.6339666,2.41056392 11.5209856,2.86417218 12.114206,3.36678134 C12.7369467,3.83998996 13.383585,4.37759975 13.9529079,4.9236097 L14.0555265,4.98241077 C15.6285445,6.43703727 17.0891035,8.05406673 18.2910073,9.76209785 C18.4864045,10.0603033 18.6579042,10.3963094 18.5496626,10.7911166" id="Fill-5" fill="#FEFEFE" mask="url(#mask-2)"></path></g><path d="M17.8685838,9.92786087 C16.3152462,7.68782006 14.2755241,5.70538394 12.1135031,3.97215236 C11.5554261,3.58154525 10.9087879,2.8983328 10.1876456,3.3869417 C7.9483091,4.92836978 5.79050526,7.01860786 4.05582778,9.15084671 C3.70298819,9.66885615 3.08587035,10.1616651 3.3656117,10.8504777 C3.56663186,11.3586869 4.01646719,11.7240936 4.30604868,12.1735018 C6.00698851,14.2091389 8.01719014,16.1089735 10.1145474,17.6364013 C11.0367098,18.221612 11.6931882,17.2751947 12.4087075,16.8397868 C13.8734838,15.6875658 15.2314242,14.2875403 16.5162664,12.9253155 L16.5162664,12.8917149 C17.0307655,12.2715036 17.5747851,11.6610924 17.9768254,10.9918802 C18.1525424,10.6642743 18.0653868,10.2162661 17.8685838,9.92786087 L17.8685838,9.92786087 Z M10.4477066,5.41697869 L10.6431039,4.79256731 L10.6684071,4.79256731 C11.0704474,5.9391882 11.4865451,7.08300904 11.9181059,8.21422965 L11.0549843,8.22962993 L11.0367098,8.33183179 L11.163226,11.4020877 L11.163226,11.4510886 C10.844124,11.5042896 10.4533296,11.4902893 10.1384449,11.4608888 L10.1145474,11.4258882 L10.2565266,8.26323054 L10.2565266,8.23943011 C10.0161459,8.21422965 9.71250703,8.23943011 9.46790907,8.21422965 L10.4477066,5.41697869 Z M9.93742469,15.6203646 C10.0217688,14.491944 10.0358262,13.4531251 10.0948671,12.3289046 C10.4912844,12.3695053 10.8356896,12.3541051 11.1969636,12.3401048 L11.2222668,12.4913076 L11.3642461,15.6301648 C10.8891076,15.698766 10.3844486,15.6595653 9.93742469,15.6203646 L9.93742469,15.6203646 Z M13.5501647,11.7058933 C11.492168,12.3443049 8.90420917,12.3149044 6.95304844,11.4608888 C6.60020885,11.2900857 6.15459073,11.0268809 6.03650896,10.6166734 C5.94794763,9.86485972 6.75624548,9.44905214 7.30588802,9.17604717 C7.62920717,9.03464459 7.95814925,8.87924176 8.31520604,8.8596414 C8.64836533,9.10324584 8.99698771,9.29924941 9.33998715,9.51765339 C8.67366857,9.69405661 7.87380512,9.84525936 7.56594907,10.5718726 C7.61936702,11.1248827 8.24632501,11.2998859 8.68350872,11.4370884 C10.2565266,11.8514959 11.9574665,11.7968949 13.4672263,11.250885 C13.7511848,11.0842819 14.2024259,10.8840783 14.1630653,10.4752708 C14.1138646,10.0356628 13.6092056,9.84105928 13.256366,9.70245676 C13.0412885,9.73185729 12.8346454,9.78085819 12.6336252,9.84525936 C12.5253836,9.54285385 12.432605,9.23484824 12.3046831,8.94224291 C12.9724074,9.1172461 13.638726,9.29924941 14.3289421,9.41965161 L14.3289421,9.43505189 C14.1869628,9.44905214 14.0309262,9.49805304 13.8931641,9.551254 L13.8931641,9.57645446 C14.2853643,9.77105801 14.8293839,10.0944639 14.8336011,10.6068732 C14.7422283,11.2270845 14.0604466,11.5098897 13.5501647,11.7058933 L13.5501647,11.7058933 Z" id="Fill-8" fill="#FEFEFE"></path><path d="M14.1946944,19.3564726 L14.1946944,19.1646691 L14.3141819,19.1646691 C14.3788457,19.1646691 14.467407,19.1716693 14.467407,19.2528707 C14.467407,19.3410724 14.4224235,19.3564726 14.3465138,19.3564726 L14.1946944,19.3564726 Z M14.1946944,19.4922751 L14.2748213,19.4922751 L14.4603783,19.8268812 L14.6613985,19.8268812 L14.4575669,19.4782749 C14.562997,19.4698747 14.6501526,19.4166737 14.6501526,19.2710711 C14.6501526,19.0890678 14.5278536,19.0302667 14.3226163,19.0302667 L14.0231946,19.0302667 L14.0231946,19.8268812 L14.1946944,19.8268812 L14.1946944,19.4922751 Z M15.0620331,19.429274 C15.0620331,18.9630655 14.7105992,18.6900605 14.3183991,18.6900605 C13.9233874,18.6900605 13.5719536,18.9630655 13.5719536,19.429274 C13.5719536,19.8954825 13.9233874,20.1670874 14.3183991,20.1670874 C14.7105992,20.1670874 15.0620331,19.8954825 15.0620331,19.429274 L15.0620331,19.429274 Z M14.8483613,19.429274 C14.8483613,19.7694802 14.6051691,19.9976843 14.3183991,19.9976843 L14.3183991,19.9962843 C14.0231946,19.9976843 13.7856254,19.7694802 13.7856254,19.429274 C13.7856254,19.0890678 14.0231946,18.8622636 14.3183991,18.8622636 C14.6051691,18.8622636 14.8483613,19.0890678 14.8483613,19.429274 L14.8483613,19.429274 Z" id="Fill-10" fill="#FEFEFE"></path></g></g></g></g></svg><!-- End User Code --></div></div></div></div></div></div></div></div></div><div id="sTop_Bar_0_0_25_0_0_14" data-toggle-property="gdpr" class="gdpr-cookie hidden hidden"><span class="js-scroll-trigger" data-target="#rm-gdpr-sTop_Bar_0_0_25_0_0_14" data-toggle-class="sticky-active"></span><div id="rm-gdpr-sTop_Bar_0_0_25_0_0_14" class="sticky-target legacy rm-gdpr"><div class="gdpr-cookie-wrapper"><div class="gdpr-cookie-content"><p>IEEE websites place cookies on your device to give you the best user experience. By using our websites, you agree to the placement of these cookies. To learn more, read our Privacy Policy.</p></div><div class="gdpr-cookie-controls"><a href="https://www.ieee.org/security-privacy.html" target="_blank" class="gdpr-cookie-info">
                        view privacy policy
                    </a><a href="#toggle-gdpr" class="gdpr-cookie-accept">
                    accept &amp; close
                </a></div></div></div></div><span class="js-brick-description hidden" data-name="__Gated_Popup"></span><div class="gated-popup" id="s__Gated_Popup_0_0_29_0_0_0"><div class="gated-popup__contents" id="s__Gated_Popup_0_0_29_0_0_0_0"><!-- User Code --><a href="javascript:;" class="js--close-gated gated-popup__close icon-close"></a><!-- End User Code --><!-- User Code --><h2 class="popup-gated-h2 popup-heading-h2 for_pdf" style="display:none">Enjoy more free content and benefits by creating an account</h2><h2 class="popup-gated-h2 popup-heading-h2 for_save" style="display:none">Saving articles to read later requires an IEEE Spectrum account</h2><h2 class="popup-gated-h2 popup-heading-h2 for_member_content" style="display:none">The Institute content is only available for members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_pdf_issues" style="display:none">Downloading full PDF issues is exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_nxtbook" style="display:none">Access to <i>Spectrum</i>&#39;s Digital Edition is exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_follow_topics" style="display:none">Following topics is a feature exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_comments" style="display:none">Adding your response to an article requires an IEEE Spectrum account</h2><h2 class="popup-gated-h2 for_pdf for_save for_comments" style="display:none">Create an account to access more content and features on <i>IEEE Spectrum</i>, including the ability to save articles to read later, download Spectrum Collections, and participate in conversations with readers and editors. For more exclusive content and features, consider <a class="ieee_link" href="">Joining IEEE</a>.</h2><h2 class="popup-gated-h2 for_pdf_issues for_nxtbook for_follow_topics for_member_content" style="display:none">Join the world’s largest professional organization devoted to engineering and applied sciences and get access to all of Spectrum’s articles, archives, PDF downloads, and other benefits. <a href="/st/join">Learn more →</a></h2><!-- End User Code --><div class="popup_links for_pdf for_save for_comments create_account" id="s__Gated_Popup_0_0_29_0_0_0_0_2"><div class="list" id="s__Gated_Popup_0_0_29_0_0_0_0_2_0"><a href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fsaml%2Fmain%2Flogin%3Fnext_url%3Dhttps%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fintegrations%2Fieee%2Fchanges%0A&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">CREATE AN ACCOUNT</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div><div class="popup_links for_pdf_issues for_nxtbook for_follow_topics for_member_content" id="s__Gated_Popup_0_0_29_0_0_0_0_3"><div class="list" id="s__Gated_Popup_0_0_29_0_0_0_0_3_0"><a href="/st/join" class="list__item" target="_self">JOIN IEEE</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div></div></div><!-- User Code --><script>
  var popupGatedElement=document.querySelector('.gated-popup'),
  closeGated,
  gatedCloseBtn = '.js--close-gated',
  gatedShownClass = 'gated-popup--shown';

  closeGated = function () {
      popupGatedElement.classList.remove(gatedShownClass);
      popupGatedElement.classList.remove('for_save');
      popupGatedElement.classList.remove('for_pdf');
      popupGatedElement.classList.remove('for_pdf_issues');
      popupGatedElement.classList.remove('for_nxtbook');
      popupGatedElement.classList.remove('for_follow_topics');
      popupGatedElement.classList.remove('for_comments');
      popupGatedElement.classList.remove('for_member_content');
  };

  function openGatedPopup(type){
    
    document.querySelectorAll(".popup_links.create_account .list__item")[0].href = 
"https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=" + encodeURIComponent(window.location.origin + "/core/saml/main/login?next_url=" + window.location.origin + "/core/integrations/ieee/changes?redirect=" + window.location.href) + "&url=" + encodeURIComponent(window.location.origin + "/core/saml/main/login?next_url=" + window.location.origin + "/core/integrations/ieee/changes?redirect=" + window.location.href) + "&autoSignin=Y&car=IEEE-Spectrum";
    
    // update popups for_member_content
    document.querySelectorAll(".popup_links.for_member_content .list__item")[1].href =  "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
    
    // update popups for_pdf for_save for_comments
	document.querySelectorAll(".popup_links.for_save .list__item")[1].href =  "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
    
    popupGatedElement.classList.add(type);
  	popupGatedElement.classList.add(gatedShownClass);
  }

  document.querySelector(gatedCloseBtn).onclick= closeGated;
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="__Session_Popup"></span><div class="lightbox-popup" id="s__Session_Popup_0_0_33_0_1_0"><div class="lightbox-popup__contents" id="s__Session_Popup_0_0_33_0_1_0_0"><!-- User Code --><a href="javascript:;" class="js--close-lightbox lightbox-popup__close icon-close hide-text">Close</a><!-- End User Code --><!-- User Code --><h2 class="popup-ligtbox-h2 popup-heading-h2">Access Thousands of Articles — Completely Free</h2><h2 class="popup-ligtbox-h2">Create an account and get exclusive content and features: <strong>Save articles, download collections,</strong> and <strong>talk to tech insiders</strong> — all free! For full access and benefits, <a class="ieee_link" href="">join IEEE</a> as a paying member.</h2><!-- End User Code --><div class="popup_links signin_button" id="s__Session_Popup_0_0_33_0_1_0_0_2"><div class="list" id="s__Session_Popup_0_0_33_0_1_0_0_2_0"><a href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum3c&signinurl=https%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fsaml%2Fmain%2Flogin%3Fnext_url%3Dhttps%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fintegrations%2Fieee%2Fchanges%0A&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">CREATE AN ACCOUNT</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div></div></div><!-- User Code --><script>
function addPopSave(){
    var save_post_links = document.querySelectorAll(".like-btn:not(.proc)");
	for (i = 0; i < save_post_links.length; i++) {
      save_post_links[i].removeAttribute("href");
      save_post_links[i].addEventListener("click", function(event){
      	openGatedPopup('for_save');
	  });
      save_post_links[i].classList.add('proc');
    } 
}
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="SS Default Post"></span><div class="" id="sSS_Default_Post_0_0_20_0_0_1"><div class="top-leader-container" id="sSS_Default_Post_0_0_20_0_0_1_1"><!-- User Code --><div id="top_leaderboard"></div><!-- End User Code --></div><div id="sSS_Default_Post_0_0_20_0_0_1_2" class="featured_columns row-wrapper clearfix "><div class="row "><div id="sSS_Default_Post_0_0_20_0_0_1_2_0" class="article_column col sm-mb-2 md-mb-4 s12 m12 l9"><div class="mb-2 article_post current_post_media current_post" id="sSS_Default_Post_0_0_20_0_0_1_2_0_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-layout_separator="inactive" data-attr-filters="section" data-attr-layout_all_sections="top" data-attr-layout_slack="inactive" data-attr-layout_flipboard="inactive" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_time_to_read="top" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-layout_pinterest="inactive" data-attr-layout_date="top" data-attr-layout_author="top" data-attr-element_classes="article_post current_post_media current_post" data-attr-posts_id="sSS_Default_Post_0_0_20_0_0_1_2_0_0_1_0" data-attr-layout_headline="top" data-attr-section_url="" data-attr-layout_twitter="inactive" data-attr-layout_tumblr="inactive" data-attr-layout_subheadline="top" data-attr-source="" data-attr-is_current_post="true" data-attr-layout_sms="inactive" data-attr-layout_photo_caption="bottom" data-attr-layout_image_column_width="33" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Email,CopyLink,Whatsapp,Facebook,Twitter,Linkedin,Separator,Tumblr,GooglePlus,Pinterest,Reddit,Flipboard,SMS,Slack" data-attr-format="posts-custom" data-attr-layout_all_image_crop="original" data-attr-data-rm-advanced="true" data-attr-layout_all_subheadline_tag="h2" data-attr-node_id="/root/blocks/block[ss_default_post]/abtests/abtest[1]/element_wrapper/row/column[1]/choose/otherwise/posts-" data-attr-layout_linkedin="inactive" data-attr-layout_googleplus="inactive" data-attr-layout_like_button="top" data-attr-source_url="current_post" data-attr-layout_copylink="active" data-attr-layout_facebook="inactive" data-attr-data-rm-device-crops="true" data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,photo_caption,photo_credit,date_modified,custom_field_TimeofRead,post_shares,body,section,primary_tag,page_views,badges,badges_sponsored,source_link,community_name,snark_line,collection_button,community_comments,main_author,tags,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,custom_field_lightbox_img_shortcode_ids,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_Editor,custom_field_PodcastTime,custom_field_PodcastEpisode,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,site_field_member_badges,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_copy_editor,custom_field_is_updated_post" data-attr-layout_photo_credit="bottom" data-attr-layout_reddit="inactive" data-attr-layout_all_headline_tag="h1" data-attr-limit="1" data-attr-v="2" data-attr-layout_quality="4"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-microrobots tag-biomemetic-robots tag-shape-memory-alloy post-section--topic/robotics" data-category="Robotics"><article elid="2657489115" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657489115" data-category="Robotics"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/type/news/">News</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/">Topic</a></div><h1 class="widget__headline h1"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/microrobots-walking" aria-label="Flea-Sized Robots Walk a Coin-Edge-Sized Path" data-type="text">
        Flea-Sized Robots Walk a Coin-Edge-Sized Path
    </a></h1><div class="widget__subheadline"><h2 class="widget__subheadline-text h2" data-type="text"><p>These crab-inspired crawlers are just half a millimeter wide</p></h2></div><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/res/avatars/default&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/payal-dhar" data-type="text">Payal Dhar</a></div><div class="social-date"><span class="social-date__text">9h</span></div><div class="time-to-read">3 min read</div><div class="like-button" data-post-likes="0"></div></div><div class="widget__head"><picture><source srcset="https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=3600&height=2700 3x, https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=2400&height=1800 2x, https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=1200&height=900 1x"/><img fetchpriority="high" role="img" alt="Close-up image of crab shaped robot" aria-label="Close-up image of crab shaped robot" src="https://spectrum.ieee.org/media-library/close-up-image-of-crab-shaped-robot.jpg?id=29964026&width=1200&height=900" style="object-fit: cover;" class="rm-lazyloadable-image" width="2400" height="1800"/></picture></div><div class="widget__body clearfix sm-mt-1"><div class="photo-caption"><p>Laser heating (and ambient cooling) of joints made from shape memory alloy allows this flea-sized &#39;bot to flex its legs and ambulate across a surface.</p></div><div class="photo-credit">
        Northwestern University
    </div></div></div></div><script type="application/json" id="post-context-2657489115">
    {"customDimensions": {"5":"Payal Dhar","6":"robotics","7":"microrobots, biomemetic robots, shape memory alloy, ~rmsc:rebelmouse-image:29964026, ~rmsc:rebelmouse-image:29964031, ~rmsc:rebelmouse-image:29964028","8":"06/11/2022","10":"microrobots","11":2657489115}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075889]} }
</script></article></div></div></div></div><div id="sSS_Default_Post_0_0_20_0_0_1_2_0_1" class=" row-wrapper clearfix "><div class="row "><div id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_0" class="tag_column col sm-mb-2 md-mb-4 s12 m12 l3"><div class="mb-2 article_post article_post-shares-and-tags" id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_0_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-layout_whatsapp="inactive" data-attr-layout_tags="top" data-attr-layout_separator="inactive" data-attr-layout_remove_image="true" data-attr-filters="section" data-attr-layout_slack="inactive" data-attr-layout_post_shares="top" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_all_date_full_format="false" data-attr-layout_pinterest="inactive" data-attr-element_classes="article_post article_post-shares-and-tags" data-attr-posts_id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_0_0_1_0" data-attr-section_url="" data-attr-layout_twitter="active" data-attr-layout_tumblr="inactive" data-attr-source="" data-attr-is_current_post="true" data-attr-layout_sms="inactive" data-attr-layout_image_column_width="33" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Email,CopyLink,Twitter,Facebook,Separator,Linkedin,GooglePlus,Whatsapp,Tumblr,Slack,Pinterest,Reddit,Flipboard,SMS" data-attr-format="posts-custom" data-attr-layout_all_image_crop="3x2" data-attr-data-rm-advanced="true" data-attr-source_url="current_post" data-attr-node_id="/root/blocks/block[ss_default_post]/abtests/abtest[1]/element_wrapper/row/column[1]/row/column[1]/choose/otherwise/posts-" data-attr-layout_linkedin="active" data-attr-layout_googleplus="inactive" data-attr-layout_custom_field_pdf_version="top" data-attr-layout_flipboard="inactive" data-attr-layout_copylink="active" data-attr-layout_facebook="active" data-attr-data-rm-device-crops="true" data-attr-all_element_order="post_shares,custom_field_pdf_version,tags,all_sections,headline,subheadline,custom_field_PodcastEpisode,date,custom_field_PodcastTime,like_button,body,author,custom_field_TimeofRead,page_views,badges,section,primary_tag,community_name,badges_sponsored,source_link,photo_caption,photo_credit,community_comments,snark_line,collection_button,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,main_author,custom_field_FullwidthCardPosition,product_prices,custom_field_Issue,custom_field_FullwidthCardColor,site_field_Twitter,product_vendor,product_buy_link,site_field_LinkedIn,custom_field_Editor,site_field_Instagram,site_field_Facebook,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_lightbox_img_shortcode_ids,custom_field_copy_editor,custom_field_is_updated_post" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_reddit="inactive" data-attr-limit="1" data-attr-v="2" data-attr-headline_text="" data-attr-layout_quality="13"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-microrobots tag-biomemetic-robots tag-shape-memory-alloy post-section--topic/robotics" data-category="Robotics"><article elid="2657489115" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-SD post-2657489115" data-category="Robotics"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="widget__shares share-panel"><!-- EMAIL --><a href="mailto:?subject=Flea-Sized%20Robots%20Walk%20a%20Coin-Edge-Sized%20Path&body=https://spectrum.ieee.org/microrobots-walking" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK --><a href="https://spectrum.ieee.org/microrobots-walking" data-clipboard-text="https://spectrum.ieee.org/microrobots-walking" class="share share-copy-link" title="Copy this link to clipboard"><i class="icons-share" style="width: 60%"><svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i></a><!-- TWITTER --><a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/microrobots-walking&text=Flea-Sized%20Robots%20Walk%20a%20Coin-Edge-Sized%20Path&" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK --><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Fmicrorobots-walking%3Fxrs%3DRebelMouse_fb%26ts%3D1654952401" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN --><a href="http://www.linkedin.com/shareArticle?mini=false&url=https://spectrum.ieee.org/microrobots-walking&" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a></div><div class="tags"><a class="tags__item" href="https://spectrum.ieee.org/tag/microrobots">microrobots</a><a class="tags__item" href="https://spectrum.ieee.org/tag/biomemetic-robots">biomemetic robots</a><a class="tags__item" href="https://spectrum.ieee.org/tag/shape-memory-alloy">shape memory alloy</a></div></div><div class="widget__head"></div></div></div><script type="application/json" id="post-context-2657489115">
    {"customDimensions": {"5":"Payal Dhar","6":"robotics","7":"microrobots, biomemetic robots, shape memory alloy, ~rmsc:rebelmouse-image:29964026, ~rmsc:rebelmouse-image:29964031, ~rmsc:rebelmouse-image:29964028","8":"06/11/2022","10":"microrobots","11":2657489115}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075889]} }
</script></article></div></div></div></div></div><div id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_1" class="current_post_content col sm-mb-2 md-mb-4 s12 m12 l9"><div class="" id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_1_0"><div class="non_member_follow" id="sSS_Default_Post_0_0_20_0_0_1_2_0_1_1_0_0_1_0"><span class="js-brick-description hidden" data-name="__gated_structured_data"></span><!-- User Code --><script>
function addSection_Gate(){
  	var postMagazine = document.querySelectorAll(".all-related-sections a[href*='/magazine/']:not(.proc)");
  	var currentDate = new Date();
    var postMagazine_link, magazineDate;
  	var gatedPost;
  
	for (i = 0; i < postMagazine.length; i++) {
    	postMagazine_link = postMagazine[i].getAttribute("href").split("/");
      	magazineDate = parseInt(postMagazine_link[postMagazine_link.length - 2]);	
     
      	if(magazineDate < currentDate.getFullYear() - 1){
          	gatedPost = postMagazine[i].parentElement.parentElement.parentElement;
            gatedPost.querySelector(".content-container").remove();
          	gatedPost.querySelector(".js-appear-on-expand").remove();
          	gatedPost.querySelector(".widget__show-more").addEventListener("click", function(event){
      			openGatedPopup('for_gated_sections');
	  		});
            postMagazine[i].classList.add('gated');
      		postMagazine[i].classList.add('proc');
        }
    } 
}
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="Open Current Default Post"></span><div class="mb-2 article_post article_post--body-and-tags" id="sOpen_Current_Default_Post_0_0_14_0_0_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-layout_tags="bottom" data-attr-layout_separator="inactive" data-attr-layout_remove_image="true" data-attr-filters="section" data-attr-layout_all_image_crop="3x2" data-attr-layout_slack="inactive" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_body="top" data-attr-layout_all_date_full_format="false" data-attr-layout_pinterest="inactive" data-attr-element_classes="article_post article_post--body-and-tags" data-attr-posts_id="sOpen_Current_Default_Post_0_0_14_0_0_0_1_0" data-attr-section_url="" data-attr-layout_twitter="inactive" data-attr-layout_tumblr="inactive" data-attr-source="" data-attr-is_current_post="true" data-attr-layout_sms="inactive" data-attr-layout_image_column_width="33" data-attr-update_url_on_post_view="true" data-attr-all_share_buttons="Email,CopyLink,Whatsapp,Facebook,Twitter,Linkedin,Separator,Tumblr,GooglePlus,Pinterest,Reddit,Flipboard,SMS,Slack" data-attr-format="posts-custom" data-attr-layout_flipboard="inactive" data-attr-data-rm-advanced="true" data-attr-node_id="/root/blocks/block[open_current_default_post]/abtests/abtest[1]/choose[1]/otherwise/current_post-" data-attr-layout_linkedin="inactive" data-attr-layout_googleplus="inactive" data-attr-layout_copylink="active" data-attr-layout_facebook="inactive" data-attr-show_around_the_web="true" data-attr-data-rm-device-crops="true" data-attr-all_element_order="body,tags,custom_field_lightbox_img_shortcode_ids,author,all_sections,headline,subheadline,custom_field_PodcastEpisode,date,custom_field_PodcastTime,like_button,post_shares,custom_field_TimeofRead,page_views,badges,section,primary_tag,community_name,badges_sponsored,source_link,photo_caption,photo_credit,community_comments,snark_line,collection_button,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,main_author,custom_field_FullwidthCardPosition,product_prices,custom_field_Issue,custom_field_FullwidthCardColor,site_field_Twitter,product_vendor,product_buy_link,site_field_LinkedIn,custom_field_Editor,site_field_Instagram,site_field_Facebook,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition,custom_field_disable_comments,custom_field_copy_editor" data-attr-show_full_post_body="true" data-attr-layout_custom_field_lightbox_img_shortcode_ids="bottom" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_reddit="inactive" data-attr-limit="1" data-attr-v="2" data-attr-layout_quality="1" data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-microrobots tag-biomemetic-robots tag-shape-memory-alloy post-section--topic/robotics" data-category="Robotics"><article elid="2657489115" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657489115" data-category="Robotics"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><span class="js-scroll-trigger" data-target="body" data-triggers="render-rebelbar" data-toggle-class="with-floating-shares"></span><div id="utm_campaign"></div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2657489115" data-elid="2657489115" data-post-url="https://spectrum.ieee.org/microrobots-walking" data-authors="Payal Dhar" data-headline="Flea-Sized Robots Walk a Coin-Edge-Sized Path"><div class="body-description"><p>Microrobotics engineers often turn to <a href="https://spectrum.ieee.org/tag/microrobots" target="_self">nature</a> to inspire their builds. A group of researchers at Northwestern University have picked the <a href="https://seafoods.com/product/66-atlantic-rock-peekytoe?print" rel="noopener noreferrer" target="_blank">peekytoe crab</a> to build a remote-controlled microbot that is tiny enough to walk comfortably on the edge of a coin.<br/></p><p>According to <a href="http://rogersgroup.northwestern.edu/" rel="noopener noreferrer" target="_blank">John A. Rogers</a>, the lead investigator of the <a href="https://www.science.org/doi/10.1126/scirobotics.abn0602" rel="noopener noreferrer" target="_blank">study</a>, their work complements that of other scientists who are working on millimeter-scale robots, for example, worm-like structures that can move through liquid media with flagella. But to the best of his knowledge, their crab microbots are the smallest terrestrial robots—just half a millimeter wide—to walk on solid surfaces in open air.</p><p>The tiny robot moves with a scuttling motion thanks to <a href="https://www.nsmedicaldevices.com/analysis/shape-memory-alloys-medical-uses/" rel="noopener noreferrer" target="_blank">shape memory alloys</a> (SMA). This class of materials undergoes a phase transition at a certain temperature, triggering a shape change. “So you create material in an initial geometry, deform it, and then when you heat it up, it’ll go back to that initial geometry,” Rogers says. “We exploit the shape changes [as] the basis of kind of a mechanical actuator or kind of a muscle.”</p><p class="pull-quote">To move the robot, lasers heat its “legs” in sequence; the shape memory alloy in each leg bends in response to the heat—and then returns to its original orientation upon cooling.</p><p class="shortcode-media shortcode-media-rebelmouse-image"><img alt="Tiny crab robot stands on the edge of a coin." class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="076138f16003c2d9af6f38df5e4fc929" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/tiny-crab-robot-stands-on-the-edge-of-a-coin.jpg?id=29964031&width=980" height="1800" id="6d334" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 2400 1800&#39;%3E%3C/svg%3E" width="2400"/><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Northwestern University</small></p><p>The robot comprises three key materials—an electronics-grade polymer for the body and parts of the limbs; the SMA, which forms the “active” component; and a thin layer of glass as an exoskeleton to give the structure rigidity. Rogers adds that they are not constrained by these particular materials, however, and his team are looking at ways to integrate semiconducting materials and other kinds of conductors.</p><div class="ad-in-content"></div><p>For movement, the researchers use the focus spot of a laser beam on the robot body. “Whenever the laser beam illuminates the shape memory alloy components of the robot, you induce [its] phase change and corresponding motion,” Rogers says, “and when the laser beam moves off, you get a fast cooling and the limb returns to the deformed geometry.” Thus, scanning the laser spot across the body of the robot can sequentially activate various joints, and thereby establish a gait and direction for motion.</p><p class="shortcode-media shortcode-media-rebelmouse-image rm-resized-container rm-resized-container-25 rm-float-left" data-rm-resized-container="25%" style="float: left;"><img alt="Animated gif showing one still and one robotic crab walking  right and then left." class="rm-shortcode rm-lazyloadable-image rm-resized-image" data-rm-shortcode-id="e099615e6fd5010eb8419d62f4b1ffc7" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/animated-gif-showing-one-still-and-one-robotic-crab-walking-right-and-then-left.gif?id=29964028&width=980" height="406" id="786a2" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 592 406&#39;%3E%3C/svg%3E" style="max-width: 100%" width="592"/><small class="image-media media-photo-credit" placeholder="Add Photo Credit..." style="max-width: 100%;">Northwestern University</small></p><p>Though this method has its advantages, Rogers would like to explore more options. “With the laser, you need some kind of optical access… [but depending] on where you want the robot to operate, that approach is going to be feasible or not,” says Rogers.</p><p>This is not the first time Rogers has had a hand in creating submillimeter-sized robots. His lab has developed tiny structures resembling worms and beetles, and even a <a href="https://www.nature.com/articles/s41586-021-03847-y" rel="noopener noreferrer" target="_blank">winged microchip</a> that moves through the air passively, using the same principles as the wind dispersal of seeds.</p><p>In 2015, Rogers and his colleagues also published a <a href="https://www.pnas.org/doi/full/10.1073/pnas.1515602112" rel="noopener noreferrer" target="_blank">paper</a> about using the concepts of <a href="https://www.thesprucecrafts.com/an-introduction-to-kirigami-paper-cutting-2540656" rel="noopener noreferrer" target="_blank">kirigami</a>, the Japanese art of paper cutting, as seen in pop-up books, for example, to design their robots. They use high-fidelity multilayer stacks of patterned materials supported by a silicon wafer, but while those are great for integrated circuits, they’re “no good for robots,” says Rogers, as they are flat. To move them into the third dimension, studying the principles of kirigami was a starting point.</p><p>As Rogers emphasizes, their research is purely exploratory at the moment, an attempt to introduce some some additional ideas into microrobotic engineering. “We can move these robots around, make them walk in different directions, but they don’t execute a specific task,” he says. For example, even though the crab-bots have claws, these are just for visual purposes, they don’t move or grasp objects. “Creating capabilities for task execution would be a next step in research in this area,” he says. For now, though, making multi-material 3D structures and using SMAs for two-way actuation are the two key pieces of contribution to the broader community from his team.</p><p>For further exploration, he and his colleagues are thinking about how to add the ability to grasp or manipulate objects at this scale, as well as adding microcircuits, digital sensors, and wireless communication to the bots. Communication between the robots could allow them to operate as a swarm, for instance. Another area to work on is adding some kind of local power supply, powered by photovoltaics, for example, with a microcontroller to provide local heating in a timed sequence to control movement.</p><div class="ad-in-content"></div><p>In terms of potential applications, Rogers envisages the tiny robots to be useful for working in confined spaces, primarily for minimally invasive surgeries, followed by vehicles for building other tiny machines. But he also advocates caution: “I wouldn’t want to oversell what we’ve done. It’s pretty easy to slide into fantastical visions of these robots getting in the body and doing something powerful in terms of medical treatment. [But] that’s where we’d like to go, and it’s what&#39;s motivating a lot of our work.&quot;</p><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div><ul class="around-the-web__list"><li class="from-your-site__item"><a href="https://spectrum.ieee.org/nanotweezers-move-into-a-new-era-with-plasmonics-and-magnetic-microrobots" class="from-your-site__link" target="_blank" rel="noopener noreferrer">New Nanotweezers Blend Plasmonics With Magnetic Microrobots ... ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/tiny-robots-deliver-stem-cells-in-the-body" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Microbots Deliver Stem Cells in the Body - IEEE Spectrum ›</a></li></ul><div class="around-the-web__headline">Related Articles Around the Web</div><ul class="around-the-web__list"><li class="around-the-web__item"><a href="https://pubs.acs.org/doi/10.1021/acs.chemrev.0c00999" class="around-the-web__link" target="_blank" rel="noopener noreferrer">Smart Materials for Microrobots | Chemical Reviews ›</a></li><li class="around-the-web__item"><a href="https://pubs.rsc.org/en/content/articlelanding/2017/lc/c7lc00064b" class="around-the-web__link" target="_blank" rel="noopener noreferrer">Mobile microrobots for bioengineering applications - Lab on a Chip ... ›</a></li></ul></div></div></div><span class="js-scrolled-url" data-elid="2657489115" data-post-url="https://spectrum.ieee.org/microrobots-walking" data-authors="Payal Dhar" data-headline="Flea-Sized Robots Walk a Coin-Edge-Sized Path"></span></div><div class="widget__head"></div><div class="widget__body clearfix sm-mt-1"><div class="tags"><a class="tags__item" href="https://spectrum.ieee.org/tag/microrobots">microrobots</a><a class="tags__item" href="https://spectrum.ieee.org/tag/biomemetic-robots">biomemetic robots</a><a class="tags__item" href="https://spectrum.ieee.org/tag/shape-memory-alloy">shape memory alloy</a></div></div></div></div><script type="application/json" id="post-context-2657489115">
    {"customDimensions": {"5":"Payal Dhar","6":"robotics","7":"microrobots, biomemetic robots, shape memory alloy, ~rmsc:rebelmouse-image:29964026, ~rmsc:rebelmouse-image:29964031, ~rmsc:rebelmouse-image:29964028","8":"06/11/2022","10":"microrobots","11":2657489115}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075889]} }
</script></article></div></div></div></div><div class="" id="sOpen_Current_Default_Post_0_0_14_0_0_1"><div class="mb-2 post-author-list" id="sOpen_Current_Default_Post_0_0_14_0_0_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="None" data-format="posts-custom" data-source="current_post" data-source-type="current_post" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="false" data-attr-layout_remove_image="true" data-attr-filters="section" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_all_subheadline_tag="h2" data-attr-layout_author="top" data-attr-element_classes="post-author-list" data-attr-posts_id="sOpen_Current_Default_Post_0_0_14_0_0_1_0" data-attr-section_url="" data-attr-source="" data-attr-is_current_post="true" data-attr-show_authors_bio="true" data-attr-format="posts-custom" data-attr-node_id="/root/blocks/block[open_current_default_post]/abtests/abtest[1]/element_wrapper/current_post-" data-attr-all_element_order="author,headline,subheadline,section,community_name,date,date_modified,badges,badges_sponsored,photo_credit,photo_caption,body,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,all_sections,product_prices,product_vendor,product_buy_link,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_Instagram,site_field_member_badges,site_field_Twitter,site_field_LinkedIn,site_field_grade,site_field_Facebook,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_pdf_version,custom_field_copy_editor,custom_field_FullwidthCardColor,custom_field_disable_comments,custom_field_PodcastVideoTime,custom_field_fullwidthbackgroundposition,custom_field_lightbox_img_shortcode_ids,custom_field_access,custom_field_Editor,custom_field_PodcastEpisode,custom_field_publication_date,custom_field_TimeofRead,custom_field_FeaturePostColor,custom_field_FullwidthCardPosition,custom_field_is_updated_post" data-attr-layout_all_headline_tag="h1" data-attr-v="2" data-attr-layout_quality="1"><div class="posts-wrapper clearfix"><div class="widget post-partial tag-microrobots tag-biomemetic-robots tag-shape-memory-alloy post-section--topic/robotics" data-category="Robotics"><article elid="2657489115" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657489115" data-category="Robotics"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/res/avatars/default&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/payal-dhar" data-type="text">Payal Dhar</a><div class="social-author__bio">Payal Dhar (she/they) is a freelance journalist on science, technology, and society. They write about AI, cybersecurity, surveillance, space, online communities, games, and any shiny new technology that catches their eye. You can find and DM Payal on Twitter (@payaldhar). </div></div></div><div class="widget__head"></div></div></div><script type="application/json" id="post-context-2657489115">
    {"customDimensions": {"5":"Payal Dhar","6":"robotics","7":"microrobots, biomemetic robots, shape memory alloy, ~rmsc:rebelmouse-image:29964026, ~rmsc:rebelmouse-image:29964031, ~rmsc:rebelmouse-image:29964028","8":"06/11/2022","10":"microrobots","11":2657489115}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075889]} }
</script></article></div></div></div></div></div><div class="" id="sOpen_Current_Default_Post_0_0_14_0_0_2_1_0"><div class="post-partial article__comments"><div class="article-content__comments-wrapper"><div id="comments-widget"><div class="talk-comments-wrp community-native-wrp " data-talk_id="post:2657489115:comments" data-limit="3" data-order="best" data-is_amp="" data-count_top_level="0" data-count_featured="0" data-show_rating="False" data-all_element_order="avatar,title,date,site_field_member_badges,site_field_grade,message,update_avatar,follow,bio,review" data-words-per-message="{&quot;max&quot;: 250, &quot;min&quot;: 1}" data-inactive_layout_attributes="update_avatar,follow,bio,review" data-active_layout_attributes="site_field_member_badges,site_field_grade"><div class="editmode-section-title"></div><a href="#" class="hidden new-comments-notification" aria-label="New coments notification"></a><div class="comment-headline">The Conversation (0)</div><div class="add-comment"><div class="comment_placeholder-wrp"><div class="animated-background"><div class="placeholder__textarea_top"></div><div class="placeholder__textarea_botmiddle_left"></div><div class="placeholder__textarea_botmiddle_right"></div><div class="placeholder__textarea_bottom"></div><div class="placeholder__button_b"></div><div class="placeholder__button_i"></div><div class="placeholder__button_publish"></div></div><div class="comment-login-wrp"></div></div></div><div class="comment-header"></div><div class="talk--messages"><div class="talk--messages__featured"></div><div class="talk--messages__top_level"></div></div><script type="rm-preact-state">{"featuredComments": [], "authors": {}, "forcedComments": [], "topLevelComments": []}
        </script><div class="talk--load_more-wrp "></div></div></div></div></div><!-- User Code --><script>
    var clickeableItems = [
      ".talk-comments-wrp .add-comment",
      ".talk-comments-wrp .comment-item--publish",
      ".talk-comments-wrp .comment--item__reply",
      ".talk-comments-wrp .comment--item__like",
      ".talk-comments-wrp .comment--item__dislike",
      ".talk-comments-wrp .replies"];
    var talkItems = document.querySelectorAll(clickeableItems.join(",")) || [];
    talkItems.forEach(function(item) {
      item.addEventListener("click", function(event){
        event.preventDefault();
        event.stopPropagation();
        openGatedPopup('for_comments');
        }, true);
    });
</script><!-- End User Code --></div><div class="mb-2 read_also_posts" id="sOpen_Current_Default_Post_0_0_14_0_0_3_1_0"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_1" data-format="posts-custom" data-source="filtered_parent_site" data-source-type="page" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-source_site="parent_site" data-attr-layout_all_sections="right" data-attr-from_regular_sections_other_than="webinar,whitepaper,sponsored,podcast,video,tests,issue-cover-posts,feature" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_time_to_read="right" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_all_date_full_format="false" data-attr-source_unique="true" data-attr-element_classes="read_also_posts" data-attr-posts_id="sOpen_Current_Default_Post_0_0_14_0_0_3_1_0" data-attr-layout_headline="right" data-attr-from_regular_sections_of_current_post="true" data-attr-source="filtered" data-attr-layout_date="right" data-attr-all_element_order="all_sections,headline,date,time_to_read,like_button,custom_field_TimeofRead,section,primary_tag,author,badges,badges_sponsored,photo_credit,community_name,subheadline,snark_line,page_views,photo_caption,follow_button,community_comments,body,collection_button,tags,source_link,main_author,post_shares,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition" data-attr-layout_image_column_width="28" data-attr-format="posts-custom" data-attr-layout_all_image_crop="original" data-attr-data-rm-advanced="true" data-attr-node_id="/root/blocks/block[open_current_default_post]/abtests/abtest[1]/choose[3]/otherwise/posts-" data-attr-layout_like_button="right" data-attr-layout_desktop_image_crop="original" data-attr-without_current="true" data-attr-data-rm-device-crops="true" data-attr-limit="3" data-attr-v="2" data-attr-layout_quality="1"><div class="posts-wrapper clearfix"><div class="widget tag-video-friday tag-robotics" elid="2657488453" data-category="Robotics"><article elid="2657488453" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657488453"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/video-friday-robot-soccer-finals" aria-label="Video Friday: Robot Soccer Finals"><img fetchpriority="high" role="img" type="lazy-image" alt="Five large orange robots with wheels line up on an indoor soccer field" aria-label="Five large orange robots with wheels line up on an indoor soccer field" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 4500 2430&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/five-large-orange-robots-with-wheels-line-up-on-an-indoor-soccer-field.jpg?id=29963438&width=1200&height=648" style="object-fit: cover;" class="rm-lazyloadable-image" width="4500" height="2430"/></a></div></div><div id="col-right" class="col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/type/news/">News</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/">Topic</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/video-friday-robot-soccer-finals" aria-label="Video Friday: Robot Soccer Finals" data-type="text">
        Video Friday: Robot Soccer Finals
    </a></h2><div class="social-date"><span class="social-date__text">10 Jun 2022</span></div><div class="time-to-read">3 min read</div><div class="like-button" data-post-likes="0"></div></div></div></div><script type="application/json" id="post-context-2657488453">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"video friday, robotics, ~rmsc:rebelmouse-image:29963438","8":"06/10/2022","10":"robotics","11":2657488453}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075149]} }
</script></article></div><div class="widget tag-cryptocurrencies tag-regulation tag-economics post-section--topic/computing" elid="2657483854" data-category="Computing"><article elid="2657483854" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657483854"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/cryptocurrency-blockchain-regulation" aria-label="Regulators Rush to Become “Crypto-Friendly”"><img fetchpriority="high" role="img" type="lazy-image" alt="A collection of cryptocurrency coins with a gavel" aria-label="A collection of cryptocurrency coins with a gavel" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 5117 3838&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/a-collection-of-cryptocurrency-coins-with-a-gavel.jpg?id=29963035&width=1200&height=900" style="object-fit: cover;" class="rm-lazyloadable-image" width="5117" height="3838"/></a></div></div><div id="col-right" class="col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/computing/">Computing</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/news/">News</a><a href="https://spectrum.ieee.org/type/">Type</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/cryptocurrency-blockchain-regulation" aria-label="Regulators Rush to Become “Crypto-Friendly”" data-type="text">
        Regulators Rush to Become “Crypto-Friendly”
    </a></h2><div class="social-date"><span class="social-date__text">10 Jun 2022</span></div><div class="time-to-read">5 min read</div><div class="like-button" data-post-likes="0"></div></div></div></div><script type="application/json" id="post-context-2657483854">
    {"customDimensions": {"5":"Edd Gent","6":"computing","7":"cryptocurrencies, regulation, economics, ~rmsc:rebelmouse-image:29963035","8":"06/10/2022","10":"cryptocurrencies","11":2657483854}, "post": {"split_testing": {}, "providerId": 0, "sections": [497728257, 544169523, 544169516, 539617903], "buckets": [], "authors": [21081576]} }
</script></article></div><div class="widget tag-apple tag-processors tag-security tag-side-channel-attacks tag-speculative-execution tag-spectre tag-meltdown tag-computer-architecture tag-hacking post-section--topic/computing" elid="2657484755" data-category="Computing"><article elid="2657484755" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2657484755"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/pacman-hack-can-break-apple-m1s-last-line-of-defense" aria-label="“PACMAN” Hack Can Break Apple M1’s Last Line of Defense"><img fetchpriority="high" role="img" type="lazy-image" alt="product photograph of a microprocessor" aria-label="product photograph of a microprocessor" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1284 964&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/product-photograph-of-a-microprocessor.jpg?id=29961290&width=1200&height=900" style="object-fit: cover;" class="rm-lazyloadable-image" width="1284" height="964"/></a></div></div><div id="col-right" class="col" style="width:72.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/computing/">Computing</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/topic/semiconductors/">Semiconductors</a><a href="https://spectrum.ieee.org/type/news/">News</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/pacman-hack-can-break-apple-m1s-last-line-of-defense" aria-label="“PACMAN” Hack Can Break Apple M1’s Last Line of Defense" data-type="text">
        “PACMAN” Hack Can Break Apple M1’s Last Line of Defense
    </a></h2><div class="social-date"><span class="social-date__text">10 Jun 2022</span></div><div class="time-to-read">4 min read</div><div class="like-button" data-post-likes="2"></div></div></div></div><script type="application/json" id="post-context-2657484755">
    {"customDimensions": {"5":"Samuel K. Moore","6":"computing","7":"Apple, processors, security, side channel attacks, speculative execution, Spectre, meltdown, computer architecture, hacking, ~rmsc:rebelmouse-image:29961290","8":"06/10/2022","10":"hacking","11":2657484755}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 544169516, 539617903, 539621009, 544169523, 550122300, 550122302], "buckets": [], "authors": [21075160]} }
</script></article></div></div></div></div></div></div></div></div></div></div><div id="sSS_Default_Post_0_0_20_0_0_1_2_1" class="widget_column col sm-mb-2 md-mb-4 s12 m12 l3"><span class="js-brick-description hidden" data-name="Popular widget"></span><div class="popular_widget" id="sPopular_widget_0_0_18_0_0_1_3_0_2_0"><div class="" id="sPopular_widget_0_0_18_0_0_1_3_0_2_0_0"><div id="sPopular_widget_0_0_18_0_0_1_3_0_2_0_0_0"><div class="module-headline"><h2 class="module-headline__text h2">
        Related Stories
    </h2></div></div></div><div class="mb-2 " id="sPopular_widget_0_0_18_0_0_1_3_0_2_0_1"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_2" data-format="posts-custom" data-source="filtered_parent_site_newest" data-source-type="page" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-posts_id="sPopular_widget_0_0_18_0_0_1_3_0_2_0_1" data-attr-layout_remove_image="true" data-attr-layout_all_sections="top" data-attr-layout_headline="top" data-attr-format="posts-custom" data-attr-all_element_order="all_sections,headline,subheadline,section,author,community_name,date,date_modified,badges,badges_sponsored,photo_credit,photo_caption,body,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_FullwidthCardColor,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,custom_field_TimeofRead,custom_field_Issue,custom_field_FullwidthCardPosition,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,custom_field_publication_date,custom_field_FeaturePostColor,site_field_member_badges,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version" data-attr-without_current="true" data-attr-source="filtered" data-attr-from_regular_sections_other_than="webinar,whitepaper,sponsored,podcast,video,slideshow,tests,issue-cover-posts,topic/the-institute" data-attr-limit="3" data-attr-source_unique="true" data-attr-v="2" data-attr-source_site="parent_site" data-attr-node_id="/root/blocks/block[popular_widget]/abtests/abtest/choose/when[post_page==true]/choose/otherwise/element_wrapper/posts-" data-attr-order="newest" data-attr-layout_quality="1" data-attr-from_regular_tags_of_current_post="true"><div class="posts-wrapper clearfix"><div class="widget tag-robotics tag-flying-robots tag-microrobots tag-robobee post-section--topic/robotics" elid="2656520381" data-category="Robotics"><article elid="2656520381" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2656520381"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/news/">News</a><a href="https://spectrum.ieee.org/type/">Type</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/robobee-robot-precision-control" aria-label="RoboBee Can Now Pivot on a Dime" data-type="text">
        RoboBee Can Now Pivot on a Dime
    </a></h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/robobee-robot-precision-control" aria-label="RoboBee Can Now Pivot on a Dime"></a></div></div></div><script type="application/json" id="post-context-2656520381">
    {"customDimensions": {"5":"Michelle Hampson","6":"robotics","7":"robotics, flying robots, microrobots, RoboBee, ~rmsc:rebelmouse-image:29207479","8":"02/02/2022","10":"RoboBee","11":2656520381}, "post": {"split_testing": {}, "providerId": 0, "sections": [539266128, 497728257, 544169523, 544169516], "buckets": [], "authors": [21075168]} }
</script></article></div><div class="widget tag-journal-watch tag-biomemetic-robots tag-robotics" elid="2656052776" data-category="Robotics"><article elid="2656052776" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2656052776"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/news/">News</a><a href="https://spectrum.ieee.org/type/">Type</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/robotic-inchworm" aria-label="This Robotic Inchworm Just Made It to Higher Ground" data-type="text">
        This Robotic Inchworm Just Made It to Higher Ground
    </a></h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/robotic-inchworm" aria-label="This Robotic Inchworm Just Made It to Higher Ground"></a></div></div></div><script type="application/json" id="post-context-2656052776">
    {"customDimensions": {"5":"Michelle Hampson","6":"robotics","7":"journal watch, biomemetic robots, robotics, ~rmsc:rebelmouse-image:28249306","8":"12/17/2021","10":"robotics","11":2656052776}, "post": {"split_testing": {}, "providerId": 0, "sections": [539266128, 497728257, 559931002, 544169523, 544169516], "buckets": [], "authors": [21075168]} }
</script></article></div><div class="widget tag-medical-devices tag-ethics tag-microrobots tag-algorithms tag-biology tag-bioengineering tag-robotics tag-evolutionary-algorithm post-section--topic/biomedical" elid="2650279541" data-category="Biomedical"><article elid="2650279541" data-is-frozen="false" class="clearfix page-article sm-mb-1 quality-HD post-2650279541"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/biomedical/">Biomedical</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/type/news/">News</a><a href="https://spectrum.ieee.org/type/">Type</a></div><h2 class="widget__headline h2"><a class="widget__headline-text " href="https://spectrum.ieee.org/aidesigned-living-robots-crawl-heal-themselves" aria-label="AI-Designed &#39;Living Robots&#39; Crawl, Heal Themselves" data-type="text">
        AI-Designed &#39;Living Robots&#39; Crawl, Heal Themselves
    </a></h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/aidesigned-living-robots-crawl-heal-themselves" aria-label="AI-Designed &#39;Living Robots&#39; Crawl, Heal Themselves"></a></div></div></div><script type="application/json" id="post-context-2650279541">
    {"customDimensions": {"5":"Megan Scudellari","6":"biomedical","7":"medical devices, ethics, microrobots, algorithms, biology, bioengineering, robotics, evolutionary algorithm","8":"01/15/2020","10":"medical devices","11":2650279541}, "post": {"split_testing": {}, "providerId": 20, "sections": [0, 497728257, 544169523, 544169516, 539266149], "buckets": [], "authors": [21075154]} }
</script></article></div></div></div></div></div><div class="sidebar_ad_container" id="sSS_Default_Post_0_0_20_0_0_1_2_1_0_1_1"><!-- User Code --><div class="sidebar_sticky_parent"><div class="stick_in_parent"><div class="sidebar_repeat_ad"></div></div></div><!-- End User Code --></div></div></div></div><div class="" id="sSS_Default_Post_0_0_20_0_0_1_3"><div class="non_member_follow" id="sSS_Default_Post_0_0_20_0_0_1_3_0_0_0"></div></div><div class="mb-2 feature_post_full" id="sSS_Default_Post_0_0_20_0_0_1_5"><div class="posts-custom posts-custom-section section-holder clearfix" data-block="section_3" data-format="posts-custom" data-source="multi_filtered_parent_site_filtered_parent_site" data-source-type="multi" data-source-unique="true" data-section-id="" data-is-reordable="false" data-using-stickers="false" data-has-more="true" data-attr-layout_whatsapp="inactive" data-attr-layout_separator="inactive" data-attr-layout_all_sections="top" data-attr-layout_slack="inactive" data-attr-layout_post_shares="top" data-attr-use_tag_image_for_lead_media="true" data-attr-layout_time_to_read="top" data-attr-strategy="mutually-exclusive" data-attr-layout_all_date_full_format="false" data-attr-layout_body="bottom" data-attr-source_unique="true" data-attr-layout_author="top" data-attr-element_classes="feature_post_full" data-attr-posts_id="sSS_Default_Post_0_0_20_0_0_1_5" data-attr-layout_headline="top" data-attr-layout_custom_field_featurepostcolor="bottom" data-attr-layout_tumblr="inactive" data-attr-layout_subheadline="top" data-attr-source="multi" data-attr-layout_date="top" data-attr-layout_sms="inactive" data-attr-layout_photo_caption="bottom" data-attr-layout_image_column_width="20" data-attr-update_url_on_post_view="true" data-attr-layout_custom_field_featurepostimgposition="top" data-attr-all_share_buttons="Email,CopyLink,Twitter,Facebook,Linkedin,Tumblr,GooglePlus,Pinterest,Whatsapp,Reddit,Separator,Flipboard,SMS,Slack" data-attr-format="posts-custom" data-attr-layout_all_image_crop="3x2" data-attr-data-rm-advanced="true" data-attr-show_more_button_text="Keep Reading ↓" data-attr-layout_photo_credit="bottom" data-attr-node_id="/root/blocks/block[ss_default_post]/abtests/abtest[1]/element_wrapper/posts-" data-attr-layout_linkedin="active" data-attr-layout_googleplus="inactive" data-attr-layout_custom_field_pdf_version="top" data-attr-layout_like_button="top" data-attr-without_current="true" data-attr-use_smart_keep_reading="true" data-attr-layout_copylink="active" data-attr-layout_pinterest="inactive" data-attr-show_around_the_web="true" data-attr-data-rm-device-crops="true" data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,custom_field_pdf_version,post_shares,custom_field_FeaturePostImgPosition,photo_caption,photo_credit,custom_field_FeaturePostColor,body,custom_field_lightbox_img_shortcode_ids,primary_tag,community_name,badges,section,custom_field_TimeofRead,snark_line,follow_button,community_comments,page_views,collection_button,badges_sponsored,source_link,main_author,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,tags,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,product_vendor,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,custom_field_due_date,site_field_first_name,site_field_last_name,site_field_grade,custom_field_fullwidthbackgroundposition,custom_field_disable_comments" data-attr-layout_flipboard="inactive" data-attr-layout_custom_field_lightbox_img_shortcode_ids="bottom" data-attr-layout_all_date_format="%d %b %Y" data-attr-layout_reddit="inactive" data-attr-limit="1" data-attr-v="2" data-attr-layout_quality="1" data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix"><div class="widget tag-military-robots tag-arl tag-robotics tag-artificial-intelligence tag-ai post-section--topic/robotics" elid="2655067972" data-category="Robotics"><article elid="2655067972" data-is-frozen="false" class="clearfix image-article sm-mb-1 quality-HD post-2655067972"><div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="all-related-sections"><a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a><a href="https://spectrum.ieee.org/topic/">Topic</a><a href="https://spectrum.ieee.org/magazine/">Magazine</a><a href="https://spectrum.ieee.org/type/">Type</a><a href="https://spectrum.ieee.org/type/feature/">Feature</a><a href="https://spectrum.ieee.org/special-reports/">Special Reports</a></div><h2 class="widget__headline h2"><a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/ai-army-robots" aria-label="How the U.S. Army Is Turning Robots Into Team Players" data-type="text">
        How the U.S. Army Is Turning Robots Into Team Players
    </a></h2><div class="widget__subheadline"><h3 class="widget__subheadline-text h3" data-type="text"><p>Engineers battle the limits of deep learning for battlefield bots</p></h3></div><div class="social-author clearfix"><div class="social-author__avatar image"><div class="cover-all image" style="background-image: url(&quot;https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzA3MjAwNS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTcxNjgyMTgzOH0.5h5h13MlPw_GqfVeUNmZJ-jRmGXDoMaAXy3U2vtNBxM/image.png?width=210&quot;)"></div></div><a class="social-author__name" href="https://spectrum.ieee.org/u/evan-ackerman" data-type="text">Evan Ackerman</a></div><div class="social-date"><span class="social-date__text">23 Sep 2021</span></div><div class="time-to-read">11 min read</div><div class="like-button" data-post-likes="17"></div><div class="widget__shares share-panel"><!-- EMAIL --><a href="mailto:?subject=How%20the%20U.S.%20Army%20Is%20Turning%20Robots%20Into%20Team%20Players&body=https://spectrum.ieee.org/ai-army-robots" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK --><a href="https://spectrum.ieee.org/ai-army-robots" data-clipboard-text="https://spectrum.ieee.org/ai-army-robots" class="share share-copy-link" title="Copy this link to clipboard"><i class="icons-share" style="width: 60%"><svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i></a><!-- TWITTER --><a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/ai-army-robots&text=How%20the%20U.S.%20Army%20Is%20Turning%20Robots%20Into%20Team%20Players&" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK --><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Fai-army-robots%3Fxrs%3DRebelMouse_fb%26ts%3D1647039962" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN --><a href="http://www.linkedin.com/shareArticle?mini=false&url=https://spectrum.ieee.org/ai-army-robots&" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a></div></div><div class="widget__head"><a href="https://spectrum.ieee.org/ai-army-robots" aria-label="How the U.S. Army Is Turning Robots Into Team Players"><img fetchpriority="high" role="img" type="lazy-image" alt="Robot with threads near a fallen branch" aria-label="Robot with threads near a fallen branch" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/robot-with-threads-near-a-fallen-branch.jpg?id=27529807&width=1200&quality=85&coordinates=0%2C256%2C0%2C0&height=800" style="object-fit: cover;" class="rm-lazyloadable-image" width="1200" height="800"/></a></div><div class="widget__body clearfix sm-mt-1"><div class="photo-caption"><p>RoMan, the Army Research Laboratory&#39;s robotic manipulator, considers the best way to grasp and move a tree branch at the Adelphi Laboratory Center, in Maryland.</p></div><div class="photo-credit">
        Evan Ackerman
    </div><div class="custom-field-FeaturePostColor">LightGreen</div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2655067972" data-elid="2655067972" data-post-url="https://spectrum.ieee.org/ai-army-robots" data-authors="Evan Ackerman" data-headline="How the U.S. Army Is Turning Robots Into Team Players"><div class="body-description"><div class="widget__brief"><p><strong>“I should probably</strong> not be standing this close,&quot; I think to myself, as the robot slowly approaches a large tree branch on the floor in front of me. It&#39;s not the size of the branch that makes me nervous—it&#39;s that the robot is operating autonomously, and that while I know what it&#39;s <em>supposed</em> to do, I&#39;m not entirely sure what it <em>will</em> do. If everything works the way the roboticists at the <a href="https://www.arl.army.mil/who-we-are/locations/alc/" rel="noopener noreferrer" target="_blank">U.S. Army Research Laboratory (ARL)</a> in Adelphi, Md., expect, the robot will identify the branch, grasp it, and drag it out of the way. These folks know what they&#39;re doing, but I&#39;ve spent enough time around robots that I take a small step backwards anyway.<br/></p><p><div class="ieee-sidebar-small"><p>This article is part of our special report on AI, “<a href="https://spectrum.ieee.org/special-reports/the-great-ai-reckoning/" target="_blank">The Great AI Reckoning</a>.”</p></div></p><p>
	The robot, named 
	<a href="https://www.army.mil/article/228094/army_researchers_test_human_like_robots" rel="noopener noreferrer" target="_blank"><u>RoMan, for Robotic Manipulator</u></a>, is about the size of a large lawn mower, with a tracked base that helps it handle most kinds of terrain. At the front, it has a squat torso equipped with cameras and depth sensors, as well as a pair of arms that were harvested from a <a href="https://www.jpl.nasa.gov/robotics-at-jpl/robosimian" rel="noopener noreferrer" target="_blank">prototype disaster-response robot</a> originally developed at NASA&#39;s Jet Propulsion Laboratory for a DARPA robotics competition. RoMan&#39;s job today is roadway clearing, a multistep task that ARL wants the robot to complete as autonomously as possible. Instead of instructing the robot to grasp specific objects in specific ways and move them to specific places, the operators tell RoMan to &quot;go clear a path.&quot; It&#39;s then up to the robot to make all the decisions necessary to achieve that objective.
</p><div class="ad-in-content"></div></div><div class="content-container"></div><div class="js-appear-on-expand"><template><p>The ability to make decisions autonomously is not just what makes robots useful, it&#39;s what makes robots 
	<em>robots</em>. We value robots for their ability to sense what&#39;s going on around them, make decisions based on that information, and then take useful actions without our input. In the past, robotic decision making followed highly structured rules—if you sense this, then do that. In structured environments like factories, this works well enough. But in chaotic, unfamiliar, or poorly defined settings, reliance on rules makes robots notoriously bad at dealing with anything that could not be precisely predicted and planned for in advance.<br/></p><p><strong>RoMan, along with </strong>many other robots including <a href="https://spectrum.ieee.org/irobot-home-autonomy-update" target="_self"><u>home vacuums</u></a>, drones, and autonomous cars, handles the challenges of semistructured environments through artificial neural networks—a computing approach that loosely mimics the structure of neurons in biological brains. About a decade ago, artificial neural networks began to be applied to a wide variety of semistructured data that had previously been very difficult for computers running rules-based programming (generally referred to as symbolic reasoning) to interpret. Rather than recognizing specific data structures, an artificial neural network is able to recognize data patterns, identifying novel data that are similar (but not identical) to data that the network has encountered before. Indeed, part of the appeal of artificial neural networks is that they are trained by example, by letting the network ingest annotated data and learn its own system of pattern recognition. For neural networks with multiple layers of abstraction, this technique is called deep learning.
</p><p>
	Even though humans are typically involved in the training process, and even though artificial neural networks were inspired by the neural networks in human brains, the kind of pattern recognition a deep learning system does is fundamentally different from the way humans see the world. It&#39;s often nearly impossible to understand the relationship between the data input into the system and the interpretation of the data that the system outputs. And that difference—the &quot;black box&quot; opacity of deep learning—poses a potential problem for robots like RoMan and for the Army Research Lab.
</p><p class="pull-quote">
	In chaotic, unfamiliar, or poorly defined settings, reliance on rules makes robots notoriously bad at dealing with anything that could not be precisely predicted and planned for in advance.
</p><p>
	This opacity means that robots that rely on deep learning have to be used carefully. A deep-learning system is good at recognizing patterns, but lacks the world understanding that a human typically uses to make decisions, which is why such systems do best when their applications are well defined and narrow in scope. &quot;When you have well-structured inputs and outputs, and you can encapsulate your problem in that kind of relationship, I think deep learning does very well,&quot; says 
	<a href="http://www2.ece.rochester.edu/projects/rail/people/rail-people-thomashoward.html" rel="noopener noreferrer" target="_blank">Tom Howard</a>, who directs the University of Rochester&#39;s Robotics and Artificial Intelligence Laboratory and has developed natural-language interaction algorithms for RoMan and other ground robots. &quot;The question when programming an intelligent robot is, at what practical size do those deep-learning building blocks exist?&quot; Howard explains that when you apply deep learning to higher-level problems, the number of possible inputs becomes very large, and solving problems at that scale can be challenging. And the potential consequences of unexpected or unexplainable behavior are much more significant when that behavior is manifested through a 170-kilogram two-armed military robot.
</p><div class="ad-in-content"></div><p><strong>After a couple</strong> of minutes, RoMan hasn&#39;t moved—it&#39;s still sitting there, pondering the tree branch, arms poised like a praying mantis. For the last 10 years, the Army Research Lab&#39;s <a href="https://www.arl.army.mil/wp-content/uploads/2019/11/cta-Robotics_cta_overview_08.pdf" rel="noopener noreferrer" target="_blank"><u>Robotics Collaborative Technology Alliance</u></a> (RCTA) has been <a href="https://www.eurekalert.org/news-releases/854281" rel="noopener noreferrer" target="_blank">working with roboticists</a> from Carnegie Mellon University, Florida State University, General Dynamics Land Systems, JPL, MIT, QinetiQ North America, University of Central Florida, the University of Pennsylvania, and other top research institutions to develop robot autonomy for use in future ground-combat vehicles. RoMan is one part of that process.
</p><p>
	The &quot;go clear a path&quot; task that RoMan is slowly thinking through is difficult for a robot because the task is so abstract. RoMan needs to identify objects that might be blocking the path, reason about the physical properties of those objects, figure out how to grasp them and what kind of manipulation technique might be best to apply (like pushing, pulling, or lifting), and then make it happen. That&#39;s a lot of steps and a lot of unknowns for a robot with a limited understanding of the world.
</p><p>
	This limited understanding is where the ARL robots begin to differ from other robots that rely on deep learning, says Ethan Stump, chief scientist of the AI for Maneuver and Mobility program at ARL. &quot;The Army can be called upon to operate basically anywhere in the world. We do not have a mechanism for collecting data in all the different domains in which we might be operating. We may be deployed to some unknown forest on the other side of the world, but we&#39;ll be expected to perform just as well as we would in our own backyard,&quot; he says. Most deep-learning systems function reliably only within the domains and environments in which they&#39;ve been trained. Even if the domain is something like &quot;every drivable road in San Francisco,&quot; the robot will do fine, because that&#39;s a data set that has already been collected. But, Stump says, that&#39;s not an option for the military. If an Army deep-learning system doesn&#39;t perform well, they can&#39;t simply solve the problem by collecting more data.
</p><p>
	ARL&#39;s robots also need to have a broad awareness of what they&#39;re doing. &quot;In a standard operations order for a mission, you have goals, constraints, a paragraph on the commander&#39;s intent—basically a narrative of the purpose of the mission—which provides contextual info that humans can interpret and gives them the structure for when they need to make decisions and when they need to improvise,&quot; Stump explains. In other words, RoMan may need to clear a path quickly, or it may need to clear a path quietly, depending on the mission&#39;s broader objectives. That&#39;s a big ask for even the most advanced robot. &quot;I can&#39;t think of a deep-learning approach that can deal with this kind of information,&quot; Stump says.
</p><div class="ieee-sidebar-medium"><p class="shortcode-media shortcode-media-rebelmouse-image"><img alt="A robot moving through a group of trees.  " class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="51307568103ca48a0bbeff20e9bc7e45" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/a-robot-moving-through-a-group-of-trees.jpg?id=27530116&width=980" height="1294" id="fe94a" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1940 1294&#39;%3E%3C/svg%3E" width="1940"/></p><p class="shortcode-media shortcode-media-rebelmouse-image"><img alt="A robot moving up a hill." class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="e32060fb91aafa3ac1fc445e45c9eee6" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/a-robot-moving-up-a-hill.jpg?id=27530117&width=980" height="1323" id="afa98" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1984 1323&#39;%3E%3C/svg%3E" width="1984"/></p><p class="shortcode-media shortcode-media-rebelmouse-image"><img alt="A robot moving towards a metal drum." class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="ae5a40364c02d4f8159b773db472dc76" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/a-robot-moving-towards-a-metal-drum.jpg?id=27530120&width=980" height="1324" id="fdbb6" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1984 1324&#39;%3E%3C/svg%3E" width="1984"/><small class="image-media media-caption" placeholder="Add Photo Caption...">Robots at the Army Research Lab test autonomous navigation techniques in rough terrain [top, middle] with the goal of being able to keep up with their human teammates. ARL is also developing robots with manipulation capabilities [bottom] that can interact with objects so that humans don&#39;t have to.</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Evan Ackerman</small></p></div><p>
	While I watch, RoMan is reset for a second try at branch removal. ARL&#39;s approach to autonomy is modular, where deep learning is combined with other techniques, and the robot is helping ARL figure out which tasks are appropriate for which techniques. At the moment, RoMan is testing two different ways of identifying objects from 3D sensor data: UPenn&#39;s approach is deep-learning-based, while Carnegie Mellon is using a method called perception through search, which relies on a more traditional database of 3D models. Perception through search works only if you know exactly which objects you&#39;re looking for in advance, but training is much faster since you need only a single model per object. It can also be more accurate when perception of the object is difficult—if the object is partially hidden or upside-down, for example. ARL is testing these strategies to determine which is the most versatile and effective, letting them run simultaneously and compete against each other.
</p><p><strong>Perception is one</strong> of the things that deep learning tends to excel at. &quot;The computer vision community has made crazy progress using deep learning for this stuff,&quot; says <a href="https://www.linkedin.com/in/maggie-wigness-907a0984/" rel="noopener noreferrer" target="_blank"><u>Maggie Wigness</u></a>, a computer scientist at ARL. &quot;We&#39;ve had good success with some of these models that were trained in one environment generalizing to a new environment, and we intend to keep using deep learning for these sorts of tasks, because it&#39;s the state of the art.&quot;
</p><p>
	 ARL&#39;s modular approach might combine several techniques in ways that leverage their particular strengths. For example, a perception system that uses deep-learning-based vision to classify terrain could work alongside an autonomous driving system based on an approach called inverse reinforcement learning, where the model can rapidly be created or refined by observations from human soldiers. Traditional reinforcement learning optimizes a solution based on established reward functions, and is often applied when you&#39;re not necessarily sure what optimal behavior looks like. This is less of a concern for the Army, which can generally assume that well-trained humans will be nearby to show a robot the right way to do things. &quot;When we deploy these robots, things can change very quickly,&quot; Wigness says. &quot;So we wanted a technique where we could have a soldier intervene, and with just a few examples from a user in the field, we can update the system if we need a new behavior.&quot; A deep-learning technique would require &quot;a lot more data and time,&quot; she says.
</p><p>
	It&#39;s not just data-sparse problems and fast adaptation that deep learning struggles with. There are also questions of robustness, explainability, and safety. &quot;These questions aren&#39;t unique to the military,&quot; says Stump, &quot;but it&#39;s especially important when we&#39;re talking about systems that may incorporate lethality.&quot; To be clear, ARL is not currently working on lethal autonomous weapons systems, but the lab is helping to lay the groundwork for autonomous systems in the U.S. military more broadly, which means considering ways in which such systems may be used in the future.
</p><p class="pull-quote">
	The requirements of a deep network are to a large extent misaligned with the requirements of an Army mission, and that&#39;s a problem.
</p><p>
	Safety is an obvious priority, and yet there isn&#39;t a clear way of making a deep-learning system verifiably safe, according to Stump. &quot;Doing deep learning with safety constraints is a major research effort. It&#39;s hard to add those constraints into the system, because you don&#39;t know where the constraints already in the system came from. So when the mission changes, or the context changes, it&#39;s hard to deal with that. It&#39;s not even a data question; it&#39;s an architecture question.&quot; ARL&#39;s modular architecture, whether it&#39;s a perception module that uses deep learning or an autonomous driving module that uses inverse reinforcement learning or something else, can form parts of a broader autonomous system that incorporates the kinds of safety and adaptability that the military requires. Other modules in the system can operate at a higher level, using different techniques that are more verifiable or explainable and that can step in to protect the overall system from adverse unpredictable behaviors. &quot;If other information comes in and changes what we need to do, there&#39;s a hierarchy there,&quot; Stump says. &quot;It all happens in a rational way.&quot;
</p><p><a href="https://www.csail.mit.edu/person/nicholas-roy" rel="noopener noreferrer" target="_blank"><u>Nicholas Roy</u></a>, who leads the <a href="http://groups.csail.mit.edu/rrg/" rel="noopener noreferrer" target="_blank"><u>Robust Robotics Group at MIT</u></a> and describes himself as &quot;somewhat of a rabble-rouser&quot; due to his skepticism of some of the claims made about the power of deep learning, agrees with the ARL roboticists that deep-learning approaches often can&#39;t handle the kinds of challenges that the Army has to be prepared for. &quot;The Army is always entering new environments, and the adversary is always going to be trying to change the environment so that the training process the robots went through simply won&#39;t match what they&#39;re seeing,&quot; Roy says. &quot;So the requirements of a deep network are to a large extent misaligned with the requirements of an Army mission, and that&#39;s a problem.&quot;
</p><p>
	Roy, who has worked on abstract reasoning for ground robots as part of the RCTA, emphasizes that deep learning is a useful technology when applied to problems with clear functional relationships, but when you start looking at abstract concepts, it&#39;s not clear whether deep learning is a viable approach. &quot;I&#39;m very interested in finding how neural networks and deep learning could be assembled in a way that supports higher-level reasoning,&quot; Roy says. &quot;I think it comes down to the notion of combining multiple low-level neural networks to express higher level concepts, and I do not believe that we understand how to do that yet.&quot; Roy gives the example of using two separate neural networks, one to detect objects that are cars and the other to detect objects that are red. It&#39;s harder to combine those two networks into one larger network that detects red cars than it would be if you were using a symbolic reasoning system based on structured rules with logical relationships. &quot;Lots of people are working on this, but I haven&#39;t seen a real success that drives abstract reasoning of this kind.&quot;
</p><p><strong>For the foreseeable</strong> future, ARL is making sure that its autonomous systems are safe and robust by keeping humans around for both higher-level reasoning and occasional low-level advice. Humans might not be directly in the loop at all times, but the idea is that humans and robots are more effective when working together as a team. When the most recent phase of the Robotics Collaborative Technology Alliance program began in 2009, Stump says, &quot;we&#39;d already had many years of being in Iraq and Afghanistan, where robots were often used as tools. We&#39;ve been trying to figure out what we can do to transition robots from tools to acting more as teammates within the squad.&quot;
</p><p>
	RoMan gets a little bit of help when a human supervisor points out a region of the branch where grasping might be most effective. The robot doesn&#39;t have any fundamental knowledge about what a tree branch actually is, and this lack of world knowledge (what we think of as common sense) is a fundamental problem with autonomous systems of all kinds. Having a human leverage our vast experience into a small amount of guidance can make RoMan&#39;s job much easier. And indeed, this time RoMan manages to successfully grasp the branch and noisily haul it across the room.
</p><p>
	Turning a robot into a good teammate can be difficult, because it can be tricky to find the right amount of autonomy. Too little and it would take most or all of the focus of one human to manage one robot, which may be appropriate in special situations like explosive-ordnance disposal but is otherwise not efficient. Too much autonomy and you&#39;d start to have issues with trust, safety, and explainability.
</p><p>
	&quot;I think the level that we&#39;re looking for here is for robots to operate on the level of working dogs,&quot; explains Stump. &quot;They understand exactly what we need them to do in limited circumstances, they have a small amount of flexibility and creativity if they are faced with novel circumstances, but we don&#39;t expect them to do creative problem-solving. And if they need help, they fall back on us.&quot;
</p><p><strong>RoMan is not likely </strong>to find itself out in the field on a mission anytime soon, even as part of a team with humans. It&#39;s very much a research platform. But the software being developed for RoMan and other robots at ARL, called <a href="https://arxiv.org/abs/2105.07620" rel="noopener noreferrer" target="_blank"><u>Adaptive Planner Parameter Learning (APPL)</u></a>, will likely be used first in autonomous driving, and later in more complex robotic systems that could include mobile manipulators like RoMan. APPL combines different machine-learning techniques (including inverse reinforcement learning and deep learning) arranged hierarchically underneath classical autonomous navigation systems. That allows high-level goals and constraints to be applied on top of lower-level programming. Humans can use teleoperated demonstrations, corrective interventions, and evaluative feedback to help robots adjust to new environments, while the robots can use unsupervised reinforcement learning to adjust their behavior parameters on the fly. The result is an autonomy system that can enjoy many of the benefits of machine learning, while also providing the kind of safety and explainability that the Army needs. With APPL, a learning-based system like RoMan can operate in predictable ways even under uncertainty, falling back on human tuning or human demonstration if it ends up in an environment that&#39;s too different from what it trained on.
</p><p>
	It&#39;s tempting to look at the rapid progress of commercial and industrial autonomous systems (autonomous cars being just one example) and wonder why the Army seems to be somewhat behind the state of the art. But as Stump finds himself having to explain to Army generals, when it comes to autonomous systems, &quot;there are lots of hard problems, but industry&#39;s hard problems are different from the Army&#39;s hard problems.&quot; The Army doesn&#39;t have the luxury of operating its robots in structured environments with lots of data, which is why ARL has put so much effort into APPL, and into maintaining a place for humans. Going forward, humans are likely to remain a key part of the autonomous framework that ARL is developing. &quot;That&#39;s what we&#39;re trying to build with our robotics systems,&quot; Stump says. &quot;That&#39;s our bumper sticker: &#39;From tools to teammates.&#39; &quot;
</p><p><em>This article appears in the October 2021 print issue as &quot;Deep Learning Goes to Boot Camp<span></span></em><em>.&quot;</em></p><p><div class="ieee-sidebar-large"><h3>
	Special Report: The Great AI Reckoning</h3><p class="shortcode-media shortcode-media-rebelmouse-image"><a href="https://spectrum.ieee.org/special-reports/the-great-ai-reckoning/" target="_blank"><img src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzUxNTIyNC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY3NTE5NDgyOH0.m2EpRmhzxdUva3Y-0S_2tebrXbHrKqBfsKopqCCdtLY/image.jpg?width=1000&quality=80"/></a></p><p><strong>READ NEXT:</strong><a href="https://spectrum.ieee.org/ai-failures" target="_self">7 Revealing Ways AIs Fail</a></p><p>
		Or see the <a href="https://spectrum.ieee.org/special-reports/the-great-ai-reckoning/" target="_blank">full report</a> for more articles on the future of AI.
	</p></div></p><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div><ul class="around-the-web__list"><li class="from-your-site__item"><a href="https://spectrum.ieee.org/humans-cognitive-biases-facing-ai" class="from-your-site__link" target="_blank" rel="noopener noreferrer">AI and Robots Are a Minefield of Cognitive Biases - IEEE Spectrum ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/lethal-autonomous-weapons-exist-they-must-be-banned" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Lethal Autonomous Weapons Exist; They Must Be Banned - IEEE ... ›</a></li><li class="from-your-site__item"><a href="https://spectrum.ieee.org/army-trains-ai-to-identify-faces-in-the-dark" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Army Trains AI to Identify Faces in the Dark - IEEE Spectrum ›</a></li></ul><div class="around-the-web__headline">Related Articles Around the Web</div><ul class="around-the-web__list"><li class="around-the-web__item"><a href="https://www.cmu.edu/news/stories/archives/2020/april/army-ai-innovation-framework.html" class="around-the-web__link" target="_blank" rel="noopener noreferrer">CMU Selected by U.S. Army to Lead Artificial Intelligence Innovation ... ›</a></li><li class="around-the-web__item"><a href="https://www.army.mil/article/237258/artificial_intelligence_task_force_welcomes_inaugural_class_of_ai_scholars" class="around-the-web__link" target="_blank" rel="noopener noreferrer">Artificial Intelligence Task Force Welcomes Inaugural Class of AI ... ›</a></li><li class="around-the-web__item"><a href="https://www.army.mil/standto/archive/2020/04/10/" class="around-the-web__link" target="_blank" rel="noopener noreferrer">U.S. Army STAND-TO! | U.S. Army&#39;s Artificial Intelligence and Ethical ... ›</a></li></ul></div></template></div><div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds"><span class="show-more js-expand">Keep Reading ↓</span><span class="show-less js-contract">Show less</span></div></div></div><span class="js-scrolled-url" data-elid="2655067972" data-post-url="https://spectrum.ieee.org/ai-army-robots" data-authors="Evan Ackerman" data-headline="How the U.S. Army Is Turning Robots Into Team Players"></span></div></div></div><script type="application/json" id="post-context-2655067972">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"military robots, arl, robotics, artificial intelligence, ai, ~rmsc:rebelmouse-image:27529807, ~rmsc:rebelmouse-image:27530116, ~rmsc:rebelmouse-image:27530117, ~rmsc:rebelmouse-image:27530120","8":"09/23/2021","10":"military robots","11":2655067972}, "post": {"split_testing": {}, "providerId": 0, "sections": [0, 497728257, 539626628, 544169516, 544169517, 545658351, 539266128, 539633585, 554320594, 554738970, 550122300], "buckets": [], "authors": [21075149]} }
</script></article></div></div></div></div><div class="" id="sSS_Default_Post_0_0_20_0_0_1_6"><!-- User Code --><!-- div id='infinite_leaderboard_1'><script>
    googletag.cmd.push(function() { googletag.display('infinite_leaderboard_1'); });
  </script></div --><div class="infinite-leaderboard"></div><!-- End User Code --></div><div class="wrapper-lazy-loading infinite-scroll-wrapper next-page-wrapper" style="display: block !important;" data-skl-id="/root/blocks/block[ss_default_post]/abtests/abtest[1]/element_wrapper/lazyload-" data-has-more="true" data-more-posts-exists="true" data-posts-sources="post_most_sections,post_sponsor_webinar_whitepaper,multi_filtered_parent_site_filtered_parent_site,frontpage_parent_site_podcast" data-ignore-page-number="false"></div></div><span class="js-brick-description hidden" data-name="JS post functions"></span><!-- User Code --><script>
  function feature_post_full_style(){
    var feature_post_full = document.querySelectorAll(".feature_post_full:not(.proc)");
	for (i = 0; i < feature_post_full.length; i++) {
      var style_post_color = feature_post_full[i].querySelector(".custom-field-FeaturePostColor");
      var style_post_position = feature_post_full[i].querySelector(".custom-field-FeaturePostImgPosition");
      if(style_post_color){
         feature_post_full[i].classList.add(style_post_color.innerText);
      }else{
      	 feature_post_full[i].classList.add('DarkGray');
      }
      if(style_post_position){
         feature_post_full[i].classList.add(style_post_position.innerText);
      }
      feature_post_full[i].classList.add('proc');
    }  
  }
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="Parsely Spectrum Tags"></span><span class="js-brick-description hidden" data-name="__Lightbox_Functionality"></span><div class="lightbox-layout" id="s__Lightbox_Functionality_0_0_31_0_0_1_1_1"><!-- User Code --><div class="lightbox__close hm__close"></div><!-- End User Code --></div></div></div><ul id="notification" class="notification"></ul><script defer="defer" src="https://www.googletagmanager.com/gtag/js?id=UA-747464-1"></script><script>

            (function (i, s, o, g, r, a, m) {
                i["GoogleAnalyticsObject"] = r;
                (i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments);}),(i[r].l = 1 * new Date());
            })(window, document, "script", "/", "ga");
            ga('create', 'UA-747464-1', 'auto', {'name': 'b'});

            window.dataLayer = window.dataLayer || [];
            window.gtag = function(){dataLayer.push(arguments);}
            gtag('js', new Date());

            var utmCampaignData = null;// ADD REFERRER AS SOURCE IF SOURCE IS NOT PRESENT OR IF ISN'T URL UTM
            if(utmCampaignData && (utmCampaignData.dataSource != "url" || !utmCampaignData['campaignSource'])) {
                var referrerAnchor = document.createElement('a');
                referrerAnchor.setAttribute('href', document.referrer);
                if(referrerAnchor.href && referrerAnchor.host) {
                    var splitHost = referrerAnchor.host.split(".");
                    var nakedDomain = splitHost.length < 3 ? splitHost[0] : splitHost[1];
                    if (nakedDomain) {
                        nakedDomain = nakedDomain[0].toUpperCase() + nakedDomain.substring(1);
                        utmCampaignData['campaignSource'] = nakedDomain;
                    }
                }
            }

            var configParams = { transport: 'beacon', send_page_view: false };
            // DEFAULTS
            if (utmCampaignData) {
                configParams.campaignName = utmCampaignData.campaignName;
                configParams.campaignSource = utmCampaignData.campaignSource;
                configParams.campaignMedium = utmCampaignData.campaignMedium;
                configParams.campaignContent = utmCampaignData.campaignContent;
                if (utmCampaignData.campaignKeyword) {
                    configParams.campaignKeyword = utmCampaignData.campaignKeyword;
                }
            }

            gtag('config', 'UA-747464-1', configParams);gtag('config', 'G-DPQFLXZCWN', configParams);
  window._ga_cd_params = window._ga_cd_params || {};

    

    window._ga_cd_params["dimension9"] = 'ieee,1784';window._ga_cd_params["dimension5"] = "Payal Dhar";

          window._ga_cd_params["dimension11"] = '2657489115';

          window._ga_cd_params["dimension7"] = "microrobots, biomemetic robots, shape memory alloy, ~rmsc:rebelmouse-image:29964026, ~rmsc:rebelmouse-image:29964031, ~rmsc:rebelmouse-image:29964028";

          window._ga_cd_params["dimension10"] = 'microrobots';

          window._ga_cd_params["dimension6"] = 'robotics';

          

          window._ga_cd_params["dimension8"] = '06/11/2022';

          

          

          

          
            if(window._ga_cd_params && Object.keys(window._ga_cd_params).length){
                gtag('event', 'page_view', window._ga_cd_params);
            }else{
                gtag('event', 'page_view');
            }
        </script><script>
        if (typeof window.gtag === 'function') {
            var anchors = document.getElementsByTagName('a');
            for(var i = 0; i < anchors.length; i++) {
                var elem = anchors[i];
                elem.addEventListener('click', function (evnt) {
                    if (document.location.hostname === evnt.currentTarget.hostname) {
                        return;
                    }
                    if (!evnt.currentTarget.href) {
                        return;
                    }
                    if (evnt.currentTarget.href.lastIndexOf('javascript:', 0) === 0) {
                        return;
                    }
                    window.gtag('event', 'click', {
                        'event_category': 'outgoing_links',
                        'event_action': 'click',
                        'event_label': evnt.currentTarget.href,
                        'nonInteraction': 1,
                    });
                }, false);
            }
        }
    </script><script type="application/ld+json">

{
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
        "@type": "WebPage"
      },
    "headline": "Flea-Sized Robots Walk a Coin-Edge-Sized Path",
    
        "image": "https://assets.rbl.ms/29964026/origin.jpg",
    
    "datePublished": "2022-06-11T13:00:01Z",
    "dateModified": "2022-06-11T13:00:01Z",
    
        "author": {
            "name": "Payal Dhar",
            "@type": "Person",
			"url": "https://spectrum.ieee.org/u/payal-dhar"
        },
        "creator": {
            "name": "Payal Dhar",
            "@type": "Person"
        },
	"publisher": {
        "logo": {
            "url": "https://assets.rbl.ms/26794698/origin.png",
            "@type": "ImageObject",
            "width": 2000,
            "height": 210
        },
        "name": "IEEE Spectrum",
        "@type": "Organization"
    },
    "description": "",
    "isAccessibleForFree": "False",
    "hasPart": [
    {
        "@type": "WebPageElement",
        "isAccessibleForFree": "False",
        "cssSelector" : ".gated"
     }
]
}</script><script class="lazy-style" type="css">
        

    </script><script id="parsely-cfg" src="//cdn.parsely.com/keys/spectrum.ieee.org/p.js"></script><script id="user-javascript-medium-normal">
        window.REBELMOUSE_TASKS_QUEUE.push(function loadFonts(){
window.REBELMOUSE_STDLIB.loadFontFace('IvarText', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Regular.woff2', {selector: '',
  weight: '400',
  style: 'normal'
});
window.REBELMOUSE_STDLIB.loadFontFace('IvarTextItalic', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Italic.woff2', {selector: '',
  weight: '400',
  style: 'italic'
});
window.REBELMOUSE_STDLIB.loadFontFace('IvarText', 'https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Bold.woff2', {selector: '',
  weight: '700',
  style: 'normal'
});});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        REBELMOUSE_STDLIB
  .createElementChangeListener('.rm-shortcode[href*=".pdf"]', function(pdfLink){
    pdfLink.href = 'javascript:void(0);';
    pdfLink.classList.add('pdf-link-nonmember');
    pdfLink.addEventListener('click', function(){
      openGatedPopup('for_pdf_issues');
    });
});
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        //var ssoValidatorUrl = 'https://oamssoqae.ieee.org/ieeevendorsso/rest/auth/validatePFToken?_=' + (+ new Date());

var ssoValidatorUrl = 'https://securesso.ieee.org/ieeevendorsso/rest/auth/validatePFToken?_=' + (+ new Date());

function getCookie(name) {
  const value = `; ${document.cookie}`;
  const parts = value.split(`; ${name}=`);
  if (parts.length === 2) return parts.pop().split(';').shift();
}

fetch(ssoValidatorUrl, {
    method: 'GET',
    mode: 'cors',
    credentials: 'include',
}).then(function (response) {
	// The API call was successful!
	if (response.ok) {
		response.json().then(function(result) {
          if (typeof result == 'object' && result.cookieValid && getCookie('user_logged_in') !== "1") { 		//SSO
              console.log('we should be logged in, redirect to SSO iDP');
              //window.location.href = 'https://spectrumtest.ieee.org/core/saml/main/login?next_url=' + window.location.href;
              window.location.href = "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
          } else if (typeof result == 'object' && !result.cookieValid) {		//SLO
              console.log('we should be logged out, remove cookie and do not show user');
              //document.cookie = "sessionid= ; expires = Thu, 01 Jan 1970 00:00:00 GMT";
          }
        });
      
	} else {
		return Promise.reject(response);
	}
}).then(function (data) {
	// This is the JSON from our response
	console.log(data);
}).catch(function (err) {
	// There was an error
	console.warn('Something went wrong.', err);
});
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        function changeDateFormat(widget){
  var dates_toChange=widget.querySelectorAll('.widget .social-date__text:not(.processed),.widget .social-date-modified__text:not(.processed)');
  if(dates_toChange){
    dates_toChange.forEach(function(date) {

      if(!date.innerHTML.trim()==""){
        date.classList.add('processed')
        var date_string=date.innerHTML.toString();
        var slpit_dateText=date_string.split(" ");


        if(slpit_dateText.length==1){
          let plural=true;
          if(slpit_dateText[0].length==2){
            if(slpit_dateText[0].charAt(0)=="1"){
              plural=false;
            }
          }
          let modifier=plural ? 'hours ago':'hour ago';

          if(slpit_dateText[0].substr(-1)=='m'){
            modifier=plural ? 'minutes ago':'minute ago';
          }
          if(slpit_dateText[0].substr(-1)=='s'){
            modifier=plural ? 'seconds ago':'second ago';
          }
          var new_dateText=slpit_dateText[0].slice(0,-1);
          date.innerHTML=  new_dateText+" "+ modifier;
          date.classList.add("modified");
        }
      }
    });

  }
}
_createElementChangeListener= function (selector, callback) {
  const initializedNodes = new Set([]);

  document.querySelectorAll(selector).forEach((node) => {
    callback(node);
    initializedNodes.add(node);
  });

  const mutationObserver = new MutationObserver(() => {
    const nodes = document.querySelectorAll(selector);
    nodes.forEach((node) => {
      if (!initializedNodes.has(node)) {
        callback(node);
        initializedNodes.add(node);
      }
    });
  });

  mutationObserver.observe(document.body, {
    childList: true,
    subtree: true,
  });
}
_createElementChangeListener(".widget",changeDateFormat);
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        feature_post_full_style();
    

});</script><script id="user-javascript-active" type="text">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</script><script id="user-javascript-lowest" type="text">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</script></body></html>