    <!DOCTYPE html>
<!-- Powered by RebelMouse. https://www.rebelmouse.com -->
<html lang="en">
<head prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#"><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"></link><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Italic.woff2" type="font/woff2" crossorigin="" rel="preload"></link><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarText-Bold.woff2" type="font/woff2" crossorigin="" rel="preload"></link>
    <meta name="twitter:card"               content="summary">
<meta name="twitter:site"               content="@">
<meta name="twitter:site:id"            content="">
<meta property="fb:app_id"              content="525370847662646">
<meta property="og:type"                content="article">
<meta property="article:section"        content="The Institute">
        <meta property="og:url" content="https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts">
        <link rel="canonical" href="https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts" />
    <meta property="og:site_name"           content="IEEE Spectrum">
    
<meta property="og:image"               content="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjg4NDUyMC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTYzNjkyNzQzOX0.mNqUZqo5a_BsPraQgLORhtWMCwZkh3R1prMdTe4pEFY/image.png?width=210">
<meta property="og:image:width"               content="210">
<meta property="og:image:height"               content="2000">
    <meta property="og:title"               content="Tomorrow’s AI Will Reason Like Humans, IBM Watson Developer Predicts">
    <meta property="og:description"         content="David Nahamoo says machines will grok us">

<meta name="referrer" content="always" />

    <meta charset="utf-8">
    <link rel="preconnect" href="https://assets.rebelmouse.io/" crossorigin>
    <link rel="preconnect" href="https://user-stats.rbl.ms/" crossorigin>
    <link rel="preconnect" href="https://pages-stats.rbl.ms/" crossorigin>
    <!--link rel="preload" href="https://static.rbl.ms/static/fonts/fontawesome/fontawesome-mini.woff" as="font" type="font/woff2" crossorigin-->
    <script>window.REBELMOUSE_BOOTSTRAP_DATA = {"engine": {"changeParticleUrlScroll": true, "lazyLoadShortcodeImages": true, "theoPlayerLibraryLocation": "", "defaultVideoPlayer": "", "backButtonGoToPage": true, "webVitalsSampleRate": 100, "countKeepReadingAsPageview": true, "uplynkAdsConfig": "", "trackPageViewOnParticleUrlScroll": true}, "isUserLoggedIn": false, "runner": {"id": 20265424}, "resourceId": "pp_2654877000", "section": {"id": null}, "fbId": "525370847662646", "site": {"id": 20265424}, "pathParams": {"slug": "tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts"}, "messageBusUri": "wss://messages.rebelmouse.io", "tag": {"slug": "ieee-member-news"}, "clientGaId": "UA-747464-1", "post": {"sections": [0, 497728257, 544169516, 539628627, 544169528, 539626938], "shareUrl": "https%3A%2F%2Fspectrum.ieee.org%2Ftomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts", "id": 2654877000}, "fbAppVersion": "v2.5", "useRiver": true, "fullBootstrapUrl": "/res/bootstrap/data.js?path_params=%7B%22slug%22%3A%22tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts%22%7D\u0026post_id=2654877000\u0026site_id=20265424\u0026override_device=desktop\u0026resource_id=pp_2654877000"};
    </script>
    <script>
        window.REBELMOUSE_BASE_ASSETS_URL = "https://spectrum.ieee.org/static/dist/social-ux/";
        window.REBELMOUSE_BASE_SSL_DOMAIN = "https://spectrum.ieee.org";
        window.REBELMOUSE_TASKS_QUEUE = [];
        window.REBELMOUSE_LOW_TASKS_QUEUE = [];
        window.REBELMOUSE_LOWEST_TASKS_QUEUE = [];
        window.REBELMOUSE_ACTIVE_TASKS_QUEUE = [];
        window.REBELMOUSE_STDLIB = {};
        window.RM_OVERRIDES = {};
        window.RM_AD_LOADER = [];
    </script>
    <script type="module" async src="https://spectrum.ieee.org/static/dist/social-ux/main.7dce9371651e34c38497.bundle.mjs"></script>
    <script nomodule defer src="https://spectrum.ieee.org/static/dist/social-ux/main.36281ab2473de62963ec.bundle.js"></script>

    <script type="module" async src="https://spectrum.ieee.org/static/dist/social-ux/runtime.5f799026dc7607827e1f.bundle.mjs"></script>
    <script nomodule defer src="https://spectrum.ieee.org/static/dist/social-ux/runtime.a23f0bdfa8e61def07fb.bundle.js"></script>

    
    <!-- we collected enough need to fix it first before turn in back on-->
    <!--script src="//cdn.ravenjs.com/3.16.0/raven.min.js" crossorigin="anonymous"></script-->
    <!--script type="text/javascript">
        Raven.config('https://6b64f5cc8af542cbb920e0238864390a@sentry.io/147999').install();
    </script-->
    <link rel="manifest" href="/manifest.json">
    <meta name="theme-color" content="#647187"/><script>
        if ('serviceWorker' in navigator) {
          window.addEventListener('load', function() {
            navigator.serviceWorker.register('/sw.js').then(function(registration) {
              console.log('ServiceWorker registration successful with scope: ', registration.scope);
            }, function(err) {
              console.log('ServiceWorker registration failed: ', err);
            });
          });
        } else {
          console.log('ServiceWorker not enabled');
        }
    </script>
    <script>
        // fallback error prone google tag setup
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

    

    

    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    
    
        
        <link rel="alternate" type="application/rss+xml" title="IEEE Spectrum" href="/feeds/topic/the-institute.rss" />
        
    
    


    <!-- Mobile viewport optimized: h5bp.com/viewport -->
    <meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1.0,maximum-scale=1.0,user-scalable=no">

    

    

    

    <title>Tomorrow’s AI Will Reason Like Humans, IBM Watson Developer Predicts - IEEE Spectrum</title>
    
    
    
    <style>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</style>
    <script>
        window.REBELMOUSE_LOW_TASKS_QUEUE.push(function() {
            window.REBELMOUSE_STDLIB.loadExternalStylesheet("/static/css-build/roar/runner/social-ux-non-critical.css?v=rmxassetsf3e0ced51f20c9c86aed5e8b5ada35fbRMCSS", function(){
                document.body.classList.add("rm-non-critical-loaded");
            });
        });
    </script>
    
    <script>
        var __RUNNER_PUBLIC__ = {
          root: '#runner-root',
          events: {
            PAGE_VIEW: 'page_view.url_change.listicle_switch_page',
            URL_CHANGE_PAGE_VIEW: 'page_view.url_change',
            LISTICLE_CHANGE_PAGE_VIEW: 'page_view.listicle_switch_page'
          }
        }
    </script>
    <script>
        window.__rebelmouseJsBaseUrl = "/static/js-build/";
        
        window.__rebelmousePrimaryColor = "#FF4C00";
        
    </script>
    
    
    
    
    
    <link rel="apple-touch-icon"      href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjU5NjY0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1OTYwMjUwNn0.83ww7bkGqpGwDJ0lJUQ9t40jCxvzIiI09EEqwNcU8HE/img.png?width=192&amp;height=192" sizes="192x192"/>
<link rel="icon" type="image/png" href="https://assets.rebelmouse.io/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjU5NjY0OS9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY1OTYwMjUwNn0.83ww7bkGqpGwDJ0lJUQ9t40jCxvzIiI09EEqwNcU8HE/img.png?width=32&amp;height=32"   sizes="16x16"/><meta property="article:published_time" content="2021-09-03T18:00:00+00:00" /><meta property="article:modified_time" content="2021-09-03T18:50:29+00:00" /><meta name="keywords" content="IBM, ibm watson, speech recognition technology, natural language processing, pryon, ai, Artificial Intelligence, ieee member news, type:ti"/><meta name="description" content="David Nahamoo says machines will grok us"/><link rel="amphtml" href="https://spectrum.ieee.org/amp/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts-2654877000"><script>
window.postid = "2654877000";
window.category = ["type", "profile", "topic", "careers", "the-institute"];
window.tags = ["ibm", "ibm-watson", "speech-recognition-technology", "natural-language-processing", "pryon", "ai", "artificial-intelligence", "ieee-member-news", "type:ti"];

</script><link as="font" href="https://partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Light.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Bold.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Book.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Light.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Regular.woff2" type="font/woff2" crossorigin="" rel="preload"/><link as="font" href="https://partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Bold.woff2" type="font/woff2" crossorigin="" rel="preload"/><style> 
  @font-face { 
    font-family: 'Favorit-Mono'; 
    font-weight: normal;
    src: url('//partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Regular.woff2') format('woff2'),
      url('//partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Regular.woff') format('woff'); 
    font-display:swap;
  }
  
   @font-face { 
    font-family: 'Favorit-Mono'; 
    font-weight: 100;
    src: url('//partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Light.woff2') format('woff2'),
      url('//partners.rebelmouse.com/IEEE/FavoritMono/ABCFavoritMono-Light.woff') format('woff'); 
    font-display:swap;
  }
  
  @font-face { 
    font-family: 'Favorit-Pro'; 
    font-weight: normal;
    src: url('//partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Regular.woff2') format('woff2'),
      url('//partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Regular.woff') format('woff'); 
    font-display:swap;
  }
  
  @font-face { 
    font-family: 'Favorit-Pro'; 
    font-weight: bold;
    src: url('//partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Bold.woff2') format('woff2'),
      url('//partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Bold.woff') format('woff'); 
    font-display:swap;
  }
  
  @font-face { 
    font-family: 'Favorit-Pro-Book'; 
    font-weight: normal;
    src: url('//partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Book.woff2') format('woff2'),
      url('//partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Book.woff') format('woff'); 
    font-display:swap;
  }
  
  @font-face { 
    font-family: 'Favorit-Pro-Light'; 
    font-weight: normal;
    src: url('//partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Light.woff2') format('woff2'),
      url('//partners.rebelmouse.com/IEEE/ABCFavoritProFullWeb/ABCFavoritPro-Light.woff') format('woff'); 
    font-display:swap;
  }
  
  @font-face { 
    font-family: 'Ivar-Headline'; 
    font-weight: normal; 
    src: url('//partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Regular.woff2') format('woff2'),
      url('//partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Regular.woff') format('woff'); 
    font-display:swap;
  }
  
  @font-face { 
    font-family: 'Ivar-Headline-Bold'; 
    font-weight: normal; 
    src: url('//partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Bold.woff2') format('woff2'),
      url('//partners.rebelmouse.com/IEEE/IvarCompleteWeb/IvarHeadline-Bold.woff') format('woff'); 
    font-display:swap;
  }
  
  @font-face { 
    font-family: 'Telegraf'; 
    font-weight: bold; 
    src: url('//partners.rebelmouse.com/IEEE/Telegraf/Telegraf%2520UltraBold%2520800.otf') format('otf'); 
    font-display:swap;
  }
  
</style><meta name="google-site-verification" content="TL2pz9TZSlPds24a3mqZClMC79zWmgOKFwO4aYRjdXk" /><style id="custom-post-styles-2654877000">
</style><style id="custom-post-styles-2654804251">
										.css-listicle-body-2654804251 #rebelltitem3  {
										}
</style>

   <meta name="parsely-section" content="The Institute" />
  

 <meta name="parsely-tags" content="IBM,ibm watson,speech recognition technology,natural language processing,pryon,ai,Artificial Intelligence,ieee member news,type:ti,SpectrumType.Profile"/>

<meta name="parsely-author" content="Joanna Goodrich" />


    


    <script>
    
        (function() {
    var cookie = 'rebelmouse_abtests=';
        cookie += '; Max-Age=0';
    document.cookie = cookie + '; Path=/; SameSite=None; Secure';
})();
    
    </script>


    <!--[if IE]>
        <script type="text/javascript" src="/static/js-build/libs/html5shiv/html5shiv.js"></script>
    <![endif]-->
</head>

<body 
    class="logged-out-user section-the-institute"
 >
    <div id="fb-root"></div>
    <div id="runner-root"></div>
    
    <div id="curtain" class="curtain"></div>
    
    <nav class="menu-global">
    <div class="main-menu-wrapper">
        <div class="menu-global__search-form hide-tablet-and-desktop">
            <form action="/search/">
                <button aria-label="Submit" type="submit" class="menu-global__submit fa fa-search" value=""></button>
                <input aria-label="Search" placeholder="Search..." type="text" name="q" class="menu-global__text-input"></input>
            </form>
        </div>
        <div class="divider hide-tablet-and-desktop"></div>
        <ul class="sections-list"></ul>
            <div class="divider"></div>
        <ul id="main-menu" class="main-menu">
</ul></div>
</nav><extra_asset_fields></extra_asset_fields><post_types_supported></post_types_supported><site_specific_data_schema><site_specific_data_property name="first_name" default="" description="SSO First Name" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="last_name" default="" description="SSO Last Name" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Instagram" default="" description="Add the link to your Instagram account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="member_badges" default="" description="Membership Badges" enum="STAFF EDITOR,CONTRIBUTOR" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Twitter" default="" description="Add the link to your Twitter account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="LinkedIn" default="" description="Add the link to your LinkedIn account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property><site_specific_data_property name="grade" default="" description="SSO Grade" visibility="Public" type="string" grouping=""></site_specific_data_property><site_specific_data_property name="Facebook" default="" description="Add the link to your Facebook account" visibility="" type="string" grouping="Social Networks"></site_specific_data_property></site_specific_data_schema><post_image_settings _3x2="true" _1x1="true" _3x1="true" _3x4="true" _2x1="true" _9x16="true" _16x9="true" _4x3="true"></post_image_settings><div class="all-content-wrapper">
        <div class="main v-sep">
                <span class="js-brick-description hidden" data-name="Post"></span><div data-share-status-id="menu-toggle" data-toggle-class="menu-opened" class="menu-overlay js-toggle" data-target="body"></div><!-- User Code --><!-- Google Tag Manager (noscript) --><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5WJB5X2"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><!-- End Google Tag Manager (noscript) --><!-- End User Code --><span class="js-brick-description hidden" data-name="CSS Fonts"></span><span class="js-brick-description hidden" data-name="CSS Spectrum"></span><span class="js-brick-description hidden" data-name="CSS for Posts"></span><span class="js-brick-description hidden" data-name="CSS Article Components"></span><span class="js-brick-description hidden" data-name="CSS for Comments"></span><div class="topbar topbar--static" id="sTop_Bar_0_0_19_0_0_11"><div class="" id="sTop_Bar_0_0_19_0_0_11_0"><span class="js-brick-description hidden" data-name="Element Bar"></span><div class="dark_top_bar" id="sElement_Bar_0_0_6_0_0_0"><div class="" id="sElement_Bar_0_0_6_0_0_0_0"><div class="top_menu_links" id="sElement_Bar_0_0_6_0_0_0_0_0"><div class="list" id="sElement_Bar_0_0_6_0_0_0_0_0_0"><a href="https://ieee.org/" class="list__item" target="_blank">IEEE.org</a><a href="https://ieeexplore.ieee.org/Xplore/home.jsp" class="list__item" target="_blank">IEEE Xplore Digital Library</a><a href="https://standards.ieee.org/" class="list__item" target="_blank">IEEE Standards</a><a href="https://www.ieee.org/sitemap.html" class="list__item" target="_blank">More Sites</a></div></div><div class="" id="sElement_Bar_0_0_6_0_0_0_0_1"><div class="access_links" id="sElement_Bar_0_0_6_0_0_0_0_1_0_1_1"><div class="list" id="sElement_Bar_0_0_6_0_0_0_0_1_0_1_1_0"><a href="https://www.ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https://spectrum.ieee.org/core/saml/main/login&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">Sign In</a><a href="/st/join" class="list__item" target="_self">Join IEEE</a></div></div><div class="" id="sElement_Bar_0_0_6_0_0_0_0_1_1"><!-- User Code --><svg width="70px" height="21px" viewBox="0 0 70 21" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="0 0 21.3639449 0 21.3639449 21 0 21"></polygon></defs><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-IEEE-Bar-/-Signed-out-/-1376" transform="translate(-1274.000000, -14.000000)"><g id="Group-13" transform="translate(1274.000000, 14.000000)"><polygon id="Fill-1" fill="#FEFEFE" points="23.4111174 18.6889405 27.8363724 18.6889405 27.8363724 2.77905063 23.4111174 2.77905063"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="29.7536549 18.6881005 29.7536549 2.77821061 41.9217005 2.77821061 41.9217005 5.8624668 34.17891 5.8624668 34.17891 9.14692664 41.3017712 9.14692664 41.3017712 12.2311828 34.17891 12.2311828 34.17891 15.6024442 41.9217005 15.6024442 41.9217005 18.6881005"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="43.7923126 18.6881005 43.7923126 2.77821061 55.9603583 2.77821061 55.9603583 5.8624668 48.2175677 5.8624668 48.2175677 9.14692664 55.3418347 9.14692664 55.3418347 12.2311828 48.2175677 12.2311828 48.2175677 15.6024442 55.9603583 15.6024442 55.9603583 18.6881005"></polygon><polygon id="Fill-4" fill="#FEFEFE" points="57.8305486 2.77793061 57.8305486 18.6878205 70 18.6878205 70 15.6021642 62.2558037 15.6021642 62.2558037 12.2323028 69.3800707 12.2323028 69.3800707 9.14664663 62.2558037 9.14664663 62.2558037 5.8621868 70 5.8621868 70 2.77793061"></polygon><g id="Group-12"><g id="Group-7"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-6"></g><path d="M20.9520644,9.85449953 L20.8930235,9.84469935 C19.0838421,8.61967703 17.3983653,7.23365178 15.8098843,5.66142314 L14.0555265,3.83578988 C13.3442244,3.05037557 12.6540084,2.18095973 11.9961242,1.35074461 L11.1976665,0.22232405 C11.099265,0.164923005 10.976966,0.0669212192 10.8687244,0.0375206836 C10.6339666,-0.0646811784 10.3795285,0.0571210406 10.1883485,0.202723693 L8.74184673,2.07875787 C6.42378906,4.93900998 3.67838782,7.60885862 0.684171419,9.65429588 C0.448007872,9.84049927 0.0951682866,10.0211026 0.0220700458,10.3235081 C-0.0566511366,10.596513 0.0853281388,10.8219172 0.256827858,10.9913202 C2.65360672,12.6363502 4.94776689,14.5907858 6.98748895,16.8168264 C7.35016869,17.1962333 7.64396739,17.5728401 7.99680697,17.9284466 C8.59424452,18.719461 9.29570648,19.5160755 9.84534902,20.364491 C10.0168487,20.5450943 10.0463692,20.8390996 10.3148646,20.9259012 C10.525725,20.9987026 10.785786,21.0477034 10.9868062,20.9259012 L11.1878263,20.7256976 C13.6675436,17.2256338 16.8149851,14.0825766 20.3293236,11.5429303 C20.6821632,11.2321246 21.3541047,11.1145225 21.3639449,10.5335119 C21.3386417,10.264707 21.182605,10.0015022 20.9520644,9.85449953 M18.5496626,10.7911166 C18.1476223,11.7879348 17.3337015,12.5831492 16.6238051,13.4525651 C15.0845249,15.1017951 13.4623062,16.6992242 11.6432846,17.9718474 C11.2763877,18.2322522 10.7815688,18.4702565 10.3401679,18.2658528 C9.00190778,17.56724 7.87450799,16.4248192 6.7035304,15.3860003 C5.34559001,14.1301774 3.98202667,12.6713508 2.95302836,11.142523 C2.80120893,10.9283191 2.75763114,10.6651143 2.76184834,10.3823091 C2.89398747,9.85449953 3.2566672,9.42049162 3.60107238,8.97668354 C4.81562776,7.43385543 6.30570729,5.96942875 7.80984416,4.63240439 C7.84498755,4.59740376 7.90824564,4.5232024 7.96306932,4.48960179 C8.60970761,3.93379167 9.25212869,3.44098269 9.92828741,2.95657386 C10.6339666,2.41056392 11.5209856,2.86417218 12.114206,3.36678134 C12.7369467,3.83998996 13.383585,4.37759975 13.9529079,4.9236097 L14.0555265,4.98241077 C15.6285445,6.43703727 17.0891035,8.05406673 18.2910073,9.76209785 C18.4864045,10.0603033 18.6579042,10.3963094 18.5496626,10.7911166" id="Fill-5" fill="#FEFEFE" mask="url(#mask-2)"></path></g><path d="M17.8685838,9.92786087 C16.3152462,7.68782006 14.2755241,5.70538394 12.1135031,3.97215236 C11.5554261,3.58154525 10.9087879,2.8983328 10.1876456,3.3869417 C7.9483091,4.92836978 5.79050526,7.01860786 4.05582778,9.15084671 C3.70298819,9.66885615 3.08587035,10.1616651 3.3656117,10.8504777 C3.56663186,11.3586869 4.01646719,11.7240936 4.30604868,12.1735018 C6.00698851,14.2091389 8.01719014,16.1089735 10.1145474,17.6364013 C11.0367098,18.221612 11.6931882,17.2751947 12.4087075,16.8397868 C13.8734838,15.6875658 15.2314242,14.2875403 16.5162664,12.9253155 L16.5162664,12.8917149 C17.0307655,12.2715036 17.5747851,11.6610924 17.9768254,10.9918802 C18.1525424,10.6642743 18.0653868,10.2162661 17.8685838,9.92786087 L17.8685838,9.92786087 Z M10.4477066,5.41697869 L10.6431039,4.79256731 L10.6684071,4.79256731 C11.0704474,5.9391882 11.4865451,7.08300904 11.9181059,8.21422965 L11.0549843,8.22962993 L11.0367098,8.33183179 L11.163226,11.4020877 L11.163226,11.4510886 C10.844124,11.5042896 10.4533296,11.4902893 10.1384449,11.4608888 L10.1145474,11.4258882 L10.2565266,8.26323054 L10.2565266,8.23943011 C10.0161459,8.21422965 9.71250703,8.23943011 9.46790907,8.21422965 L10.4477066,5.41697869 Z M9.93742469,15.6203646 C10.0217688,14.491944 10.0358262,13.4531251 10.0948671,12.3289046 C10.4912844,12.3695053 10.8356896,12.3541051 11.1969636,12.3401048 L11.2222668,12.4913076 L11.3642461,15.6301648 C10.8891076,15.698766 10.3844486,15.6595653 9.93742469,15.6203646 L9.93742469,15.6203646 Z M13.5501647,11.7058933 C11.492168,12.3443049 8.90420917,12.3149044 6.95304844,11.4608888 C6.60020885,11.2900857 6.15459073,11.0268809 6.03650896,10.6166734 C5.94794763,9.86485972 6.75624548,9.44905214 7.30588802,9.17604717 C7.62920717,9.03464459 7.95814925,8.87924176 8.31520604,8.8596414 C8.64836533,9.10324584 8.99698771,9.29924941 9.33998715,9.51765339 C8.67366857,9.69405661 7.87380512,9.84525936 7.56594907,10.5718726 C7.61936702,11.1248827 8.24632501,11.2998859 8.68350872,11.4370884 C10.2565266,11.8514959 11.9574665,11.7968949 13.4672263,11.250885 C13.7511848,11.0842819 14.2024259,10.8840783 14.1630653,10.4752708 C14.1138646,10.0356628 13.6092056,9.84105928 13.256366,9.70245676 C13.0412885,9.73185729 12.8346454,9.78085819 12.6336252,9.84525936 C12.5253836,9.54285385 12.432605,9.23484824 12.3046831,8.94224291 C12.9724074,9.1172461 13.638726,9.29924941 14.3289421,9.41965161 L14.3289421,9.43505189 C14.1869628,9.44905214 14.0309262,9.49805304 13.8931641,9.551254 L13.8931641,9.57645446 C14.2853643,9.77105801 14.8293839,10.0944639 14.8336011,10.6068732 C14.7422283,11.2270845 14.0604466,11.5098897 13.5501647,11.7058933 L13.5501647,11.7058933 Z" id="Fill-8" fill="#FEFEFE"></path><path d="M14.1946944,19.3564726 L14.1946944,19.1646691 L14.3141819,19.1646691 C14.3788457,19.1646691 14.467407,19.1716693 14.467407,19.2528707 C14.467407,19.3410724 14.4224235,19.3564726 14.3465138,19.3564726 L14.1946944,19.3564726 Z M14.1946944,19.4922751 L14.2748213,19.4922751 L14.4603783,19.8268812 L14.6613985,19.8268812 L14.4575669,19.4782749 C14.562997,19.4698747 14.6501526,19.4166737 14.6501526,19.2710711 C14.6501526,19.0890678 14.5278536,19.0302667 14.3226163,19.0302667 L14.0231946,19.0302667 L14.0231946,19.8268812 L14.1946944,19.8268812 L14.1946944,19.4922751 Z M15.0620331,19.429274 C15.0620331,18.9630655 14.7105992,18.6900605 14.3183991,18.6900605 C13.9233874,18.6900605 13.5719536,18.9630655 13.5719536,19.429274 C13.5719536,19.8954825 13.9233874,20.1670874 14.3183991,20.1670874 C14.7105992,20.1670874 15.0620331,19.8954825 15.0620331,19.429274 L15.0620331,19.429274 Z M14.8483613,19.429274 C14.8483613,19.7694802 14.6051691,19.9976843 14.3183991,19.9976843 L14.3183991,19.9962843 C14.0231946,19.9976843 13.7856254,19.7694802 13.7856254,19.429274 C13.7856254,19.0890678 14.0231946,18.8622636 14.3183991,18.8622636 C14.6051691,18.8622636 14.8483613,19.0890678 14.8483613,19.429274 L14.8483613,19.429274 Z" id="Fill-10" fill="#FEFEFE"></path></g></g></g></g></svg><!-- End User Code --></div></div></div></div><div class="topbar-sticky" id="sTop_Bar_0_0_19_0_0_11_0_1">

<div id="sTop_Bar_0_0_19_0_0_11_0_1_0" class="js-hidden-panel" data-offset="0">
    
</div><div class="rebelbar-wrapper_static" id="sTop_Bar_0_0_19_0_0_11_0_1_1"><span class="js-brick-description hidden" data-name="__TopBar Second Bar"></span><div class="" id="s__TopBar_Second_Bar_0_0_26_0_0_0"><div class="site_logo" id="s__TopBar_Second_Bar_0_0_26_0_0_0_0"><!-- User Code --><a href="/" title="Spectrum Logo"><svg width="214px" height="30px" viewBox="0 0 214 30" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-Sticky-Site-Header-/-1376" transform="translate(-33.000000, -17.000000)" fill="#0D0D0D" fill-rule="nonzero"><g id="IEEE-Spectrum-Logo" transform="translate(32.000000, 15.000000)"><g id="IEEESpectrum-LogoFinal-Black" transform="translate(1.454545, 2.909091)"><path d="M67.5731087,15.3769418 C67.7375958,17.1915012 68.9067885,18.8411007 71.9786975,18.8411007 C74.7749795,18.8411007 75.8285865,17.851341 75.8285865,16.3310345 C75.8285865,14.882062 74.9750314,14.1553466 73.3301597,13.923511 L68.5600317,13.3974225 C64.6123396,12.9515848 62.3361928,10.6911877 62.3361928,6.96398467 C62.3361928,2.83552769 65.4481122,6.3357346e-15 71.7475264,6.3357346e-15 C78.4915004,6.3357346e-15 81.1899792,3.23232323 81.4833887,7.133403 L75.7485657,7.133403 C75.5173945,5.38126088 74.2014972,4.22654127 71.7475264,4.22654127 C69.5247267,4.22654127 68.191047,5.11821665 68.191047,6.57164751 C68.191047,7.6907001 68.8489957,8.51549983 70.5294322,8.71612679 L74.7082955,9.16196447 C79.5095427,9.60780216 81.6834407,11.8994079 81.6834407,15.8495298 C81.6834407,20.1741553 78.984962,23.0765587 71.8764488,23.0765587 C64.6701324,23.0765587 62.1717056,19.3136886 61.9405344,15.390317 L67.5731087,15.3769418 Z" id="Path"></path><path d="M101.439684,14.266806 C101.439684,18.8544758 99.3013506,23.0141414 93.8821651,23.0141414 C91.0858831,23.0141414 89.2098403,21.9575061 88.102886,20.1741553 L88.102886,29.0909091 L82.456975,29.0909091 L82.456975,6.00543365 L88.1162228,6.00543365 L88.1162228,8.23462208 C89.2320682,6.48693835 91.1081111,5.46597005 93.8955019,5.46597005 C99.3013506,5.47934518 101.439684,9.53646813 101.439684,14.266806 Z M95.7804359,14.266806 C95.7804359,11.1994427 94.7935129,9.91097179 91.997231,9.91097179 C89.1031459,9.91097179 88.1162228,11.3287356 88.1162228,14.266806 C88.1162228,17.2048763 89.1031459,18.6226402 91.997231,18.6226402 C94.7935129,18.6092651 95.7804359,17.3207941 95.7804359,14.266806 Z" id="Shape"></path><path d="M114.367486,17.5214211 L119.862247,17.5214211 C119.302102,20.3569488 117.065965,23.0319749 111.077743,23.0319749 C104.364888,23.0319749 101.995384,18.7430164 101.995384,14.2222222 C101.995384,9.43838384 104.760546,5.47934518 111.077743,5.47934518 C117.790598,5.47934518 119.928931,9.73263671 119.928931,14.3203065 C119.934228,14.7845667 119.900021,15.2484337 119.826682,15.7068617 L107.490144,15.7068617 C107.819119,18.3462208 109.103897,19.2378962 111.211111,19.2378962 C112.887102,19.2378962 113.905144,18.5111808 114.367486,17.5214211 Z M107.556828,12.4076628 L114.563093,12.4076628 C114.367486,10.3256008 113.349444,9.20654824 111.144427,9.20654824 C109.103897,9.20654824 107.921368,10.031348 107.556828,12.4076628 Z" id="Shape"></path><path d="M129.811498,5.47934518 C135.764156,5.47934518 138.662686,8.84096134 138.791609,12.9649599 L133.247946,12.9649599 C133.083459,11.0211076 132.096536,9.89759666 129.895965,9.89759666 C127.52646,9.89759666 126.174998,10.954232 126.174998,14.2534309 C126.174998,17.5526297 127.459776,18.6092651 129.793716,18.6092651 C132.127655,18.6092651 133.119024,17.3207941 133.31463,15.4884013 L138.876075,15.4884013 C138.742707,19.4162313 136.013109,23.0141966 129.895965,23.0141966 C123.085307,23.0319749 120.520196,18.7251829 120.520196,14.266806 C120.520196,9.80842912 123.018623,5.47934518 129.811498,5.47934518 Z" id="Path"></path><path d="M141.77016,16.0011146 L141.77016,10.2542668 L138.876075,10.2542668 L138.876075,7.62382445 L142.228057,6.13472658 L144.566442,2.01072797 L147.429408,2.01072797 L147.429408,6.02326715 L151.901681,6.02326715 L151.901681,10.2542668 L147.429408,10.2542668 L147.429408,18.0163009 L151.3771,18.0163009 L151.3771,22.5014281 L148.380766,22.5014281 C143.348348,22.5014281 141.77016,20.2588645 141.77016,16.0011146 Z" id="Path"></path><path d="M164.304903,5.74238941 L164.304903,11.2529432 L162.299938,11.2529432 C159.565894,11.2529432 158.414484,12.5904563 158.414484,15.9030303 L158.414484,22.5014281 L152.755236,22.5014281 L152.755236,6.00543365 L158.263333,6.00543365 L158.263333,9.36259143 C158.921282,7.0174852 160.272744,5.73347266 162.935658,5.73347266 L164.304903,5.74238941 Z" id="Path"></path><path d="M182.989757,6.00543365 L182.989757,22.5014281 L177.330509,22.5014281 L177.330509,19.5009404 C176.281347,21.6454197 174.405304,23.0319749 171.511219,23.0319749 C167.198988,23.0319749 165.256261,20.3569488 165.256261,16.0367816 L165.256261,6.00543365 L170.915509,6.00543365 L170.915509,15.0470219 C170.915509,17.2762104 171.804629,18.4443051 173.81404,18.4443051 C176.014611,18.4443051 177.330509,16.9239986 177.330509,13.758551 L177.330509,6.00543365 L182.989757,6.00543365 Z" id="Path"></path><path d="M213.090909,12.4834552 L213.090909,22.5148032 L207.431661,22.5148032 L207.431661,13.3305468 C207.431661,11.2172762 206.613671,10.0625566 204.737628,10.0625566 C202.514828,10.0625566 201.479004,11.5159875 201.479004,14.7483107 L201.479004,22.5014281 L195.917559,22.5014281 L195.917559,13.3305468 C195.917559,11.2172762 195.095123,10.0625566 193.223526,10.0625566 C191.000726,10.0625566 189.964902,11.5159875 189.964902,14.7483107 L189.964902,22.5014281 L184.305654,22.5014281 L184.305654,6.00543365 L189.964902,6.00543365 L189.964902,8.8097527 C190.982944,6.76335772 192.725619,5.47934518 195.557466,5.47934518 C198.389312,5.47934518 200.163106,6.81685824 200.985542,9.13967259 C202.003585,6.91048415 203.812943,5.47934518 206.809277,5.47934518 C211.117063,5.47934518 213.090909,8.14991292 213.090909,12.4834552 Z" id="Path"></path><polygon id="Path" points="11.9408796 7.10219436 11.9408796 3.0450714 0 3.0450714 0 7.10219436 3.14303867 7.10219436 3.14303867 18.4086381 0 18.4086381 0 22.4702194 11.9408796 22.4702194 11.9408796 18.4086381 8.80228652 18.4086381 8.80228652 7.10219436"></polygon><polygon id="Path" points="18.8537864 18.4086381 18.8537864 14.467433 26.0378748 14.467433 26.0378748 10.6956461 18.8537864 10.6956461 18.8537864 7.10219436 26.9136579 7.10219436 26.9136579 3.0450714 18.8537864 3.0450714 13.1945386 3.0450714 13.1945386 22.4613027 13.1945386 22.4702194 27.0025699 22.4702194 27.0025699 18.4086381"></polygon><polygon id="Path" points="33.6487408 18.4086381 33.6487408 14.467433 40.8372748 14.467433 40.8372748 10.6956461 33.6487408 10.6956461 33.6487408 7.10219436 41.7086122 7.10219436 41.7086122 3.0450714 33.6487408 3.0450714 27.9939385 3.0450714 27.9939385 22.4613027 27.9939385 22.4702194 41.7975242 22.4702194 41.7975242 18.4086381"></polygon><polygon id="Path" points="48.4481407 18.4086381 48.4481407 14.467433 55.6322291 14.467433 55.6322291 10.6956461 48.4481407 10.6956461 48.4481407 7.10219436 56.5080121 7.10219436 56.5080121 3.0450714 48.4481407 3.0450714 42.7888928 3.0450714 42.7888928 22.4613027 42.7888928 22.4702194 56.5924785 22.4702194 56.5924785 18.4086381"></polygon></g></g></g></g></svg></a><!-- End User Code --><div class="topbar__sticky-headline topbar__sticky-headline--post" id="s__TopBar_Second_Bar_0_0_26_0_0_0_0_1_0_1"><div class="text-element" id="s__TopBar_Second_Bar_0_0_26_0_0_0_0_1_0_1_0">Tomorrow’s AI Will Reason Like Humans, IBM Watson Developer Predicts</div></div><!-- User Code --><span class="floating-shares hide-desktop">Share</span><!-- End User Code --><!-- User Code --><script>
  function createElementChangeListener(selector, callback, oneTime) {
    const initializedNodes = new Set([]);
    let reported = false;

    document.querySelectorAll(selector).forEach((node) => {
      if (oneTime && reported) {
        return;
      }
      reported = true;
      callback(node);
      initializedNodes.add(node);
    });

    const mutationObserver = new MutationObserver(() => {
      const nodes = document.querySelectorAll(selector);
      nodes.forEach((node) => {
        if (oneTime && reported) {
          return;
        }

        if (!initializedNodes.has(node)) {
          reported = true;
          callback(node);
          initializedNodes.add(node);
          if (oneTime) {
            mutationObserver.disconnect();
          }
        }
      });
    });

    if (!oneTime || !reported) {
      mutationObserver.observe(document.body, {
        childList: true,
        subtree: true,
      });
    }
    return mutationObserver;
  }
  
</script><!-- End User Code --><div class="topbar__static-headline" id="s__TopBar_Second_Bar_0_0_26_0_0_0_0_2"><div class="text-element" id="s__TopBar_Second_Bar_0_0_26_0_0_0_0_2_0">FOR THE TECHNOLOGY INSIDER</div></div></div><div class="" id="s__TopBar_Second_Bar_0_0_26_0_0_0_1"><div class="search-form"><form action="/search/"><input placeholder="Type to search" type="text" name="q" class="search-form__text-input"><button aria-label="Search" type="submit" class="search-form__submit" value="Search"><svg width="18px" height="19px" viewBox="0 0 18 19" version="1.1"
  xmlns="http://www.w3.org/2000/svg"
  xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="1376---Sample-Front-Page" transform="translate(-826.000000, -102.000000)" stroke="#0D0D0D" stroke-width="1.5"><g id="Light-/-Nav" transform="translate(816.857864, 96.000000)"><g id="Search-Icon" transform="translate(7.307612, 5.000000)"><path d="M11.631728,14.6819805 C15.2215789,14.6819805 18.131728,11.7718314 18.131728,8.18198052 C18.131728,4.59212964 15.2215789,1.68198052 11.631728,1.68198052 C8.04187711,1.68198052 5.13172798,4.59212964 5.13172798,8.18198052 C5.13172798,11.7718314 8.04187711,14.6819805 11.631728,14.6819805 Z M11.631728,14.5814755 L11.631728,21.5814755" id="Combined-Shape" transform="translate(11.631728, 11.631728) rotate(-45.000000) translate(-11.631728, -11.631728) "></path></g></g></g></g></svg></button></form></div><span class="js-brick-description hidden" data-name="Element Menu"></span><div class="main-menu-el" id="sElement_Menu_0_0_7_0_0_0"><div class="menu-item" id="sElement_Menu_0_0_7_0_0_0_0"><!-- User Code --><div class="menu-item__title">Explore by topic</div><!-- End User Code --><div class="menu-dropdown" id="sElement_Menu_0_0_7_0_0_0_0_1"><div class="list" id="sElement_Menu_0_0_7_0_0_0_0_1_0"><a href="/topic/aerospace/" class="list__item" target="_self">Aerospace</a><a href="/topic/artificial-intelligence/" class="list__item" target="_self">Artificial Intelligence</a><a href="/topic/biomedical/" class="list__item" target="_self">Biomedical</a><a href="/topic/computing/" class="list__item" target="_self">Computing</a><a href="/topic/consumer-electronics/" class="list__item" target="_self">Consumer Electronics</a><a href="/topic/energy/" class="list__item" target="_self">Energy</a><a href="/topic/tech-history/" class="list__item" target="_self">History of Technology</a><a href="/topic/robotics/" class="list__item" target="_self">Robotics</a><a href="/topic/semiconductors/" class="list__item" target="_self">Semiconductors</a><a href="/topic/sensors/" class="list__item" target="_self">Sensors</a><a href="/topic/telecommunications/" class="list__item" target="_self">Telecommunications</a><a href="/topic/transportation/" class="list__item" target="_self">Transportation</a></div></div></div></div><!-- User Code --><div data-share-status-id="huge-menu-toggle" data-toggle-class="huge-menu-opened" class="rebelbar__menu-toggle js-toggle hambg-btn" data-target="body"><svg width="32px" height="18px" viewBox="0 0 32 18" version="1.1"
    xmlns="http://www.w3.org/2000/svg"
    xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="992---Search---Open-filters---selected" transform="translate(-928.000000, -75.000000)"><g id="Light-/-Collapsed-Site-Header" transform="translate(0.000000, 56.000000)"><g id="Light-/-Nav" transform="translate(432.857864, 12.000000)"><g id="Group" transform="translate(495.142136, 7.000000)"><rect id="Rectangle" x="0" y="0" width="32" height="2"></rect><rect id="Rectangle-Copy" x="0" y="8" width="32" height="2"></rect><rect id="Rectangle-Copy-2" x="0" y="16" width="32" height="2"></rect></g></g></g></g></g></svg></div><!-- End User Code --></div></div></div></div></div></div><div class="huge-menu" id="sTop_Bar_0_0_19_0_0_12"><span class="js-brick-description hidden" data-name="__Huge Menu Links"></span><div id="s__Huge_Menu_Links_0_0_23_0_0_1" class="dark_layout row-wrapper clearfix  content sm-cp-2 md-cp-4">
    <div class="row px20">
        

<div id="s__Huge_Menu_Links_0_0_23_0_0_1_0" class="Top_hugeMenu col sm-mb-2 md-mb-4 s12 m12 l12">
    <div class="" id="s__Huge_Menu_Links_0_0_23_0_0_1_0_0"><!-- User Code --><a href="/"><svg width="214px" height="30px" class="site_logo_menu" viewBox="0 0 214 30" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-Sticky-Site-Header-/-1376" transform="translate(-33.000000, -17.000000)" fill="#F2F2F2" fill-rule="nonzero"><g id="IEEE-Spectrum-Logo" transform="translate(32.000000, 15.000000)"><g id="IEEESpectrum-LogoFinal-Black" transform="translate(1.454545, 2.909091)"><path d="M67.5731087,15.3769418 C67.7375958,17.1915012 68.9067885,18.8411007 71.9786975,18.8411007 C74.7749795,18.8411007 75.8285865,17.851341 75.8285865,16.3310345 C75.8285865,14.882062 74.9750314,14.1553466 73.3301597,13.923511 L68.5600317,13.3974225 C64.6123396,12.9515848 62.3361928,10.6911877 62.3361928,6.96398467 C62.3361928,2.83552769 65.4481122,6.3357346e-15 71.7475264,6.3357346e-15 C78.4915004,6.3357346e-15 81.1899792,3.23232323 81.4833887,7.133403 L75.7485657,7.133403 C75.5173945,5.38126088 74.2014972,4.22654127 71.7475264,4.22654127 C69.5247267,4.22654127 68.191047,5.11821665 68.191047,6.57164751 C68.191047,7.6907001 68.8489957,8.51549983 70.5294322,8.71612679 L74.7082955,9.16196447 C79.5095427,9.60780216 81.6834407,11.8994079 81.6834407,15.8495298 C81.6834407,20.1741553 78.984962,23.0765587 71.8764488,23.0765587 C64.6701324,23.0765587 62.1717056,19.3136886 61.9405344,15.390317 L67.5731087,15.3769418 Z" id="Path"></path><path d="M101.439684,14.266806 C101.439684,18.8544758 99.3013506,23.0141414 93.8821651,23.0141414 C91.0858831,23.0141414 89.2098403,21.9575061 88.102886,20.1741553 L88.102886,29.0909091 L82.456975,29.0909091 L82.456975,6.00543365 L88.1162228,6.00543365 L88.1162228,8.23462208 C89.2320682,6.48693835 91.1081111,5.46597005 93.8955019,5.46597005 C99.3013506,5.47934518 101.439684,9.53646813 101.439684,14.266806 Z M95.7804359,14.266806 C95.7804359,11.1994427 94.7935129,9.91097179 91.997231,9.91097179 C89.1031459,9.91097179 88.1162228,11.3287356 88.1162228,14.266806 C88.1162228,17.2048763 89.1031459,18.6226402 91.997231,18.6226402 C94.7935129,18.6092651 95.7804359,17.3207941 95.7804359,14.266806 Z" id="Shape"></path><path d="M114.367486,17.5214211 L119.862247,17.5214211 C119.302102,20.3569488 117.065965,23.0319749 111.077743,23.0319749 C104.364888,23.0319749 101.995384,18.7430164 101.995384,14.2222222 C101.995384,9.43838384 104.760546,5.47934518 111.077743,5.47934518 C117.790598,5.47934518 119.928931,9.73263671 119.928931,14.3203065 C119.934228,14.7845667 119.900021,15.2484337 119.826682,15.7068617 L107.490144,15.7068617 C107.819119,18.3462208 109.103897,19.2378962 111.211111,19.2378962 C112.887102,19.2378962 113.905144,18.5111808 114.367486,17.5214211 Z M107.556828,12.4076628 L114.563093,12.4076628 C114.367486,10.3256008 113.349444,9.20654824 111.144427,9.20654824 C109.103897,9.20654824 107.921368,10.031348 107.556828,12.4076628 Z" id="Shape"></path><path d="M129.811498,5.47934518 C135.764156,5.47934518 138.662686,8.84096134 138.791609,12.9649599 L133.247946,12.9649599 C133.083459,11.0211076 132.096536,9.89759666 129.895965,9.89759666 C127.52646,9.89759666 126.174998,10.954232 126.174998,14.2534309 C126.174998,17.5526297 127.459776,18.6092651 129.793716,18.6092651 C132.127655,18.6092651 133.119024,17.3207941 133.31463,15.4884013 L138.876075,15.4884013 C138.742707,19.4162313 136.013109,23.0141966 129.895965,23.0141966 C123.085307,23.0319749 120.520196,18.7251829 120.520196,14.266806 C120.520196,9.80842912 123.018623,5.47934518 129.811498,5.47934518 Z" id="Path"></path><path d="M141.77016,16.0011146 L141.77016,10.2542668 L138.876075,10.2542668 L138.876075,7.62382445 L142.228057,6.13472658 L144.566442,2.01072797 L147.429408,2.01072797 L147.429408,6.02326715 L151.901681,6.02326715 L151.901681,10.2542668 L147.429408,10.2542668 L147.429408,18.0163009 L151.3771,18.0163009 L151.3771,22.5014281 L148.380766,22.5014281 C143.348348,22.5014281 141.77016,20.2588645 141.77016,16.0011146 Z" id="Path"></path><path d="M164.304903,5.74238941 L164.304903,11.2529432 L162.299938,11.2529432 C159.565894,11.2529432 158.414484,12.5904563 158.414484,15.9030303 L158.414484,22.5014281 L152.755236,22.5014281 L152.755236,6.00543365 L158.263333,6.00543365 L158.263333,9.36259143 C158.921282,7.0174852 160.272744,5.73347266 162.935658,5.73347266 L164.304903,5.74238941 Z" id="Path"></path><path d="M182.989757,6.00543365 L182.989757,22.5014281 L177.330509,22.5014281 L177.330509,19.5009404 C176.281347,21.6454197 174.405304,23.0319749 171.511219,23.0319749 C167.198988,23.0319749 165.256261,20.3569488 165.256261,16.0367816 L165.256261,6.00543365 L170.915509,6.00543365 L170.915509,15.0470219 C170.915509,17.2762104 171.804629,18.4443051 173.81404,18.4443051 C176.014611,18.4443051 177.330509,16.9239986 177.330509,13.758551 L177.330509,6.00543365 L182.989757,6.00543365 Z" id="Path"></path><path d="M213.090909,12.4834552 L213.090909,22.5148032 L207.431661,22.5148032 L207.431661,13.3305468 C207.431661,11.2172762 206.613671,10.0625566 204.737628,10.0625566 C202.514828,10.0625566 201.479004,11.5159875 201.479004,14.7483107 L201.479004,22.5014281 L195.917559,22.5014281 L195.917559,13.3305468 C195.917559,11.2172762 195.095123,10.0625566 193.223526,10.0625566 C191.000726,10.0625566 189.964902,11.5159875 189.964902,14.7483107 L189.964902,22.5014281 L184.305654,22.5014281 L184.305654,6.00543365 L189.964902,6.00543365 L189.964902,8.8097527 C190.982944,6.76335772 192.725619,5.47934518 195.557466,5.47934518 C198.389312,5.47934518 200.163106,6.81685824 200.985542,9.13967259 C202.003585,6.91048415 203.812943,5.47934518 206.809277,5.47934518 C211.117063,5.47934518 213.090909,8.14991292 213.090909,12.4834552 Z" id="Path"></path><polygon id="Path" points="11.9408796 7.10219436 11.9408796 3.0450714 0 3.0450714 0 7.10219436 3.14303867 7.10219436 3.14303867 18.4086381 0 18.4086381 0 22.4702194 11.9408796 22.4702194 11.9408796 18.4086381 8.80228652 18.4086381 8.80228652 7.10219436"></polygon><polygon id="Path" points="18.8537864 18.4086381 18.8537864 14.467433 26.0378748 14.467433 26.0378748 10.6956461 18.8537864 10.6956461 18.8537864 7.10219436 26.9136579 7.10219436 26.9136579 3.0450714 18.8537864 3.0450714 13.1945386 3.0450714 13.1945386 22.4613027 13.1945386 22.4702194 27.0025699 22.4702194 27.0025699 18.4086381"></polygon><polygon id="Path" points="33.6487408 18.4086381 33.6487408 14.467433 40.8372748 14.467433 40.8372748 10.6956461 33.6487408 10.6956461 33.6487408 7.10219436 41.7086122 7.10219436 41.7086122 3.0450714 33.6487408 3.0450714 27.9939385 3.0450714 27.9939385 22.4613027 27.9939385 22.4702194 41.7975242 22.4702194 41.7975242 18.4086381"></polygon><polygon id="Path" points="48.4481407 18.4086381 48.4481407 14.467433 55.6322291 14.467433 55.6322291 10.6956461 48.4481407 10.6956461 48.4481407 7.10219436 56.5080121 7.10219436 56.5080121 3.0450714 48.4481407 3.0450714 42.7888928 3.0450714 42.7888928 22.4613027 42.7888928 22.4702194 56.5924785 22.4702194 56.5924785 18.4086381"></polygon></g></g></g></g></svg></a><!-- End User Code --><div class="text-element" id="s__Huge_Menu_Links_0_0_23_0_0_1_0_0_1">FOR THE TECHNOLOGY INSIDER</div><!-- User Code --><div data-share-status-id="huge-menu-toggle" data-toggle-class="huge-menu-opened" class="rebelbar__menu-toggle js-toggle hm__close js--active" data-target="body" data-loaded="true"></div><!-- End User Code --></div>
</div>



<div id="s__Huge_Menu_Links_0_0_23_0_0_1_1" class="top-menu top-menu--big-links col sm-mb-2 md-mb-4 s12 m12 l6">
    <div id="s__Huge_Menu_Links_0_0_23_0_0_1_1_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        Topics
    </h2>
</div></div><div class="list" id="s__Huge_Menu_Links_0_0_23_0_0_1_1_1"><a href="/topic/aerospace/" class="list__item" target="_self">Aerospace</a><a href="/topic/artificial-intelligence/" class="list__item" target="_self">Artificial Intelligence</a><a href="/topic/biomedical/" class="list__item" target="_self">Biomedical</a><a href="/topic/computing/" class="list__item" target="_self">Computing</a><a href="/topic/consumer-electronics/" class="list__item" target="_self">Consumer Electronics</a><a href="/topic/energy/" class="list__item" target="_self">Energy</a><a href="/topic/tech-history/" class="list__item" target="_self">History of Technology</a><a href="/topic/robotics/" class="list__item" target="_self">Robotics</a><a href="/topic/semiconductors/" class="list__item" target="_self">Semiconductors</a><a href="/topic/sensors/" class="list__item" target="_self">Sensors</a><a href="/topic/telecommunications/" class="list__item" target="_self">Telecommunications</a><a href="/topic/transportation/" class="list__item" target="_self">Transportation</a></div>
</div>



<div id="s__Huge_Menu_Links_0_0_23_0_0_1_2" class="top-menu top-menu--sm-links col sm-mb-2 md-mb-4 s6 m12 l3">
    <div class="" id="s__Huge_Menu_Links_0_0_23_0_0_1_2_0"><div id="s__Huge_Menu_Links_0_0_23_0_0_1_2_0_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        Sections
    </h2>
</div></div><div class="list" id="s__Huge_Menu_Links_0_0_23_0_0_1_2_0_1"><a href="/type/feature/" class="list__item" target="_self">Features</a><a href="/type/news/" class="list__item" target="_self">News</a><a href="/type/opinion/" class="list__item" target="_self">Opinion</a><a href="/topic/careers/" class="list__item" target="_self">Careers</a><a href="/topic/diy/" class="list__item" target="_self">DIY</a><a href="/engineering-resources/" class="list__item" target="_self">Engineering Resources</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_23_0_0_1_2_1"><div id="s__Huge_Menu_Links_0_0_23_0_0_1_2_1_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        More
    </h2>
</div></div><div class="list" id="s__Huge_Menu_Links_0_0_23_0_0_1_2_1_1"><a href="/special-reports/" class="list__item" target="_self">Special Reports</a><a href="/type/explainer/" class="list__item" target="_self">Explainers</a><a href="/type/podcast/" class="list__item" target="_self">Podcasts</a><a href="/type/video/" class="list__item" target="_self">Videos</a><a href="/newsletters/" class="list__item" target="_self">Newsletters</a><a href="/top-programming-languages" class="list__item" target="_self">Top Programming Languages</a><a href="https://robots.ieee.org/" class="list__item" target="_blank">Robots Guide</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_23_0_0_1_2_2"><div id="s__Huge_Menu_Links_0_0_23_0_0_1_2_2_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        For IEEE Members
    </h2>
</div></div><div class="list" id="s__Huge_Menu_Links_0_0_23_0_0_1_2_2_1"><a href="/magazine/" class="list__item" target="_self">The Magazine</a><a href="/the-institute/" class="list__item" target="_self">The Institute</a></div></div>
</div>



<div id="s__Huge_Menu_Links_0_0_23_0_0_1_3" class="top-menu top-menu--sm-links col sm-mb-2 md-mb-4 s6 m12 l3">
    <div class="" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_0"><div id="s__Huge_Menu_Links_0_0_23_0_0_1_3_0_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        For IEEE Members
    </h2>
</div></div><div class="list" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_0_1"><a href="/magazine/" class="list__item" target="_self">The Magazine</a><a href="/the-institute/" class="list__item" target="_self">The Institute</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_1"><div id="s__Huge_Menu_Links_0_0_23_0_0_1_3_1_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        IEEE Spectrum
    </h2>
</div></div><div class="list" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_1_1"><a href="/st/about" class="list__item" target="_self">About Us</a><a href="/st/contact" class="list__item" target="_self">Contact Us</a><a href="https://www.parsintl.com/publication/ieee-spectrum/" class="list__item" target="_blank">Reprints & Permissions</a><a href="https://advertise.ieee.org/ " class="list__item" target="_blank">Advertising</a></div></div><div class="" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_2"><div id="s__Huge_Menu_Links_0_0_23_0_0_1_3_2_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        Follow IEEE Spectrum
    </h2>
</div></div><div class="sm-mb-2" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_2_1"><div class="social-links">
        




<a class="social-links__link share-twitter" href="https://twitter.com/ieeespectrum" target="_blank" rel="noopener noreferrer" aria-label="Open twitter">
    <span aria-hidden="true" class="fa fa-twitter"></span>
</a>




<a class="social-links__link share-facebook" href="https://www.facebook.com/IEEE.Spectrum" target="_blank" rel="noopener noreferrer" aria-label="Open facebook">
    <span aria-hidden="true" class="fa fa-facebook"></span>
</a>




<a class="social-links__link share-instagram" href="https://www.instagram.com/ieeespectrum/" target="_blank" rel="noopener noreferrer" aria-label="Open instagram">
    <span aria-hidden="true" class="fa fa-instagram"></span>
</a>




<a class="social-links__link share-linkedin" href="https://www.linkedin.com/company/ieee-spectrum/" target="_blank" rel="noopener noreferrer" aria-label="Open linkedin">
    <span aria-hidden="true" class="fa fa-linkedin"></span>
</a>




<a class="social-links__link share-tumblr" href="/feeds/feed.rss" target="_blank" rel="noopener noreferrer" aria-label="Open tumblr">
    <span aria-hidden="true" class="fa fa-tumblr"></span>
</a>
    </div>
</div></div><div class="" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_3"><div id="s__Huge_Menu_Links_0_0_23_0_0_1_3_3_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        Support IEEE Spectrum
    </h2>
</div></div><div class="text-element" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_3_1"><i>IEEE Spectrum</i> is the flagship publication of the IEEE &#8212; the world&#8217;s largest professional organization devoted to engineering and applied sciences. Our articles, podcasts, and infographics inform our readers about developments in technology, engineering, and science.</div><div class="text-element" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_3_2"><a href="/st/join" class="color-inherit" rel="orange_button" target="_self">Join IEEE</a></div><div class="text-element" id="s__Huge_Menu_Links_0_0_23_0_0_1_3_3_3"><a href="https://ieee.omeda.com/ieee/r-main.do" class="color-inherit" rel="orange_button" target="_blank">Subscribe</a></div></div>
</div>



<div id="s__Huge_Menu_Links_0_0_23_0_0_1_4" class=" col sm-mb-2 md-mb-4 s12 m12 l12">
    
</div>



<div id="s__Huge_Menu_Links_0_0_23_0_0_1_5" class=" col sm-mb-2 md-mb-4 s12 m12 l12">
    <span class="js-brick-description hidden" data-name="Footer"></span><div class="footer" id="sFooter_0_0_8_0_0_0"><div class="" id="sFooter_0_0_8_0_0_0_0"><div id="sFooter_0_0_8_0_0_0_0_0" class=" row-wrapper clearfix  content sm-cp-2 md-cp-4">
    <div class="row ">
        

<div id="sFooter_0_0_8_0_0_0_0_0_0" class=" col sm-mb-2 md-mb-4 s12 m10 l10">
    <div class="bottom_menu_links" id="sFooter_0_0_8_0_0_0_0_0_0_0"><div class="list" id="sFooter_0_0_8_0_0_0_0_0_0_0_0"><a href="https://www.ieee.org/about/" class="list__item" target="_blank">About IEEE</a><a href="https://www.ieee.org/about/contact.html" class="list__item" target="_blank">Contact & Support</a><a href="https://www.ieee.org/accessibility-statement.html" class="list__item" target="_blank">Accessibility</a><a href="https://www.ieee.org/about/corporate/governance/p9-26.html" class="list__item" target="_blank">Nondiscrimination Policy</a><a href="https://www.ieee.org/about/help/site-terms-conditions.html" class="list__item" target="_blank">Terms</a><a href="https://www.ieee.org/security-privacy.html" class="list__item" target="_blank">IEEE Privacy Policy</a></div></div><div class="ftr-copy" id="sFooter_0_0_8_0_0_0_0_0_0_1">&#169; Copyright 2021 IEEE &#8212; All rights reserved. A not-for-profit organization, IEEE is the world's largest technical professional organization dedicated to advancing technology for the benefit of humanity.</div>
</div>



<div id="sFooter_0_0_8_0_0_0_0_0_1" class=" col sm-mb-2 md-mb-4 s12 m2 l2">
    <!-- User Code --><svg viewBox="0 0 70 21" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="0 0 21.3639449 0 21.3639449 21 0 21"></polygon></defs><g id="Symbols" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="Light-/-IEEE-Bar-/-Signed-out-/-1376" transform="translate(-1274.000000, -14.000000)"><g id="Group-13" transform="translate(1274.000000, 14.000000)"><polygon id="Fill-1" fill="#FEFEFE" points="23.4111174 18.6889405 27.8363724 18.6889405 27.8363724 2.77905063 23.4111174 2.77905063"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="29.7536549 18.6881005 29.7536549 2.77821061 41.9217005 2.77821061 41.9217005 5.8624668 34.17891 5.8624668 34.17891 9.14692664 41.3017712 9.14692664 41.3017712 12.2311828 34.17891 12.2311828 34.17891 15.6024442 41.9217005 15.6024442 41.9217005 18.6881005"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="43.7923126 18.6881005 43.7923126 2.77821061 55.9603583 2.77821061 55.9603583 5.8624668 48.2175677 5.8624668 48.2175677 9.14692664 55.3418347 9.14692664 55.3418347 12.2311828 48.2175677 12.2311828 48.2175677 15.6024442 55.9603583 15.6024442 55.9603583 18.6881005"></polygon><polygon id="Fill-4" fill="#FEFEFE" points="57.8305486 2.77793061 57.8305486 18.6878205 70 18.6878205 70 15.6021642 62.2558037 15.6021642 62.2558037 12.2323028 69.3800707 12.2323028 69.3800707 9.14664663 62.2558037 9.14664663 62.2558037 5.8621868 70 5.8621868 70 2.77793061"></polygon><g id="Group-12"><g id="Group-7"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-6"></g><path d="M20.9520644,9.85449953 L20.8930235,9.84469935 C19.0838421,8.61967703 17.3983653,7.23365178 15.8098843,5.66142314 L14.0555265,3.83578988 C13.3442244,3.05037557 12.6540084,2.18095973 11.9961242,1.35074461 L11.1976665,0.22232405 C11.099265,0.164923005 10.976966,0.0669212192 10.8687244,0.0375206836 C10.6339666,-0.0646811784 10.3795285,0.0571210406 10.1883485,0.202723693 L8.74184673,2.07875787 C6.42378906,4.93900998 3.67838782,7.60885862 0.684171419,9.65429588 C0.448007872,9.84049927 0.0951682866,10.0211026 0.0220700458,10.3235081 C-0.0566511366,10.596513 0.0853281388,10.8219172 0.256827858,10.9913202 C2.65360672,12.6363502 4.94776689,14.5907858 6.98748895,16.8168264 C7.35016869,17.1962333 7.64396739,17.5728401 7.99680697,17.9284466 C8.59424452,18.719461 9.29570648,19.5160755 9.84534902,20.364491 C10.0168487,20.5450943 10.0463692,20.8390996 10.3148646,20.9259012 C10.525725,20.9987026 10.785786,21.0477034 10.9868062,20.9259012 L11.1878263,20.7256976 C13.6675436,17.2256338 16.8149851,14.0825766 20.3293236,11.5429303 C20.6821632,11.2321246 21.3541047,11.1145225 21.3639449,10.5335119 C21.3386417,10.264707 21.182605,10.0015022 20.9520644,9.85449953 M18.5496626,10.7911166 C18.1476223,11.7879348 17.3337015,12.5831492 16.6238051,13.4525651 C15.0845249,15.1017951 13.4623062,16.6992242 11.6432846,17.9718474 C11.2763877,18.2322522 10.7815688,18.4702565 10.3401679,18.2658528 C9.00190778,17.56724 7.87450799,16.4248192 6.7035304,15.3860003 C5.34559001,14.1301774 3.98202667,12.6713508 2.95302836,11.142523 C2.80120893,10.9283191 2.75763114,10.6651143 2.76184834,10.3823091 C2.89398747,9.85449953 3.2566672,9.42049162 3.60107238,8.97668354 C4.81562776,7.43385543 6.30570729,5.96942875 7.80984416,4.63240439 C7.84498755,4.59740376 7.90824564,4.5232024 7.96306932,4.48960179 C8.60970761,3.93379167 9.25212869,3.44098269 9.92828741,2.95657386 C10.6339666,2.41056392 11.5209856,2.86417218 12.114206,3.36678134 C12.7369467,3.83998996 13.383585,4.37759975 13.9529079,4.9236097 L14.0555265,4.98241077 C15.6285445,6.43703727 17.0891035,8.05406673 18.2910073,9.76209785 C18.4864045,10.0603033 18.6579042,10.3963094 18.5496626,10.7911166" id="Fill-5" fill="#FEFEFE" mask="url(#mask-2)"></path></g><path d="M17.8685838,9.92786087 C16.3152462,7.68782006 14.2755241,5.70538394 12.1135031,3.97215236 C11.5554261,3.58154525 10.9087879,2.8983328 10.1876456,3.3869417 C7.9483091,4.92836978 5.79050526,7.01860786 4.05582778,9.15084671 C3.70298819,9.66885615 3.08587035,10.1616651 3.3656117,10.8504777 C3.56663186,11.3586869 4.01646719,11.7240936 4.30604868,12.1735018 C6.00698851,14.2091389 8.01719014,16.1089735 10.1145474,17.6364013 C11.0367098,18.221612 11.6931882,17.2751947 12.4087075,16.8397868 C13.8734838,15.6875658 15.2314242,14.2875403 16.5162664,12.9253155 L16.5162664,12.8917149 C17.0307655,12.2715036 17.5747851,11.6610924 17.9768254,10.9918802 C18.1525424,10.6642743 18.0653868,10.2162661 17.8685838,9.92786087 L17.8685838,9.92786087 Z M10.4477066,5.41697869 L10.6431039,4.79256731 L10.6684071,4.79256731 C11.0704474,5.9391882 11.4865451,7.08300904 11.9181059,8.21422965 L11.0549843,8.22962993 L11.0367098,8.33183179 L11.163226,11.4020877 L11.163226,11.4510886 C10.844124,11.5042896 10.4533296,11.4902893 10.1384449,11.4608888 L10.1145474,11.4258882 L10.2565266,8.26323054 L10.2565266,8.23943011 C10.0161459,8.21422965 9.71250703,8.23943011 9.46790907,8.21422965 L10.4477066,5.41697869 Z M9.93742469,15.6203646 C10.0217688,14.491944 10.0358262,13.4531251 10.0948671,12.3289046 C10.4912844,12.3695053 10.8356896,12.3541051 11.1969636,12.3401048 L11.2222668,12.4913076 L11.3642461,15.6301648 C10.8891076,15.698766 10.3844486,15.6595653 9.93742469,15.6203646 L9.93742469,15.6203646 Z M13.5501647,11.7058933 C11.492168,12.3443049 8.90420917,12.3149044 6.95304844,11.4608888 C6.60020885,11.2900857 6.15459073,11.0268809 6.03650896,10.6166734 C5.94794763,9.86485972 6.75624548,9.44905214 7.30588802,9.17604717 C7.62920717,9.03464459 7.95814925,8.87924176 8.31520604,8.8596414 C8.64836533,9.10324584 8.99698771,9.29924941 9.33998715,9.51765339 C8.67366857,9.69405661 7.87380512,9.84525936 7.56594907,10.5718726 C7.61936702,11.1248827 8.24632501,11.2998859 8.68350872,11.4370884 C10.2565266,11.8514959 11.9574665,11.7968949 13.4672263,11.250885 C13.7511848,11.0842819 14.2024259,10.8840783 14.1630653,10.4752708 C14.1138646,10.0356628 13.6092056,9.84105928 13.256366,9.70245676 C13.0412885,9.73185729 12.8346454,9.78085819 12.6336252,9.84525936 C12.5253836,9.54285385 12.432605,9.23484824 12.3046831,8.94224291 C12.9724074,9.1172461 13.638726,9.29924941 14.3289421,9.41965161 L14.3289421,9.43505189 C14.1869628,9.44905214 14.0309262,9.49805304 13.8931641,9.551254 L13.8931641,9.57645446 C14.2853643,9.77105801 14.8293839,10.0944639 14.8336011,10.6068732 C14.7422283,11.2270845 14.0604466,11.5098897 13.5501647,11.7058933 L13.5501647,11.7058933 Z" id="Fill-8" fill="#FEFEFE"></path><path d="M14.1946944,19.3564726 L14.1946944,19.1646691 L14.3141819,19.1646691 C14.3788457,19.1646691 14.467407,19.1716693 14.467407,19.2528707 C14.467407,19.3410724 14.4224235,19.3564726 14.3465138,19.3564726 L14.1946944,19.3564726 Z M14.1946944,19.4922751 L14.2748213,19.4922751 L14.4603783,19.8268812 L14.6613985,19.8268812 L14.4575669,19.4782749 C14.562997,19.4698747 14.6501526,19.4166737 14.6501526,19.2710711 C14.6501526,19.0890678 14.5278536,19.0302667 14.3226163,19.0302667 L14.0231946,19.0302667 L14.0231946,19.8268812 L14.1946944,19.8268812 L14.1946944,19.4922751 Z M15.0620331,19.429274 C15.0620331,18.9630655 14.7105992,18.6900605 14.3183991,18.6900605 C13.9233874,18.6900605 13.5719536,18.9630655 13.5719536,19.429274 C13.5719536,19.8954825 13.9233874,20.1670874 14.3183991,20.1670874 C14.7105992,20.1670874 15.0620331,19.8954825 15.0620331,19.429274 L15.0620331,19.429274 Z M14.8483613,19.429274 C14.8483613,19.7694802 14.6051691,19.9976843 14.3183991,19.9976843 L14.3183991,19.9962843 C14.0231946,19.9976843 13.7856254,19.7694802 13.7856254,19.429274 C13.7856254,19.0890678 14.0231946,18.8622636 14.3183991,18.8622636 C14.6051691,18.8622636 14.8483613,19.0890678 14.8483613,19.429274 L14.8483613,19.429274 Z" id="Fill-10" fill="#FEFEFE"></path></g></g></g></g></svg><!-- End User Code -->
</div>


    </div>
</div>


</div></div>
</div>


    </div>
</div>


</div>

<div id="sTop_Bar_0_0_19_0_0_13" data-toggle-property="gdpr" class="gdpr-cookie hidden hidden">
    <span class="js-scroll-trigger" data-target="#rm-gdpr-sTop_Bar_0_0_19_0_0_13" data-toggle-class="sticky-active"></span>
    <div id="rm-gdpr-sTop_Bar_0_0_19_0_0_13" class="sticky-target legacy rm-gdpr">
        <div class="gdpr-cookie-wrapper">
            <div class="gdpr-cookie-content"><p>IEEE websites place cookies on your device to give you the best user experience. By using our websites, you agree to the placement of these cookies. To learn more, read our Privacy Policy.</p></div>
            <div class="gdpr-cookie-controls">
                
                    <a href="https://www.ieee.org/security-privacy.html" target="_blank" class="gdpr-cookie-info">
                        view privacy policy
                    </a>
                
                <a href="#toggle-gdpr" class="gdpr-cookie-accept">
                    accept &amp; close
                </a>
            </div>
        </div>
    </div>
    
</div><span class="js-brick-description hidden" data-name="__Gated_Popup"></span><div class="gated-popup" id="s__Gated_Popup_0_0_22_0_0_0"><div class="gated-popup__contents" id="s__Gated_Popup_0_0_22_0_0_0_0"><!-- User Code --><a href="javascript:;" class="js--close-gated gated-popup__close icon-close"></a><!-- End User Code --><!-- User Code --><h2 class="popup-gated-h2 popup-heading-h2 for_pdf" style="display:none">Enjoy more free content and benefits by creating an account</h2><h2 class="popup-gated-h2 popup-heading-h2 for_save" style="display:none">Saving articles to read later requires an IEEE Spectrum account</h2><h2 class="popup-gated-h2 popup-heading-h2 for_member_content" style="display:none">The Institute content is only available for members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_pdf_issues" style="display:none">Downloading full PDF issues is exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_nxtbook" style="display:none">Access to <i>Spectrum</i>'s Digital Edition is exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_follow_topics" style="display:none">Following topics is a feature exclusive for IEEE Members</h2><h2 class="popup-gated-h2 popup-heading-h2 for_comments" style="display:none">Adding your response to an article requires an IEEE Spectrum account</h2><h2 class="popup-gated-h2 for_pdf for_save for_comments" style="display:none">Create an account to access more content and features on <i>IEEE Spectrum</i>, including the ability to save articles to read later, download Spectrum Collections, and participate in conversations with readers and editors. For more exclusive content and features, consider <a class="ieee_link" href="">Joining IEEE</a>.</h2><h2 class="popup-gated-h2 for_pdf_issues for_nxtbook for_follow_topics for_member_content" style="display:none">Join the world&#8217;s largest professional organization devoted to engineering and applied sciences and get access to all of Spectrum&#8217;s articles, archives, PDF downloads, and other benefits. <a href="/st/join">Learn more &#8594;</a></h2><!-- End User Code --><div class="popup_links for_pdf for_save for_comments create_account" id="s__Gated_Popup_0_0_22_0_0_0_0_2"><div class="list" id="s__Gated_Popup_0_0_22_0_0_0_0_2_0"><a href="https://ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fsaml%2Fmain%2Flogin%3Fnext_url%3Dhttps%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fintegrations%2Fieee%2Fchanges%0A&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">CREATE AN ACCOUNT</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div><div class="popup_links for_pdf_issues for_nxtbook for_follow_topics for_member_content" id="s__Gated_Popup_0_0_22_0_0_0_0_3"><div class="list" id="s__Gated_Popup_0_0_22_0_0_0_0_3_0"><a href="/st/join" class="list__item" target="_self">JOIN IEEE</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div></div></div><!-- User Code --><script>
  var popupGatedElement=document.querySelector('.gated-popup'),
  closeGated,
  gatedCloseBtn = '.js--close-gated',
  gatedShownClass = 'gated-popup--shown';

  closeGated = function () {
      popupGatedElement.classList.remove(gatedShownClass);
      popupGatedElement.classList.remove('for_save');
      popupGatedElement.classList.remove('for_pdf');
      popupGatedElement.classList.remove('for_pdf_issues');
      popupGatedElement.classList.remove('for_nxtbook');
      popupGatedElement.classList.remove('for_follow_topics');
      popupGatedElement.classList.remove('for_comments');
      popupGatedElement.classList.remove('for_member_content');
  };

  function openGatedPopup(type){
        document.querySelector(".popup_links.create_account .list__item").href = "https://ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=" + encodeURIComponent("https://spectrum.ieee.org/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href) + "&url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href) + "&autoSignin=Y&car=IEEE-Spectrum";
    
    popupGatedElement.classList.add(type);
  	popupGatedElement.classList.add(gatedShownClass);
  }

  document.querySelector(gatedCloseBtn).onclick= closeGated;
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="__Session_Popup"></span><div class="lightbox-popup" id="s__Session_Popup_0_0_25_0"><div class="lightbox-popup__contents" id="s__Session_Popup_0_0_25_0_0"><!-- User Code --><a href="javascript:;" class="js--close-lightbox lightbox-popup__close icon-close"></a><!-- End User Code --><!-- User Code --><h2 class="popup-ligtbox-h2 popup-heading-h2">Enjoy more free content and benefits by creating an account</h2><h2 class="popup-ligtbox-h2">Create an account to access more content and features on IEEE Spectrum, including the ability to <strong>save articles to read later</strong>, <strong>download Spectrum Collections</strong>, and <strong>participate in conversations</strong> with readers and editors. For more exclusive content and features, consider <a class="ieee_link" href="">Joining IEEE</a>.</h2><!-- End User Code --><div class="popup_links" id="s__Session_Popup_0_0_25_0_0_2"><div class="list" id="s__Session_Popup_0_0_25_0_0_2_0"><a href="https://ieee.org/profile/public/createwebaccount/showCreateAccount.html?ShowMGAMarkeatbilityOptIn=true&sourceCode=spectrum&signinurl=https%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fsaml%2Fmain%2Flogin%3Fnext_url%3Dhttps%3A%2F%2Fspectrum.ieee.org%2Fcore%2Fintegrations%2Fieee%2Fchanges%0A&url=https://spectrum.ieee.org/&autoSignin=Y&car=IEEE-Spectrum" class="list__item" target="_self">CREATE AN ACCOUNT</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div></div></div><!-- User Code --><script>
function addPopSave(){
    var save_post_links = document.querySelectorAll(".like-btn:not(.proc)");
	for (i = 0; i < save_post_links.length; i++) {
      save_post_links[i].removeAttribute("href");
      save_post_links[i].addEventListener("click", function(event){
      	openGatedPopup('for_save');
	  });
      save_post_links[i].classList.add('proc');
    } 
}
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="Social Stream Element"></span><div class="" id="sSocial_Stream_Element_0_0_15_0_0_1"><div class="top-leader-container" id="sSocial_Stream_Element_0_0_15_0_0_1_1"><!-- User Code --><div id='top_leaderboard'><script></script></div><!-- End User Code --></div><div id="sSocial_Stream_Element_0_0_15_0_0_1_2" class="featured_columns row-wrapper clearfix ">
    <div class="row ">
        

<div id="sSocial_Stream_Element_0_0_15_0_0_1_2_0" class="article_column col sm-mb-2 md-mb-4 s12 m12 l9">
    <div class="mb-2 article_post current_post_media current_post" id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_0"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="None"
        data-format="posts-custom"
        data-source="current_post"
        data-source-type="current_post"
        data-source-unique="true"
        data-section-id=""
        data-is-reordable="false"
        data-using-stickers="false"
        data-has-more="false"

    
        data-attr-layout_Separator="inactive"
        data-attr-filters="section"
        data-attr-layout_all_sections="top"
        data-attr-layout_Slack="inactive"
        data-attr-layout_Flipboard="inactive"
        data-attr-use_tag_image_for_lead_media="true"
        data-attr-layout_time_to_read="top"
        data-attr-layout_all_date_format="%d %b %Y"
        data-attr-layout_all_date_full_format="false"
        data-attr-layout_Pinterest="inactive"
        data-attr-layout_date="top"
        data-attr-layout_author="top"
        data-attr-element_classes="article_post current_post_media current_post"
        data-attr-posts_id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_0"
        data-attr-layout_headline="top"
        data-attr-section_url=""
        data-attr-layout_Twitter="inactive"
        data-attr-layout_Tumblr="inactive"
        data-attr-layout_subheadline="top"
        data-attr-source=""
        data-attr-is_current_post="true"
        data-attr-layout_SMS="inactive"
        data-attr-layout_photo_caption="bottom"
        data-attr-layout_image_column_width="33"
        data-attr-update_url_on_post_view="true"
        data-attr-all_share_buttons="Email,CopyLink,Whatsapp,Facebook,Twitter,Linkedin,Separator,Tumblr,GooglePlus,Pinterest,Reddit,Flipboard,SMS,Slack"
        data-attr-format="posts-custom"
        data-attr-layout_all_image_crop="original"
        data-attr-data-rm-advanced="true"
        data-attr-layout_all_subheadline_tag="h2"
        data-attr-node_id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/row/column[1]/posts-"
        data-attr-layout_Linkedin="inactive"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_like_button="top"
        data-attr-source_url="current_post"
        data-attr-layout_CopyLink="active"
        data-attr-layout_Facebook="inactive"
        data-attr-data-rm-device-crops="true"
        data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,photo_caption,photo_credit,custom_field_TimeofRead,post_shares,body,section,primary_tag,page_views,badges,badges_sponsored,source_link,community_name,snark_line,collection_button,community_comments,main_author,tags,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_Editor,custom_field_PodcastTime,custom_field_PodcastEpisode,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,site_field_member_badges,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition"
        data-attr-layout_photo_credit="bottom"
        data-attr-layout_Reddit="inactive"
        data-attr-layout_all_headline_tag="h1"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-layout_quality="4"><div class="posts-wrapper clearfix">
            
                
                <div class="widget post-partial tag-ibm tag-ibm-watson tag-speech-recognition-technology tag-natural-language-processing tag-pryon tag-ai tag-artificial-intelligence tag-ieee-member-news tag-type-ti post-section--topic/the-institute"
                
                data-category="The Institute">
<article 
    elid="2654877000" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654877000" 
    
    data-category="The Institute"
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/topic/the-institute/">The Institute</a>
            
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/profile/">Profile</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            
                <a href="https://spectrum.ieee.org/topic/careers/">Careers</a>
            </div><h1 class="widget__headline h1">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts"  aria-label="Tomorrow’s AI Will Reason Like Humans, IBM Watson Developer Predicts" data-type="text">
        Tomorrow’s AI Will Reason Like Humans, IBM Watson Developer Predicts
    </a>
</h1>
<div class="widget__subheadline">
    <h2 class="widget__subheadline-text h2" data-type="text"><p>David Nahamoo says machines will grok us</p></h2>
</div>


<div class="social-author clearfix">
    

    
        
    <div class="social-author__avatar image" >
             <div class="cover-all image" style='background-image: url("https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjY0NTkxNC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY5MTMxNTE3M30.C2X-OTG0-5r8AVXmAHUfERzXBnJgJi20PTOoBt4sNko/image.png?width=210")'></div>
        </div>
        <a class="social-author__name" href="https://spectrum.ieee.org/u/joanna_goodrich" data-type="text">Joanna Goodrich</a>
        
</div>
<div class="social-date">
        <span class="social-date__text">03 Sep 2021</span>
    </div><div class="time-to-read">4 min read</div><div class="like-button" data-post-likes="0"></div></div><div class="widget__body clearfix sm-mt-1"></div></div></div>
    
    
<script type="application/json" id="post-context-2654877000">
    {"customDimensions": {"5":"Joanna Goodrich","6":"the-institute","7":"IBM, ibm watson, speech recognition technology, natural language processing, pryon, ai, Artificial Intelligence, ieee member news, type:ti","8":"09/03/2021","10":"ieee member news","11":2654877000}, "post": {"providerId": 0, "sections": [0, 497728257, 544169516, 539628627, 544169528, 539626938], "buckets": [], "authors": [21075164]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div><div id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1" class=" row-wrapper clearfix ">
    <div class="row ">
        

<div id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_0" class="tag_column col sm-mb-2 md-mb-4 s12 m12 l3">
    <div class="mb-2 article_post article_post-shares-and-tags" id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_0_0_1_0"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="None"
        data-format="posts-custom"
        data-source="current_post"
        data-source-type="current_post"
        data-source-unique="true"
        data-section-id=""
        data-is-reordable="false"
        data-using-stickers="false"
        data-has-more="false"

    
        data-attr-layout_Whatsapp="inactive"
        data-attr-layout_tags="top"
        data-attr-layout_Separator="inactive"
        data-attr-layout_remove_image="true"
        data-attr-filters="section"
        data-attr-layout_Slack="inactive"
        data-attr-layout_post_shares="top"
        data-attr-use_tag_image_for_lead_media="true"
        data-attr-layout_all_date_full_format="false"
        data-attr-layout_Pinterest="inactive"
        data-attr-element_classes="article_post article_post-shares-and-tags"
        data-attr-posts_id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_0_0_1_0"
        data-attr-section_url=""
        data-attr-layout_Twitter="active"
        data-attr-layout_Tumblr="inactive"
        data-attr-source=""
        data-attr-is_current_post="true"
        data-attr-layout_SMS="inactive"
        data-attr-layout_image_column_width="33"
        data-attr-update_url_on_post_view="true"
        data-attr-all_share_buttons="Email,CopyLink,Twitter,Facebook,Separator,Linkedin,GooglePlus,Whatsapp,Tumblr,Slack,Pinterest,Reddit,Flipboard,SMS"
        data-attr-format="posts-custom"
        data-attr-layout_all_image_crop="3x2"
        data-attr-data-rm-advanced="true"
        data-attr-source_url="current_post"
        data-attr-node_id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/row/column[1]/row/column[1]/choose/otherwise/posts-"
        data-attr-layout_Linkedin="active"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_Flipboard="inactive"
        data-attr-layout_CopyLink="active"
        data-attr-layout_Facebook="active"
        data-attr-data-rm-device-crops="true"
        data-attr-all_element_order="post_shares,tags,all_sections,headline,subheadline,custom_field_PodcastEpisode,date,custom_field_PodcastTime,like_button,body,author,custom_field_TimeofRead,page_views,badges,section,primary_tag,community_name,badges_sponsored,source_link,photo_caption,photo_credit,community_comments,snark_line,collection_button,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,main_author,custom_field_FullwidthCardPosition,product_prices,custom_field_Issue,custom_field_FullwidthCardColor,site_field_Twitter,product_vendor,product_buy_link,site_field_LinkedIn,custom_field_Editor,site_field_Instagram,site_field_Facebook,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition"
        data-attr-layout_all_date_format="%d %b %Y"
        data-attr-layout_Reddit="inactive"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-layout_quality="13"><div class="posts-wrapper clearfix">
            
                
                <div class="widget post-partial tag-ibm tag-ibm-watson tag-speech-recognition-technology tag-natural-language-processing tag-pryon tag-ai tag-artificial-intelligence tag-ieee-member-news tag-type-ti post-section--topic/the-institute"
                
                data-category="The Institute">
<article 
    elid="2654877000" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-SD post-2654877000" 
    
    data-category="The Institute"
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><div class="widget__shares share-panel">
    <!-- EMAIL -->
<a href="mailto:?subject=Tomorrow%E2%80%99s%20AI%20Will%20Reason%20Like%20Humans%2C%20IBM%20Watson%20Developer%20Predicts&amp;body=https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK -->
<a href="https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts" data-clipboard-text="https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts" class="share share-copy-link" title="Copy this link to clipboard">
  <i class="icons-share" style="width: 60%">
  <svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i>
</a><!-- TWITTER -->
<a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts&amp;text=Tomorrow%E2%80%99s%20AI%20Will%20Reason%20Like%20Humans%2C%20IBM%20Watson%20Developer%20Predicts&amp;" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK -->
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Ftomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts%3Fxrs%3DRebelMouse_fb%26ts%3D1630695029" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN -->
<a href="http://www.linkedin.com/shareArticle?mini=false&amp;url=https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts&amp;" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a>
</div><div class="tags">
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/ibm"
            >IBM</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/ibm-watson"
            >ibm watson</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/speech-recognition-technology"
            >speech recognition technology</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/natural-language-processing"
            >natural language processing</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/pryon"
            >pryon</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/ai"
            >ai</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/artificial-intelligence"
            >Artificial Intelligence</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/ieee-member-news"
            >ieee member news</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/type-ti"
            >type:ti</a>
        
    </div></div></div></div>
    
    
<script type="application/json" id="post-context-2654877000">
    {"customDimensions": {"5":"Joanna Goodrich","6":"the-institute","7":"IBM, ibm watson, speech recognition technology, natural language processing, pryon, ai, Artificial Intelligence, ieee member news, type:ti","8":"09/03/2021","10":"ieee member news","11":2654877000}, "post": {"providerId": 0, "sections": [0, 497728257, 544169516, 539628627, 544169528, 539626938], "buckets": [], "authors": [21075164]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div>
</div>



<div id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_1" class="current_post_content col sm-mb-2 md-mb-4 s12 m12 l9">
    <div class="mb-2 article_post article_post--body-and-tags" id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_1_0_1_0"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="None"
        data-format="posts-custom"
        data-source="current_post"
        data-source-type="current_post"
        data-source-unique="true"
        data-section-id=""
        data-is-reordable="false"
        data-using-stickers="false"
        data-has-more="false"

    
        data-attr-layout_tags="bottom"
        data-attr-layout_Separator="inactive"
        data-attr-layout_remove_image="true"
        data-attr-filters="section"
        data-attr-layout_all_image_crop="3x2"
        data-attr-layout_Slack="inactive"
        data-attr-use_tag_image_for_lead_media="true"
        data-attr-layout_body="top"
        data-attr-layout_all_date_full_format="false"
        data-attr-layout_Pinterest="inactive"
        data-attr-element_classes="article_post article_post--body-and-tags"
        data-attr-posts_id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_1_0_1_0"
        data-attr-section_url=""
        data-attr-layout_Twitter="inactive"
        data-attr-layout_Tumblr="inactive"
        data-attr-source=""
        data-attr-is_current_post="true"
        data-attr-layout_SMS="inactive"
        data-attr-layout_image_column_width="33"
        data-attr-update_url_on_post_view="true"
        data-attr-all_share_buttons="Email,CopyLink,Whatsapp,Facebook,Twitter,Linkedin,Separator,Tumblr,GooglePlus,Pinterest,Reddit,Flipboard,SMS,Slack"
        data-attr-format="posts-custom"
        data-attr-layout_Flipboard="inactive"
        data-attr-data-rm-advanced="true"
        data-attr-source_url="current_post"
        data-attr-node_id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/row/column[1]/row/column[2]/choose[1]/otherwise/posts-"
        data-attr-layout_Linkedin="inactive"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_CopyLink="active"
        data-attr-layout_Facebook="inactive"
        data-attr-show_around_the_web="true"
        data-attr-data-rm-device-crops="true"
        data-attr-all_element_order="body,tags,all_sections,headline,subheadline,custom_field_PodcastEpisode,date,custom_field_PodcastTime,like_button,post_shares,author,custom_field_TimeofRead,page_views,badges,section,primary_tag,community_name,badges_sponsored,source_link,photo_caption,photo_credit,community_comments,snark_line,collection_button,follow_button,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,main_author,custom_field_FullwidthCardPosition,product_prices,custom_field_Issue,custom_field_FullwidthCardColor,site_field_Twitter,product_vendor,product_buy_link,site_field_LinkedIn,custom_field_Editor,site_field_Instagram,site_field_Facebook,custom_field_PodcastVideoTime,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition"
        data-attr-show_full_post_body="true"
        data-attr-layout_all_date_format="%d %b %Y"
        data-attr-layout_Reddit="inactive"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-layout_quality="7"
        data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix">
            
                
                <div class="widget post-partial tag-ibm tag-ibm-watson tag-speech-recognition-technology tag-natural-language-processing tag-pryon tag-ai tag-artificial-intelligence tag-ieee-member-news tag-type-ti post-section--topic/the-institute"
                
                data-category="The Institute">
<article 
    elid="2654877000" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-MD post-2654877000" 
    
    data-category="The Institute"
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1"><span class="js-scroll-trigger" data-target="body" data-triggers="render-rebelbar" data-toggle-class="with-floating-shares"></span>
<div id="utm_campaign"></div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2654877000"
        
            data-elid="2654877000"
            data-post-url="https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts"
            
                data-authors="Joanna Goodrich"
            
            
                data-headline="Tomorrow’s AI Will Reason Like Humans, IBM Watson Developer Predicts"
            
        ><div class="body-description"><p>
	When <a href="https://www.linkedin.com/in/davidnahamoo/" rel="noopener noreferrer" target="_blank">David Nahamoo</a> was a high school student in Iran, he wanted to pursue a career in mathematics or physics. But after talking over career options with his friends, he says, he was "pointed in the direction of a good career in Iran" and instead decided to become an electrical engineer. Today the IEEE Life Fellow is CTO of <a href="https://pryon.com/" rel="noopener noreferrer" target="_blank">Pryon</a>, a startup in Raleigh, N.C., that is developing a natural-language-processing AI system for businesses. The company's programs aim to make companies more productive, reducing costs and eliminating inefficiencies.
</p><p class="shortcode-media shortcode-media-rebelmouse-image rm-float-left" style="float: left;">
<img alt="Photo of DAVID NAHAMOO" class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="fcc00998346ccfda4d820c143cd70f85" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM3Njk1Ny9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzOTY4OTUwMH0.cFQkxxaAIuGpzTzmyePArmhx2Kw4CVGIT5g3xnTtJg0/image.jpg?width=980" height="1799" id="2469a" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1479 1799'%3E%3C/svg%3E" width="1479"/>
<small class="image-media media-photo-credit" placeholder="Add Photo Credit...">DAVID NAHAMOO</small>
</p><p>
	Nahamoo is an expert in speech and language technologies. He spent almost 35 years at <a href="https://www.research.ibm.com/" rel="noopener noreferrer" target="_blank">IBM Research</a> in Yorktown Heights, N.Y., developing innovative AI technologies such as <a href="https://www.ibm.com/watson" rel="noopener noreferrer" target="_blank">Watson</a>. The supercomputer won a game on Jeopardy! in 2011 against two of the U.S. TV show's most successful contestants. Watson answers questions using advanced natural language processing, information retrieval, knowledge representation, automated reasoning, and machine learning technologies.
</p><p>
	"I love taking a problem, sitting down, and figuring out how I can solve it," Nahamoo says. "And when I do [solve the problem], I get a rush of joy."
</p><p>
	He received this year's IEEE <a href="https://www.ieee.org/content/dam/ieee-org/ieee/web/org/about/awards/recipients/flanagan_rl.pdf" rel="noopener noreferrer" target="_blank">James L. Flanagan Speech and Audio Processing Award</a> "for contributions to and leadership in research and deployment of spoken-language technologies." The speech and audio-processing award is sponsored by the <a href="https://signalprocessingsociety.org/" rel="noopener noreferrer" target="_blank">IEEE Signal Processing Society</a> and <a href="https://merl.com/" rel="noopener noreferrer" target="_blank">Mitsubishi Electric Research Labs</a>.
</p><p>
	Nahamoo worked with <a href="https://spectrum.ieee.org/sultan-of-sound" target="_self">Flanagan</a> throughout his career. Flanagan, who died in 2015, worked at <a href="https://www.bell-labs.com/" rel="noopener noreferrer" target="_blank">Bell Labs</a> in Holmdel, N.J., for 33 years before he joined <a href="https://www.rutgers.edu/" rel="noopener noreferrer" target="_blank">Rutgers University</a> in New Brunswick, N.J., as vice president for research. He was a pioneer in the field of acoustics and provided the technical foundation for speech recognition, teleconferencing, MP3 music files, and the efficient digital transmission of human conversation.
</p><p>
	"I was very happy and thankful that I got an award that honors a person I knew very well," Nahamoo says.
</p><p>
<strong>CHOOSING A DIFFERENT PATH</strong>
</p><p>
	Nahamoo grew up in Hamadan, and when he was 12 years old, he moved to Tehran. After graduating from high school at the top of his class, he earned a bachelor's degree in electrical engineering in 1975 from the <a href="https://ut.ac.ir/en" rel="noopener noreferrer" target="_blank">University of Tehran</a>, then a master's degree in EE from <a href="https://www.imperial.ac.uk/" rel="noopener noreferrer" target="_blank">Imperial College London</a> in 1976. He left England to pursue a doctorate in electrical, electronics, and communications engineering at <a href="https://www.purdue.edu/" rel="noopener noreferrer" target="_blank">Purdue University</a>, in West Lafayette, Ind. He conducted his doctoral thesis research at Purdue in ultrasound diffraction imaging. He developed a technique that allowed for tomographic medical imaging using diffracted projections—images created when waves bend around objects.
</p><p>
	After graduating in 1982, he switched his interests and joined the continuous speech recognition team at IBM Research.
</p><p>
	"I just fell in love [with the group] because I thought that they were solving problems that appeared to be impossible to solve," he says. "And I love that challenge of impossibility."
</p><p>
	Looking back, he says, he can divide his career at IBM into three parts. For the first 10 years, he was a "pure technologist" who solely worked to improve the technology being developed. During his second decade, he became more interested in the delivery of speech recognition products to the market. For the last 10 years, as CTO of speech technology, his interests centered more on the strategic impact that spoken language technologies have on businesses.
</p><p>
<strong>WHAT IS: IBM WATSON</strong>
</p><p>
	Nahamoo was dedicated to expanding the capabilities of speech recognition technologies. He wanted to develop a machine that could interact like humans with other humans.
</p><p>
	That idea led to a one-year study by IBM that gave birth to the Watson Group, Nahamoo says. The study examined market needs for cognitive computing technologies and business opportunities surrounding automating human sensory, language, learning, and reasoning capabilities.
</p><p>
	The supercomputer's data analytics processor analyzed human speech for meaning and syntax so that it could answer questions posed to the machine, similar to how <a href="https://www.aboutamazon.com/" rel="noopener noreferrer" target="_blank">Amazon</a>'s <a href="https://www.google.com/aclk?sa=l&amp;ai=DChcSEwjfq-CpvpXyAhWCwMgKHSeGBXsYABAAGgJxdQ&amp;ae=2&amp;sig=AOD64_21BkB8RU6WsjyOb0NDyYYcKHcV3A&amp;q&amp;adurl&amp;ved=2ahUKEwjX8NapvpXyAhWmElkFHf9DDZsQ0Qx6BAgCEAE" rel="noopener noreferrer" target="_blank">Alexa</a> and <a href="https://www.apple.com/newsroom/" rel="noopener noreferrer" target="_blank">Apple</a>'s <a href="https://spectrum.ieee.org/apple-cofounder-steve-wozniak-on-smart-watches-motivating-engineers-siri-and-more" target="_self">Siri</a> now work.
</p><p>
	Nahamoo says the Watson project was all about making progress on programming machines with the cognitive abilities of humans. The supercomputer was the first step to creating an AI machine that people could interact with as if they were speaking to another person, he says.
</p><p>
	One day, he says, AI machines will be able to understand physical cues such as head nodding and posture changes, as well as mimic human emotions. That would enable machines to interact more closely and could let them form connections with humans, he says.
</p><div class="ad-in-content"></div><p>
	Building such a machine, Nahamoo says, is "my interest, my love."
</p><p>
<strong>SWITCHING GEARS</strong>
</p><p>
	Nahamoo now has an opportunity to take his work forward. In 2018 <a href="https://www.dreamit.com/igor-jablokov" rel="noopener noreferrer" target="_blank">Igor Jablokov</a>, founder and CEO of Pryon, offered Nahamoo the CTO position. The two had worked together at IBM in the early 2000s, when Jablokov led the development of IBM Watson Assistant—a forerunner to IBM Watson. The two collaborated again in the late 2000s, when Jablokov, founder and CEO of tech company <a href="https://en.wikipedia.org/wiki/Yap_(company)" rel="noopener noreferrer" target="_blank">Yap</a>, licensed IBM's <a href="http://ieeexplore.ieee.org/abstract/document/5700829/" rel="noopener noreferrer" target="_blank">Attila</a> speech-recognition engine.
</p><p>
	Nahamoo says he took the offer because he wanted to go back to working at the "cross section of deep technology innovation and business impact."
</p><p>
	Pryon has about 30 employees and aims to help companies use AI to improve their operations. One of its products, Answer, is a question-answering platform that companies can add to their AI assistants, chatbots, and help desks.
</p><p>
	An employee can ask via text or voice how many vacation days she has available, for example. The platform organizes, reads, and searches a company's applications and documents to find the answer. Unlike other AI assistants and chatbots that can respond only to a limited set of requests, Pryon attempts to retrieve responses to any company-related questions. The system also collects user feedback and monitors usage in order to improve the quality of the answers.
</p><p>
	"We are trying to build the best question-answering system out there," Nahamoo says. "One that can filter content from different kinds of files—from PDFs, HTML, and Microsoft Word or Google documents to PowerPoint presentations."
</p><p>
	The company has one customer using Answers and others that are interested in implementing the system, he says.
</p><p>
<strong>IEEE APPRECIATION</strong>
</p><p>
	Nahamoo joined IEEE in 1978 as a student. He wanted to be able to read the organization's publications, take part in its activities, and connect with other engineers, he says.
</p><p>
	"I appreciate the insight and greatness of those who started IEEE and of those who have helped the [engineering] community," Nahamoo says. "I believe our community would have been a lot less effective and capable of making the impact that it has made without IEEE."
</p><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div>
        <ul class="around-the-web__list"><li class="from-your-site__item">
                        <a href="https://spectrum.ieee.org/tag/history-of-natural-language-processing" class="from-your-site__link" target="_blank" rel="noopener noreferrer">history-of-natural-language-processing - IEEE Spectrum &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://spectrum.ieee.org/natural-language-processing-dates-back-to-kabbalist-mystics" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Natural Language Processing Dates Back to Kabbalist Mystics ... &rsaquo;</a>
                    </li></ul><div class="around-the-web__headline">Related Articles Around the Web</div>
        <ul class="around-the-web__list"><li class="around-the-web__item">
                        <a href="https://becominghuman.ai/a-simple-introduction-to-natural-language-processing-ea66a1747b32" class="around-the-web__link" target="_blank" rel="noopener noreferrer">A Simple Introduction to Natural Language Processing | by Dr ... &rsaquo;</a>
                    </li><li class="around-the-web__item">
                        <a href="https://www.ibm.com/cloud/learn/natural-language-processing" class="around-the-web__link" target="_blank" rel="noopener noreferrer">What is Natural Language Processing? | IBM &rsaquo;</a>
                    </li></ul></div></div>
        

        

    </div>



<span class="js-scrolled-url"
    data-elid="2654877000"
    data-post-url="https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts"
    
        data-authors="Joanna Goodrich"
    
    
        data-headline="Tomorrow’s AI Will Reason Like Humans, IBM Watson Developer Predicts"
    >
</span>
</div><div class="widget__body clearfix sm-mt-1"><div class="tags">
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/ibm"
            >IBM</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/ibm-watson"
            >ibm watson</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/speech-recognition-technology"
            >speech recognition technology</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/natural-language-processing"
            >natural language processing</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/pryon"
            >pryon</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/ai"
            >ai</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/artificial-intelligence"
            >Artificial Intelligence</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/ieee-member-news"
            >ieee member news</a>
        
            <a
                class="tags__item"
                href="https://spectrum.ieee.org/tag/type-ti"
            >type:ti</a>
        
    </div></div></div></div>
    
    
<script type="application/json" id="post-context-2654877000">
    {"customDimensions": {"5":"Joanna Goodrich","6":"the-institute","7":"IBM, ibm watson, speech recognition technology, natural language processing, pryon, ai, Artificial Intelligence, ieee member news, type:ti","8":"09/03/2021","10":"ieee member news","11":2654877000}, "post": {"providerId": 0, "sections": [0, 497728257, 544169516, 539628627, 544169528, 539626938], "buckets": [], "authors": [21075164]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div><div id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_1_1" class="post-partial article__authors"><div class="post-author-list"><div class="post-author">
            <a href="https://spectrum.ieee.org/u/joanna_goodrich">
                <div class="post-author__avatar image" style='background-image: url("https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjY0NTkxNC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTY5MTMxNTE3M30.C2X-OTG0-5r8AVXmAHUfERzXBnJgJi20PTOoBt4sNko/image.png?width=210")'></div>
            </a>
            <a href="https://spectrum.ieee.org/u/joanna_goodrich" class="post-author__name" data-type="text">Joanna Goodrich</a>
            
            <div class="post-author__bio"><p>
	<a href="https://twitter.com/theamarnamove" target="_blank">Joanna Goodrich</a> is the assistant editor of The Institute, covering the work and accomplishments of IEEE members and IEEE and technology-related events. She has a master's degree in health communications from Rutgers University, in New Brunswick, N.J.
</p></div>
            
        </div></div></div><div class="" id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_1_2"><div class="post-partial article__comments">
  <div class="article-content__comments-wrapper">
    <div id="comments-widget">
      <div class="talk-comments-wrp community-native-wrp "
        data-talk_id="post:2654877000:comments"
        data-limit='10'
        data-order='best'
        data-is_amp=''
        
        data-count_top_level='0'
        data-count_featured='0'
        data-show_rating='False'
        data-all_element_order='update_avatar,avatar,title,follow,date,bio,site_field_member_badges,site_field_grade,message,update_avatar,bio,follow'
        data-inactive_layout_attributes='update_avatar,follow,bio,update_avatar,bio,follow'
        data-active_layout_attributes='site_field_member_badges,site_field_grade'
        >
        <div class="editmode-section-title"></div>
        <a href="#" class="hidden new-comments-notification" aria-label="New coments notification"></a>
        <div class="comment-headline">The Conversation (0)</div><div class="add-comment">
            <div class="comment_placeholder-wrp">
                <div class="animated-background">

                    <div class="placeholder__textarea_top"></div>
                    <div class="placeholder__textarea_botmiddle_left"></div>
                    <div class="placeholder__textarea_botmiddle_right"></div>
                    <div class="placeholder__textarea_bottom"></div>

                    <div class="placeholder__button_b"></div>
                    <div class="placeholder__button_i"></div>
                    <div class="placeholder__button_publish"></div>
                </div><div class="comment-login-wrp"></div></div>
        </div>
        <div class="comment-header"></div><div class="talk--messages">
            <div class="talk--messages__featured"></div>
            <div class="talk--messages__top_level"></div>
        </div>
        <script type="rm-preact-state">{"featuredComments": [], "authors": {}, "forcedComments": [], "topLevelComments": []}
        </script>
        
        <div class="talk--load_more-wrp "></div>
      </div>
    </div>
  </div>
</div><!-- User Code --><script>
    var clickeableItems = [
      ".talk-comments-wrp .add-comment",
      ".talk-comments-wrp .comment-item--publish",
      ".talk-comments-wrp .comment--item__reply",
      ".talk-comments-wrp .comment--item__like",
      ".talk-comments-wrp .comment--item__dislike",
      ".talk-comments-wrp .replies"];
    var talkItems = document.querySelectorAll(clickeableItems.join(",")) || [];
    talkItems.forEach(function(item) {
      item.addEventListener("click", function(event){
        event.preventDefault();
        event.stopPropagation();
        openGatedPopup('for_comments');
        }, true);
    });
</script><!-- End User Code --></div><div class="mb-2 read_also_posts" id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_1_3_1_0"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_1"
        data-format="posts-custom"
        data-source="filtered_parent_site"
        data-source-type="page"
        data-source-unique="true"
        data-section-id=""
        data-is-reordable="false"
        data-using-stickers="false"
        data-has-more="true"

    
        data-attr-source_site="parent_site"
        data-attr-layout_all_sections="right"
        data-attr-from_regular_sections_other_than="webinar,whitepaper,sponsored,podcast,video,tests,issue-cover-posts,feature"
        data-attr-use_tag_image_for_lead_media="true"
        data-attr-layout_time_to_read="right"
        data-attr-layout_all_date_format="%d %b %Y"
        data-attr-layout_all_date_full_format="false"
        data-attr-source_unique="true"
        data-attr-element_classes="read_also_posts"
        data-attr-posts_id="sSocial_Stream_Element_0_0_15_0_0_1_2_0_1_1_3_1_0"
        data-attr-layout_headline="right"
        data-attr-from_regular_sections_of_current_post="true"
        data-attr-source="filtered"
        data-attr-layout_date="right"
        data-attr-all_element_order="all_sections,headline,date,time_to_read,like_button,custom_field_TimeofRead,section,primary_tag,author,badges,badges_sponsored,photo_credit,community_name,subheadline,snark_line,page_views,photo_caption,follow_button,community_comments,body,collection_button,tags,source_link,main_author,post_shares,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,custom_field_FeaturePostColor,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition"
        data-attr-layout_image_column_width="28"
        data-attr-format="posts-custom"
        data-attr-layout_all_image_crop="original"
        data-attr-data-rm-advanced="true"
        data-attr-node_id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/row/column[1]/row/column[2]/choose[2]/otherwise/posts-"
        data-attr-layout_like_button="right"
        data-attr-layout_desktop_image_crop="original"
        data-attr-without_current="true"
        data-attr-data-rm-device-crops="true"
        data-attr-limit="3"
        data-attr-v="2"
        data-attr-layout_quality="7"><div class="posts-wrapper clearfix">
            
                
                <div class="widget tag-video-friday tag-robot-videos tag-robots post-section--topic/robotics"
                 elid="2654889223"
                data-category="Robotics">
<article 
    elid="2654889223" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-MD post-2654889223" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/video-friday-robot-gecko-catapult"  aria-label="Video Friday: Robot Gecko Smashes Face Into Tree">
                        
                        <img
                                            role="img"
                                            type="lazy-image"
                                            alt="Video Friday: Robot Gecko Smashes Face Into Tree"
                                            aria-label="Video Friday: Robot Gecko Smashes Face Into Tree"
                                            src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 750 385&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM3OTk1OC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzMzU4MzA4OH0.3BT1Nuh5Q7eSciRIH0b3MenGmXkpBQz3mO3Sg2-NLQk/image.jpg?width=600&amp;height=308"
                                            
                                            
                                            style="object-fit: cover;"
                                            
                                            class="rm-lazyloadable-image"
                                            width="750"
                                            height="385"
                                        /></a>
                        
                </div></div><div id="col-right" class="col" style="width:72.0%;">
                <div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/topic/robotics/">Robotics</a>
            
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/news/">News</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/video-friday-robot-gecko-catapult"  aria-label="Video Friday: Robot Gecko Smashes Face Into Tree" data-type="text">
        Video Friday: Robot Gecko Smashes Face Into Tree
    </a>
</h2><div class="social-date">
        <span class="social-date__text">03 Sep 2021</span>
    </div><div class="time-to-read">3 min read</div><div class="like-button" data-post-likes="0"></div></div>
            </div></div>
    
    
<script type="application/json" id="post-context-2654889223">
    {"customDimensions": {"5":"Evan Ackerman","6":"robotics","7":"video friday, robot videos, robots","8":"09/03/2021","10":"video friday","11":2654889223}, "post": {"providerId": 0, "sections": [0, 539266128, 544169523, 544169516, 497728257], "buckets": [], "authors": [21075149]} }
</script>
</article>
                </div>
            
                
                <div class="widget tag-ions tag-memristors tag-neuroscience tag-biomimickry tag-artificial-neurons"
                 elid="2654884691"
                data-category="Type">
<article 
    elid="2654884691" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-MD post-2654884691" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/these-artificial-neurons-use-ions-rather-than-electrons"  aria-label="These Super-Efficient, Artificial Neurons Do Not Use Electrons">
                        
                        <img
                                            role="img"
                                            type="lazy-image"
                                            alt="Artificial neurons illustration"
                                            aria-label="Artificial neurons illustration"
                                            src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 5616 3744&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM3ODY1Ni9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY3NjAwNjY0MH0.ZO10QNb90kNqaRN4MCQss8cd6DSxhLREdBpS4NCNjWY/image.jpg?width=600&amp;height=400"
                                            
                                            
                                            style="object-fit: cover;"
                                            
                                            class="rm-lazyloadable-image"
                                            width="5616"
                                            height="3744"
                                        /></a>
                        
                </div></div><div id="col-right" class="col" style="width:72.0%;">
                <div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/news/">News</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            
                <a href="https://spectrum.ieee.org/topic/semiconductors/">Semiconductors</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/these-artificial-neurons-use-ions-rather-than-electrons"  aria-label="These Super-Efficient, Artificial Neurons Do Not Use Electrons" data-type="text">
        These Super-Efficient, Artificial Neurons Do Not Use Electrons
    </a>
</h2><div class="social-date">
        <span class="social-date__text">03 Sep 2021</span>
    </div><div class="time-to-read">3 min read</div><div class="like-button" data-post-likes="1"></div></div>
            </div></div>
    
    
<script type="application/json" id="post-context-2654884691">
    {"customDimensions": {"5":"Payal Dhar","6":"type","7":"ions, memristors, neuroscience, biomimickry, artificial neurons","8":"09/03/2021","10":"artificial neurons","11":2654884691}, "post": {"providerId": 0, "sections": [0, 497728257, 544169523, 544169516, 539621009], "buckets": [], "authors": [21075889]} }
</script>
</article>
                </div>
            
                
                <div class="widget tag-airline-safety tag-5g tag-4g tag-faa tag-wireless"
                 elid="2654866709"
                data-category="Type">
<article 
    elid="2654866709" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-MD post-2654866709" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:28.0%;"><div class="widget__head"><a href="https://spectrum.ieee.org/faa-tested-4g-5g-flights"  aria-label="Exclusive: FAA Investigates If It&#39;s Safer to Leave Cellphones On">
                        
                        <img
                                            role="img"
                                            type="lazy-image"
                                            alt="Rear view of a man with headphones looking out of the window from a private plane. Below is an aerial view of land"
                                            aria-label="Rear view of a man with headphones looking out of the window from a private plane. Below is an aerial view of land"
                                            src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 3600 2700&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM3ODA5Mi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY4NTc4MzQ5MH0.4Bt1OoWpVL3PrCDqSt15vVZH2YdXO-F8Vb1p3KXzTbw/image.jpg?width=600&amp;height=450"
                                            
                                            
                                            style="object-fit: cover;"
                                            
                                            class="rm-lazyloadable-image"
                                            width="3600"
                                            height="2700"
                                        /></a>
                        
                </div></div><div id="col-right" class="col" style="width:72.0%;">
                <div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/news/">News</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            
                <a href="https://spectrum.ieee.org/topic/telecommunications/">Telecommunications</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/faa-tested-4g-5g-flights"  aria-label="Exclusive: FAA Investigates If It&#39;s Safer to Leave Cellphones On" data-type="text">
        Exclusive: FAA Investigates If It&#39;s Safer to Leave Cellphones On
    </a>
</h2><div class="social-date">
        <span class="social-date__text">02 Sep 2021</span>
    </div><div class="time-to-read">3 min read</div><div class="like-button" data-post-likes="3"></div></div>
            </div></div>
    
    
<script type="application/json" id="post-context-2654866709">
    {"customDimensions": {"5":"Mark Harris","6":"type","7":"airline safety, 5g, 4g, faa, wireless","8":"09/02/2021","10":"wireless","11":2654866709}, "post": {"providerId": 0, "sections": [0, 497728257, 544169523, 544169516, 539622110], "buckets": [], "authors": [21079483]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div>
</div>


    </div>
</div>



</div>


    
    
    

<div id="sSocial_Stream_Element_0_0_15_0_0_1_2_1" class="widget_column col sm-mb-2 md-mb-4 s12 m12 l3">
    <span class="js-brick-description hidden" data-name="Popular widget"></span><div class="popular_widget" id="sPopular_widget_0_0_13_0_0_1_3_0_1_0"><div class="" id="sPopular_widget_0_0_13_0_0_1_3_0_1_0_0"><div id="sPopular_widget_0_0_13_0_0_1_3_0_1_0_0_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        More from  The Institute
    </h2>
</div></div></div><div class="mb-2 " id="sPopular_widget_0_0_13_0_0_1_3_0_1_0_1"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_2"
        data-format="posts-custom"
        data-source="frontpage_parent_site_the-institute_newest"
        data-source-type="page"
        data-source-unique="true"
        data-section-id="539626938"
        data-is-reordable="true"
        data-using-stickers="true"
        data-has-more="true"

    
        data-attr-without_current="true"
        data-attr-posts_id="sPopular_widget_0_0_13_0_0_1_3_0_1_0_1"
        data-attr-layout_remove_image="true"
        data-attr-layout_headline="top"
        data-attr-layout_all_sections="top"
        data-attr-format="posts-custom"
        data-attr-all_element_order="all_sections,headline,subheadline,section,author,community_name,date,date_modified,badges,badges_sponsored,photo_credit,photo_caption,body,snark_line,page_views,post_shares,follow_button,community_comments,like_button,source_link,collection_button,tags,primary_tag,main_author,product_prices,product_vendor,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_FullwidthCardColor,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,custom_field_TimeofRead,custom_field_Issue,custom_field_FullwidthCardPosition,custom_field_due_date,custom_field_FeaturePostImgPosition,custom_field_access,custom_field_publication_date,custom_field_FeaturePostColor,site_field_member_badges,words_count,time_to_read,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version"
        data-attr-source_url="the-institute"
        data-attr-section_url="the-institute"
        data-attr-node_id="/root/blocks/block[popular_widget]/abtests/abtest/choose/when[post_page==true]/choose/when[539626938_in_post.sections]/element_wrapper/posts-"
        data-attr-limit="5"
        data-attr-layout_quality="1"
        data-attr-v="2"
        data-attr-source_site="parent_site"
        data-attr-order="newest"
        data-attr-source_unique="true"><div class="posts-wrapper clearfix">
            
                
                <div class="widget tag-ieee-news tag-type-ti post-section--topic/the-institute"
                 elid="2654865859"
                data-category="The Institute">
<article 
    elid="2654865859" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654865859" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/topic/the-institute/">The Institute</a>
            
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/article/">Article</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            
                <a href="https://spectrum.ieee.org/magazine/">Magazine</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/ieee-presidents-note-investing-in-ieees-financial-future"  aria-label="IEEE President’s Note: Investing in IEEE’s Financial Future" data-type="text">
        IEEE President’s Note: Investing in IEEE’s Financial Future
    </a>
</h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/ieee-presidents-note-investing-in-ieees-financial-future"  aria-label="IEEE President’s Note: Investing in IEEE’s Financial Future">
                        
                        </a>
                        
                </div></div></div>
    
    
<script type="application/json" id="post-context-2654865859">
    {"customDimensions": {"5":"Susan K. \u201cKathy\u201d Land","6":"the-institute","7":"ieee news, type:ti","8":"09/01/2021","10":"ieee news","11":2654865859}, "post": {"providerId": 0, "sections": [0, 497728257, 539626628, 554217349, 544175596, 544169516, 545658351, 539626938], "buckets": [], "authors": [22900976]} }
</script>
</article>
                </div>
            
                
                <div class="widget tag-ieee-scholarships tag-google tag-stem-education tag-careers tag-ieee-products-services tag-type-ti post-section--topic/the-institute"
                 elid="2654839532"
                data-category="The Institute">
<article 
    elid="2654839532" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654839532" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/topic/the-institute/">The Institute</a>
            
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/guest-article/">Guest Article</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/7-scholarships-exclusively-for-women-studying-engineering"  aria-label="7 Scholarships Exclusively for Women Studying Engineering" data-type="text">
        7 Scholarships Exclusively for Women Studying Engineering
    </a>
</h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/7-scholarships-exclusively-for-women-studying-engineering"  aria-label="7 Scholarships Exclusively for Women Studying Engineering">
                        
                        </a>
                        
                </div></div></div>
    
    
<script type="application/json" id="post-context-2654839532">
    {"customDimensions": {"5":"Ryan Ayers","6":"the-institute","7":"ieee scholarships, Google, stem education, careers, ieee products services, type:ti","8":"08/30/2021","10":"ieee products services","11":2654839532}, "post": {"providerId": 0, "sections": [0, 551648209, 539626938, 544169516, 497728257], "buckets": [], "authors": [23732520]} }
</script>
</article>
                </div>
            
                
                <div class="widget tag-smart-glasses tag-mems tag-augmented-reality tag-google-glass tag-lasers tag-virtual-reality tag-standards tag-ieee-industry-standards-and-technology-organization tag-ieee-isto tag-stmicroelectronics tag-ieee-products-services tag-type-ti post-section--topic/the-institute"
                 elid="2654814103"
                data-category="The Institute">
<article 
    elid="2654814103" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654814103" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/topic/the-institute/">The Institute</a>
            
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/article/">Article</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            
                <a href="https://spectrum.ieee.org/topic/consumer-electronics/">Consumer Electronics</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/tiny-lasers-could-finally-bring-us-really-smart-ar-glasses"  aria-label="Tiny Lasers Could Finally Bring Us Really Smart AR Glasses" data-type="text">
        Tiny Lasers Could Finally Bring Us Really Smart AR Glasses
    </a>
</h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/tiny-lasers-could-finally-bring-us-really-smart-ar-glasses"  aria-label="Tiny Lasers Could Finally Bring Us Really Smart AR Glasses">
                        
                        </a>
                        
                </div></div></div>
    
    
<script type="application/json" id="post-context-2654814103">
    {"customDimensions": {"5":"Kathy Pretz","6":"the-institute","7":"smart glasses, mems, augmented reality, google glass, lasers, virtual reality, standards, ieee industry standards and technology organization, ieee-isto, stmicroelectronics, ieee products services, type:ti","8":"08/27/2021","10":"ieee products services","11":2654814103}, "post": {"providerId": 0, "sections": [0, 497728257, 544169516, 544175596, 539618616, 539626938], "buckets": [], "authors": [21075156]} }
</script>
</article>
                </div>
            
                
                <div class="widget tag-ieee-news tag-biomedical tag-life-sciences tag-careers tag-startups tag-cancer tag-breast-cancer tag-prostate-cancer tag-ieee-member-news tag-artificial-intelligence tag-medical-diagnostics tag-medical-devices post-section--topic/the-institute"
                 elid="2654774081"
                data-category="The Institute">
<article 
    elid="2654774081" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654774081" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/topic/the-institute/">The Institute</a>
            
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/profile/">Profile</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            
                <a href="https://spectrum.ieee.org/topic/artificial-intelligence/">Artificial Intelligence</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/ai-diagnosis-cancer"  aria-label="Paige&#39;s AI Diagnostic Tech Is Revolutionizing Cancer Diagnosis" data-type="text">
        Paige&#39;s AI Diagnostic Tech Is Revolutionizing Cancer Diagnosis
    </a>
</h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/ai-diagnosis-cancer"  aria-label="Paige&#39;s AI Diagnostic Tech Is Revolutionizing Cancer Diagnosis">
                        
                        </a>
                        
                </div></div></div>
    
    
<script type="application/json" id="post-context-2654774081">
    {"customDimensions": {"5":"Prachi Patel","6":"the-institute","7":"ieee news, biomedical, life sciences, careers, startups, cancer, breast cancer, prostate cancer, ieee member news, artificial intelligence, medical diagnostics, medical devices","8":"08/24/2021","10":"medical diagnostics","11":2654774081}, "post": {"providerId": 0, "sections": [0, 497728257, 497728259, 544169516, 544169528, 539626938], "buckets": [], "authors": [21078870]} }
</script>
</article>
                </div>
            
                
                <div class="widget tag-careers tag-ieee-xplore-digital-library tag-startups tag-entrepreneurs tag-ieee-entrepreneurship tag-ieee-dataport tag-ieee-products-services post-section--topic/the-institute"
                 elid="2654725409"
                data-category="The Institute">
<article 
    elid="2654725409" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654725409" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/topic/the-institute/">The Institute</a>
            
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/news/">News</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            
                <a href="https://spectrum.ieee.org/topic/careers/">Careers</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/powered-by-ieee-program-saves-startups-money"  aria-label="Powered By IEEE Program Saves Startups Money" data-type="text">
        Powered By IEEE Program Saves Startups Money
    </a>
</h2></div><div class="widget__head"><a href="https://spectrum.ieee.org/powered-by-ieee-program-saves-startups-money"  aria-label="Powered By IEEE Program Saves Startups Money">
                        
                        </a>
                        
                </div></div></div>
    
    
<script type="application/json" id="post-context-2654725409">
    {"customDimensions": {"5":"Kathy Pretz","6":"the-institute","7":"careers, ieee xplore digital library, startups, entrepreneurs, ieee entrepreneurship, ieee dataport, ieee products services","8":"08/19/2021","10":"ieee products services","11":2654725409}, "post": {"providerId": 0, "sections": [0, 497728257, 544169516, 544169523, 539628627, 539626938], "buckets": [], "authors": [21075156]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div></div><div class="sidebar_ad_container" id="sSocial_Stream_Element_0_0_15_0_0_1_2_1_0_1_1"><!-- User Code --><div class="sidebar_sticky_parent"><div class="stick_in_parent"><div class='sidebar_repeat_ad'></div></div></div><!-- End User Code --></div>
</div>


    
    
    
    </div>
</div>



        
        
        
        
        
        
        <div class="" id="sSocial_Stream_Element_0_0_15_0_0_1_3_0"><span class="js-brick-description hidden" data-name="Widget CTA Become Member"></span><div class="" id="sWidget_CTA_Become_Member_0_0_21_0_0_0"><div id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0" class="cta-membership row-wrapper clearfix  content">
    <div class="row px20">
        

<div id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_0" class="cta-member__left-column col sm-mb-2 md-mb-4 s12 m6 l6">
    <div id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_0_0"><div class="module-headline">
    <h2 class="module-headline__text h2">
        Get unlimited IEEE Spectrum access
    </h2>
</div></div><div class="text-element" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_0_1">Become an IEEE member and get exclusive access to more stories and resources, including our vast article archive and full PDF downloads</div><div class="popup_links" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_0_2"><div class="list" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_0_2_0"><a href="/st/join" class="list__item" target="_self">JOIN IEEE</a><a href="/core/saml/main/login?next_url=https://spectrum.ieee.org/core/integrations/ieee/changes" class="list__item" target="_self">SIGN IN</a></div></div>
</div>



<div id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1" class="cta-member__right-column col sm-mb-2 md-mb-4 s12 m6 l6">
    <div class="benefit_container_cta" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1"><div class="benefit_column" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1_0"><div class="text-element" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1_0_0">Get access to unlimited IEEE Spectrum content</div><div class="text-element" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1_0_1">Network with other technology professionals</div><div class="text-element" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1_0_2">Establish a professional profile</div></div><div class="benefit_column" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1_1"><div class="text-element" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1_1_0">Create a group to share and collaborate on projects</div><div class="text-element" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1_1_1">Discover IEEE events and activities</div><div class="text-element" id="sWidget_CTA_Become_Member_0_0_21_0_0_0_0_1_0_1_1_1_2">Join and participate in discussions</div></div></div>
</div>


    </div>
</div>


</div></div><div class="mb-2 feature_post_full" id="sSocial_Stream_Element_0_0_15_0_0_1_4"><div
        class="posts-custom posts-custom-section section-holder clearfix"
        
        data-block="section_3"
        data-format="posts-custom"
        data-source="multi_filtered_parent_site_filtered_parent_site"
        data-source-type="multi"
        data-source-unique="true"
        data-section-id=""
        data-is-reordable="false"
        data-using-stickers="false"
        data-has-more="true"

    
        data-attr-layout_Whatsapp="inactive"
        data-attr-layout_Separator="inactive"
        data-attr-layout_all_sections="top"
        data-attr-layout_Slack="inactive"
        data-attr-layout_post_shares="top"
        data-attr-use_tag_image_for_lead_media="true"
        data-attr-layout_time_to_read="top"
        data-attr-strategy="mutually-exclusive"
        data-attr-layout_all_date_full_format="false"
        data-attr-layout_body="bottom"
        data-attr-source_unique="true"
        data-attr-layout_author="top"
        data-attr-element_classes="feature_post_full"
        data-attr-posts_id="sSocial_Stream_Element_0_0_15_0_0_1_4"
        data-attr-layout_headline="top"
        data-attr-layout_custom_field_FeaturePostColor="bottom"
        data-attr-layout_Tumblr="inactive"
        data-attr-layout_subheadline="top"
        data-attr-source="multi"
        data-attr-layout_date="top"
        data-attr-layout_SMS="inactive"
        data-attr-layout_photo_caption="bottom"
        data-attr-layout_image_column_width="20"
        data-attr-update_url_on_post_view="true"
        data-attr-layout_custom_field_FeaturePostImgPosition="top"
        data-attr-all_share_buttons="Email,CopyLink,Twitter,Facebook,Linkedin,Tumblr,GooglePlus,Pinterest,Whatsapp,Reddit,Separator,Flipboard,SMS,Slack"
        data-attr-format="posts-custom"
        data-attr-layout_all_image_crop="3x2"
        data-attr-data-rm-advanced="true"
        data-attr-show_more_button_text="Keep Reading ↓"
        data-attr-layout_photo_credit="bottom"
        data-attr-node_id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/posts-"
        data-attr-layout_Linkedin="active"
        data-attr-layout_GooglePlus="inactive"
        data-attr-layout_like_button="top"
        data-attr-without_current="true"
        data-attr-use_smart_keep_reading="true"
        data-attr-layout_CopyLink="active"
        data-attr-layout_Pinterest="inactive"
        data-attr-show_around_the_web="true"
        data-attr-data-rm-device-crops="true"
        data-attr-all_element_order="all_sections,headline,subheadline,author,date,time_to_read,like_button,post_shares,custom_field_FeaturePostImgPosition,photo_caption,photo_credit,custom_field_FeaturePostColor,body,primary_tag,community_name,badges,section,custom_field_TimeofRead,snark_line,follow_button,community_comments,page_views,collection_button,badges_sponsored,source_link,main_author,custom_field_contact-person-phone,custom_field_event-performer,custom_field_event-street-address,custom_field_job-type,custom_field_event-postal-code,custom_field_contact-person-title,custom_field_event-start,custom_field_company_name,custom_field_event-end,custom_field_hiring-organization,custom_field_event-price,custom_field_job-tags,custom_field_event-city,custom_field_contact_email,custom_field_posted-on-date,custom_field_job-title,custom_field_job-location,custom_field_event-region,custom_field_event-currency,custom_field_base-salary,custom_field_event-country,custom_field_contact_person,custom_field_expire-date,date_modified,custom_field_ContentType,custom_field_CustomFieldTestEG,custom_field_Issue,custom_field_FullwidthCardColor,custom_field_FullwidthCardPosition,product_prices,tags,product_buy_link,site_field_Twitter,site_field_Facebook,site_field_Instagram,site_field_LinkedIn,custom_field_PodcastVideoTime,custom_field_Editor,custom_field_PodcastEpisode,product_vendor,custom_field_access,site_field_member_badges,custom_field_publication_date,words_count,custom_field_due_date,site_field_first_name,site_field_last_name,site_field_grade,custom_field_pdf_version,custom_field_fullwidthbackgroundposition"
        data-attr-layout_Flipboard="inactive"
        data-attr-layout_all_date_format="%d %b %Y"
        data-attr-layout_Reddit="inactive"
        data-attr-limit="1"
        data-attr-v="2"
        data-attr-layout_quality="1"
        data-attr-header_template="jinja/post/custom-css.html"><div class="posts-wrapper clearfix">
            
                
                <div class="widget tag-ai tag-machine-learning tag-deep-learning tag-reinforcement-learning tag-intel tag-artificial-intelligence"
                 elid="2654804251"
                data-category="Type">
<article 
    elid="2654804251" data-is-frozen="false" 
    class="clearfix page-article sm-mb-1 quality-HD post-2654804251" 
    
    
    
    
    
>
    <div class="row px10"><div id="col-center" class="col sm-mb-1" style="width:100.0%;"><div class="widget__body clearfix sm-mt-1">
               
        
               
        
               
        
               
        <div class="all-related-sections">
                <a href="https://spectrum.ieee.org/type/">Type</a>
            
                <a href="https://spectrum.ieee.org/type/feature/">Feature</a>
            
                <a href="https://spectrum.ieee.org/topic/">Topic</a>
            
                <a href="https://spectrum.ieee.org/topic/artificial-intelligence/">Artificial Intelligence</a>
            </div><h2 class="widget__headline h2">
    <a class="widget__headline-text custom-post-headline" href="https://spectrum.ieee.org/reinforcement-learning"  aria-label="Greedy AI Agents Learn to Cooperate" data-type="text">
        Greedy AI Agents Learn to Cooperate
    </a>
</h2>
<div class="widget__subheadline">
    <h3 class="widget__subheadline-text h3" data-type="text"><p>How to overcome reinforcement learning's inherent selfishness</p></h3>
</div>


<div class="social-author clearfix">
    

    
        
    <div class="social-author__avatar image" >
             <div class="cover-all image" style='background-image: url("https://spectrum.ieee.org/res/avatars/default")'></div>
        </div>
        <a class="social-author__name" href="https://spectrum.ieee.org/u/somdeb_majumdar" data-type="text">Somdeb Majumdar</a>
        
</div>
<div class="social-date">
        <span class="social-date__text">02 Sep 2021</span>
    </div><div class="time-to-read">11 min read</div><div class="like-button" data-post-likes="3"></div><div class="widget__shares share-panel">
    <!-- EMAIL -->
<a href="mailto:?subject=Greedy%20AI%20Agents%20Learn%20to%20Cooperate&amp;body=https://spectrum.ieee.org/reinforcement-learning" data-track-share="Email" class="share share-popup share-email" rel="noopener noreferrer" aria-label="Share via Email"><i aria-hidden="true" class="icons-share em fa fa-envelope"></i></a><!-- COPY LINK -->
<a href="https://spectrum.ieee.org/reinforcement-learning" data-clipboard-text="https://spectrum.ieee.org/reinforcement-learning" class="share share-copy-link" title="Copy this link to clipboard">
  <i class="icons-share" style="width: 60%">
  <svg aria-hidden="true" data-prefix="far" data-icon="copy" class="svg-inline--fa fa-copy fa-w-14" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M433.941 65.941l-51.882-51.882A48 48 0 0 0 348.118 0H176c-26.51 0-48 21.49-48 48v48H48c-26.51 0-48 21.49-48 48v320c0 26.51 21.49 48 48 48h224c26.51 0 48-21.49 48-48v-48h80c26.51 0 48-21.49 48-48V99.882a48 48 0 0 0-14.059-33.941zM266 464H54a6 6 0 0 1-6-6V150a6 6 0 0 1 6-6h74v224c0 26.51 21.49 48 48 48h96v42a6 6 0 0 1-6 6zm128-96H182a6 6 0 0 1-6-6V54a6 6 0 0 1 6-6h106v88c0 13.255 10.745 24 24 24h88v202a6 6 0 0 1-6 6zm6-256h-64V48h9.632c1.591 0 3.117.632 4.243 1.757l48.368 48.368a6 6 0 0 1 1.757 4.243V112z"></path></svg></i>
</a><!-- TWITTER -->
<a href="https://twitter.com/intent/tweet?url=https://spectrum.ieee.org/reinforcement-learning&amp;text=Greedy%20AI%20Agents%20Learn%20to%20Cooperate&amp;" data-track-share="Twitter" class="share share-popup share-tw" rel="noopener noreferrer" aria-label="Share on Twitter"><i aria-hidden="true" class="icons-share tw fa fa-twitter"></i></a><!-- FACEBOOK -->
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fspectrum.ieee.org%2Freinforcement-learning%3Fxrs%3DRebelMouse_fb%26ts%3D1630686615" data-track-share="Facebook" class="share share-popup share-fb" rel="noopener noreferrer" aria-label="Share on Facebook"><i aria-hidden="true" class="icons-share fb fa fa-facebook"></i></a><!-- LINKEDIN -->
<a href="http://www.linkedin.com/shareArticle?mini=false&amp;url=https://spectrum.ieee.org/reinforcement-learning&amp;" class="share share-popup share-linkedin" data-track-share="Linkedin" rel="noopener noreferrer" aria-label="Share on Linkedin"><i aria-hidden="true" class="icons-share fa fa-linkedin"></i></a>
</div></div><div class="widget__head"><a href="https://spectrum.ieee.org/reinforcement-learning"  aria-label="Greedy AI Agents Learn to Cooperate">
                        
                        <img
                                            role="img"
                                            type="lazy-image"
                                            alt="Small white figures collectively form a brain shape on a pink and orange background."
                                            aria-label="Small white figures collectively form a brain shape on a pink and orange background."
                                            src="data:image/svg+xml,%3Csvg xmlns=&#39;http://www.w3.org/2000/svg&#39; viewBox=&#39;0 0 1200 800&#39;%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM1ODM2Mi9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzNzg5MjE3NX0.r2duFPZ0YVF3FsGi8B7a0aDhmx3BVXfAE--xgQg_z0U/image.jpg?width=1200&quality=85&coordinates=0%2C187%2C0%2C188&height=800"
                                            
                                            
                                            style="object-fit: cover;"
                                            
                                            class="rm-lazyloadable-image"
                                            width="1200"
                                            height="800"
                                        /></a>
                        
                </div><div class="widget__body clearfix sm-mt-1"><div class="photo-credit">
        Getty Images
    </div><div class="custom-field-FeaturePostColor">DarkGray</div><div class="body js-expandable clearfix js-listicle-body js-update-url css-listicle-body-2654804251"
        
            data-elid="2654804251"
            data-post-url="https://spectrum.ieee.org/reinforcement-learning"
            
                data-authors="Somdeb Majumdar"
            
            
                data-headline="Greedy AI Agents Learn to Cooperate"
            
        ><div class="body-description"><div class="widget__brief"><p>
	Imagine you're sitting at a casino's poker table. Someone has explained the basic rules to you, but you've never played before and don't know even the simplest strategies. While this might sound like the setup for an anxiety dream, it's also a fair analogy for the beginning of a training session for a certain kind of artificial intelligence (AI) program.
</p><p>
	If an AI system was confronted with such a situation, it would commence taking random actions within the parameters of the rules—if playing five-card draw, for example, it wouldn't ask for seven cards. When, by dumb luck, it won a hand, it would take careful note of the actions that led to that reward. If it played the game for long enough, perhaps playing millions of hands, it could devise a good strategy for winning.
</p></div>
            <div class="content-container"></div>
            <div class="js-appear-on-expand"><template>
                    <p>
	This type of training is known as
	<a href="https://en.wikipedia.org/wiki/Reinforcement_learning" rel="noopener noreferrer" target="_blank"> <u>reinforcement learning</u></a> (RL), and it's one of the most exciting areas of machine learning today. RL can be used to teach agents, be they pieces of software or physical robots, how to act to achieve certain goals. And it has been responsible for some of the most impressive triumphs by AI in recent years, such as<a href="https://en.wikipedia.org/wiki/AlphaGo_versus_Lee_Sedol" rel="noopener noreferrer" target="_blank"> <u>AlphaGo's win</u></a> at the board game of Go in a match against a top-ranked human professional.
</p><p>
	RL differs from another approach called
	<a href="https://towardsdatascience.com/a-brief-introduction-to-supervised-learning-54a3e3932590" rel="noopener noreferrer" target="_blank"> <u>supervised learning</u></a>, in which systems are trained using an existing labeled dataset. To continue the poker example: In a supervised-learning regimen, the AI player would ingest data about millions of hands. Each data point would be labeled to describe how good or bad an action is for a given state of the game. This would allow the player to take good actions when it sees game states similar to those in the training data. This isn't a very practical way to train on such sequential decision-making problems, since building a dataset with a massive number of game states and actions is intractable.
</p><p class="pull-quote">Reinforcement learning is responsible for some of the most impressive triumphs by AI in recent years.</p><p>
	In contrast, RL offers a more effective way of training by allowing the player to interact with the world 
	<em>during</em> the training. You don't need a labeled dataset for RL, which proves a big advantage when dealing with real-world applications that don't come with heaps of carefully curated observations. What's more, RL agents can learn strategies that enable them to act even in an uncertain and changing environment, taking their best guesses at the appropriate action when confronted with a new situation.
</p><p>
	One typical critique of RL is that it's inefficient, that it's just a glorified trial-and-error process that succeeds because of brute-force computing power put to it. But
	<a href="https://www.intel.com/content/www/us/en/artificial-intelligence/bios/somdeb-majumdar.html" rel="noopener noreferrer" target="_blank"> <u>my research group</u></a> at Intel's AI Lab has devised efficient techniques that can leverage RL for practical breakthroughs.
</p><p>
	We've been working on RL agents that can quickly figure out extremely complex tasks and that can work together in teams, putting the group's overall objective ahead of their own individual goals. We're planning soon to test our methods in robots and other autonomous systems to bring these achievements into the real world.
</p><p>
<strong>In RL, we assume that the agent</strong> operates with some sort of dynamic environment and that it can at least partially observe the state of that environment. For example, an autonomous vehicle could sense the raw pixel values from an on-board camera, or it could take in more processed data like the location of pedestrians, cars, and lane markings. The environment must also reinforce the agent's actions with certain kinds of feedback—whether an autonomous vehicle reaches its destination without incident or crashes into a wall, say. This feedback signal is typically called the reward.
</p><p>
	In modern RL, the agents are typically deep neural networks, ones that map input observations to output actions. A common procedure is for an RL agent to begin by taking a bunch of random actions and logging the feedback signal for each, storing all of these in what's known as a replay buffer—essentially, the agent's memory. Over time, the agent creates a large dataset of experiences that are in the form of a state, an action, the next state, and any resulting reward.
</p><p class="pull-quote">
	In reinforcement learning, there's a fundamental tension between exploiting an existing strategy and exploring alternatives.
</p><div class="ad-in-content"></div><p>
	Using this data, the agent trains itself and comes up with a policy, or a way of acting in the environment, that will maximize its total reward. Its policy should get better over time as it learns, but the agent doesn't know whether its policy is optimal at any given point. So it has to make a decision: Should it keep choosing actions based on its current policy or deviate from it and explore new possibilities? If it chooses the former, it will never improve.
</p><p>
	Most RL agents therefore have an important mandate to sometimes ignore their current best policy in favor of trying new things. How often agents go "off-policy" is an extra parameter of the training system. Often, the exploration rate is kept high in the beginning of training and lowered as the agent gains experience.
</p><p>
	Whether we're dealing with an AI poker player, an autonomous vehicle, or a virtual stock trader, this tension between exploitation of an existing policy and exploration of alternatives is fundamental to RL.
</p><p>
<strong>The challenges get even greater </strong>when an agent is acting in an environment with sparse rewards. In this situation, the environment provides a feedback signal very rarely--perhaps only at the end of a long multi-step task. So most of the agent's actions produce no helpful feedback. For example, our hypothetical AI poker player would only get a positive reward if it wins a hand, not if it had a good hand but was narrowly beaten by another player. The sparser the rewards, the more difficult the problem.
</p><p>
	To test RL agents' abilities in such tricky situations, many researchers have made use of a benchmark created by OpenAI called
	<a href="https://gym.openai.com/envs/Humanoid-v2/" rel="noopener noreferrer" target="_blank"> <u>Mujoco Humanoid</u></a>. Here, researchers must train a computer model of a 3D humanoid figure to walk for a fixed amount of time without falling. While walking sounds simple enough, it's an incredibly difficult task for an RL system to master.
</p><p>
	The RL agent's observations include the angles of all the humanoid's joints, each of which has three degrees of freedom. With such a complex array of possible states, a policy of random actions is almost guaranteed to fail. It's incredibly rare that the humanoid stays on its feet and takes enough successful steps to achieve a reward.
</p><p class="pull-quote">
	For the Mujoco Humanoid challenge, we had many learners working on smaller problems such as not falling over and raising a foot.</p><p>We came up with a novel solution, which we call CERL:
	<a href="https://www.intel.ai/cerl/#gs.1fjxxq" rel="noopener noreferrer" target="_blank"> <u>Collaborative Evolutionary Reinforcement Learning</u></a>. Our<a href="https://arxiv.org/abs/1905.00976" rel="noopener noreferrer" target="_blank"> <u>paper</u></a> about it demonstrated that the challenge at hand can be broken down into two kinds of components: smaller problems for which the system can get some immediate feedback and the larger optimization problem that needs to be solved over a longer time span.
</p><p>
	We argued that for each of those smaller problems, we could make faster progress with a population of agents that jointly explore and share experiences. For our hypothetical AI poker player, this would be the equivalent of suddenly spawning many avatars and having them all play hands simultaneously to collectively come up with a strategy.
</p><p>
	For the Mujoco Humanoid challenge, we had many learners working on smaller problems such as not falling over, raising a foot, and so forth. The learners received immediate feedback as they tried to achieve these small goals. Each learner thus became an expert in its own skill area, skills that could contribute to the overall goal of sustained walking—although each learner has no chance of attaining that larger objective itself.</p><p class="shortcode-media shortcode-media-rebelmouse-image" style="">
<img alt='The words Learner A on a blue background. On the right, it says "maintain balance" and above is a skeletal stick figure falling backwards.' class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="74259dccc08f53c42beb449ce7482b6c" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM3MzQ1NC9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzNzAxNzE0OH0.s3gz6CjMLWGYOdPapKP5q0R_s13i5BW8BRjKPaisM4c/image.jpg?width=980" height="807" id="715fc" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1451 807'%3E%3C/svg%3E" width="1451"/>
<small class="image-media media-caption" placeholder="Add Photo Caption...">In our approach to the Mujoco Humanoid challenge, a number of "learners" worked on discrete skills, which an "actor" later put together into a complete walking strategy.</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Intel AI</small></p><p>In a standard RL process, each agent has its own replay buffer, the memory bank it uses to learn what actions are good or bad. But in our design, we allowed all learners simultaneously to contribute to and draw from a single buffer. This meant that each learner could access the experiences of all the others, helping its own exploration and making it significantly more efficient at its own task. For while they were tackling discrete problems, they were all learning the same rules of basic physics.<br/></p><p>A second set of agents, which we called actors, aimed to synthesize all the small movements to achieve the larger objective of sustained walking. Because these agents rarely came close enough to this objective to register a reward, we didn't use RL here. Instead, we employed what's known as a genetic algorithm, a procedure that mimics biological evolution by natural selection.
	<a href="https://en.wikipedia.org/wiki/Genetic_algorithm" rel="noopener noreferrer" target="_blank"> <u>Genetic algorithms</u></a>, which are a subtype of evolutionary algorithms, start with a population of possible solutions to a problem, and use a fitness function to gradually evolve toward the optimal solution.
</p><p>
	In each "generation" we initialized a set of actors, each with a different strategy for carrying out the walking task. We then ranked them by performance, retained the top performing ones, and threw away the rest. The next generation of actors were the "offspring" of the survivors and inherited their policies, though we varied these policies via both mutation (random changes in a single parent's policy) and crossover (mixing two parents' policies).
</p><p class="shortcode-media shortcode-media-rebelmouse-image rm-float-left" style="float: left;">
<img alt="Chart with the green CERL performance rising high while other programs, labeled Neuroevolution, TD3 and ERL have low flat lines" class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="c7529f5dd176d04e6e0964f31cc075e4" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM1ODU5NS9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTY0Mzc1NjM1NX0.xjtvsR9R0SU-b4gmzfw1bWBmk3evGOF1m-PK52bhlKE/image.jpg?width=980" height="929" id="c3cf8" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1240 929'%3E%3C/svg%3E" width="1240"/>
<small class="image-media media-caption" placeholder="Add Photo Caption...">Our system outperformed other baselines on the complex Mujoco Humanoid task.</small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Intel AI</small>
</p><p>
	On its own,
	<a href="https://en.wikipedia.org/wiki/Evolutionary_algorithm" rel="noopener noreferrer" target="_blank"> <u>evolutionary search</u></a> is known to be extremely slow and inefficient, since it requires a lot of inputs to come up with a good solution. But it's also renowned for its completeness—if a solution exists, it will be found eventually. Our goal was to make use of this completeness while boosting search speed by exploiting fast RL methods. Our RL learners quickly provided reasonably good but sub-optimal solutions, which we inserted into the evolutionary search population to guide our actors towards better solutions. Our hybrid system speedily arrived at an optimal policy that enabled the Mujoco Humanoid to go for a stroll, and greatly outperformed other algorithms at that time.
</p><p>
<strong>While a sparsity of rewards</strong> make RL hard enough, it becomes even more complicated when a task requires several agents to work cooperatively to achieve a common goal. For example, in a benchmark involving simulated Mars rovers, two rovers have to work together to find multiple targets in the shortest amount of time. For this task, we needed to train the individual rovers not only on skills like navigation, but also on cooperative strategies that would allow a pair of rovers to achieve a joint objective, even without communicating directly.
</p><p class="pull-quote">
	Rover 1 scrapped its local objective and instead took the longer route to a different target—for the greater good of the team.
</p><p>
	Here, the global objective is for the team as a whole to visit the largest number of targets. To achieve that objective, each rover needs to learn how to navigate quickly to a target and also needs to learn how to strategize with its partner. At first, the rovers explore the landscape randomly, using LIDAR sensors to scan for targets. Over a given time interval, one rover might well stumble across a target, so we say that the local objective of navigating to a target has dense rewards. The global objective is achieved only if both rovers find targets, which is a much sparser reward signal.
</p><p>
	Imagine that both rovers have a certain target in view. Rover 1 has just enough fuel to reach the target, but can go no farther. In this scenario, the best team strategy is for Rover 1 to go to that visible destination and for Rover 2 to sacrifice its local objective—minimizing its time to a target—and to head out in search of other targets.
</p><p class="shortcode-media shortcode-media-rebelmouse-image rm-float-left" style="float: left;">
<img alt="2 Red boxes with wheels and green lights in a rocky red Martian landscape, labeled Rover 1 and Rover 2" class="rm-shortcode rm-lazyloadable-image" data-rm-shortcode-id="9b96ae50dc9111a3c778c100c737daa1" data-rm-shortcode-name="rebelmouse-image" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM1ODYwNS9vcmlnaW4uanBnIiwiZXhwaXJlc19hdCI6MTYzMTM5MDU3Nn0.Kvy-eGh1f11wwL0L2Y7WbzyyaJMBNF8zCo-UJdUR-Ps/image.jpg?width=980" height="924" id="326a1" lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1240 924'%3E%3C/svg%3E" width="1240"/>
<small class="image-media media-caption" placeholder="Add Photo Caption...">In a benchmark involving simulated rovers, the agents have to work together to achieve the overall goal. </small><small class="image-media media-photo-credit" placeholder="Add Photo Credit...">Intel AI </small>
</p><p>
	This problem can be made tougher still by adding another requirement. Imagine that the teams are larger and that several rovers must reach a target simultaneously for it to count. This condition represents situations like search and rescue where multiple agents might be needed to complete a task, such as lifting a heavy beam. If fewer than the required number of rovers reach a target, they receive no reward at all. The rovers therefore have to learn the skills needed to find a target and must also learn to link up with others and visit targets together to achieve the team's global objective. What's more, at the outset, the rovers on a team don't know how many rovers must visit a target together—they get that information only when they are successful.
</p><p>
	To tackle this difficult multi-agent task, we extended our CERL framework. We presented our new technique, which we call
	<a href="https://www.intel.ai/introducing-merl/" rel="noopener noreferrer" target="_blank"> <u>Multiagent Evolutionary Reinforcement Learning</u></a> (<a href="https://arxiv.org/abs/1906.07315" rel="noopener noreferrer" target="_blank"><u>MERL</u></a><u>),</u> at the 2020 International Conference on Machine Learning. We again broke down the problem into two parts. Each rover used RL to master a local objective, such as reducing its distance to a target. But that success didn't help with the larger problems of forming alliances and maximizing the total number of targets visited.
</p><p>
	Again, we solved the global problem with evolutionary search. This time, we were working with teams, so we essentially made many copies of an entire rover team. Across those teams, all the Rover 1s shared a single replay buffer, as did all the Rover 2s, and so forth. We deliberately separated the replay buffers by rovers because it allowed each to focus on its own local learning. (We've run similar experiments with a
	<a href="https://arxiv.org/abs/2010.03694" rel="noopener noreferrer" target="_blank"> <u>simulated soccer team</u></a>, where this approach enables goalies, strikers, and other players to learn different skills.)
</p><p>
	Because each target was counted only when enough rovers reached it, the rovers were required to work together. Just as in CERL, locally optimized policies were injected into the evolutionary search, which could try out the best policies from the Rover 1s, Rover 2s, and so on. Evolution only needed to deal with the larger team strategy.
</p><p>
	We compared the performance of MERL with that of another state-of-the-art system for multi-agent RL, the
	<a href="https://towardsdatascience.com/openais-multi-agent-deep-deterministic-policy-gradients-maddpg-9d2dad34c82" rel="noopener noreferrer" target="_blank"> <u>MADDPG algorithm</u></a> from the University of California, Berkeley. First we tested our virtual robots on the simpler rover problem where only one rover must reach a target. We found that MERL reached more targets than MADDPG, and also saw interesting team behavior emerge in MERL.
</p>
                    
<div
    class="ieee-sidebar-fullwidth-columns  rebellt-item is--desktop col2"
    id="rebelltitem1"
    data-id="1"
    data-is-image="True"
    
    data-href="https://spectrum.ieee.org/reinforcement-learning/particle-1"
    data-published-at="1630498496"
    data-basename="particle-1"
    data-post-id="2654804251"
><img id="ac22c" data-rm-shortcode-id="34a7ff583d18a9a37cc5ae579ae9f878" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1200 900'%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM2NDk1MS9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY5MDI0ODIyNX0.1Z3Ifq7G7oC2zv8-iDheY_sVbYclsLapMdFHGS2AWiw/image.gif?width=980" width="1200" height="900"  alt="Animated gifs show yellow, pink and grey squares moving on a green background towards 4 grey target circles."  /></div>

<div
    class="ieee-sidebar-fullwidth-columns  rebellt-item is--desktop col2"
    id="rebelltitem3"
    data-id="3"
    data-is-image="True"
    
    data-href="https://spectrum.ieee.org/reinforcement-learning/particle-3"
    data-published-at="1630498496"
    data-basename="particle-3"
    data-post-id="2654804251"
><img id="95542" data-rm-shortcode-id="f167b4c633753d0f36b782eb8b155a75" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1200 900'%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM2NDk3MC9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY0ODU3MjE2NX0.HbXjZw-HBVMfDzcvs4LR80e6Ahf8KvRXCQyN3SoVXjI/image.gif?width=980" width="1200" height="900"  alt="Animated gifs show yellow, pink and grey squares moving on a green background towards 4 grey target circles."  /></div>

<div
    class="ieee-sidebar-fullwidth  rebellt-item is--desktop col1"
    id="rebelltitem6"
    data-id="6"
    data-is-image="False"
    
    data-href="https://spectrum.ieee.org/reinforcement-learning/particle-6"
    data-published-at="1630498496"
    data-basename="particle-6"
    data-post-id="2654804251"
><p>In our system [right], the red rover sacrifices its local objective to help the team. In this example, only one rover must reach a target for it to be counted.<br></p><p class="caption">Intel AI</p></div>

<div
    class="  rebellt-item is--desktop col1"
    id="rebelltitem14"
    data-id="14"
    data-is-image="False"
    
    data-href="https://spectrum.ieee.org/reinforcement-learning/particle-14"
    data-published-at="1630498496"
    data-basename="particle-14"
    data-post-id="2654804251"
><p> In one example, Rovers 1 and 2 both set out towards the same target, but Rover 1 changed course mid-way and headed for a different target. That made sense: If both rovers reached the target, they wouldn't score additional points. So Rover 1 scrapped its local objective and instead took the longer route to a different target—for the greater good of the team. </p></div>

<div
    class="ieee-sidebar-fullwidth-columns  rebellt-item is--desktop col2"
    id="rebelltitem15"
    data-id="15"
    data-is-image="True"
    
    data-href="https://spectrum.ieee.org/reinforcement-learning/particle-15"
    data-published-at="1630498496"
    data-basename="particle-15"
    data-post-id="2654804251"
><img id="1387a" data-rm-shortcode-id="69ec3de9e6cfc54335f393e9ccc43138" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1200 900'%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM2NjIwMy9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY2OTk3MjQzM30.7AXuKPhmVN6mLAPxPmpOLATQ1_x-WO_oSQPH9zJSchQ/image.gif?width=980" width="1200" height="900"  alt="Animated gifs show yellow, dark pink, light pink, blue, orange, grey squares moving on a green background towards 4 grey target circles."  /></div>

<div
    class="ieee-sidebar-fullwidth-columns  rebellt-item is--desktop col2"
    id="rebelltitem16"
    data-id="16"
    data-is-image="True"
    
    data-href="https://spectrum.ieee.org/reinforcement-learning/particle-16"
    data-published-at="1630498496"
    data-basename="particle-16"
    data-post-id="2654804251"
><img id="dcda7" data-rm-shortcode-id="5cebddfcfe3e1c23f2e656401bc537a5" data-rm-shortcode-name="rebelmouse-image" class="rm-shortcode rm-lazyloadable-image " lazy-loadable="true" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 1200 900'%3E%3C/svg%3E" data-runner-src="https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNzM2NjIwNC9vcmlnaW4uZ2lmIiwiZXhwaXJlc19hdCI6MTY4ODM3NDYyMn0.KJ2VR-rvvc_h_1a9GkcKEijCdtwHR2dQfSkSNnveaKY/image.gif?width=980" width="1200" height="900"  alt="Animated gifs show yellow, dark pink, light pink, blue, orange, grey squares moving on a green background towards 4 grey target circles."  /></div>

<div
    class="ieee-sidebar-fullwidth  rebellt-item is--desktop col1"
    id="rebelltitem17"
    data-id="17"
    data-is-image="False"
    
    data-href="https://spectrum.ieee.org/reinforcement-learning/particle-17"
    data-published-at="1630498496"
    data-basename="particle-17"
    data-post-id="2654804251"
><p>In this example, three rovers must reach a target for it to be counted. Our system [right] can handle this challenging task, but others failed at it. <br></p><p class="caption">Intel AI</p></div>

                    <p>
	When three rovers had to reach a target simultaneously, MADDPG completely failed and MERL's emergent team formation was even more obvious, a trend we increasingly observed as the required number of rovers mounted. We checked our work using several different multiagent benchmarks. In each case, the two-part optimization of MERL substantially outperformed existing state-of-the-art algorithms.
</p><p>
	At Intel's AI lab, we're also exploring how communication could help multi-agent systems optimize performance. In particular, we're investigating whether agents on a team that are in communication with one another can form a language of sorts.
</p><p>
	To give an example from the rover simulation: If we allowed each rover a limited bandwidth to communicate with the others, what kind of messages would it transmit? And would the rovers jointly come up with codewords for certain actions? This experiment could give us insight into how language develops to achieve a common goal.
</p><p>
<strong>Autonomous systems of many forms</strong> are now becoming part of everyday life. While your Roomba is unlikely to do much damage, even if it went haywire, a robotic truck driving down the highway erratically could kill people. So we need to ensure that any agent that's been trained via RL will operate safely in the real world. How to do that, though, isn't particularly clear.
</p><p>
	We're exploring ways to define a
	<a href="https://arxiv.org/abs/2010.02846" rel="noopener noreferrer" target="_blank"> <u>common safety benchmark</u></a> for various RL algorithms and a common framework which can be used to train RL agents to operate safely, regardless of the application. This is easier said than done, because an abstracted concept of safety is hard to define, and a task-specific definition of safety is hard to scale across tasks. It's important to figure out now how to get such systems to act safely, because we believe that RL systems have a big role to play in society. Today's AI excels at perception tasks such as object and speech recognition, but it's ill-suited to taking actions. For robots, self-driving cars, and other such autonomous systems, RL training will enable them to learn how to act in an environment with changing and unexpected conditions.
</p><p>
	In one ongoing test of our theories, we're using RL combined with search algorithms to teach robots how to
	<a href="https://arxiv.org/pdf/2010.09832.pdf" rel="noopener noreferrer" target="_blank"> <u>develop successful trajectories</u></a> with minimal interaction with the real world. This technique could allow robots to try out new actions without the risk of damaging themselves in the process. We're now applying knowledge acquired in this way to an actual<a href="https://mime.oregonstate.edu/research/drl/" rel="noopener noreferrer" target="_blank"> <u>bipedal robot</u></a> at Oregon State University.
</p><p>
	Finally, in a leap from robotic systems to systems design, we have applied the same approach to improving various aspects of software and hardware systems. In a recent paper, we demonstrated that an RL agent can learn how to efficiently perform memory management on a hardware accelerator. Our approach,
	<a href="https://arxiv.org/abs/2007.07298" rel="noopener noreferrer" target="_blank"> <u>Evolutionary Graph RL</u></a>, was able to almost double the speed of execution on hardware compared to the native compiler simply by efficiently allocating chunks of data to various memory components. This accomplishment and<a href="https://ai.googleblog.com/2020/04/chip-design-with-deep-reinforcement.html" rel="noopener noreferrer" target="_blank"> <u>other</u></a><a href="https://arxiv.org/abs/1906.08879" rel="noopener noreferrer" target="_blank"> <u>recent</u></a><a href="https://openreview.net/forum?id=Hkc-TeZ0W" rel="noopener noreferrer" target="_blank"> <u>works</u></a> by the research community show that RL is moving from solving games to solving problems in real life.
</p><div class="around-the-web"><div class="from-your-site__headline">From Your Site Articles</div>
        <ul class="around-the-web__list"><li class="from-your-site__item">
                        <a href="https://spectrum.ieee.org/powerful-ai-can-now-be-trained-on-a-single-computer" class="from-your-site__link" target="_blank" rel="noopener noreferrer">Powerful AI Can Now Be Trained on a Single Computer - IEEE ... &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://spectrum.ieee.org/ai-agents-startle-researchers-with-unexpected-strategies-in-hideandseek" class="from-your-site__link" target="_blank" rel="noopener noreferrer">AI Agents Startle Researchers With Unexpected Hide-and-Seek ... &rsaquo;</a>
                    </li><li class="from-your-site__item">
                        <a href="https://spectrum.ieee.org/ai-agent-learns-about-the-world-by-gameplay" class="from-your-site__link" target="_blank" rel="noopener noreferrer">AI Agents Play "Hide the Toilet Plunger" to Learn Deep Concepts ... &rsaquo;</a>
                    </li></ul><div class="around-the-web__headline">Related Articles Around the Web</div>
        <ul class="around-the-web__list"><li class="around-the-web__item">
                        <a href="https://www.geeksforgeeks.org/what-is-reinforcement-learning/" class="around-the-web__link" target="_blank" rel="noopener noreferrer">Reinforcement learning - GeeksforGeeks &rsaquo;</a>
                    </li><li class="around-the-web__item">
                        <a href="https://www.coursera.org/specializations/reinforcement-learning" class="around-the-web__link" target="_blank" rel="noopener noreferrer">Reinforcement Learning | Coursera &rsaquo;</a>
                    </li><li class="around-the-web__item">
                        <a href="https://en.wikipedia.org/wiki/Reinforcement_learning" class="around-the-web__link" target="_blank" rel="noopener noreferrer">Reinforcement learning - Wikipedia &rsaquo;</a>
                    </li></ul></div></template></div>
            <div class="widget__show-more with-primary-color js-keep-reading js-page-view-and-reload-embeds">
                <span class="show-more js-expand">Keep Reading ↓</span>
                <span class="show-less js-contract">Show less</span>
            </div></div>
        

        

    </div>

<span class="js-scrolled-url"
    data-elid="2654804251"
    data-post-url="https://spectrum.ieee.org/reinforcement-learning"
    
        data-authors="Somdeb Majumdar"
    
    
        data-headline="Greedy AI Agents Learn to Cooperate"
    >
</span>
</div></div></div>
    
    
<script type="application/json" id="post-context-2654804251">
    {"customDimensions": {"5":"Somdeb Majumdar","6":"type","7":"ai, machine learning, deep learning, reinforcement learning, Intel, artificial intelligence","8":"09/02/2021","10":"artificial intelligence","11":2654804251}, "post": {"providerId": 0, "sections": [0, 497728257, 497728259, 544169516, 544169517], "buckets": [], "authors": [23639105]} }
</script>
</article>
                </div>
    </div></div>
    

    

    
    </div><div class="" id="sSocial_Stream_Element_0_0_15_0_0_1_5"><!-- User Code -->
              
              
              <!-- div id='infinite_leaderboard_1'><script>
    googletag.cmd.push(function() { googletag.display('infinite_leaderboard_1'); });
  </script></div --><div class="infinite-leaderboard"></div><!-- End User Code --></div>




<div
        class="wrapper-lazy-loading infinite-scroll-wrapper next-page-wrapper"
        style="display: block !important;"
        
    data-skl-id="/root/blocks/block[social_stream_element]/abtests/abtest[1]/element_wrapper/lazyload-"
    data-has-more="true"
    data-more-posts-exists="true"
    data-posts-sources="post_most_sections,post_sponsor_webinar_whitepaper,multi_filtered_parent_site_filtered_parent_site,frontpage_parent_site_podcast"
    data-ignore-page-number="false"

>
    
</div>
</div><span class="js-brick-description hidden" data-name="JS post functions"></span><!-- User Code --><script>
  function feature_post_full_style(){
    var feature_post_full = document.querySelectorAll(".feature_post_full:not(.proc)");
	for (i = 0; i < feature_post_full.length; i++) {
      var style_post_color = feature_post_full[i].querySelector(".custom-field-FeaturePostColor");
      var style_post_position = feature_post_full[i].querySelector(".custom-field-FeaturePostImgPosition");
      if(style_post_color){
         feature_post_full[i].classList.add(style_post_color.innerText);
      }else{
      	 feature_post_full[i].classList.add('DarkGray');
      }
      if(style_post_position){
         feature_post_full[i].classList.add(style_post_position.innerText);
      }
      feature_post_full[i].classList.add('proc');
    }  
  }
</script><!-- End User Code --><span class="js-brick-description hidden" data-name="Parsely Spectrum Tags"></span></div>
            </div>



    
    


    
    


    



    

    

    

    

    
    


    

    

<ul id="notification" class="notification"></ul>




    
    <script defer src="https://www.googletagmanager.com/gtag/js?id=UA-747464-1"></script><script>

            (function (i, s, o, g, r, a, m) {
                i["GoogleAnalyticsObject"] = r;
                (i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments);}),(i[r].l = 1 * new Date());
            })(window, document, "script", "/", "ga");
            ga('create', 'UA-747464-1', 'auto', {'name': 'b'});

            window.dataLayer = window.dataLayer || [];
            window.gtag = function(){dataLayer.push(arguments);}
            gtag('js', new Date());

            var utmCampaignData = null;// ADD REFERRER AS SOURCE IF SOURCE IS NOT PRESENT OR IF ISN'T URL UTM
            if(utmCampaignData && (utmCampaignData.dataSource != "url" || !utmCampaignData['campaignSource'])) {
                var referrerAnchor = document.createElement('a');
                referrerAnchor.setAttribute('href', document.referrer);
                if(referrerAnchor.href && referrerAnchor.host) {
                    var splitHost = referrerAnchor.host.split(".");
                    var nakedDomain = splitHost.length < 3 ? splitHost[0] : splitHost[1];
                    if (nakedDomain) {
                        nakedDomain = nakedDomain[0].toUpperCase() + nakedDomain.substring(1);
                        utmCampaignData['campaignSource'] = nakedDomain;
                    }
                }
            }

            var configParams = { transport: 'beacon', send_page_view: false };
            // DEFAULTS
            if (utmCampaignData) {
                configParams.campaignName = utmCampaignData.campaignName;
                configParams.campaignSource = utmCampaignData.campaignSource;
                configParams.campaignMedium = utmCampaignData.campaignMedium;
                configParams.campaignContent = utmCampaignData.campaignContent;
                if (utmCampaignData.campaignKeyword) {
                    configParams.campaignKeyword = utmCampaignData.campaignKeyword;
                }
            }gtag('config', 'UA-747464-1', configParams);<!-- ga_custom_dimensions: {u'layoutId': 9, u'postDate': 8, u'postTags': 7, u'primaryTag': 10, u'authorName': 5, u'postID': 11, u'sections': 6} -->

          window._ga_cd_params = {};
          window._ga_cd_params["dimension5"] = "Joanna Goodrich";
          window._ga_cd_params["dimension11"] = '2654877000';
          window._ga_cd_params["dimension7"] = "IBM, ibm watson, speech recognition technology, natural language processing, pryon, ai, Artificial Intelligence, ieee member news, type:ti";
          window._ga_cd_params["dimension10"] = 'ieee member news';
          window._ga_cd_params["dimension6"] = 'the-institute';
          
          window._ga_cd_params["dimension8"] = '09/03/2021';
          
          
          
          
          
          window._ga_cd_params["dimension9"] = 'ieee,633';
          
            if(window._ga_cd_params && Object.keys(window._ga_cd_params).length){
                gtag('event', 'page_view', window._ga_cd_params);
            }else{
                gtag('event', 'page_view');
            }
        </script>
    
    
    <script>
        if (typeof window.gtag === 'function') {
            var anchors = document.getElementsByTagName('a');
            for(var i = 0; i < anchors.length; i++) {
                var elem = anchors[i];
                elem.addEventListener('click', function (evnt) {
                    if (document.location.hostname === evnt.currentTarget.hostname) {
                        return;
                    }
                    if (!evnt.currentTarget.href) {
                        return;
                    }
                    if (evnt.currentTarget.href.lastIndexOf('javascript:', 0) === 0) {
                        return;
                    }
                    window.gtag('event', 'click', {
                        'event_category': 'outgoing_links',
                        'event_action': 'click',
                        'event_label': evnt.currentTarget.href,
                        'nonInteraction': 1,
                    });
                }, false);
            }
        }
    </script>
    
        <script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type":  "NewsArticle" ,
        "mainEntityOfPage": {
            "@type": "WebPage",
            "@id": "https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts"
        },
        "url": "https://spectrum.ieee.org/tomorrows-ai-will-reason-like-humans-ibm-watson-developer-predicts",
        "headline": "Tomorrow\u2019s AI Will Reason Like Humans, IBM Watson Developer Predicts",
        "image": {
            "@type": "ImageObject",
            "url": "https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjg4NDUyMC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTYzNjkyNzQzOX0.mNqUZqo5a_BsPraQgLORhtWMCwZkh3R1prMdTe4pEFY/image.png?width=210",
            "width": 1200,
            "height": 600
        },
        "datePublished": "2021-09-03T18:00:00Z",
        "dateModified": "2021-09-03T18:50:29Z",
        "author": {
            "@type": "Person",
            "name": "Joanna Goodrich"
        },
        "publisher": {
        "@type": "Organization",
        "name": "IEEE Spectrum",
        "logo": {
            "@type": "ImageObject",
            "url": "https://spectrum.ieee.org/media-library/eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpbWFnZSI6Imh0dHBzOi8vYXNzZXRzLnJibC5tcy8yNjg4NDUyMC9vcmlnaW4ucG5nIiwiZXhwaXJlc19hdCI6MTYzNjkyNzQzOX0.mNqUZqo5a_BsPraQgLORhtWMCwZkh3R1prMdTe4pEFY/image.png?width=210"
            }
        },
        "articleSection": "The Institute",
        "description": "David Nahamoo says machines will grok us",
        "keywords": ["IBM", "ibm watson", "speech recognition technology", "natural language processing", "pryon", "ai", "Artificial Intelligence", "ieee member news", "type:ti"]}
</script>


    <script class="lazy-style" type="css">
        

    </script>

    
        <script id="parsely-cfg" src="//cdn.parsely.com/keys/spectrum.ieee.org/p.js"></script>
    <script id="user-javascript-medium-normal">
        window.REBELMOUSE_TASKS_QUEUE.push(function loadFonts(){});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        //var ssoValidatorUrl = 'https://oamssoqae.ieee.org/ieeevendorsso/rest/auth/validatePFToken?_=' + (+ new Date());

var ssoValidatorUrl = 'https://securesso.ieee.org/ieeevendorsso/rest/auth/validatePFToken?_=' + (+ new Date());

function getCookie(name) {
  const value = `; ${document.cookie}`;
  const parts = value.split(`; ${name}=`);
  if (parts.length === 2) return parts.pop().split(';').shift();
}

fetch(ssoValidatorUrl, {
    method: 'GET',
    mode: 'cors',
    credentials: 'include',
}).then(function (response) {
	// The API call was successful!
	if (response.ok) {
		response.json().then(function(result) {
          if (typeof result == 'object' && result.cookieValid && getCookie('user_logged_in') !== "1") { 		//SSO
              console.log('we should be logged in, redirect to SSO iDP');
              //window.location.href = 'https://spectrumtest.ieee.org/core/saml/main/login?next_url=' + window.location.href;
              window.location.href = "https://spectrum.ieee.org/core/saml/main/login?next_url=" + encodeURIComponent("https://spectrum.ieee.org/core/integrations/ieee/changes?redirect=" + window.location.href);
          } else if (typeof result == 'object' && !result.cookieValid) {		//SLO
              console.log('we should be logged out, remove cookie and do not show user');
              //document.cookie = "sessionid= ; expires = Thu, 01 Jan 1970 00:00:00 GMT";
          }
        });
      
	} else {
		return Promise.reject(response);
	}
}).then(function (data) {
	// This is the JSON from our response
	console.log(data);
}).catch(function (err) {
	// There was an error
	console.warn('Something went wrong.', err);
});
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        function changeDateFormat(widget){
  var dates_toChange=widget.querySelectorAll('.widget .social-date__text:not(.processed),.widget .social-date-modified__text:not(.processed)');
  if(dates_toChange){
    dates_toChange.forEach(function(date) {

      if(!date.innerHTML.trim()==""){
        date.classList.add('processed')
        var date_string=date.innerHTML.toString();
        var slpit_dateText=date_string.split(" ");


        if(slpit_dateText.length==1){
          let plural=true;
          if(slpit_dateText[0].length==2){
            if(slpit_dateText[0].charAt(0)=="1"){
              plural=false;
            }
          }
          let modifier=plural ? 'hours ago':'hour ago';

          if(slpit_dateText[0].substr(-1)=='m'){
            modifier=plural ? 'minutes ago':'minute ago';
          }
          var new_dateText=slpit_dateText[0].slice(0,-1);
          date.innerHTML=  new_dateText+" "+ modifier;
          date.classList.add("modified");
        }
      }
    });

  }
}
_createElementChangeListener= function (selector, callback) {
  const initializedNodes = new Set([]);

  document.querySelectorAll(selector).forEach((node) => {
    callback(node);
    initializedNodes.add(node);
  });

  const mutationObserver = new MutationObserver(() => {
    const nodes = document.querySelectorAll(selector);
    nodes.forEach((node) => {
      if (!initializedNodes.has(node)) {
        callback(node);
        initializedNodes.add(node);
      }
    });
  });

  mutationObserver.observe(document.body, {
    childList: true,
    subtree: true,
  });
}
_createElementChangeListener(".widget",changeDateFormat);
    

});

window.REBELMOUSE_TASKS_QUEUE.push(function(){

    
        feature_post_full_style();
    

});</script>
    <script id="user-javascript-active" type="text">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</script>
    <script id="user-javascript-lowest" type="text">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</script>
</body>
</html>