
<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en"><!--<![endif]-->
<head>
    <meta charset="utf-8">
    <title>Robots Continue Attempting to Master Ikea Furniture Assembly - IEEE Spectrum</title>
    <meta name="viewport" content="width=1024"> 
    
    <link rel="icon" href="/favicon.png" type="image/png"/>
    <link rel="alternate" title="IEEE Spectrum Recent Content" href="https://spectrum.ieee.org/rss/fulltext" type="application/rss+xml" />
    
    <!--[if IE]>
		<meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7; IE=EDGE; chrome=1"/>
	<![endif]-->
    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.4/css/bootstrap.min.css"/>
    <link rel="stylesheet" href="/assets/frontend-be3adcc93203b1a6ff4eb5804e2c8eef.css"/>
    <script src="//code.jquery.com/jquery-1.11.2.min.js"></script>
    <script src="//code.jquery.com/jquery-migrate-1.2.1.min.js"></script>
    <script src="//maxcdn.bootstrapcdn.com/bootstrap/3.3.4/js/bootstrap.min.js"/></script>
    <script type="text/javascript" src="/assets/header/header-2fca869ee14503f3a87282a60a05c741.js" ></script>
    <!-- begin static module global-head-spectrum4 -->
<style>

@media screen and (min-width: 1640px) and (max-width: 1720px), screen and (min-width: 1320px) and (max-width: 1400px), screen and (min-width: 1025px) and (max-width: 1100px){
.addthis-smartlayers-desktop{
    display:block;
}
#lbCaption em {
    font-style: italic;
    display: inline;
}
.wide-slides {
    clear: both;
}
</style> 
<script><!--
$(function(){
$(".article-options-bar #trending").hide();

  var s = document.createElement('script');
        s.async = true;
        s.type = 'text/javascript';
        s.src = 'https://ieeespectrum.disqus.com/count.js';
        (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
});
var addthis_config = addthis_config||{};
    addthis_config.data_track_addressbar = false;
    addthis_config.data_track_clickback = false;
//--></script>
<!-- end static module -->

    <script type="text/javascript">
					var adinfo = {
					"zone":"IEEE",
					"addomain":"IEEESpectrum"
					}
				</script>
    <!-- begin static module gpt-header-standard-module -->
<!-- GPT Header Standard Code --> 
<script type="text/javascript">
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement("script");
gads.async = true;
gads.type = "text/javascript";
var useSSL = "https:" == document.location.protocol;
gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
var node =document.getElementsByTagName("script")[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<!-- end static module -->

    <!-- begin static module gpt-header-ad-comp-module -->
<script>
	googletag.cmd.push(function() {
	googletag.defineSlot("/4250/" + adinfo.addomain + "/" + adinfo.zone, [728, 90], "div-gpt-ad-leaderboard").setTargeting('pos', ['1']).addService(googletag.pubads())
	googletag.defineSlot("/4250/" + adinfo.addomain + "/" + adinfo.zone, [728, 90], "div-gpt-ad-leaderboard-2").setTargeting('pos', ['2']).addService(googletag.pubads())
	googletag.defineSlot("/4250/" + adinfo.addomain + "/" + adinfo.zone, [300, 250], "div-gpt-ad-med-rectangle").setTargeting('pos', ['1']).addService(googletag.pubads())
	googletag.defineSlot("/4250/" + adinfo.addomain + "/" + adinfo.zone, [300, 250], "div-gpt-ad-med-rectangle-2").setTargeting('pos', ['2']).addService(googletag.pubads())
	googletag.defineSlot("/4250/" + adinfo.addomain + "/" + adinfo.zone, [300, 600], "div-gpt-ad-halfpage").addService(googletag.pubads())
	googletag.enableServices();
});
</script>
<!-- end static module -->

    <!-- begin static fragment crazy-egg-script --><script type="text/javascript">
setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0056/0444.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script><!-- end static fragment -->
    
    <meta name="layout" content="spectrum"/>
    
    <meta name="keywords" content="furniture,ikea,ntu,singapore"/>

    
        <meta name="description" content="These robots are slow, careful, and successful, making them way better than humans at assembling an Ikea chair"/>
    
    
    
        <link rel="image_src" href="/image/MzA0Nzc1Mg.jpeg"/>
    
    <script type="application/ld+json">
{
    "@context": "http://schema.org",
    "@type": "BlogPosting",
    "headline": "Robots Continue Attempting to Master Ikea Furniture Assembly",
    "description": "These robots are slow, careful, and successful, making them way better than humans at assembling an Ikea chair",
    "publisher": {
        "@type": "Organization",
        "name": "IEEE Spectrum",
        "url": "https://spectrum.ieee.org",
        "logo": {
            "@type": "ImageObject",
            "url": "https://spectrum.ieee.org/assets/footer-logo-54ded86f182c0bcf8f26c9de4cb7c8f7.png"
        }
    },
    "dateModified": "2018-04-18T01:04:12.971-0400",
    "datePublished": "2018-04-18T14:00:00.000-0400",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://spectrum.ieee.org/automaton/robotics/industrial-robots/robots-continue-attempting-to-master-ikea-furniture-assembly"
    },
    "author": {
        "@type": "Person",
        "name": "Evan Ackerman"
    },
    "image": {
        "@type": "ImageObject",
        "url": "https://spectrum.ieee.org/image/MzA0Nzc0Mg.jpeg",
        "height": null,
        "width": null
    }
}
</script>
    
<link rel="canonical" href="https://spectrum.ieee.org/automaton/robotics/industrial-robots/robots-continue-attempting-to-master-ikea-furniture-assembly" />
<link rel="amphtml" href="https://spectrum.ieee.org/automaton/robotics/industrial-robots/robots-continue-attempting-to-master-ikea-furniture-assembly.amp.html" />
<!-- Google Analytics -->
<script class="ga-tag">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-747464-1', 'auto');
ga('send', 'pageview');
ga('set', 'dimension1', 'blog-post');
ga('set', 'dimension3', 'Evan Ackerman');

</script>
<!-- End Google Analytics -->




    <meta property="og:site_name" content="IEEE Spectrum: Technology, Engineering, and Science News" />
    <meta property="og:title" content="Robots Continue Attempting to Master Ikea Furniture Assembly" />
    <meta property="og:url" content="https://spectrum.ieee.org/automaton/robotics/industrial-robots/robots-continue-attempting-to-master-ikea-furniture-assembly" />
    <meta property="og:description" content="These robots are slow, careful, and successful, making them way better than humans at assembling an Ikea chair" />
    <meta property="og:image" content="https://spectrum.ieee.org/image/MzA0Nzc1Nw.jpeg" />
    <meta property="og:type" content="blog-automaton" />
    
    <!-- Parsely Tags --><meta name="parsely-page" content='{"title":"Robots Continue Attempting to Master Ikea Furniture Assembly","link":"https://spectrum.ieee.org/automaton/robotics/industrial-robots/robots-continue-attempting-to-master-ikea-furniture-assembly","image_url":"https://spectrum.ieee.org/image/MzA0Nzc1MA.jpeg","type":"post","post_id":"/automaton/robotics/industrial-robots/robots-continue-attempting-to-master-ikea-furniture-assembly","pub_date":"2018-04-18T18:00:00Z","section":"Automaton","author":"Evan Ackerman","tags":["furniture","ikea","ntu","singapore","topic.robotics","subtopic.industrial-robots"]}'>
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:site" content="@IEEESpectrum" />
    <meta name="twitter:title" content="Robots Continue Attempting to Master Ikea Furniture Assembly" />
    <meta name="twitter:description" content="These robots are slow, careful, and successful, making them way better than humans at assembling an Ikea chair" />
    <meta name="twitter:image" content="https://spectrum.ieee.org/image/MzA0Nzc0Mg.jpeg" />


    <style>
        #header {
        margin-bottom: 0;
        }
    </style>

</head>
<body class="pageBody" onload="">


    
<script type="text/template" id="tmpl-interstitial-ad">
	<div id="tmpl-slashpage">
		<div id="header" style="background: #5a5a5a;text-align:right; padding:20px; overflow:auto; margin-bottom:25px;">
			<img src="/assets/logo-main-feb42a39ad411519bd3bbfbf85743dfe.png" alt="IEEE Spectrum logo" style="float: left;height: 40px;"/>
			<a href="javascript:splashpage.closeit()">Continue to site&nbsp;➔</a>
		</div>
		<div style="color:gray; font-size:18px; text-align:center; margin-bottom:8px;">ADVERTISEMENT</div>
		<iframe name="splashpage-iframe" src="about:blank" scrolling="no" seamless="seamless" style="overflow:hidden; padding:0; z-index:6000000; width:660px; height:500px; margin:0 auto; display:block;" frameborder="0"></iframe>
	</div>
</script>
    
<script>
	splashpage.splashenabled=1;
	splashpage.splashpageurl= '/interstitial?splashType=welcome';
	splashpage.enablefrequency=1;
	splashpage.displayfrequency='sessiononly';
	splashpage.cookiename = ['interstitialpagecookie3012157', 'path=/'];		
	splashpage.autohidetimer=15;
	splashpage.enablecounter=true;
	splashpage.counter=1;
	splashpage.timeremaining=0;
	splashpage.sessiononlyCookieLifeTime=24;
	if (splashpage.browserdetectstr && splashpage.splashenabled==1) {
        //console.info('initializing interstitial ad');
        splashpage.init();
        //console.info('interstitial ad init finished');
    }
</script>


<a href="/" class="backtotop"></a>
<header id="header">
	
	
<style>
header #ieee-metanav ul li a:hover {
    color: #03a6e3;
}
</style>

<div id="ieee-metanav" role="banner">
    <div class="commonwrap">
        <ul class="inline-list left-nav">
            <li><a href="/static/enhance-your-spectrum-experience-become-an-ieee-member">Join IEEE</a></li>
            <li class="sep">|</li>
            <li><a href="http://www.ieee.org" target="_blank">IEEE.org</a></li>
            <li class="sep">|</li>
            <li><a href="http://ieeexplore.ieee.org" target="_blank">IEEE <em>Xplore</em> Digital Library</a></li>
            <li class="sep">|</li>
            <li><a href="http://standards.ieee.org" target="_blank">IEEE Standards</a></li>
            <li class="sep">|</li>
            <li><a href="/"><span>IEEE Spectrum</span></a></li>
            <li class="sep">|</li>
            <li><a href="http://www.ieee.org/sitemap" target="_blank">More Sites</a></li>
        </ul>
        
    </div>
</div>
<section id="masthead">
    <div class="masthead-wrap">
        <div class="brand-space" role="img">
            <a href="/" id="brand">
                <img src="/assets/logo-main-feb42a39ad411519bd3bbfbf85743dfe.png" alt="IEEE Spectrum logo"/>
            </a>

            <div id="social-space">
                <span class="follow">Follow on:</span>
                <ul class="inline-list social-links">
                    
                    
                    <li><a href="http://www.facebook.com/IEEE.Spectrum" target="_blank"><span class="faceBook"></span>
                    </a></li>
                    <li><a href="http://twitter.com/#!/IEEESpectrum" target="_blank"><span class="twitter"></span></a>
                    </li>
                    <li><a href="http://www.linkedin.com/groups/IEEE-Spectrum-1982451?home=&gid=1982451&trk=anet_ug_hm"
                           target="_blank"><span class="linkedIn"></span></a></li>
                    <li><a href="https://plus.google.com/105079317383160047042/posts" target="_blank"><span
                            class="google"></span></a></li>
                    <li><a href="/static/rss" target="_blank"><span class="rssFeed"></span></a></li>
                </ul>
            </div>
        </div>

        <div class="ad-space" role="img">
            <span>Advertisement</span>

            <div class="leaderboard-wrap">
                <!-- begin static module gpt-body-ad-module-728-90 -->
<div id="div-gpt-ad-leaderboard" style="728px; height: 90px"> 
 <script type="text/javascript">
						googletag.cmd.push(function() {
						googletag.display("div-gpt-ad-leaderboard");
						});
						</script> 
</div>
<!-- end static module -->

            </div>
        </div>
    </div>
</section>

<script>
var Registration = {

    popupwindow: function(url, title, w, h) {
        var y = window.outerHeight / 2 + window.screenY - ( h / 2)
        var x = window.outerWidth / 2 + window.screenX - ( w / 2)
        return window.open(url, title, 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=' + w + ', height=' + h + ', top=' + y + ', left=' + x);
    },

    logout: function() {
        console.log("Logging out");
    }
}

</script>
	<nav id="mainNav" role="navigation">

	
	<div class="commonwrap">
		<ul class="primary" role="menubar">
			<li><a href="#" onclick="return false;" id="topics"><span class="trunc">Engineering </span>Topics<span class="arrow-icon">&nbsp;</span></a></li>
			<li><a href="#" onclick="return false;" id="reports"><span class="trunc">Special </span>Reports<span class="arrow-icon">&nbsp;</span></a></li>
			<li><a href="#" onclick="return false;" id="blogs">Blogs<span class="arrow-icon">&nbsp;</span></a></li>
			<li><a href="#" onclick="return false;" id="multimedia">Multimedia<span class="arrow-icon">&nbsp;</span></a></li>
			<li><a href="#" onclick="return false;" id="magazine"><span class="trunc">The </span>Magazine<span class="arrow-icon">&nbsp;</span></a></li>
			<li><a href="#" onclick="return false;" id="resources"><span class="trunc">Professional </span>Resources<span class="arrow-icon">&nbsp;</span></a></li>
			<li><a href="#" onclick="return false;" class="last" id="searchmenu">Search<span class="arrow-icon">&nbsp;</span></a></li>
		</ul><!-- /.primary -->
	</div>	
	
	<div class="slider collapsed" role="landmark">
		<div id="menuCentered">
			<div id="menuContainer"></div>
		</div>
	</div>
	
	
</nav>
</header>

<div id="main" role="main" class="automaton">
    <div class="wrap">
        <section id="medium-center">
            <article id="3047316" role="heading" class="article-detail article-page blog-post">
                <!-- Breadcrumbs - global module -->
                <ul id="breadcrumbs" role="menubar">
                    <li role="menuitem"><a href="/blog/automaton">Automaton</a></li>
                    <li role="menuitem"><a href="/robotics">Robotics</a></li>
                    <li role="menuitem"><a href="/robotics/industrial-robots">Industrial Robots</a></li>
                </ul>

                
                    <div class="byline">
                            <div><label>18 Apr 2018 | 18:00 GMT</label></div>
                    </div>
                

                <h1 class="article-main-title">Robots Continue Attempting to Master Ikea Furniture Assembly</h1>
                <h2 class="article-dek">These robots are slow, careful, and successful, making them way better than humans at assembling an Ikea chair</h2>

                
                    <div class="auth-byline">
                        By <span class="author-name"><a href="/author/ackerman-evan-">Evan Ackerman</a></span>
                    </div>
                
                


<script type="text/javascript" class="addthis" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f4cf61812d7916f"></script>
                

                <div class="entry-content">
                                
                    <figure class="xlrg blogImg">
                        <img src="/image/MzA0Nzc0MQ.jpeg" alt="Robots Continue Attempting to Master Ikea Furniture Assembly"/>
                        
                            <figcaption class="hi-cap">Image: NTU</figcaption>
                        
                        
                    </figure>
                
                <section id="side-module">
    <div class="medium-top-ad">
        <!-- begin static module gpt-body-ad-module-300-250 -->
<div class="ad-module"> 
 <div class="adtext">
   Advertisement 
 </div> 
 <div id="div-gpt-ad-med-rectangle" style="300px; height: 250px"> 
  <script type="text/javascript">
				googletag.cmd.push(function() {
					googletag.display("div-gpt-ad-med-rectangle");
				});
		</script> 
 </div> 
</div>
<!-- end static module -->

    </div>
    
        <div id="recommended-side">
            <div class="title">Editor&rsquo;s Picks</div>

            <div id="article-rec">
                
                    <a class="article" href="/automaton/robotics/home-robots/study-you-will-love-your-robot-more-if-you-assemble-it-yourself">
                        <div class="image-column">
                            <img src="/image/Mjc2NDkyOQ.jpeg" width="140" height="140" alt="Humanoid robot assembly instructions"/>
                        </div>

                        <div class="text-column">
                            <h4>Study: You'll Love Your Robot More If You Assemble It Yourself</h4>
                        </div>
                    </a>
                
                    <a class="article" href="/automaton/robotics/home-robots/mit-ikeabot-autonomous-furniture-assembly-robots">
                        <div class="image-column">
                            <img src="/image/MjI4MjQyOQ.jpeg" width="140" height="140"/>
                        </div>

                        <div class="text-column">
                            <h4>MIT Robots Can Assemble Your IKEA Furniture For You</h4>
                        </div>
                    </a>
                
                    <a class="article" href="/automaton/robotics/artificial-intelligence/robots-learning-better-ways-to-ask-clueless-humans-for-help">
                        <div class="image-column">
                            <img src="/image/MjM3MDAxNw.jpeg" width="140" height="140"/>
                        </div>

                        <div class="text-column">
                            <h4>Robots Learning Better Ways to Ask Clueless Humans for Help</h4>
                        </div>
                    </a>
                
            </div>
        </div>
    
</section>
                    <p>Apparently, one of the standards by which we should be measuring the progress of useful robotic manipulation is through the assembly of Ikea furniture. With its minimalistic and affordable Baltoscandian design coupled with questionably creditable promises of effortless assembly, Ikea has managed to convince generations of inexperienced and desperate young adults (myself included) that we can pretend to be grownups by buying and putting together our own furniture. It’s never as easy as that infuritatingly calm little Ikea manual dude makes it look, though, and in terms of things we wish robots would solve, Ikea furniture assembly has ended up way higher on the priority list than maybe it should be.&nbsp;</p> 
<p>We’ve seen a variety of robotic systems tackle Ikea in the past, but today in <em>Science Robotics</em> is (perhaps for the first time) a mostly off-the-shelf system of a few arms and basic sensors that can put together the frame of a Stefan chair kit autonomously(ish) and&nbsp;from scratch.</p> 
<!--nextpage--> 
<p>This research comes from the <a href="http://www.ntu.edu.sg/home/cuong/">Control Robotics Intelligence (CRI) group at NTU in Singapore</a>, and they’ve been working on the whole Ikea chair assembly thing for a while. First, they had to teach robots to insert those wooden pins that Ikea uses to connect parts to one another:</p> 
<p><iframe allowfullscreen frameborder="0" height="349" src="//www.youtube.com/embed/dVQ_WW_WsEQ?rel=0" width="620"></iframe></p> 
<p>Then you’ve got multiple pin insertion under uncertainty:</p> 
<p><iframe allowfullscreen frameborder="0" height="349" src="//www.youtube.com/embed/CFxP6Y_RR3E?rel=0" width="620"></iframe></p> 
<p>Next, cooperatively moving partially assembled chair pieces around:</p> 
<p><iframe allowfullscreen frameborder="0" height="349" src="//www.youtube.com/embed/PUkNS3gykC8?rel=0" width="620"></iframe></p> 
<p>And finally, bimanual whole-chair manipulation:</p> 
<p><iframe allowfullscreen frameborder="0" height="349" src="//www.youtube.com/embed/4DcMwr2xxrQ?rel=0" width="620"></iframe></p> 
<p>The research being presented today in <em>Science Robotics</em> is essentially a synthesis of these skills, all put together resulting in a fully autonomous Ikea chair frame assembly:</p> 
<p><iframe allowfullscreen frameborder="0" height="349" src="//www.youtube.com/embed/RxlP77CE81Q" width="620"></iframe></p> 
<p>To help put this research in perspective, let’s briefly take a look at a few other attempts at Ikea furniture assembly by robots, both from 2013:</p> 
<p>Willow Garage:</p> 
<p><iframe allowfullscreen frameborder="0" height="349" src="//www.youtube.com/embed/lm5myFAsP9M?rel=0" width="620"></iframe></p> 
<p>IkeaBot:</p> 
<p><iframe allowfullscreen frameborder="0" height="349" src="//www.youtube.com/embed/B9sYogRVF8Q?rel=0" width="620"></iframe></p> 
<p><a href="/automaton/robotics/home-robots/mit-ikeabot-autonomous-furniture-assembly-robots">IkeaBot in particular is notable because it’s fully autonomous</a>— the system doesn’t require human input of any sort, not even instructions. Rather, it uses a reasoning system to determine the best way to fit all of the parts together, utilizing all available holes for fasteners and all available parts, and follows its own optimized assembly technique to end up with a piece of furniture that ends up being what Ikea intended it to be almost by default.</p> 
<p>The assembly process from CRI is not quite that autonomous; "although all the steps were automatically planned and controlled, their sequence was hard-coded through a considerable engineering effort." The researchers mention that they can "envision such a sequence being automatically determined from the assembly manual, through natural-language interaction with a human supervisor or, ultimately, from an image of the chair," although we feel like they should have a chat with <a href="http://www.cs.cornell.edu/~rak/">Ross Knepper</a>, whose IkeaBot seemed to do just fine without any of that stuff.&nbsp;</p> 
<p>What is different about this new research is that it relies on very simple (deliberately simple) COTS (commercial off the shelf) hardware. There are two Denso industrial arms, Robotiq parallel grippers, force sensors, and a single depth camera. The system used no fiducials and no motion tracking, and although it did take 20 minutes (11 minutes of which was motion planning), randomly scattered chair parts were successfully turned into a chair frame in one single take. And really, 20 minutes is not that long— not even long enough to enjoy a surprisingly affordable meal of traditional meatballs with a side of lingonberries.&nbsp;</p> 
<p>And in case you were wondering whether robots are fundamentally better at putting together Ikea furniture than you are, this should make you feel (a little bit) better:</p> 
<p><iframe allowfullscreen frameborder="0" height="349" src="//www.youtube.com/embed/W_YjULQIwLI" width="620"></iframe></p> 
<p>Too bad all of those clips cut out just before the robot grabs the piece and throws it against the wall while screaming incoherently.</p> 
<p>[ <em><a href="http://robotics.sciencemag.org/lookup/doi/10.1126/scirobotics.aat6385">Science Robotics</a></em> ]</p>
                </div>
                <!-- begin static fragment automaton-blog-static-module --><article class="sml_article_static automaton"> 
 <div class="module-header"> 
  <h3 class="isotope-title">Robotics News</h3> 
  <a class="newsletter-signup" href="/static/newsletters-signup?utm_source=internal&amp;utm_medium=blog_page&amp;utm_campaign=automaton" title="Sign Up">Sign Up</a> 
  <p> Biweekly newsletter on advances and news in robotics, automation, control systems, interviews with leading roboticists, and more.</p> 
 </div> 
 <div class="module-body"> 
  <h4 class="isotope-title">About the Automaton blog</h4> 
  <div class="left"> 
   <p> <em>IEEE Spectrum</em>’s award-winning robotics blog, featuring news, articles, and videos on robots, humanoids, automation, artificial intelligence, and more.</p> 
   <div class="column"> 
    <a class="twitter-follow-button" data-dnt="true" data-show-count="false" data-size="large" href="https://twitter.com/AutomatonBlog">Follow @AutomatonBlog</a> 
    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script> 
   </div> 
  </div> 
  <div class="right"> 
   <ul> 
    <li><a href="/author/guizzo-erico">Erico Guizzo</a>, Editor</li> 
    <li><a href="/author/ackerman-evan-">Evan Ackerman</a>, Senior Writer</li> 
    <li><a href="https://www.linkedin.com/in/fan-shi-a680b48a/">Fan Shi</a>, Contributor</li> 
   </ul> 
   <a href="/rss/blog/automaton/fulltext" class="btn btn-primary sign-up blog-rss" title="Automaton RSS">Subscribe to RSS Feed</a> 
  </div> 
 </div> 
</article><!-- end static fragment -->
                <section id="recommended">
    <div style="margin:0 auto;width:940px;">
        <div class="title">Recommended For You</div>

        <div id="article-rec">
            
                
                    <a class="article" href="/energywise/energy/nuclear/fifteen-years-to-a-fusion-power-plant-might-be-a-reach">
                        <div class="image-column">
                            <img src="/image/MzA0Mzk2Mw.jpeg" width="140" height="140" alt="Visualization of the proposed SPARC tokamak experiment. Using high-field magnets built with newly available high-temperature superconductor, this experiment would be the first controlled fusion plasma to produce net energy output"/>
                        </div>

                        <div class="text-column">
                            <h4>MIT Spin-off Faces Daunting Challenges on Path to Build a Fusion Power Plant in 15 Years</h4>
                        </div>
                    </a>
                
            
                
                    <a class="article" href="/tech-talk/robotics/artificial-intelligence/real-dog-behavior-could-inspire-robot-dogs">
                        <div class="image-column">
                            <img src="/image/MzA0NzkyMw.jpeg" width="140" height="140" alt="Still image from video showing Alaskan Malamute Kelp M. Redmon, with camera and sensors."/>
                        </div>

                        <div class="text-column">
                            <h4>“Dog Cam” Trains Computer Vision Software for Robot Dogs</h4>
                        </div>
                    </a>
                
            
                
                    <a class="article" href="/automaton/robotics/drones/epfl-flyjacket-exosuit-lets-you-control-a-drone-with-your-body">
                        <div class="image-column">
                            <img src="/image/MzA0NjY4Mw.jpeg" width="140" height="140" alt="EPFL's FlyJacket exosuit allows you to embody a drone, making it feel like you're flying"/>
                        </div>

                        <div class="text-column">
                            <h4>FlyJacket Lets You Control a Drone With Your Body</h4>
                        </div>
                    </a>
                
            
                
                    <a class="article" href="/the-human-os/biomedical/bionics/cyborg-drumming-arm-seeks-kickstarter-help-to-escape-the-lab">
                        <div class="image-column">
                            <img src="/image/MzA0NjIzMg.jpeg" width="140" height="140" alt="Jason Barnes with the robotic drumming prosthesis."/>
                        </div>

                        <div class="text-column">
                            <h4>Drummer With Cyborg Arm Wants to Take It On Tour</h4>
                        </div>
                    </a>
                
            
                
                    <a class="article" href="/automaton/robotics/robotics-hardware/video-friday-robot-with-scissors-cassie-on-a-segway-atlas-kicking">
                        <div class="image-column">
                            <img src="/image/MzA0NTI5MQ.jpeg" width="140" height="140" alt="Robot with scissors"/>
                        </div>

                        <div class="text-column">
                            <h4>Video Friday: Robot With Scissors, Cassie on a Segway, and Atlas Kicking</h4>
                        </div>
                    </a>
                
            
                
                    <a class="article" href="/static/the-race-to-5g-technology">
                        <div class="image-column">
                            
                        </div>

                        <div class="text-column">
                            <h4>The Race to 5G: Technology</h4>
                        </div>
                    </a>
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
                
            
        </div>
    </div>
</section>
                

    <section class="learn-more" role="menu">
        <h5>Learn More</h5>
        


<style>
u {
    text-decoration: none;
}
</style>

    
        
            <a href="/tag/singapore">singapore</a>
        
        
    
        
            <a href="/tag/ikea">ikea</a>
        
        
    
        
            <a href="/tag/ntu">ntu</a>
        
        
    
        
            <a href="/tag/furniture">furniture</a>
        
        
    

    </section>


<section id="comments-section" role="complementary">
    <div class="split">
        <div class="column">
            <h6 class="section-title">Comments</h6>
        </div>

        <div class="column last align-right">
            <div class="policy"><a href="/static/comment-policy">Comment Policy</a></div>
        </div>

        <div class="clear"></div>
    </div>

    <div id="disqus_thread"></div>

    
    
        <script type="text/javascript">
            var disqus_shortname = 'ieeespectrum';
            var disqus_identifier = '/automaton/robotics/industrial-robots/robots-continue-attempting-to-master-ikea-furniture-assembly';
            var disqus_title = 'Robots Continue Attempting to Master Ikea Furniture Assembly';
            var disqus_url = 'https://spectrum.ieee.org/automaton/robotics/industrial-robots/robots-continue-attempting-to-master-ikea-furniture-assembly';

            
            (function () {
                var dsq = document.createElement('script');
                dsq.type = 'text/javascript';
                dsq.async = true;
                dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
                (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
            })();
        </script>
        <noscript>Please enable JavaScript to view the &lt;a
        href="http://disqus.com/?ref_noscript"&gt;comments powered by
        Disqus.&lt;/a&gt;</noscript>
        <a href="http://disqus.com" class="dsq-brlink">Comments powered
        by <span class="logo-disqus">Disqus</span></a>
    
</section>

            </article>
        </section>
        
            
                
            
        
    </div>
</div>


<footer id="global-footer" role="landmark">

	
    <div id="topFooter" role="region" >
        <div class="commonwrap" role="section">
            <a href="/">
                
                <img src="/assets/footer-logo-54ded86f182c0bcf8f26c9de4cb7c8f7.png" class="footerLogo" alt="IEEE Spectrum logo" width="270" role="img"/>
            </a>
            <div id="footerTopMenu" role="navigation">
                <ul class="topics" role="menu">
                    <h4 role="heading">Topics</h4>
                    
                        <li role="menuitem"><a href="/aerospace">Aerospace</a></li>
                    
                        <li role="menuitem"><a href="/at-work">At Work</a></li>
                    
                        <li role="menuitem"><a href="/biomedical">Biomedical</a></li>
                    
                        <li role="menuitem"><a href="/computing">Computing</a></li>
                    
                        <li role="menuitem"><a href="/energy">Energy</a></li>
                    
                        <li role="menuitem"><a href="/consumer-electronics">Gadgets</a></li>
                    
                        <li role="menuitem"><a href="/geek-life">Geek Life</a></li>
                    
                        <li role="menuitem"><a href="/green-tech">Green Tech</a></li>
                    
                        <li role="menuitem"><a href="/tech-history">History</a></li>
                    
                        <li role="menuitem"><a href="/robotics">Robotics</a></li>
                    
                        <li role="menuitem"><a href="/semiconductors">Semiconductors</a></li>
                    
                        <li role="menuitem"><a href="/telecom">Telecom</a></li>
                    
                        <li role="menuitem"><a href="/transportation">Transportation</a></li>
                    
                </ul>

                <ul class="social-links" role="menu">
                    <h4 role="heading">Connect</h4>
                    <li role="menuitem"><a href="http://www.facebook.com/IEEE.Spectrum" class="icn-sml" target="_blank"><span class="faceBook"></span>Facebook</a></li>
                    <li role="menuitem"><a href="http://twitter.com/#!/IEEESpectrum" class="icn-sml" target="_blank"><span class="twitter"></span>Twitter</a></li>
					<li role="menuitem"><a href="http://www.linkedin.com/groups/IEEE-Spectrum-1982451?home=&gid=1982451&trk=anet_ug_hm" class="icn-sml" target="_blank"><span class="linkedIn"></span>LinkedIn</a></li>
                    <li role="menuitem"><a href="https://plus.google.com/105079317383160047042/posts" class="icn-sml" target="_blank"><span class="google"></span>Google+</a></li>
                    <li role="menuitem"><a href="/static/rss" class="icn-sml" target="_blank"><span class="rssFeed"></span>RSS</a></li>
                </ul>

                <ul class="spectrum-footer-links" role="menu">
                    <h4 role="heading">IEEE Spectrum</h4>
                    <li role="menuitem"><a href="/static/contactus">Contact Us</a></li>
                    <li role="menuitem"><a href="/static/aboutus">About</a></li>
                    <li role="menuitem"><a href="/static/newsletters">Newsletters</a></li>
                    <li role="menuitem"><a href="http://ieeespectrumreprints.magreprints.com/" target="_blank">Reprints &amp; Permissions</a></li>
                    <h4 class="footerTitle" role="heading">IEEE Partners</h4>
                    <li role="menuitem"><a href="http://advertise.ieee.org">Advertising &amp; Media Center</a></li>
                    <li role="menuitem"><a href="http://careers.ieee.org/">IEEE Job Site</a></li>
                    <li role="menuitem"><a href="http://spectrumsuppliermarketplace.com/">Buyer&rsquo;s Guide</a></li>
                </ul>

                <ul class="magazine-links" role="menu">
                    <h4 role="heading">The Magazine</h4>
                    <li role="menuitem"><a href="/magazine"><img src="/assets/x-7616b49c48ca0cd6cbd15e9f747c8886.gif" class="lazy" data-original="/image/MzA0MDM5MQ.jpeg" width="100" height="133" alt="Magazine cover image"/></a></li>
                    <li role="menuitem"><a href="/static/readerservices">Subscribe Now</a></li>
                    
                </ul>
            </div>

            <ul id="footerCopy">
                <li id="copyrightTag" role="contentinfo">&copy; Copyright 2018 IEEE Spectrum</li>
                <li role="menu" id="policyNav"><a href="http://www.ieee.org/site_terms_conditions.html">Terms &amp; Conditions</a> | <a href="http://www.ieee.org/privacy">Privacy &amp; Opting Out of Cookies</a> | <a href="http://www.ieee.org/accessibility_statement.html">Accessibility</a> | <a href="http://www.ieee.org/nondiscrimination">Nondiscrimination Policy</a></li>
            </ul>
        </div>
    </div>

	
    <div id="subFooter" role="navigation">
        <div class="commonwrap" role="region">
            <a href="http://www.ieee.org">
                <img src="/assets/ieee-logo-851bf96265ef3f9dfa532b4db93f0843.png" class="footerLogo" width="142" height="41" alt="IEEE logo" role="img"/>
            </a>
            <div id="footerSubMenu" role="section">
                <ul role="menu">
                    <li role="menuitem"><a href="/static/enhance-your-spectrum-experience-become-an-ieee-member">Join IEEE</a></li>
                    <li role="menuitem"><a href="http://www.ieee.org/about/index.html">About IEEE</a></li>
                    <li role="menuitem"><a href="http://www.ieee.org/conferences_events/index.html">Conferences &amp; Events</a></li>
                    <li role="menuitem"><a href="http://www.ieee.org/education_careers/index.html">Education &amp; Careers</a></li>
                </ul>

                <ul role="menu">
                    <li role="menuitem"><a href="http://www.ieee.org/membership_services/index.html">Membership &amp; Services</a></li>
                    <li role="menuitem"><a href="http://www.ieee.org/publications_standards/index.html">Publications and Standards</a></li>
                    <li role="menuitem"><a href="http://www.ieee.org/societies_communities/index.html">Societies &amp; Communities</a></li>
                </ul>
                <p class="legalText">© Copyright 2018 IEEE — All rights reserved. Use of this Web site signifies your agreement to the <a href="http://www.ieee.org/site_terms_conditions.html?WT.mc_id=hpf_terms" target="_blank">IEEE Terms and Conditions</a>.<br>A not-for-profit organization, IEEE is the world's largest technical professional organization dedicated to advancing technology for the benefit of humanity.</p>
            </div>
        </div>
    </div>
</footer>


<script type="text/javascript" src="/assets/footer/footer-becb23e41f5b6a6bc3bb43f0abbdbf2d.js" ></script>


<script type="text/javascript">
    function ss_track(slideshow_image, image_number, image_name, image_caption, path_to_assets) {
        _gaq.push(['_setAccount', 'UA-747464-1']);
        _gaq.push(['_trackEvent', 'Slideshows', 'Change Slide', '', image_number, true]);
    }
</script>

    
    
    
        <!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="spectrum.ieee.org"></div>
</div>
<script>
(function(s, p, d) {
var h=d.location.protocol, i=p+"-"+s,
e=d.getElementById(i), r=d.getElementById(p+"-root"),
u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
:"static."+p+".com";
if (e) return;
e = d.createElement(s); e.id = i; e.async = true;
e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>
<!-- END Parse.ly Include -->
    









</body>
</html>